On Tue, Sep 24, 2013 at 09:20:50PM +0900, Akira Hayakawa wrote:
> * Deferring ACK for barrier writes
> Barrier flags such as REQ_FUA and REQ_FLUSH are handled lazily.
> Immediately handling these bios badly slows down writeboost.
> It surveils the bios with these flags and forcefully flushes them
>
Hi, Mike
I have made another progress yesterday:
Splitting the monolithic source code into
meaningful pieces is done.
It will follow in the next mail.
> Yes, please share your plan. Anything that can simplify the code layout
> is best done earlier to simplfy code review.
Sorry, should have been
On Wed 2013-09-25 16:39:29, Iker Pedrosa wrote:
> The previously used printk lacked the warning level, now we've got a more
> accurate way to know the error.
>
> Signed-off-by: Iker Pedrosa
Acked-by: Pavel Machek
--
(english) http://www.livejournal.com/~pavelmachek
(cesky, pictures)
http://
On Sun, 2013-09-22 at 11:05 +, Hanjun Guo wrote:
> In acpi_bus_register_driver(), there is an if (acpi_disabled) check,
> so the if(acpi_disabled) before it is reduplicate, remove it.
>
> Signed-off-by: Hanjun Guo
Acked-by: Toshi Kani
-Toshi
> ---
> drivers/staging/quickstart/quickstart.
On Wed, Sep 25, 2013 at 08:20:22PM -0300, Fabio Estevam wrote:
> Hi Greg,
>
> On Tue, Sep 17, 2013 at 4:55 PM, Greg KH wrote:
>
> >> Greg,
> >>
> >> The offending commit that causes the regression is in 3.12-rc1 now, so this
> >> patch could go via your staging tree.
> >
> > Thanks for this, I'l
On Mon, Sep 16, 2013 at 03:43:28PM +0200, Iker Pedrosa wrote:
> According to the documentation it is not recommended to use msleep for 1ms -
> 20ms because it may sleep longer than 20ms. So, it is recommended to use
> usleep instead.
>
> In the first revision Greg KH pointed out that this change
On Fri, Sep 13, 2013 at 11:55:50AM +0200, Dominik Paulus wrote:
> Hi,
>
> this patch series includes an updated version of the IPv6 support patch (a
> call
> to freeaddrinfo() was missing) as well as:
>
> - The client/server authentication support using GnuTLS Tobias already
>announced on t
Hi Greg,
On Tue, Sep 17, 2013 at 4:55 PM, Greg KH wrote:
>> Greg,
>>
>> The offending commit that causes the regression is in 3.12-rc1 now, so this
>> patch could go via your staging tree.
>
> Thanks for this, I'll take it now.
Do you think this one can reach 3.12-rc3?
Thanks,
Fabio Estevam
_
On Sat, Sep 14, 2013 at 02:21:03PM +0300, Elad Wexler wrote:
> From: Elad Wexler
>
> 'timed_gpio_probe()' shall return -ENXIO (no such address or device) in case
> of NULL platform data.
Care to wrap your lines in the future? :)
Anyway, how can platform data be NULL? Have you sen this happy?
This patch removes this smatch warning:
unsigned '--un->un_open_count' is never less than zero
The code decremented the un_open_count variable
and tested to see if it was less than zero. Because
un_open_count is unsigned and can't be below zero,
this test didn't work.
Signed-off-by: Lidza Louina
The PCL-727 board uses different register offsets for the digital input and
output ports. Instead of having all the register offsets in the boardinfo,
replace them with a simple bit-field flag, 'is_pcl727'. Use that flag in the
(*insn_bits) functions to determine what registers need to be used.
To
This patch removes these smatch warnings:
redundant null check on dgap_TmpWriteBuf calling kfree()
redundant null check on brd->SerialDriver->ttys calling kfree()
redundant null check on brd->PrintDriver->ttys calling kfree()
The code checked to see if these variables are null
before freeing. This
Convert the boardinfo declaration to C99 format to make it less error
prone and easier to maintain.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/pcl726.c | 76 ++---
1 file changed, 61 insertions(+), 15 de
For aesthetics, add some whitespace to the subdevice initialization.
Only allocate, and initialize, the digital input and output subdevices
if the boardinfo indicates that they exist on the board.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comed
Rename this CamelCase variable in the boardinfo.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/pcl726.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/comedi/drivers/pcl726.c
b/drivers/stagi
On Wed, Sep 25, 2013 at 04:02:44PM -0700, Greg Kroah-Hartman wrote:
> On Sat, Aug 31, 2013 at 03:56:06PM -0700, Guenter Roeck wrote:
> > Use device_create_with_groups to create sysfs attributes together with
> > device.
> > Also create class attribute together with class registration.
> > This sim
On Wed, Sep 25, 2013 at 7:08 PM, Greg KH wrote:
> On Mon, Sep 09, 2013 at 03:01:27PM -0400, Lidza Louina wrote:
>> The arguments that were passed into sizeof were
>> generic. This patch changes this by putting
>> the actual item that we need a size of instead.
>>
>> For example:
>> - kzalloc(siz
This patch removes this smatch warning:
info: ignoring unreachable code.
There were instances where there was extra code after
the default action in switch statements. These default
actions ended with a break so the code wasn't being run
at anytime. This patch removes that extra code.
Signed-off-b
On Mon, Sep 09, 2013 at 03:01:27PM -0400, Lidza Louina wrote:
> The arguments that were passed into sizeof were
> generic. This patch changes this by putting
> the actual item that we need a size of instead.
>
> For example:
> - kzalloc(sizeof(struct dgnc_board), GFP_KERNEL);
> + kzalloc(sizeo
This patch changes error handling to the
tty_driver allocations in dgap_tty_register.
Before, it didn't handle the possibility of an
alloc_tty_driver failure. This patch makes
dgap_register_driver return -ENOMEM if that fails.
This patch also adds handling to the possibility that
the brd->SerialD
This patch removes these smatch warnings from dgap_driver.c:
redundant null check on dgap_config_buf calling kfree()
redundant null check on brd->flipbuf calling kfree()
redundant null check on brd->flipflagbuf calling kfree()
Signed-off-by: Lidza Louina
---
drivers/staging/dgap/dgap_driver.c |
On Tue, Sep 24, 2013 at 09:20:50PM +0900, Akira Hayakawa wrote:
> Hi, Mike
>
> I am now working on redesigning and implementation
> of dm-writeboost.
Ok, I'm dropping your original patch, please resend when you have
something you want merged into drivers/staging/
thanks,
greg k-h
__
On Sat, Aug 31, 2013 at 03:56:06PM -0700, Guenter Roeck wrote:
> Use device_create_with_groups to create sysfs attributes together with device.
> Also create class attribute together with class registration.
> This simplifies the code and ensures that attribute files exist when udev
> events are ge
On Thu, Sep 26, 2013 at 12:29:03AM +0200, Alexander Holler wrote:
> Am 26.09.2013 00:10, schrieb Greg Kroah-Hartman:
>
> > Please stick to technical discussions about the code on the kernel
> > mailing lists. Legal discussions can be left up to the lawyers, of
> > which we are not.
>
> Hmm, but
'boardtypes' is pretty generic, rename this static const variable.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/pcl726.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/comedi/drivers/pcl726.
Change the MODULE_DESCRIPTION to something useful instead of the
generic "Comedi low-level driver".
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/pcl726.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/sta
The ACL-6126 board supports an external interrupt signal on pin 17 of
its I/O connector (CN3). Add a new subdevice to this driver to support
asynchronous commands with this input.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/pcl726.c
On Wed, Sep 25, 2013 at 6:29 PM, Dan Carpenter wrote:
> On Wed, Sep 25, 2013 at 06:13:47PM -0400, Lidza Louina wrote:
>> On Wed, Sep 25, 2013 at 2:34 PM, Dan Carpenter
>> wrote:
>> > On Wed, Sep 25, 2013 at 01:22:08PM -0400, Lidza Louina wrote:
>> >>
>> >> I looked at other uses of the function
Tidy up the multi-line comments to follow the CodingStyle.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/pcl726.c | 118
1 file changed, 58 insertions(+), 60 deletions(-)
diff --git a/drivers/staging/
For aesthetics, rearrange the boardinfo struct definition a bit to give
it a bit of logical order.
Also, rename the 'n_aochan' member to it has better visual association
with the other analog output members.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/st
The *_SIZE defines are only used to initialize the 'io_range' members in
the boardinfo. Remove the defines and just open code the values.
For aesthetics, change the type of the 'io_range' and rename it to better
match the 'len' parameter to comedi_request_region().
Signed-off-by: H Hartley Sweete
The variable names provided enough information.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/pcl726.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/comedi/drivers/pcl726.c
b/drivers/stagin
For aesthetics, declare the comedi_lrange tables with one entry per line.
Since the range data in the boardinfo is only for the analog outputs,
rename the variables to make this clearer.
Use ARRAY_SIZE to initialize the 'ao_num_ranges' member instead of open
coding the value.
Signed-off-by: H Ha
Remove all the '= 0' entries in the boardinfo. They will default to 0.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/pcl726.c | 14 --
1 file changed, 14 deletions(-)
diff --git a/drivers/staging/comedi/drivers/pcl726.c
The analog output channels use jumpers on the board to individually set
the range used. This driver uses the configuration options passed to the
(*attach) function to setup the analog output subdevice range_table_list
for each channel.
The configuration options should be 'it->options[2 + i]' for e
Tidy up and enable the interrupt support code for the external trigger
source interrupt on the ACL-6126 board.
The interrupt handler is currently just a stub function. Once the async
command support is added this function will be completed.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Gr
Tidy up this function to follow the normal form for analog output
read back functions.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/pcl726.c | 14 --
1 file changed, 8 insertions(+), 6 deletions(-)
diff --git a/drivers/s
For aesthetics, rename the function to help with greps.
The offset binary value from the core should be saved for read back.
Move the saving of the value in the private data so it occurs before
the value is possibly munged for bipolar outputs.
Use the comedi_offset_munge() helper to munge the off
Introduce two helper functions to check if a subdevice range_table_list
for a given channel/range is bipolar or unipolar.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/comedidev.h | 14 ++
1 file changed, 14 insertions(+)
diff --
These flags are set in the private data during the attach to indicate
if the range for each channel is bipolar or unipolar. Use the helper
function conedi_chan_range_is_bipolar() to determine this by checking
the range_table_list directly.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg
Cleanup another comedi driver.
Add support for the external interrupt on the ACL-6126 board.
H Hartley Sweeten (19):
staging: comedi: pcl726: convert boardinfo declaration to C99 format
staging: comedi: core: introduce comedi_chan_range_is_{bi,uni}polar()
staging: comedi: pcl726: remove 'bi
Am 26.09.2013 00:10, schrieb Greg Kroah-Hartman:
> Please stick to technical discussions about the code on the kernel
> mailing lists. Legal discussions can be left up to the lawyers, of
> which we are not.
Hmm, but I would like to know if someone has to fear getting owned by
Microsoft if he wou
On Wed, Sep 25, 2013 at 06:13:47PM -0400, Lidza Louina wrote:
> On Wed, Sep 25, 2013 at 2:34 PM, Dan Carpenter
> wrote:
> > On Wed, Sep 25, 2013 at 01:22:08PM -0400, Lidza Louina wrote:
> >>
> >> I looked at other uses of the function alloc_tty_driver() in
> >> the kernel and none of them seem to
Hi,
On 25 Sep 2013, at 21:21, Greg Kroah-Hartman wrote:
> On Wed, Sep 25, 2013 at 09:28:56PM +0200, Alexander Holler wrote:
>>
>> Maybe a silly question, but isn't exFAT protected by some MS owned
>> patents which might drive Linux users into the hand of MS lawyers as
>> already happened with FA
On Wed, Sep 25, 2013 at 2:34 PM, Dan Carpenter wrote:
> On Wed, Sep 25, 2013 at 01:22:08PM -0400, Lidza Louina wrote:
>>
>> I looked at other uses of the function alloc_tty_driver() in
>> the kernel and none of them seem to follow up with a
>> call to kfree().
>
> Read my first response again. I
On Wed, Sep 25, 2013 at 11:57:21PM +0200, Benjamin Valentin wrote:
> Am Wed, 25 Sep 2013 10:27:04 -0700
> schrieb Greg Kroah-Hartman :
>
> > > > Also, I would really like to get a signed-off-by: from the Samsung
> > > > authors for this patch, can you do that as well please?
> > >
> > > I've trie
On Wed, Sep 25, 2013 at 10:44:15PM +0100, Anton Altaparmakov wrote:
> Hi,
>
> On 25 Sep 2013, at 21:21, Greg Kroah-Hartman
> wrote:
> > On Wed, Sep 25, 2013 at 09:28:56PM +0200, Alexander Holler wrote:
> >>
> >> Maybe a silly question, but isn't exFAT protected by some MS owned
> >> patents whi
Am 25.09.2013 23:44, schrieb Anton Altaparmakov:
> Hi,
>
> On 25 Sep 2013, at 21:21, Greg Kroah-Hartman
> wrote:
>> On Wed, Sep 25, 2013 at 09:28:56PM +0200, Alexander Holler wrote:
>>>
>>> Maybe a silly question, but isn't exFAT protected by some MS owned
>>> patents which might drive Linux use
Am Wed, 25 Sep 2013 10:27:04 -0700
schrieb Greg Kroah-Hartman :
> > > Also, I would really like to get a signed-off-by: from the Samsung
> > > authors for this patch, can you do that as well please?
> >
> > I've tried reaching them by their last public e-mail addresses I
> > could find, but they
Am 25.09.2013 22:21, schrieb Greg Kroah-Hartman:
On Wed, Sep 25, 2013 at 09:28:56PM +0200, Alexander Holler wrote:
Maybe a silly question, but isn't exFAT protected by some MS owned
patents which might drive Linux users into the hand of MS lawyers as
already happened with FAT? It would make me
On Wed, Sep 25, 2013 at 09:28:56PM +0200, Alexander Holler wrote:
> Am 25.09.2013 20:45, schrieb Greg Kroah-Hartman:
> > On Wed, Sep 25, 2013 at 07:32:36PM +0100, Matthew Garrett wrote:
> >> On Wed, Sep 25, 2013 at 10:27:04AM -0700, Greg Kroah-Hartman wrote:
> >>
> >>> Who did you contact at Samsun
Am 25.09.2013 20:45, schrieb Greg Kroah-Hartman:
> On Wed, Sep 25, 2013 at 07:32:36PM +0100, Matthew Garrett wrote:
>> On Wed, Sep 25, 2013 at 10:27:04AM -0700, Greg Kroah-Hartman wrote:
>>
>>> Who did you contact at Samsung? I'll be visiting there in a week so I
>>> can try to track some people d
On Wed, Sep 25, 2013 at 10:27:04AM -0700, Greg Kroah-Hartman wrote:
> Who did you contact at Samsung? I'll be visiting there in a week so I
> can try to track some people done in person. I really want their
> signed-off-by: on the patch, as it is their code to start with, and it's
> a bit rude t
On Wed, Sep 25, 2013 at 07:32:36PM +0100, Matthew Garrett wrote:
> On Wed, Sep 25, 2013 at 10:27:04AM -0700, Greg Kroah-Hartman wrote:
>
> > Who did you contact at Samsung? I'll be visiting there in a week so I
> > can try to track some people done in person. I really want their
> > signed-off-b
On Wed, Sep 25, 2013 at 01:22:08PM -0400, Lidza Louina wrote:
>
> I looked at other uses of the function alloc_tty_driver() in
> the kernel and none of them seem to follow up with a
> call to kfree().
Read my first response again. I showed how to do this. Your setting
up a bunch of things in a
On 09/24/2013 05:29 AM, Jiri Kosina wrote:
> On Mon, 16 Sep 2013, Joseph Salisbury wrote:
>
Can you explain a little further? Mark commit a4a23f6 as bad? An
initial bisect already reported that was the first bad commit, so it
can't be marked bad. The oops on memcpy() happens after
On Tue, Sep 24 2013 at 8:20am -0400,
Akira Hayakawa wrote:
> Hi, Mike
>
> I am now working on redesigning and implementation
> of dm-writeboost.
>
> This is a progress report.
>
> Please run
> git clone https://github.com/akiradeveloper/dm-writeboost.git
> to see full set of the code.
I li
On Wed, Sep 25, 2013 at 06:36:32PM +0200, Benjamin Valentin wrote:
> Am Fri, 30 Aug 2013 08:42:05 -0700
> schrieb Greg Kroah-Hartman :
>
> > For staging drivers I need a maintainer that is going to take the time
> > to shephard it into the core kernel tree. See other TODO files for
> > how that
On Tue, Sep 24, 2013 at 3:20 PM, Dan Carpenter wrote:
> On Tue, Sep 24, 2013 at 02:40:10PM -0400, Lidza Louina wrote:
>> Instead of writing:
>> brd->SerialDriver = alloc_tty_driver(MAXPORTS);
>> if (!brd->SerialDriver){
>> goto free_stuff;
>> return
On Wed, Sep 25, 2013 at 7:36 PM, Benjamin Valentin
wrote:
> Am Fri, 30 Aug 2013 08:42:05 -0700
> schrieb Greg Kroah-Hartman :
>
>> For staging drivers I need a maintainer that is going to take the time
>> to shephard it into the core kernel tree. See other TODO files for
>> how that person is def
Am Fri, 30 Aug 2013 08:42:05 -0700
schrieb Greg Kroah-Hartman :
> For staging drivers I need a maintainer that is going to take the time
> to shephard it into the core kernel tree. See other TODO files for
> how that person is defined. Are you going to be willing to do this?
I can see what I c
The previously used printk lacked the warning level, now we've got a more
accurate way to know the error.
Signed-off-by: Iker Pedrosa
---
drivers/staging/winbond/wb35tx.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/winbond/wb35tx.c b/drivers/stagi
Fixed coding style issue where lines are indented with spaces
instead of tabs.
Signed-off-by: Luis Ortega Perez de Villar
---
drivers/staging/dwc2/core.c |4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/dwc2/core.c b/drivers/staging/dwc2/core.c
index 06d
On Tue, Sep 24, 2013 at 11:53 PM, KY Srinivasan wrote:
> I am not sure how that magic number was arrived at (the 60HZ number). We want
> this to be little higher -
"60 * HZ" means "60 seconds".
> would there be any issues raising this to say 180 seconds. This is the value
> we currently have
64 matches
Mail list logo