https://bugs.freedesktop.org/show_bug.cgi?id=102457
Jari Tahvanainen changed:
What|Removed |Added
Assignee|intel-gfx-bugs@lists.freede |dri-devel@lists.freedesktop
Hi Daniel,
On Thu, Aug 24, 2017 at 11:43:11AM +0200, Daniel Vetter wrote:
> On Thu, Aug 24, 2017 at 11:22:30AM +0200, Maxime Ripard wrote:
> >
> > Here is a single patch that was sent recently. It could wait for 4.15,
> > but it's also minor enough so that's there's no point in delaying it
> > ei
/RFC-drm-Allow-driver-specific-ioctls-to-be-registered/20170906-130119
base: git://anongit.freedesktop.org/drm-intel for-linux-next
reproduce: make htmldocs
All warnings (new ones prefixed by >>):
WARNING: convert(1) not found, for SVG to PDF conversion install ImageMagick
Mode setup code is called from video plane update and mixer plane update.
Lets group it together in mixer_commit function like in case of other
Exynos CRTCs.
Signed-off-by: Andrzej Hajda
---
drivers/gpu/drm/exynos/exynos_mixer.c | 33 ++---
1 file changed, 18 insertio
Screen resolution configuration depends on HW version, let put it into
single function to make it consistent and simplify the code.
Signed-off-by: Andrzej Hajda
---
drivers/gpu/drm/exynos/exynos_mixer.c | 17 +++--
1 file changed, 7 insertions(+), 10 deletions(-)
diff --git a/driver
Mode commit should not be called for every plane separately. It is enough
to call it once in enable callback. The change requires also that
interlace check should be moved to mixer_commit. It should be done in
the same patch to avoid regression.
Signed-off-by: Andrzej Hajda
---
drivers/gpu/drm/e
Hi all,
This patchset does two main things:
- removes mode limitation for Exynos542x chips, multiple modes were filtered
out due to lack of HW version checking code,
- enables two modes on older chips, thanks to quirk found by Daniel Drake,
and published by Tobias Jakobi [1][2].
Beside this it
crtc::mode_fixup callback is required by crtcs which use internally
different mode than requested by user - case of Exynos Mixer.
Signed-off-by: Andrzej Hajda
---
drivers/gpu/drm/exynos/exynos_drm_crtc.c | 15 +++
drivers/gpu/drm/exynos/exynos_drm_drv.h | 3 +++
2 files changed, 18
Display mode is preserved in CRTC state, there is no need to keep local
copy of it. Moreover since HDMI should configure registers according to
requested mode, use it instead of adjusted_mode, which should contain
mode produced by CRTC - functionally it does not change anything, but
subsequent patc
Mode limitation checked in mixer driver affects only older HW.
Mixer in Exynos542x has no such limitations. While at it patch changes
validation callback to recently introduced mode_valid which is more
suitable for the check. Additionally little cleanup is performed.
Signed-off-by: Andrzej Hajda
mixer_resources adds only unnecessary redirection, removing it makes the
code shorter and cleaner.
Signed-off-by: Andrzej Hajda
---
drivers/gpu/drm/exynos/exynos_mixer.c | 323 --
1 file changed, 147 insertions(+), 176 deletions(-)
diff --git a/drivers/gpu/drm/ex
MIXER in SoCs prior to Exynos5420 supports only 4 video modes:
720x480, 720x576, 1280x720, 1920x1080. Support for other modes can be
enabled by manipulating timings of HDMI. To allow it MIXER must pass
actual video mode to HDMI, the proper way to do it is to modify
adjusted_mode property in crtc::m
MIXER in SoCs prior to Exynos5420 supports only 4 video modes:
720x480, 720x576, 1280x720, 1920x1080. Support for other modes
can be enabled by manipulating timings of HDMI. To do it
adjusted_mode should contain actual mode set on crtc.
With this patch it is possible to enable 1024x768 and 1280x102
Since HDMI can handle these modes despite of MIXER limitations lets
enable them.
Signed-off-by: Andrzej Hajda
---
drivers/gpu/drm/exynos/exynos_mixer.c | 3 +++
1 file changed, 3 insertions(+)
diff --git a/drivers/gpu/drm/exynos/exynos_mixer.c
b/drivers/gpu/drm/exynos/exynos_mixer.c
index 5aae
https://bugs.freedesktop.org/show_bug.cgi?id=102244
Vittorio changed:
What|Removed |Added
CC||vittori...@gmail.com
--- Comment #3 from Vit
gcc-7 complains about multiplying within a condition being
suspicious:
drivers/gpu/drm/stm/dw_mipi_dsi-stm.c: In function 'dsi_pll_get_clkout_khz':
drivers/gpu/drm/stm/dw_mipi_dsi-stm.c:117:10: error: '*' in boolean context,
suggest '&&' instead [-Werror=int-in-bool-context]
The code here is cor
gcc thinks that interpreting a multiplication result as a bool
is confusing:
drivers/gpu/drm/nouveau/nvkm/subdev/clk/gt215.c: In function 'read_pll':
drivers/gpu/drm/nouveau/nvkm/subdev/clk/gt215.c:133:8: error: '*' in boolean
context, suggest '&&' instead [-Werror=int-in-bool-context]
In this i
Hi,
This pull request adds firmware for adreno a3xx GPU found for example
on the APQ8016 chipset, used on the Dragonboard 410c.
The following changes since commit 9d40a17beaf271e6ad47a5e714a296100eef4692:
rtlwifi: rtl8822be: Add firmware for new driver/device (2017-08-29
11:41:47 -0700)
are a
https://bugs.freedesktop.org/show_bug.cgi?id=92248
--- Comment #38 from Armando Antonio ---
Created attachment 133995
--> https://bugs.freedesktop.org/attachment.cgi?id=133995&action=edit
new-dmesg
--
You are receiving this mail because:
You are the assignee for the bug.__
https://bugs.freedesktop.org/show_bug.cgi?id=92248
--- Comment #37 from Armando Antonio ---
i tried to reproduce on KBL and the current assert is the following:
(kms_plane_scaling:1855) igt-kms-CRITICAL: Test assertion failure function
igt_drm_plane_commit, file igt_kms.c:2244:
(kms_plane_scalin
On Tue, 2017-09-05 at 18:26 -0700, Dhinakaran Pandiyan wrote:
> The POWER_DOWN_PHY and POWER_UP_PHY sideband message transactions
> allow
> the source to reqest any node in a mst path or a whole path to be
> powered down or up. This allows drivers to target a specific sink in
> the
> MST topology,
From: Christian König
With shared reservation objects it is possible that we want to temporary
kmap an BO while it is still on the swap list.
Signed-off-by: Christian König
---
drivers/gpu/drm/ttm/ttm_bo_util.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/gpu/drm/ttm/ttm_bo_util.
From: Christian König
Use the VM instead of the BO list to find the BO for a virtual address.
This fixes UVD/VCE in physical mode with VM local BOs.
Signed-off-by: Christian König
---
drivers/gpu/drm/amd/amdgpu/amdgpu_cs.c | 42 +++---
drivers/gpu/drm/amd/amdgpu/am
From: Christian König
When we need to find the mapping we need sysvm access anyway.
Signed-off-by: Christian König
---
drivers/gpu/drm/amd/amdgpu/amdgpu.h | 8 ++---
drivers/gpu/drm/amd/amdgpu/amdgpu_cs.c | 64 -
drivers/gpu/drm/amd/amdgpu/amdgpu_uvd.c | 1
On Wed, 2017-09-06 at 11:40 -0400, Lyude Paul wrote:
> On Tue, 2017-09-05 at 18:26 -0700, Dhinakaran Pandiyan wrote:
> > The POWER_DOWN_PHY and POWER_UP_PHY sideband message transactions
> > allow
> > the source to reqest any node in a mst path or a whole path to be
> > powered down or up. This all
https://bugs.freedesktop.org/show_bug.cgi?id=100596
Chris Wilson changed:
What|Removed |Added
Resolution|--- |FIXED
Status|NEW
https://bugs.freedesktop.org/show_bug.cgi?id=102242
Chris Wilson changed:
What|Removed |Added
Status|NEW |RESOLVED
Resolution|---
https://bugs.freedesktop.org/show_bug.cgi?id=92248
--- Comment #39 from Hector Velazquez
---
The following tests FAIL on SKL
Tests List:
igt@kms_setmode@basic
==
Output Sample
==
...
(kms_plane_scaling:1981) igt
https://bugs.freedesktop.org/show_bug.cgi?id=102552
--- Comment #3 from Pauk Denis ---
I have found this behaiviour because of error in my code when some time
is_format_supported called with uninitialized value and had value >
PIPE_FORMAT_COUNT.
With check like:
-
for(int i=0; iis_format_su
On Wed, Sep 6, 2017 at 4:20 PM, Karol Herbst wrote:
>> In this instance, I think using multiplication is more intuitive
>> than '&&', so I'm adding a comparison to zero instead to shut up
>> the warning. To further improve readability, I also make the
>> error case indented and leave the normal ca
https://bugs.freedesktop.org/show_bug.cgi?id=102552
--- Comment #4 from Ilia Mirkin ---
Oh interesting. I think some of those formats were removed recently. I wonder
if such call sites should be fixed. Nouveau calls util_format_is_supported up
high in is_format_supported, I suspect that gets it o
On 09/06/2017 11:51 AM, Christian König wrote:
From: Christian König
Use the VM instead of the BO list to find the BO for a virtual address.
This fixes UVD/VCE in physical mode with VM local BOs.
The series is
Tested-by: Leo Liu
Signed-off-by: Christian König
---
drivers/gpu/drm/amd
On Wed, Sep 6, 2017 at 10:15 PM, Karol Herbst wrote:
> On Wed, Sep 6, 2017 at 10:11 PM, Arnd Bergmann wrote:
>>> but with a better name for "denominator".
>>
>> I don't know what M and P actually are in this function, so I couldn't
>> come up with a much better name either, how about simply 'divi
gcc thinks that interpreting a multiplication result as a bool
is confusing:
drivers/gpu/drm/nouveau/nvkm/subdev/clk/gt215.c: In function 'read_pll':
drivers/gpu/drm/nouveau/nvkm/subdev/clk/gt215.c:133:8: error: '*' in boolean
context, suggest '&&' instead [-Werror=int-in-bool-context]
Adding a
The POWER_DOWN_PHY and POWER_UP_PHY sideband message transactions allow
the source to reqest any node in a mst path or a whole path to be
powered down or up. This allows drivers to target a specific sink in the
MST topology, an improvement over just power managing the imediate
downstream device. Se
From: Eric Biggers
IDR only supports non-negative IDs. There used to be a
'WARN_ON_ONCE(id < 0)' in idr_replace(), but it was intentionally
removed by commit 2e1c9b286765 ("idr: remove WARN_ON_ONCE() on negative
IDs"). Then it was added back by commit 0a835c4f090a ("Reimplement IDR
and IDA usin
On Wed, Sep 6, 2017 at 3:56 PM, Arnd Bergmann wrote:
> gcc thinks that interpreting a multiplication result as a bool
> is confusing:
>
> drivers/gpu/drm/nouveau/nvkm/subdev/clk/gt215.c: In function 'read_pll':
> drivers/gpu/drm/nouveau/nvkm/subdev/clk/gt215.c:133:8: error: '*' in boolean
> conte
On Wed, Sep 6, 2017 at 10:11 PM, Arnd Bergmann wrote:
> On Wed, Sep 6, 2017 at 4:20 PM, Karol Herbst wrote:
>>> In this instance, I think using multiplication is more intuitive
>>> than '&&', so I'm adding a comparison to zero instead to shut up
>>> the warning. To further improve readability, I
https://bugs.freedesktop.org/show_bug.cgi?id=100387
Peter changed:
What|Removed |Added
CC||tuhar...@misbb.sk
--- Comment #7 from Peter --
https://bugs.freedesktop.org/show_bug.cgi?id=100387
--- Comment #8 from Peter ---
Created attachment 134034
--> https://bugs.freedesktop.org/attachment.cgi?id=134034&action=edit
screenshot - War Thunder, Radeon HD 6850
MESA 17.1.5
--
You are receiving this mail because:
You are the assignee
https://bugs.freedesktop.org/show_bug.cgi?id=100387
--- Comment #9 from Peter ---
(In reply to Hi-Angel from comment #5)
> But fixing this bug won't help to the game anyway, because the next problem
> it runs into is a very old one of requiring too many GPRs
Are You sure? I don't know the exact
On 09/04/2017 03:19 PM, Hoegeun Kwon wrote:
On 09/01/2017 04:31 PM, Marek Szyprowski wrote:
Hi Hoegeun,
On 2017-09-01 03:47, Hoegeun Kwon wrote:
The gscaler has hardware rotation limits that need to be imported from
dts. Parse them and add them to the property list.
The rotation hardware limi
Hi Benjamin,
This should be pushed to drm-misc by you, right?
Thanks,
Archit
On 09/06/2017 06:43 PM, Arnd Bergmann wrote:
gcc-7 complains about multiplying within a condition being
suspicious:
drivers/gpu/drm/stm/dw_mipi_dsi-stm.c: In function 'dsi_pll_get_clkout_khz':
drivers/gpu/drm/stm/dw_
On 09/05/2017 10:14 PM, John Stultz wrote:
On Tue, Sep 5, 2017 at 5:10 AM, Lars-Peter Clausen wrote:
Currently adv7511_get_modes() bails out early when no EDID could be
retrieved. This leaves the previous EDID in place, which is typically not
the intended behavior and might confuse applicatio
On 2017-09-05 18:26, Dhinakaran Pandiyan wrote:
> The POWER_DOWN_PHY and POWER_UP_PHY sideband message transactions allow
> the source to reqest any node in a mst path or a whole path to be
> powered down or up. This allows drivers to target a specific sink in the
> MST topology, an improvement ove
On 2017-09-05 18:26, Dhinakaran Pandiyan wrote:
> Use the POWER_DOWN_PHY and POWER_UP_PHY sideband message trasactions to
> set power states for downstream sinks. Apart from giving us the ability
> to set power state for individual sinks, this fixes the below test for
> me
>
> $ xrandr --display :
46 matches
Mail list logo