Sean,
On 07/30/2016 03:16 AM, Sean Paul wrote:
> Instead of just preparing the panel on bind, actually prepare/unprepare
> during modeset/disable. The panel must be prepared in order to read hpd
> status, so we need to refcount the prepares in order to ensure we don't
> accidentally turn the panel
Op 29-07-16 om 22:33 schreef Matt Roper:
> On Fri, Jul 29, 2016 at 12:39:05PM +0300, Ville Syrjälä wrote:
>> On Thu, Jul 28, 2016 at 05:03:52PM -0700, Matt Roper wrote:
>>> This is completely untested (and probably horribly broken/buggy), but
>>> here's a quick mockup of the general approach I wa
Am Sonntag, den 31.07.2016, 21:55 +0200 schrieb Peter Senna Tschudin:
> As the IPU has combined limitations across multiple crtcs, and as that
> can't be communicated to userspace at the moment, reorder the crtcs to
> allow support to two Full-HD monitors by avoiding assigning two
> monitors to a s
Am Sonntag, den 31.07.2016, 12:42 -0700 schrieb Steve Longerbeam:
> Adds ipu_cpmem_set_uv_offset(), to set planar U/V offsets.
>
> Signed-off-by: Steve Longerbeam
There is no need to resend already applied patches.
regards
Philipp
Am Sonntag, den 31.07.2016, 12:42 -0700 schrieb Steve Longerbeam:
> Adds the Video Deinterlacer (VDIC) unit.
>
> Signed-off-by: Steve Longerbeam
>
> ---
>
> v3:
> - renamed and exported ipu_vdi_set_top_field_man() to
> ipu_vdi_set_field_order(). Args include std and field to determine
> cor
Am Sonntag, den 31.07.2016, 12:42 -0700 schrieb Steve Longerbeam:
> Adds functions to link and unlink source channels to sink
> channels in the FSU:
>
> int ipu_fsu_link(struct ipu_soc *ipu, int src_ch, int sink_ch);
> int ipu_fsu_unlink(struct ipu_soc *ipu, int src_ch, int sink_ch);
>
> The chann
Am Donnerstag, den 28.07.2016, 16:09 -0700 schrieb Steve Longerbeam:
> > Now split the frame in half and suddenly pixel x' = 640 is the start of
> > a new tile, so it is sampled at x = 160, and pixel x' = 1279 will be
> > sampled at x = 160 + (1279 - 640) * 8192/32846. = 319.37, reading over
> > th
13 24883200 1101026 = OK
0x0108fde000 14 13 24883200 1088786 = fail
--
You are receiving this mail because:
You are the assignee for the bug.
-- next part --
An HTML attachment was scrubbed...
URL:
<https://lists.freedesktop.org/archives/dri-devel/attachments/201
Am Sonntag, den 31.07.2016, 21:55 +0200 schrieb Peter Senna Tschudin:
> Add support to attach a drm_bridge to imx-ldb in addition to
> existing support to attach a LVDS panel.
>
> This patch does a simple code refactoring by moving code
> from for_each_child_of_node iterator to a new function name
On Mon, Aug 1, 2016 at 1:30 AM, Marc-André Lureau
wrote:
>
> Hi
>
> - Original Message -
>> On Fri, Jul 29, 2016 at 3:57 PM, Rob Herring wrote:
>> > Hi,
>> >
>> > This commit in virglrenderer causes a regression in Android for me.
>> > The parameters that get passed in are last_level =
Den 30.07.2016 17:48, skrev Noralf Trønnes:
>
> Den 29.07.2016 10:23, skrev Daniel Vetter:
>> Actually adding David.
>> -Daniel
>>
>> On Fri, Jul 29, 2016 at 10:20:51AM +0200, Daniel Vetter wrote:
>>> On Thu, Jul 28, 2016 at 04:15:04PM +0200, Noralf Trønnes wrote:
This patchset explores the
receiving this mail because:
You are the assignee for the bug.
-- next part --
An HTML attachment was scrubbed...
URL:
<https://lists.freedesktop.org/archives/dri-devel/attachments/20160801/0d1c0f57/attachment.html>
On Mon, Aug 01, 2016 at 10:48:37AM +0200, Maarten Lankhorst wrote:
> Op 29-07-16 om 22:33 schreef Matt Roper:
> > On Fri, Jul 29, 2016 at 12:39:05PM +0300, Ville Syrjälä wrote:
> >> On Thu, Jul 28, 2016 at 05:03:52PM -0700, Matt Roper wrote:
> >>> This is completely untested (and probably horribl
On Fri, Jul 29, 2016 at 01:41:26PM -0700, Matt Roper wrote:
> On Fri, Jul 29, 2016 at 10:26:20PM +0300, Ville Syrjälä wrote:
> > On Fri, Jul 29, 2016 at 02:48:09PM -0400, Lyude wrote:
> > > So I've been working on trying to fix this entirely again (e.g. writing
> > > the ddb properly), since from
info shows this. Does the lockup happen
with LLVM trunk?
--
You are receiving this mail because:
You are the assignee for the bug.
-- next part --
An HTML attachment was scrubbed...
URL:
<https://lists.freedesktop.org/archives/dri-devel/attachments/20160801/64d3d0d8/attachment.html>
On 29.07.2016 20:38, Deucher, Alexander wrote:
>> -Original Message-
>> From: Sean Paul [mailto:seanpaul at google.com]
>> Sent: Friday, July 29, 2016 3:35 PM
>> To: Wei Yongjun
>> Cc: Deucher, Alexander; Koenig, Christian; Dave Airlie; Jiang, Sonny; Liu,
>> Leo;
>> Nath, Arindam; Zhou, Da
attachment was scrubbed...
URL:
<https://lists.freedesktop.org/archives/dri-devel/attachments/20160801/6c955ee4/attachment.html>
achment was scrubbed...
URL:
<https://lists.freedesktop.org/archives/dri-devel/attachments/20160801/86c8d3ea/attachment.html>
Cc Andrzej, Thierry
On Fri, 22 Jul 2016, Daniel Vetter wrote:
> On Fri, Jul 22, 2016 at 04:30:24PM +0200, Takashi Iwai wrote:
>> Hi,
>>
>> is there any reason drm-mipi-dsi can't be a module? It's fixed as a
>> built-in since its Kconfig is bool.
>
> Probably none except embedded folks eshew mo
g.
-- next part --
An HTML attachment was scrubbed...
URL:
<https://lists.freedesktop.org/archives/dri-devel/attachments/20160801/856a9152/attachment.html>
/drm/card?/device/power_dpm_force_performance_level is set to "auto".
--
You are receiving this mail because:
You are the assignee for the bug.
-- next part --
An HTML attachment was scrubbed...
URL:
<https://lists.freedesktop.org/archives/dri-devel/attachments/20160801/5b45b4e5/attachment-0001.html>
On Tue, Jul 26, 2016 at 12:06 PM, wrote:
> From: Ville Syrjälä
>
> Pretty much all driver will have need for the clipped plane
> coordinates, so let's stuff then into drm_plane_state.
>
> Signed-off-by: Ville Syrjälä
Reviewed-by: Sean Paul
> ---
> include/drm/drm_crtc.h | 13 ++
On Tue, Jul 26, 2016 at 1:34 PM, wrote:
> From: Ville Syrjälä
>
> Add a version of drm_plane_helper_check_update() which takes a plane
> state instead of having the caller pass in everything.
>
> And to reduce code duplication, let's reimplement
> drm_plane_helper_check_update() in terms of th
On Tue, Jul 26, 2016 at 12:06 PM, wrote:
> From: Ville Syrjälä
>
> Replace the private drm_rects/flags in intel_plane_state
> with the ones now living in drm_plane_state.
>
> Signed-off-by: Ville Syrjälä
Reviewed-by: Sean Paul
> ---
> drivers/gpu/drm/i915/intel_atomic_plane.c | 20 ++--
On Tue, Jul 26, 2016 at 12:07 PM, wrote:
> From: Ville Syrjälä
>
> Replace the use of drm_plane_helper_check_update() with
> drm_plane_helper_check_state() since we have a plane state.
>
> Signed-off-by: Ville Syrjälä
Reviewed-by: Sean Paul
> ---
> drivers/gpu/drm/i915/intel_atomic_pl
On Tue, Jul 26, 2016 at 12:07 PM, wrote:
> From: Ville Syrjälä
>
> Replace the private drm_rects in vop_plane_state with
> the ones now living in drm_plane_state.
>
> Cc: Yao
> Cc: linux-rockchip at lists.infradead.org
> Signed-off-by: Ville Syrjälä
Reviewed-by: Sean Paul
> ---
> drive
On Tue, Jul 26, 2016 at 12:07 PM, wrote:
> From: Ville Syrjälä
>
> Replace the use of drm_plane_helper_check_update() with
> drm_plane_helper_check_state() since we have a plane state.
>
> Rockchip looks to handling plane clipping rather well already
> (unlikje most arm drm drivers) so there a
On Tue, Jul 26, 2016 at 12:07 PM, wrote:
> From: Ville Syrjälä
>
> Replace the use of drm_plane_helper_check_update() with
> drm_plane_helper_check_state() since we have a plane state.
>
> This also eliminates the double clipping the driver was doing
> in both check and commit phases). And it
On Tue, Jul 26, 2016 at 12:07 PM, wrote:
> From: Ville Syrjälä
>
> Replace the use of drm_plane_helper_check_update() with
> drm_plane_helper_check_state() since we have a plane state.
>
> I don't see any actual users of drm_simple_kms_helper yet, so
> no actual plane clipping bugs to fix.
>
>
On Tue, Jul 26, 2016 at 12:06 PM, wrote:
> From: Ville Syrjälä
>
> Moving the clipped plane coordinates into drm_plane_state has been
> discussed a few times, but as no patches seems to have materialized,
> I decoded to do it myself. I also added a new helper function
> like drm_plane_helper_c
On Fri, Jul 29, 2016 at 5:04 AM, Bibby Hsieh
wrote:
> These patches based on 4.7-rc1 to clean up unused function & variable
> and use drm core function instead.
>
> The following patches are needed to cleanly apply on top of v4.7-rc1:
> - https://patchwork.kernel.org/patch/8044001/
>(drm: De
On Mon, Aug 01, 2016 at 11:12:05AM -0400, Sean Paul wrote:
> On Tue, Jul 26, 2016 at 12:06 PM, wrote:
> > From: Ville Syrjälä
> >
> > Moving the clipped plane coordinates into drm_plane_state has been
> > discussed a few times, but as no patches seems to have materialized,
> > I decoded to do
:
<https://lists.freedesktop.org/archives/dri-devel/attachments/20160801/f9372b92/attachment.html>
wine too.
--
You are receiving this mail because:
You are the assignee for the bug.
-- next part --
An HTML attachment was scrubbed...
URL:
<https://lists.freedesktop.org/archives/dri-devel/attachments/20160801/aa2cf5fe/attachment-0001.html>
1] https://pci-ids.ucw.cz/read/PC/1002/6938
--
You are receiving this mail because:
You are the assignee for the bug.
-- next part --
An HTML attachment was scrubbed...
URL:
<https://lists.freedesktop.org/archives/dri-devel/attachments/20160801/9183cd5f/attachment.html>
suspect it is one of those "as soon as threading is pushed
lockup happens" ;)
--
You are receiving this mail because:
You are the assignee for the bug.
-- next part --
An HTML attachment was scrubbed...
URL:
<https://lists.freedesktop.org/archives/dri-devel/attachm
his mail because:
You are the assignee for the bug.
-- next part --
An HTML attachment was scrubbed...
URL:
<https://lists.freedesktop.org/archives/dri-devel/attachments/20160801/34d870f9/attachment.html>
chment was scrubbed...
URL:
<https://lists.freedesktop.org/archives/dri-devel/attachments/20160801/bb3f3bfc/attachment.html>
On Sun, Jul 31, 2016 at 09:55:36PM +0200, Peter Senna Tschudin wrote:
> Devicetree bindings documentation for the GE B850v3 LVDS/DP++
> display bridge.
>
> Cc: Javier Martinez Canillas
> Cc: Enric Balletbo i Serra
> Cc: Philipp Zabel
> Cc: Rob Herring
> Cc: Fabio Estevam
> Signed-off-by: Pete
-- next part --
An HTML attachment was scrubbed...
URL:
<https://lists.freedesktop.org/archives/dri-devel/attachments/20160801/be41328b/attachment.html>
scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 473 bytes
Desc: not available
URL:
<https://lists.freedesktop.org/archives/dri-devel/attachments/20160801/e843072f/attachment-0001.sig>
On 08/01/2016 03:59 PM, Jani Nikula wrote:
> Cc Andrzej, Thierry
>
> On Fri, 22 Jul 2016, Daniel Vetter wrote:
>> On Fri, Jul 22, 2016 at 04:30:24PM +0200, Takashi Iwai wrote:
>>> Hi,
>>>
>>> is there any reason drm-mipi-dsi can't be a module? It's fixed as a
>>> built-in since its Kconfig is boo
URL:
<https://lists.freedesktop.org/archives/dri-devel/attachments/20160801/7529c1f0/attachment.html>
--
An HTML attachment was scrubbed...
URL:
<https://lists.freedesktop.org/archives/dri-devel/attachments/20160801/2dcb169f/attachment.html>
On Sun, Jul 31, 2016 at 11:27 PM, Yakir Yang wrote:
> Sean,
>
> On 07/30/2016 03:16 AM, Sean Paul wrote:
>>
>> Instead of just preparing the panel on bind, actually prepare/unprepare
>> during modeset/disable. The panel must be prepared in order to read hpd
>> status, so we need to refcount the pr
On Mon, Aug 1, 2016 at 4:20 PM, Sean Paul wrote:
> On Sun, Jul 31, 2016 at 11:27 PM, Yakir Yang wrote:
>> Sean,
>>
>> On 07/30/2016 03:16 AM, Sean Paul wrote:
>>>
>>> Instead of just preparing the panel on bind, actually prepare/unprepare
>>> during modeset/disable. The panel must be prepared in
<https://lists.freedesktop.org/archives/dri-devel/attachments/20160801/6b6fce73/attachment.html>
Hi Lucas,
Thank you for the prompt review.
On Monday, August 1, 2016 10:54 CEST, Lucas Stach
wrote:
> Am Sonntag, den 31.07.2016, 21:55 +0200 schrieb Peter Senna Tschudin:
> > As the IPU has combined limitations across multiple crtcs, and as that
> > can't be communicated to userspace at the
On 07/29/2016 04:38 PM, Tomeu Vizoso wrote:
> On 5 April 2016 at 04:06, Yakir Yang wrote:
>> Hi Daniel,
>>
>>
>> On 03/31/2016 06:15 PM, Daniel Vetter wrote:
>>> On Mon, Feb 15, 2016 at 07:08:05PM +0800, Yakir Yang wrote:
Hi all,
The Samsung Exynos eDP controller and Rockchip R
Hi Jose
Cc: Mark, Thierry, Daniel
> > From: Kuninori Morimoto
> >
> > Current dw-hdmi is supporting sound via AHB bus, but it has
> > I2S audio feature too. This patch adds I2S audio support to dw-hdmi.
> > This HDMI I2S is supported by using ALSA SoC common HDMI encoder
> > driver.
> >
> > Sign
Hi
- Original Message -
> On Fri, Jul 29, 2016 at 3:57 PM, Rob Herring wrote:
> > Hi,
> >
> > This commit in virglrenderer causes a regression in Android for me.
> > The parameters that get passed in are last_level = 8, width = 1. I'm
> > not really sure if this is valid (I'm guessing th
Hi Lin,
On 2016ë
07ì 29ì¼ 16:56, Lin Huang wrote:
> rk3399 platform have dfi controller can monitor ddr load,
> and dcf controller to handle ddr register so we can get the
> right ddr frequency and make ddr controller happy work(which
> will implement in bl31). So we do ddr frequency scaling
Hi Lin,
Because you remove the 'RFC' prefix on patch title,
I think that you better to make the documentation as following:
- Documentation/devicetree/bindings/devfreq/event/rockchip-dfi.txt
Regards,
Chanwoo Choi
On 2016ë
07ì 29ì¼ 16:56, Lin Huang wrote:
> on rk3399 platform, there is dfi
Hi,
On 01-08-2016 05:57, Kuninori Morimoto wrote:
> Hi Jose
> Cc: Mark, Thierry, Daniel
>
>>> From: Kuninori Morimoto
>>>
>>> Current dw-hdmi is supporting sound via AHB bus, but it has
>>> I2S audio feature too. This patch adds I2S audio support to dw-hdmi.
>>> This HDMI I2S is supported by usin
Hi Lin,
I add the one minor comment for full name of 'DRI'.
On 2016ë
08ì 01ì¼ 16:41, Chanwoo Choi wrote:
> Hi Lin,
>
> Because you remove the 'RFC' prefix on patch title,
> I think that you better to make the documentation as following:
> - Documentation/devicetree/bindings/devfreq/event/r
Hi Chanwoo Choi,
On 2016å¹´08æ01æ¥ 16:08, Chanwoo Choi wrote:
> Hi Lin,
>
> I add the one minor comment for full name of 'DRI'.
>
> On 2016ë
08ì 01ì¼ 16:41, Chanwoo Choi wrote:
>> Hi Lin,
>>
>> Because you remove the 'RFC' prefix on patch title,
>> I think that you better to make the docum
Hi Lin,
As I mentioned on patch5, you better to make the documentation as following:
- Documentation/devicetree/bindings/devfreq/rk3399_dmc.txt
And, I add the comments.
On 2016ë
07ì 29ì¼ 16:57, Lin Huang wrote:
> base on dfi result, we do ddr frequency scaling, register
> dmc driver to dev
Hi Lin,
On 2016ë
08ì 01ì¼ 17:27, hl wrote:
> Hi Chanwoo Choi,
>
> On 2016å¹´08æ01æ¥ 16:08, Chanwoo Choi wrote:
>> Hi Lin,
>>
>> I add the one minor comment for full name of 'DRI'.
>>
>> On 2016ë
08ì 01ì¼ 16:41, Chanwoo Choi wrote:
>>> Hi Lin,
>>>
>>> Because you remove the 'RFC' pref
On Fri, Jun 24, 2016 at 11:40:44AM +0900, Kuninori Morimoto wrote:
> +static int snd_dw_hdmi_probe(struct platform_device *pdev)
> +{
> + struct dw_hdmi_i2s_audio_data *audio = pdev->dev.platform_data;
> + struct platform_device_info pdevinfo;
> + struct hdmi_codec_pdata pdata;
> +
> +
On mainboards with analog VGA output the memory size is incorrectly
detected due to an invalid register probe. This leads to a corrupted
and unusable framebuffer on the analog VGA output.
Do not probe the DP501-related VGA scratch register if the DP501
device was not detected.
Tested-on: ASUS K
On 08/01/2016 02:13 AM, Philipp Zabel wrote:
> Am Sonntag, den 31.07.2016, 12:42 -0700 schrieb Steve Longerbeam:
>> Adds ipu_cpmem_set_uv_offset(), to set planar U/V offsets.
>>
>> Signed-off-by: Steve Longerbeam
> There is no need to resend already applied patches.
>
Ok, I wasn't sure whether to
Hi Chanwoo Choi,
Ah, i am base on
https://chromium.googlesource.com/chromiumos/third_party/kernel/v4.4,
and forget to rebase on
https://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git, i
will fix it in next version.
I am sorry about that. And can you help to review the devfreq
Hi Lin,
On 2016ë
08ì 01ì¼ 16:46, hl wrote:
> Hi Chanwoo Choi,
>
> Ah, i am base on
> https://chromium.googlesource.com/chromiumos/third_party/kernel/v4.4,
> and forget to rebase on
> https://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git, i will
> fix it in next version.
Remove comment for non-existent parameter in psbfb_alloc().
Signed-off-by: Jiang Biao
---
drivers/gpu/drm/gma500/framebuffer.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/gpu/drm/gma500/framebuffer.c
b/drivers/gpu/drm/gma500/framebuffer.c
index 7440bf9..f323989 100644
--- a/driv
On 08/01/2016 02:13 AM, Philipp Zabel wrote:
> Am Sonntag, den 31.07.2016, 12:42 -0700 schrieb Steve Longerbeam:
>> Adds functions to link and unlink source channels to sink
>> channels in the FSU:
>>
>> int ipu_fsu_link(struct ipu_soc *ipu, int src_ch, int sink_ch);
>> int ipu_fsu_unlink(struct ip
On 08/01/2016 02:13 AM, Philipp Zabel wrote:
>
> Please remove the unused headers. I think you can remove all but
> export.h, types.h, errno.h, and io.h.
> Other than that, the patch now looks fine to me.
>
I was able to prune all but io.h, the rest is provided by ipu-prv.h.
Steve
On Mon, Aug 1, 2016 at 9:32 PM, Dave Airlie wrote:
>
> This is the main drm pull request for 4.8, I'm down with a cold at the moment
> so hopefully this isn't in too bad a state, I finished pulling stuff last
> week mostly (nouveau fixes just went in today), so only this message should
> be influe
Sean,
On 07/30/2016 03:16 AM, Sean Paul wrote:
> Instead of just preparing the panel on bind, actually prepare/unprepare
> during modeset/disable. The panel must be prepared in order to read hpd
> status, so we need to refcount the prepares in order to ensure we don't
> accidentally turn the panel
68 matches
Mail list logo