On Thu, Jul 25, 2019 at 5:41 AM Christoph Hellwig wrote:
>
> On Wed, Jul 24, 2019 at 11:20:31AM -0400, Andrew F. Davis wrote:
> > Well then lets think on this. A given buffer can have 3 owners states
> > (CPU-owned, Device-owned, and Un-owned). These are based on the caching
> > state from the CPU
On Wed, Jul 24, 2019 at 11:20:31AM -0400, Andrew F. Davis wrote:
> Well then lets think on this. A given buffer can have 3 owners states
> (CPU-owned, Device-owned, and Un-owned). These are based on the caching
> state from the CPU perspective.
>
> If a buffer is CPU-owned then we (Linux) can writ
On 7/24/19 2:55 AM, Christoph Hellwig wrote:
> On Tue, Jul 23, 2019 at 01:09:55PM -0700, Rob Clark wrote:
>> On Mon, Jul 22, 2019 at 9:09 PM John Stultz wrote:
>>>
>>> On Thu, Jul 18, 2019 at 3:06 AM Christoph Hellwig
>>> wrote:
Is there any exlusion between mmap / vmap and the device
On Mon, Jul 22, 2019 at 09:09:25PM -0700, John Stultz wrote:
> On Thu, Jul 18, 2019 at 3:06 AM Christoph Hellwig wrote:
> >
> > > +void INIT_HEAP_HELPER_BUFFER(struct heap_helper_buffer *buffer,
> > > + void (*free)(struct heap_helper_buffer *))
> >
> > Please use a lower
On Tue, Jul 23, 2019 at 01:09:55PM -0700, Rob Clark wrote:
> On Mon, Jul 22, 2019 at 9:09 PM John Stultz wrote:
> >
> > On Thu, Jul 18, 2019 at 3:06 AM Christoph Hellwig
> > wrote:
> > >
> > > Is there any exlusion between mmap / vmap and the device accessing
> > > the data? Without that you ar
On Mon, Jul 22, 2019 at 9:09 PM John Stultz wrote:
>
> On Thu, Jul 18, 2019 at 3:06 AM Christoph Hellwig wrote:
> >
> > Is there any exlusion between mmap / vmap and the device accessing
> > the data? Without that you are going to run into a lot of coherency
> > problems.
dma_fence is basically
On Thu, Jul 18, 2019 at 3:06 AM Christoph Hellwig wrote:
>
> > +void INIT_HEAP_HELPER_BUFFER(struct heap_helper_buffer *buffer,
> > + void (*free)(struct heap_helper_buffer *))
>
> Please use a lower case naming following the naming scheme for the
> rest of the file.
Yes!
> +void INIT_HEAP_HELPER_BUFFER(struct heap_helper_buffer *buffer,
> + void (*free)(struct heap_helper_buffer *))
Please use a lower case naming following the naming scheme for the
rest of the file.
> +static void *dma_heap_map_kernel(struct heap_helper_buffer *buffer)
>
Add generic helper dmabuf ops for dma heaps, so we can reduce
the amount of duplicative code for the exported dmabufs.
This code is an evolution of the Android ION implementation, so
thanks to its original authors and maintainters:
Rebecca Schultz Zavin, Colin Cross, Laura Abbott, and others!
C