On 2022/10/26 02:17, Jason Gunthorpe wrote:
This error unwind is getting complicated. Move all the code into two
pair'd function. The functions should be called when the open_count == 1
after incrementing/before decrementing.
Signed-off-by: Jason Gunthorpe
---
drivers/vfio/vfio_main.c | 95 ++
On Tue, Nov 01, 2022 at 07:33:30AM +, Tian, Kevin wrote:
> > + /*
> > +* Here we pass the KVM pointer with the group under the read lock.
>
> Now the read lock is replaced by mutex. Let's correct it when moving this
> piece of code.
Done, thanks
Jason
> From: Jason Gunthorpe
> Sent: Wednesday, October 26, 2022 2:17 AM
>
> This error unwind is getting complicated. Move all the code into two
> pair'd function. The functions should be called when the open_count == 1
> after incrementing/before decrementing.
>
> Signed-off-by: Jason Gunthorpe
R
This error unwind is getting complicated. Move all the code into two
pair'd function. The functions should be called when the open_count == 1
after incrementing/before decrementing.
Signed-off-by: Jason Gunthorpe
---
drivers/vfio/vfio_main.c | 95 ++--
1 file