> From: Jason Gunthorpe <j...@nvidia.com>
> Sent: Wednesday, October 26, 2022 2:17 AM
> 
> This error unwind is getting complicated. Move all the code into two
> pair'd function. The functions should be called when the open_count == 1
> after incrementing/before decrementing.
> 
> Signed-off-by: Jason Gunthorpe <j...@nvidia.com>

Reviewed-by: Kevin Tian <kevin.t...@intel.com>, with a nit

> +     /*
> +      * Here we pass the KVM pointer with the group under the read lock.

Now the read lock is replaced by mutex. Let's correct it when moving this
piece of code.

Reply via email to