On Wed, 05 Sep 2018 at 10:37:39 +0100 Eric Engestrom wrote:
> Hey Karsten, thanks for the patch! I don't know if it's correct or not,
> but I'll comment on a few other things.
>
> The title of the commit should be a description of what your commit does;
> in this case you should probably keep th
.
If mode_valid is clear, mode and fb will be NULL.
Therefore, we just check mode_valid and NOT mode or fb.
4. Moved kfree inside if statement
Signed-off-by: Satendra Singh Thakur
---
v1: Hi Mr Maarten, Thanks for the comments.
I have fixed some of them and done more modifications to th
1. Currently conn_state->crtc is getting assigned a value at two places
We can just reduce this assignment to one
Signed-off-by: Satendra Singh Thakur
---
v1: Hi Mr Maarten, Thanks for the comments.
I have modified the patch suitably. Please review.
drivers/gpu/drm/drm_atomic.c
On Mon, 30 Jul 2018 at 09:33:55 -0400 Sean Paul wrote:
>Maybe this is simpler, but not overwhelmingly so.
>To be honest, I'm a bit concerned with the volume of no-op patches you're
>sending to the list. I so appreciate and encourage your participation,
>but perhaps we could redirect your efforts.
. Currently conn_state->crtc is getting assigned a value at two places
We can just reduce this assignment to one
Signed-off-by: Satendra Singh Thakur
---
drivers/gpu/drm/drm_atomic.c | 9 -
1 file changed, 4 insertions(+), 5 deletions(-)
diff --git a/drivers/gpu/drm/drm_atomic.
NULL check
Signed-off-by: Satendra Singh Thakur
---
drivers/gpu/drm/drm_plane.c | 17 +
1 file changed, 9 insertions(+), 8 deletions(-)
diff --git a/drivers/gpu/drm/drm_plane.c b/drivers/gpu/drm/drm_plane.c
index 0350544..ed42cd4 100644
--- a/drivers/gpu/drm/drm_plane.c
+++ b/driv
Satendra Singh Thakur
---
drivers/gpu/drm/drm_crtc.c | 25 +++--
1 file changed, 15 insertions(+), 10 deletions(-)
diff --git a/drivers/gpu/drm/drm_crtc.c b/drivers/gpu/drm/drm_crtc.c
index 98a36e6..9644f5b 100644
--- a/drivers/gpu/drm/drm_crtc.c
+++ b/drivers/gpu/drm/dr
checks will be required.
Thus shifting of if (ret == -EDEADLK) right after out label
won't affect normal case.
5. Also, kfree is moved inside if (connector_set).
6. Also, if major error checks are in the beginning of the func
and if user supplied invalid params, we will exit the func sooner
In the func drm_atomic_plane_check, the fb geometry checking code
can be replaced by func drm_framebuffer_check_src_coords, this will
remove several redundant lines of code.
Signed-off-by: Satendra Singh Thakur
---
v1: Hi Mr Maarten, Thanks for the comments.
I have splitted them into two
first we check whether crtc and fb both are NULL
if (!state->crtc && !state->fb)
then we check either crtc or fb is NULL
if (!state->crtc || !state->fb)
Signed-off-by: Satendra Singh Thakur
---
drivers/gpu/drm/drm_atomic.c | 37 +
1 file ch
is NULL (and fb is also NULL)
if (!state->crtc)
The same code can be re-written using 2 if statements and 4 conditions.
first we check whether crtc and fb both are NULL
if (!state->crtc && !state->fb)
then we check either crtc or fb is NULL
if (!state->crtc || !state->fb)
S
On Thu, May 08, 2018 at 16:28:30 +0530, Satendra Singh Thakur wrote:
> On Thu, May 07, 2018 at 15:46:02 +0200, Daniel Vetter wrote:
> > On Thu, May 03, 2018 at 01:53:55PM +0530, Satendra Singh Thakur wrote:
> > > 1.There is a function in drm-core to calculate display
On Thu, May 07, 2018 at 15:46:02 +0200, Daniel Vetter wrote:
> On Thu, May 03, 2018 at 01:53:55PM +0530, Satendra Singh Thakur wrote:
> > 1.There is a function in drm-core to calculate display timing parameters:
> > horizontal front porch, back porch, sync length,
> > verti
-Using drm_display_mode_to_videomode to avoid duplicate logic
-Removed index = drm_crtc_index(crtc) as it is unused
-Replaced DRM_MODE_FLAG_* flags with DISPLAY_FLAGS_* flags
-Replaced mode->h/vdisplay with vm.h/vactive
Acked-by: Stefan Agner
Signed-off-by: Satendra Singh Thakur
Cc: Mad
To avoid duplicate logic for the same
Signed-off-by: Satendra Singh Thakur
Acked-by: Madhur Verma
Cc: Hemanshu Srivastava
---
v2: Removed Mr Robin from reviewed-by field
drivers/gpu/drm/exynos/exynos_drm_dsi.c | 13 ++---
1 file changed, 2 insertions(+), 11 deletions(-)
diff
drivers will be using this new helper
-arm hdlcd
-atmel hlcdc
-exynos 5433 decon
-exynos7 decon
-exynos fimd
4.
-This change reduces several redundant lines of code for many drivers
Acked-by: Liviu Dudau
Signed-off-by: Satendra Singh Thakur
Acked-by: Madhur Verma
Cc: Hemanshu Srivastava
To avoid duplicate logic for the same
Signed-off-by: Satendra Singh Thakur
Cc: Madhur Verma
Cc: Hemanshu Srivastava
---
drivers/gpu/drm/fsl-dcu/fsl_dcu_drm_crtc.c | 29 -
1 file changed, 12 insertions(+), 17 deletions(-)
diff --git a/drivers/gpu/drm/fsl-dcu
-Duplicate logic for the timing params is avoided
-Arithmatic operator *,/ are replaced by logical >>, << operators
-The flags DRM_MODE_FLAG_* are replaced with DISPLAY_FLAGS_* flags
Signed-off-by: Satendra Singh Thakur
Cc: Madhur Verma
Cc: Hemanshu Srivastava
---
drivers/gpu/
.
Therefore, there is a duplication of the code.
This patch series replaces this redundant code with the function
drm_display_mode_to_videomode.
This removes nearly 100 redundant lines from the related drivers.
Signed-off-by: Satendra Singh Thakur
Cc: Madhur Verma
Cc: Hemanshu Srivastava
On Thu, May 03, 2018 at 11:36:39 +0100, Liviu Dudau wrote:
> On Thu, May 03, 2018 at 11:28:37AM +0530, Satendra Singh Thakur wrote:
> > 1.
> > -Added a new helper drm_display_mode_crtc_to_videomode
> > -This helper calculates mode parameters like
> > horizontal fr
To avoid duplicate logic for the same
Signed-off-by: Satendra Singh Thakur
Cc: Madhur Verma
Cc: Hemanshu Srivastava
---
drivers/gpu/drm/tilcdc/tilcdc_crtc.c | 60
1 file changed, 27 insertions(+), 33 deletions(-)
diff --git a/drivers/gpu/drm/tilcdc
To avoid duplicate logic for the same
Reviewed-by: Robin Murphy
Signed-off-by: Satendra Singh Thakur
Acked-by: Madhur Verma
Cc: Hemanshu Srivastava
---
drivers/gpu/drm/exynos/exynos_drm_dsi.c | 13 ++---
1 file changed, 2 insertions(+), 11 deletions(-)
diff --git a/drivers/gpu/drm
To avoid duplicate logic for timing parameters
Signed-off-by: Satendra Singh Thakur
Cc: Madhur Verma
Cc: Hemanshu Srivastava
---
drivers/gpu/drm/bridge/tc358767.c | 42 ++-
1 file changed, 19 insertions(+), 23 deletions(-)
diff --git a/drivers/gpu/drm
To avoid duplicate logic for horizonal/vertical sync_start/end
helper func drm_display_mode_from_videomode is used
Acked-by: Maxime Ripard
Signed-off-by: Satendra Singh Thakur
Acked-by: Madhur Verma
Cc: Hemanshu Srivastava
---
v1: Added acked-by fields
drivers/gpu/drm/sun4i/sun4i_tv.c
To avoid duplicate logic for the same
Signed-off-by: Satendra Singh Thakur
Cc: Madhur Verma
Cc: Hemanshu Srivastava
---
drivers/gpu/drm/gma500/mdfld_dsi_dpi.c | 28 ++--
1 file changed, 10 insertions(+), 18 deletions(-)
diff --git a/drivers/gpu/drm/gma500
To avoid duplicate logic for the same
Signed-off-by: Satendra Singh Thakur
Cc: Madhur Verma
Cc: Hemanshu Srivastava
---
drivers/gpu/drm/tegra/dc.c | 15 +++
1 file changed, 7 insertions(+), 8 deletions(-)
diff --git a/drivers/gpu/drm/tegra/dc.c b/drivers/gpu/drm/tegra/dc.c
index
To avoid duplicate logic for horizonal/vertical sync_start/end
helper func drm_display_mode_from_videomode is used
Signed-off-by: Satendra Singh Thakur
Cc: Madhur Verma
Cc: Hemanshu Srivastava
---
drivers/gpu/drm/sun4i/sun4i_tv.c | 67 +++-
1 file changed
To avoid duplicate logic for the same
Signed-off-by: Satendra Singh Thakur
Cc: Madhur Verma
Cc: Hemanshu Srivastava
---
drivers/gpu/drm/pl111/pl111_display.c | 40 +--
1 file changed, 15 insertions(+), 25 deletions(-)
diff --git a/drivers/gpu/drm/pl111
drivers will be using this new helper
-arm hdlcd
-atmel hlcdc
-exynos 5433 decon
-exynos7 decon
-exynos fimd
4.
-This change reduces several redundant lines of code for many drivers
Reviewed-by: Jani Nikula
Acked-by: Liviu Dudau
Signed-off-by: Satendra Singh Thakur
Acked-by: Madhur Verma
Cc
-Duplicate logic for the timing params is avoided
-Arithmatic operator *,/ are replaced by logical >>, << operators
-The flags DRM_MODE_FLAG_* are replaced with DISPLAY_FLAGS_* flags
-Combined similar if statements
Signed-off-by: Satendra Singh Thakur
Cc: Madhur Verma
Cc: Hemansh
ncoder
pl111-display
sun4i-tv
ti lcdc
tegra dc
mediatek dpi dsi
bridge-adv7533
Satendra Singh Thakur (13):
drm/kms/mode/atmel-hlcdc: using helper func
drm_display_mode_to_videomode for calculating timing parameters
drm/kms/mode/bridge-tc358767: using helper func
drm_display_mode_to_v
-Avoidded duplicate logic for the timing calculations
-Removed func ade_set_pix_clk and combined it with func ade_ldi_set_mode
Signed-off-by: Satendra Singh Thakur
Cc: Madhur Verma
Cc: Hemanshu Srivastava
---
drivers/gpu/drm/hisilicon/kirin/dw_drm_dsi.c| 42 ++--
drivers
.
Therefore, there is a duplication of the code.
This patch series replaces this redundant code with the function
drm_display_mode_to_videomode.
This removes nearly 100 redundant lines from the related drivers.
Signed-off-by: Satendra Singh Thakur
Cc: Madhur Verma
Cc: Hemanshu Srivastava
To avoid duplicate logic for the same
Signed-off-by: Satendra Singh Thakur
Cc: Madhur Verma
Cc: Hemanshu Srivastava
---
drivers/gpu/drm/exynos/exynos_drm_dsi.c | 9 +
1 file changed, 1 insertion(+), 8 deletions(-)
diff --git a/drivers/gpu/drm/exynos/exynos_drm_dsi.c
b/drivers/gpu
drivers will be using this new helper
-arm hdlcd
-atmel hlcdc
-exynos 5433 decon
-exynos7 decon
-exynos fimd
4.
-This patch removes related duplicate code from above mentioned drivers
Signed-off-by: Satendra Singh Thakur
Cc: Madhur Verma
Cc: Hemanshu Srivastava
---
drivers/gpu/drm/arm
.
Ideally, we should do nothing in this case, this patch handles the same,
and causes the program to return without doing anything in such scenario.
Signed-off-by: Satendra Singh Thakur
Cc: Madhur Verma
Cc: Hemanshu Srivastava
---
drivers/gpu/drm/drm_atomic.c | 4 +++-
1 file changed, 3
This patch uses existing method drm_display_mode_to_videomode for
calculating front/back porches, sync lengths for mediatek dsi/dpi drivers;
instead of manually calculating them
Signed-off-by: Satendra Singh Thakur
---
drivers/gpu/drm/mediatek/mtk_dpi.c | 60
Satendra,
On 20 January 2017 at 08:12, Satendra Singh Thakur
wrote:
> -Added a new ioctl in Linux DRM KMS driver.
> This ioctl allows user to set the values of an object’s multiple
> properties in one go.
> -In the absence of such ioctl, User would be calling one ioctl to set each
From: satendra singh thakur
-Added a new ioctl in Linux DRM KMS driver.
This ioctl allows user to set the values of an object’s multiple
properties in one go.
-In the absence of such ioctl, User would be calling one ioctl to set each
property value;
Thus, user needs to call N ioctls to set
39 matches
Mail list logo