While I realize this is unlikely to be an option for gaia, I'll just
note that for (Firefox Desktop's) Australis' Customization Mode, we
ended up just having a pref which tests toggle, in which case we set an
attribute, in which case we override the CSS transition duration to be
really short.
I'm happy to announce that the AsyncShutdown module is now considered
stable and to invite you to make use of it in your code, should you need
the feature.
The AsyncShutdown module is a simple mechanism designed to help us
handle dependencies between asynchronous modules during shutdown. A
typical
I am not following this thread as I should; however a contributor from
the Brazil community list was talking/planning a talk to the major
conference in Brazil - about MathML. Since he is a 'mozillian, I have
asked him to go through this whole thread and try to distill.
And he did digging work base
Do we have naming conventions for new xpcom interfaces?
I believe that I have seen all three forms on the tree. I need to pick
one for my new bug. Which one should I pick?
Cheers,
David
(Cross-posting to ask.mozilla.org)
--
David Rajchenbach-Teller, PhD
Performance Team, Mozilla
On 02/17/2014 03:15 PM, David Rajchenbach-Teller wrote:
Do we have naming conventions for new xpcom interfaces?
I believe that I have seen all three forms on the tree. I need to pick
one for my new bug. Which one should I pick?
For C++ interfaces, namespaced IFoo or Foo. For XPIDL interfaces,
On 2/17/14 9:29 AM, Ms2ger wrote:
For C++ interfaces, namespaced IFoo or Foo.
namespaced IFoo always makes me search MSDN for information about this
Windows interface we must be using... Why is that form preferable?
-Boris
___
dev-platform mailing
On Mon, Feb 17, 2014 at 6:36 AM, Boris Zbarsky wrote:
> On 2/17/14 9:29 AM, Ms2ger wrote:
>>
>> For C++ interfaces, namespaced IFoo or Foo.
>
>
> namespaced IFoo always makes me search MSDN for information about this
> Windows interface we must be using... Why is that form preferable?
>
> -Boris
On 17/02/2014 15:15, David Rajchenbach-Teller wrote:
Do we have naming conventions for new xpcom interfaces?
I believe that I have seen all three forms on the tree. I need to pick
one for my new bug. Which one should I pick?
afaik there has been a period where we tried to move off of nsI prefi
If you are observing several topics it's easy to forget to add a
Remove call when adding new observer topic. If you instead write an
array of topics and iterate over that it's impossible to screw up
(e.g. https://hg.mozilla.org/mozilla-central/rev/3a8fe7c942e3). We've
seen a couple of leaks cause
On 2/17/2014, 9:15 AM, David Rajchenbach-Teller wrote:
Do we have naming conventions for new xpcom interfaces?
I believe that I have seen all three forms on the tree. I need to pick
one for my new bug. Which one should I pick?
Avoid ISomething since that means something on Windows.
I think mo
On 2/17/2014, 12:11 PM, Marco Bonardo wrote:
On 17/02/2014 15:15, David Rajchenbach-Teller wrote:
Do we have naming conventions for new xpcom interfaces?
I believe that I have seen all three forms on the tree. I need to pick
one for my new bug. Which one should I pick?
afaik there has been a
On 2/17/14 12:41 PM, Ehsan Akhgari wrote:
On 2/17/2014, 9:15 AM, David Rajchenbach-Teller wrote:
Do we have naming conventions for new xpcom interfaces?
I believe that I have seen all three forms on the tree. I need to pick
one for my new bug. Which one should I pick?
Avoid ISomething since t
Hello,
I recently changed a way to declare function pointers to be loaded
lazily on Windows.
Traditionally, we have to write a function prototype manually to declare
a function pointer. Example:
typedef int (WINAPI *tMessageBoxW)(HWND, LPCWSTR, LPCWSTR, UINT);
tMessageBoxW messageBoxW =
On 02/17/2014 11:18 PM, Justin Dolske wrote:
On 2/17/14 12:41 PM, Ehsan Akhgari wrote:
On 2/17/2014, 9:15 AM, David Rajchenbach-Teller wrote:
Do we have naming conventions for new xpcom interfaces?
I believe that I have seen all three forms on the tree. I need to pick
one for my new bug. Which
14 matches
Mail list logo