On Wed, 4 Mar 2015 06:10:25 +0100
Florian Bruhin wrote:
Hey Florian,
> I recently added qutebrowser to the "rocks" page and it was
> subsequently removed[1]. I accept that, though it raises a few
> questions:
I sincerely hope you don't have to go into psychiatric treatment
resulting from the se
On Tue, Mar 3, 2015 at 10:14 PM, Greg Reagle wrote:
> "/usr/local/bin/surf" is a lot of typing compared to "surf".
>
There's probably a command builtin for your shell. However if you're
saving typing inside a launcher script you write, you might be saving
it in the wrong place.
This whole discu
On March 3, 2015 5:21:04 PM PST, Roger wrote:
>ST appears to compile and run fine on 64 bit and 32 bit platorms,
>except on 32
>bit (i686/pentium3), typing is extremely slow.
Try adjusting xfps and actionfps. When I had this issue on a 32 bit machine, I
seem to remember changing fps worked.
Hi!
I recently added qutebrowser to the "rocks" page and it was
subsequently removed[1]. I accept that, though it raises a few
questions:
Is that page for software (more or less) adhering to the suckless
philosophy, or is it (or at least the "application" section) about
things *working well with
> > > https://github.com/mpu/ninja
> >
> > Name clash. Ninja's a build system.
> >
> > http://martine.github.io/ninja/
>
> Hi Alex, the "name" I was asking for is "miniyacc".
Pardon me, I wasn't clear. It's just the project name with which I was
concerned. Suppose that miniyacc's adopted by su
> On Tue, Mar 03, 2015 at 09:20:23PM -0500, Roger wrote:
>>... getting "EAGAIN (Resource temporarily unavailable)", while the pselect
>>call only handles EINTR errno condition?
>
>bah. Just read-up pselect and found EAGAIN a normal return, and likely
>shouldn't delay chars printing to the scree
Alex Pilon wrote:
> On Tue, Mar 03, 2015 at 06:50:27PM +, Quentin wrote:
> > https://github.com/mpu/ninja
>
> Name clash. Ninja's a build system.
>
> http://martine.github.io/ninja/
Hi Alex, the "name" I was asking for is "miniyacc".
>... getting "EAGAIN (Resource temporarily unavailable)", while the pselect
>call only handles EINTR errno condition?
bah. Just read-up pselect and found EAGAIN a normal return, and likely
shouldn't delay chars printing to the screen.
--
Roger
http://rogerx.freeshell.org/
ST appears to compile and run fine on 64 bit and 32 bit platorms, except on 32
bit (i686/pentium3), typing is extremely slow.
Using strace/ltrace on the latest stable 0.5, I see some hangups on the
"select" call. Using the git version, I now see select substituted with
pselect. The following
On Tue, Mar 03, 2015 at 06:50:27PM +, Quentin wrote:
> https://github.com/mpu/ninja
Name clash. Ninja's a build system.
http://martine.github.io/ninja/
Would that not be an issue?
Regards,
Alex Pilon
pgpcLvT2MogFg.pgp
Description: PGP signature
On Tue, Mar 3, 2015, at 04:04 PM, Raphaël Proust wrote:
> Why do you call it `mysurf` instead of just `surf`?
Because it's not the same as surf. It behaves differently than surf.
> (You could still
> launch the original surf using /usr/bin/surf or whatever is
> appropriate on your system.)
"/us
On Tue, Mar 3, 2015 at 7:19 PM, Greg Reagle wrote:
> Here is the script I use to launch surf called mysurf:
> […]
> I don't launch surf directly
Why do you call it `mysurf` instead of just `surf`? (You could still
launch the original surf using /usr/bin/surf or whatever is
appropriate on your sys
I am presenting this in case you find it interesting, useful, or
instructive, or for any constructive criticism so I can learn more.
Here is the script I use to launch surf called mysurf:
#!/bin/sh
cd ~/downloads
exec surf "$@" 2>>surf-stder >>surf-stdout
I don't launch surf directly because:
I
Hi,
I have something that looks like a Yacc [0]. Here is
what you guys can do:
+ play with it and find bugs
[0] https://github.com/mpu/ninja
+ fix the bugs you found!
+ criticize it
+ suggest me a better name
+ print it and use it as wallpaper
I did not decide on the license y
FRIGN said:
> Or gcc(1), "generate cool columns".
This.
--
Dmitrij D. Czarkoff
On Tue, 3 Mar 2015 13:40:04 +
Dimitris Papastamos wrote:
> This reminds me, we should really find another name for cols(1) now that
> we have col(1).
>
> Any ideas?
Maybe bw(1) as opposed to col(1) (black/white - color).
Or gcc(1), "generate cool columns".
Cheers
FRIGN
--
FRIGN
On 3 March 2015 at 15:22, Connor Lane Smith wrote:
> On 3 March 2015 at 13:40, Dimitris Papastamos wrote:
>> This reminds me, we should really find another name for cols(1) now that
>> we have col(1).
>
> I suggested mcol(1) on IRC, given that it was originally mc(1), per Plan 9.
>
mcol(1) sound
On Tue, Mar 3, 2015, at 08:40 AM, Dimitris Papastamos wrote:
> This reminds me, we should really find another name for cols(1) now that
> we have col(1).
columnize, multicol
--
http://www.fastmail.com - Access all of your messages and folders
wherever you are
On 3 March 2015 at 13:40, Dimitris Papastamos wrote:
> This reminds me, we should really find another name for cols(1) now that
> we have col(1).
I suggested mcol(1) on IRC, given that it was originally mc(1), per Plan 9.
cls
On Tue, Mar 03, 2015 at 10:52:34AM +0100, Roberto E. Vargas Caballero wrote:
> col is used to display troff documents in ttys, removing the reverse
> line feeds generated by .2C in ms. This implementation keeps the limit
> of 256 lines of 800 characteres of the original implementation.
Thanks, I'v
> alloca() isn't even standard C, that's some black voodoo GNU sorcery
> right there.
>From alloca(2):
There is evedence that the alloca() function appeared in 32V,
PWB, PWD.2, 3BSD and 4BSD. There is a man page for it in
4.3BSD.
It was common before GNU, and it was not
> On Mon, Mar 2, 2015 at 3:56 PM, Anthony J. Bentley wrote:
>> VLAs are a fundamentally broken feature because they do not allow any
>> error checking. alloca() is the same.
>>
>> --
>> Anthony J. Bentley
>>
>
> But when do you ever do error checking of stack size? Is recursion a
> fundamentally
> It was my understanding that "Do not mix declarations and code" meant
> stick to ANSI C declarations. ANSI C allows declarations of variables
> only at the top of blocks, but allows them in any block so they aren't
> relegated to the top of the function. It was pointed out to me that
> "Do not mi
col is used to display troff documents in ttys, removing the reverse
line feeds generated by .2C in ms. This implementation keeps the limit
of 256 lines of 800 characteres of the original implementation.
---
Makefile | 1 +
README | 1 +
col.1| 90 +
col.c| 2
On Tue, Mar 3, 2015 at 12:56 AM, Anthony J. Bentley wrote:
> Evan Gates writes:
>> Declaring variables at the top of a block, as opposed to top of the
>> function has a few uses, but the most useful (in my limited
>> experience) is combining it with C99's variable length arrays to
>> create buffer
25 matches
Mail list logo