[ovs-dev] Nouvelle version d'123envoi pour envoyer de gros fichier !

2013-09-30 Thread Oph�lie PETIT
Title: Nouvelles licences 123envoi   Nouvelle version ! Vous avez déjà été en contact avec 123envoi ou vous êtes déjà clients de nos services e

[ovs-dev] [PATCH v3 2/4] datapath: Move mega-flow list out of rehashing struct.

2013-09-30 Thread Pravin B Shelar
ovs-flow rehash does not touch mega flow list. Following patch moves it dp struct datapath. Avoid one extra indirection for accessing mega-flow list head on every packet receive. Signed-off-by: Pravin B Shelar --- v3: No change. v2: No change. --- datapath/datapath.c | 77 +-

[ovs-dev] [PATCH v3 3/4] datapath: Simplify mega-flow APIs.

2013-09-30 Thread Pravin B Shelar
Hides mega-flow implementation in flow_table.c rather than datapath.c. This also helps next patch. Signed-off-by: Pravin B Shelar v3: No change. v2: No change. --- datapath/datapath.c | 27 +++--- datapath/flow_table.c | 136 - datapath/f

[ovs-dev] [PATCH v3 4/4] datapath: Scalable locking.

2013-09-30 Thread Pravin B Shelar
Following patch breaks down ovs_mutex into multiple locks. This patch specifically targets flow-install. By breaking down ovs-locking parallel flow-installs are possible. Signed-off-by: Pravin B Shelar --- v3: Handle dup flow in flow insert. v2: get rid of mask_list lock. --- datapath/datapath

Re: [ovs-dev] [PATCH v2 2/4] datapath: Move mega-flow list out of rehashing struct.

2013-09-30 Thread Jesse Gross
This on the previous version of the patch since I had already started writing it before you sent out the new version: On Thu, Sep 26, 2013 at 9:01 AM, Pravin B Shelar wrote: > ovs-flow rehash does not touch mega flow list. Following patch > moves it dp struct datapath. Avoid one extra indirectio

Re: [ovs-dev] [PATCH V2 1/3] ofproto-dpif: Move send_packet() to ofproto-dpif-xlate module.

2013-09-30 Thread Ethan Jackson
I think this is on the right track, just some minor comments. You aren't planning to have anyone call xlate_actions_unsafe() in future patches right? If that's true I'd rather keep the public API the same and do the safe/unsafe split internally. I.E: Rename xlate_actions_safe() to xlate_actions

[ovs-dev] [PATCH 1/2] bridge: Let ofprotos run once before reporting configuration complete.

2013-09-30 Thread Ben Pfaff
Occasionally in the unit tests the following race can happen: 1. ovs-vsctl updates database 2. ovs-vswitchd reconfigures, notifies ovs-vsctl that it is complete 3. ovs-appctl ofproto/trace fails to see newly added port 4. ovs-vswitchd main loop calls ofproto's ->type_run(), making the

Re: [ovs-dev] latest git from branch-2.0 failed to build

2013-09-30 Thread Ben Pfaff
On Mon, Sep 30, 2013 at 08:50:50AM +0400, Vasiliy Tolstov wrote: > Hi, all. I'm try to build deb package for openvswitch 2.0. > Now build fails: > https://launchpadlibrarian.net/151884888/buildlog_ubuntu-precise-amd64.openvswitch_2.0~201309300804-1ppa1~precise_FAILEDTOBUILD.txt.gz Thank you for th

[ovs-dev] [PATCH 2/2] lacp: Give LACP a moment to initialize before testing its state, in tests.

2013-09-30 Thread Ben Pfaff
These tests configured LACP and then immediately dumped out its state. Most of the time, this worked, but there was a brief race window in which the "negotiated" flag could be missing because this took one pass through the main loop. This fixes the problem. This race may be seen in the failures o

Re: [ovs-dev] [PATCH v2 2/4] datapath: Move mega-flow list out of rehashing struct.

2013-09-30 Thread Pravin Shelar
On Mon, Sep 30, 2013 at 1:16 PM, Jesse Gross wrote: > This on the previous version of the patch since I had already started > writing it before you sent out the new version: > > On Thu, Sep 26, 2013 at 9:01 AM, Pravin B Shelar wrote: >> ovs-flow rehash does not touch mega flow list. Following pat

Re: [ovs-dev] [PATCH V2 1/3] ofproto-dpif: Move send_packet() to ofproto-dpif-xlate module.

2013-09-30 Thread Alex Wang
On Mon, Sep 30, 2013 at 1:21 PM, Ethan Jackson wrote: > I think this is on the right track, just some minor comments. > > You aren't planning to have anyone call xlate_actions_unsafe() in > future patches right? If that's true I'd rather keep the public API > the same and do the safe/unsafe spli

Re: [ovs-dev] [PATCH v3 3/4] datapath: Simplify mega-flow APIs.

2013-09-30 Thread Jesse Gross
On Mon, Sep 30, 2013 at 1:01 PM, Pravin B Shelar wrote: > Hides mega-flow implementation in flow_table.c rather than > datapath.c. This also helps next patch. > > Signed-off-by: Pravin B Shelar Acked-by: Jesse Gross ___ dev mailing list dev@openvswit

Re: [ovs-dev] [PATCH V2 2/3] ofproto-dpif-monitor: Add ofproto-dpif-monitor module.

2013-09-30 Thread Ethan Jackson
On the right track, mostly nits at this point. I'd prefer we simply copied the hw_addr around instead of maintaining a pointer to the same data in multiple threads. It's only 6 bytes, so it shouldn't be too expensive. Let's rename ofproto_dpif_monitor_mport_update() => ofproto_dpif_monitor_port_

Re: [ovs-dev] [PATCH] ovs-dpctl, ofproto/trace: Show and handle the in_port name in flows.

2013-09-30 Thread Ben Pfaff
On Wed, Sep 25, 2013 at 12:55:43AM -0700, Gurucharan Shetty wrote: > With this commit, whenever the verbosity is enabled with '-m' > option, the ovs-dpctl dump-flows command will display the flows with > in_port field showing the name instead of a port number. > > Conversely, one can also use a na

Re: [ovs-dev] [PATCH v3 4/4] datapath: Scalable locking.

2013-09-30 Thread Jesse Gross
Some very quick high level things while I look at this: On Mon, Sep 30, 2013 at 1:01 PM, Pravin B Shelar wrote: > Following patch breaks down ovs_mutex into multiple locks. This > patch specifically targets flow-install. By breaking down > ovs-locking parallel flow-installs are possible. > > Si

[ovs-dev] [PATCH 1/2] flow: Fill in ->l7 in flow_compose().

2013-09-30 Thread Ben Pfaff
flow_extract() fills in ->l7 but flow_compose() wasn't doing it, which confused bfd_process_packet() when invoked via the ofproto/trace appctl command. Signed-off-by: Ben Pfaff --- lib/flow.c |1 + 1 file changed, 1 insertion(+) diff --git a/lib/flow.c b/lib/flow.c index 0678c6f..7372e3b 10

[ovs-dev] [PATCH 2/2] bfd: Improve log message.

2013-09-30 Thread Ben Pfaff
Signed-off-by: Ben Pfaff --- lib/bfd.c |6 -- 1 file changed, 4 insertions(+), 2 deletions(-) diff --git a/lib/bfd.c b/lib/bfd.c index 6c9e920..dbb0e13 100644 --- a/lib/bfd.c +++ b/lib/bfd.c @@ -625,8 +625,10 @@ bfd_process_packet(struct bfd *bfd, const struct flow *flow, msg = o

Re: [ovs-dev] [PATCH] ovs-dpctl, ofproto/trace: Show and handle the in_port name in flows.

2013-09-30 Thread Gurucharan Shetty
On Mon, Sep 30, 2013 at 2:20 PM, Ben Pfaff wrote: > On Wed, Sep 25, 2013 at 12:55:43AM -0700, Gurucharan Shetty wrote: >> With this commit, whenever the verbosity is enabled with '-m' >> option, the ovs-dpctl dump-flows command will display the flows with >> in_port field showing the name instead

Re: [ovs-dev] [PATCH V2 3/3] ofproto-dpif-monitor: Move ofproto-dpif-monitor to a single thread.

2013-09-30 Thread Ethan Jackson
Why do we need the bfd->last_tx change? Should it be in a different patch with a commit message explaining it? As discussed off list, the monitor_seq thing is a layering violation. Instead we should have a separate patch which causes time warp to wake up threads. I don't really like the function

Re: [ovs-dev] [PATCH] ovs-dpctl, ofproto/trace: Show and handle the in_port name in flows.

2013-09-30 Thread Ben Pfaff
On Mon, Sep 30, 2013 at 03:11:17PM -0700, Gurucharan Shetty wrote: > On Mon, Sep 30, 2013 at 2:20 PM, Ben Pfaff wrote: > > On Wed, Sep 25, 2013 at 12:55:43AM -0700, Gurucharan Shetty wrote: > >> With this commit, whenever the verbosity is enabled with '-m' > >> option, the ovs-dpctl dump-flows com

Re: [ovs-dev] [PATCH v3 1/4] datapath: Restructure datapath.c and flow.c

2013-09-30 Thread Jesse Gross
On Mon, Sep 30, 2013 at 1:01 PM, Pravin B Shelar wrote: > Over the time datapath.c and flow.c has became pretty large files. > Following patch restructures functionality of component into three > different components: > > flow.c: contains flow extract. > flow_netlink.c: netlink flow api. > flow_ta

Re: [ovs-dev] [PATCH v3] ofproto-dpif: Move special upcall handling into ofproto-dpif-upcall.

2013-09-30 Thread Ethan Jackson
Thanks for the review, sorry it took me so long to merge it. Ethan ___ dev mailing list dev@openvswitch.org http://openvswitch.org/mailman/listinfo/dev

Re: [ovs-dev] [PATCH v3] ofproto-dpif: Move special upcall handling into ofproto-dpif-upcall.

2013-09-30 Thread Ben Pfaff
On Mon, Sep 30, 2013 at 05:39:09PM -0700, Ethan Jackson wrote: > Thanks for the review, sorry it took me so long to merge it. No problem, I wouldn't care except that I'd told Yamamoto Takashi that I'd apply his patch from last week after yours went in. I'll take a look at that next. _

Re: [ovs-dev] [PATCH v3 1/4] datapath: Restructure datapath.c and flow.c

2013-09-30 Thread Jesse Gross
On Mon, Sep 30, 2013 at 1:01 PM, Pravin B Shelar wrote: > diff --git a/datapath/datapath.c b/datapath/datapath.c > index 4defcdb..7178513 100644 > --- a/datapath/datapath.c > +++ b/datapath/datapath.c > @@ -1428,12 +962,17 @@ static int ovs_flow_cmd_get(struct sk_buff *skb, > struct genl_info *in

Re: [ovs-dev] [PATCH 1/8] nsh: datapath support for network service headers

2013-09-30 Thread Jesse Gross
On Fri, Sep 20, 2013 at 1:04 AM, pritesh wrote: > This patch adds support for Network Service Headers (nsh) over VXLAN > as mentioned in [1]. Here changes are made to datapath to add nsh > headers whenever a vxlan port with destination port as 9030 is created. > IANA port allocation for nsh over v

Re: [ovs-dev] [PATCH 2/2] ofproto-dpif: Compute the subfacet add/del rate using coverage counters.

2013-09-30 Thread Ethan Jackson
Both of these look good to me. Would you please rebase them and send them out. Then I'll merge. Ethan On Tue, Sep 24, 2013 at 5:54 PM, Alex Wang wrote: > So far, the subfacet rates (e.g. add rate, del rate) are computed by > exponential moving averaging function in ofproto-dpif.c. This commit

Re: [ovs-dev] [PATCH V2 2/3] ofproto-dpif-monitor: Add ofproto-dpif-monitor module.

2013-09-30 Thread Alex Wang
On Mon, Sep 30, 2013 at 2:09 PM, Ethan Jackson wrote: > On the right track, mostly nits at this point. > > I'd prefer we simply copied the hw_addr around instead of maintaining > a pointer to the same data in multiple threads. It's only 6 bytes, so > it shouldn't be too expensive. > I see, I'l

Re: [ovs-dev] [PATCH 2/2] ofproto-dpif: Compute the subfacet add/del rate using coverage counters.

2013-09-30 Thread Alex Wang
Sure, I'll do that quickly, On Mon, Sep 30, 2013 at 6:05 PM, Ethan Jackson wrote: > Both of these look good to me. Would you please rebase them and send > them out. Then I'll merge. > > Ethan > > On Tue, Sep 24, 2013 at 5:54 PM, Alex Wang wrote: > > So far, the subfacet rates (e.g. add rate

[ovs-dev] [PATCH V2 1/2] coverage: Reimplement the "ovs-appctl coverage/show" command.

2013-09-30 Thread Alex Wang
This commit changes the "ovs-appctl coverage/show" command to show the the averaged per-second rates for the last few seconds, the last minute and the last hour, and the total counts of all of the coverage counters. Signed-off-by: Alex Wang --- v1 -> v2: - rebase to master. --- lib/coverage-u

[ovs-dev] [PATCH V2 2/2] ofproto-dpif: Compute the subfacet add/del rate using coverage counters.

2013-09-30 Thread Alex Wang
So far, the subfacet rates (e.g. add rate, del rate) are computed by exponential moving averaging function in ofproto-dpif.c. This commit replaces that logic with coverage counters. And the rates can be checked by running "ovs-appctl coverage/show" command. Signed-off-by: Alex Wang --- v1 ->

[ovs-dev] [PATCH] rhel: update openvswitch init script to include functionality in debians init script.

2013-09-30 Thread Duffie Cooley
From: Duffie Cooley This pulls some of the changes to the debian init script into the rhel init script. Specifically this is a fix for a request to make sure that the openvswitch status command in rhel based distros gives a useful exit status. That was fixed in commit 5e0c05bc058c78a11be6747f62

Re: [ovs-dev] [PATCH] rhel: update openvswitch init script to include functionality in debians init script.

2013-09-30 Thread Ben Pfaff
On Mon, Sep 30, 2013 at 06:47:43PM -0700, Duffie Cooley wrote: > From: Duffie Cooley > > This pulls some of the changes to the debian init script into the rhel init > script. Specifically this is a fix for a request to make sure that the > openvswitch status command in rhel based distros gives a

Re: [ovs-dev] [PATCH] rhel: update openvswitch init script to include functionality in debians init script.

2013-09-30 Thread Duffie Cooley
On 09/30/2013 07:12 PM, Ben Pfaff wrote: > On Mon, Sep 30, 2013 at 06:47:43PM -0700, Duffie Cooley wrote: >> From: Duffie Cooley >> >> This pulls some of the changes to the debian init script into the rhel init >> script. Specifically this is a fix for a request to make sure that the >> openvswitc

[ovs-dev] [PATCH] rhel: fix the exit status of the openvswitch init script.

2013-09-30 Thread Duffie Cooley
From: Duffie Cooley This is a fix for a request to make sure that the openvswitch status command in rhel based distros gives a useful exit status. That was fixed in commit 5e0c05bc058c78a11be6747f62e6ad88e5d06b70 debian: Fix exit status of openvswitch-switch init script "status" command Signed

Re: [ovs-dev] [PATCH v3] ofproto-dpif: Move special upcall handling into ofproto-dpif-upcall.

2013-09-30 Thread Simon Horman
On Wed, Sep 25, 2013 at 08:54:31AM -0700, Ben Pfaff wrote: > On Tue, Sep 24, 2013 at 04:45:14PM -0700, Ethan Jackson wrote: > > Both the IPFIX and SFLOW modules are thread safe, so there's no > > particular reason to pass them up to the main thread. Eliminating > > this step significantly simplifi

Re: [ovs-dev] [PATCH v3] ofproto-dpif: Move special upcall handling into ofproto-dpif-upcall.

2013-09-30 Thread Ben Pfaff
On Tue, Oct 01, 2013 at 01:23:20PM +0900, Simon Horman wrote: > On Wed, Sep 25, 2013 at 08:54:31AM -0700, Ben Pfaff wrote: > > On Tue, Sep 24, 2013 at 04:45:14PM -0700, Ethan Jackson wrote: > > > Both the IPFIX and SFLOW modules are thread safe, so there's no > > > particular reason to pass them up

Re: [ovs-dev] [PATCH v3] ofproto-dpif: Move special upcall handling into ofproto-dpif-upcall.

2013-09-30 Thread Simon Horman
On Mon, Sep 30, 2013 at 09:45:25PM -0700, Ben Pfaff wrote: > On Tue, Oct 01, 2013 at 01:23:20PM +0900, Simon Horman wrote: > > On Wed, Sep 25, 2013 at 08:54:31AM -0700, Ben Pfaff wrote: > > > On Tue, Sep 24, 2013 at 04:45:14PM -0700, Ethan Jackson wrote: > > > > Both the IPFIX and SFLOW modules are

Re: [ovs-dev] [PATCH v3] ofproto-dpif: Move special upcall handling into ofproto-dpif-upcall.

2013-09-30 Thread Ben Pfaff
On Tue, Oct 01, 2013 at 02:15:49PM +0900, Simon Horman wrote: > On Mon, Sep 30, 2013 at 09:45:25PM -0700, Ben Pfaff wrote: > > On Tue, Oct 01, 2013 at 01:23:20PM +0900, Simon Horman wrote: > > > On Wed, Sep 25, 2013 at 08:54:31AM -0700, Ben Pfaff wrote: > > > > On Tue, Sep 24, 2013 at 04:45:14PM -0

[ovs-dev] [PATCH] ofproto-dpif: Correct endian problem in recv_upcalls()

2013-09-30 Thread Simon Horman
Use nl_attr_get_u32() instead of nl_attr_get_be32() to parse nla so that the decoded value which is passed to mhash_add() is host byte order as mhash_add() expects. This resolves a minor regression introduced by 10e576406c7444ef ("ofproto-dpif: Move special upcall handling into ofproto-dpif-upcall

[ovs-dev] [PATCH v2.41 2/5] ofp-actions: Add separate OpenFlow 1.3 action parser

2013-09-30 Thread Simon Horman
From: Joe Stringer This patch adds new ofpact_from_openflow13() and ofpacts_from_openflow13() functions parallel to the existing ofpact handling code. In the OpenFlow 1.3 version, push_mpls is handled differently, but all other actions are handled by the existing code. In the case of push_mpls f

[ovs-dev] [PATCH v2.41 3/5] lib: Support pushing of MPLS LSE before or after VLAN tag

2013-09-30 Thread Simon Horman
From: Joe Stringer This patch modifies the push_mpls behaviour to allow pushing of an MPLS LSE either before any VLAN tag that may be present. Pushing the MPLS LSE before any VLAN tag that is present is the behaviour specified in OpenFlow 1.3. Pushing the MPLS LSE after the any VLAN tag that is

[ovs-dev] [PATCH v2.41 4/5] datapath: Break out deacceleration portion of vlan_push

2013-09-30 Thread Simon Horman
Break out deacceleration portion of vlan_push into vlan_put so that it may be re-used by mpls_push. For both vlan_push and mpls_push if there is an accelerated VLAN tag present then it should be deaccelerated, adding it to the data of the skb, before the new tag is added. Signed-off-by: Simon Hor

[ovs-dev] [PATCH v2.41 0/5] MPLS actions and matches

2013-09-30 Thread Simon Horman
Hi, This series implements MPLS actions and matches based on work by Ravi K, Leo Alterman, Yamahata-san and Joe Stringer. This series provides two changes * Patches 1 - 3 Provide user-space support for the VLAN/MPLS tag insertion order up to and including OpenFlow 1.2, and the different ord

[ovs-dev] [PATCH v2.41 1/5] odp: Allow VLAN actions after MPLS actions

2013-09-30 Thread Simon Horman
From: Joe Stringer OpenFlow 1.1 and 1.2, and 1.3 differ in their handling of MPLS actions in the presence of VLAN tags. To allow correct behaviour to be committed in each situation, this patch adds a second round of VLAN tag action handling to commit_odp_actions(), which occurs after MPLS actions

[ovs-dev] [PATCH v2.41 5/5] datapath: Add basic MPLS support to kernel

2013-09-30 Thread Simon Horman
Allow datapath to recognize and extract MPLS labels into flow keys and execute actions which push, pop, and set labels on packets. Based heavily on work by Leo Alterman, Ravi K, Isaku Yamahata and Joe Stringer. Cc: Ravi K Cc: Leo Alterman Cc: Isaku Yamahata Cc: Joe Stringer Signed-off-by: Sim