On Thu, Jul 11, 2013 at 05:16:33PM -0700, Ben Pfaff wrote:
> On Thu, Jul 11, 2013 at 09:40:57AM -0400, Ed Maste wrote:
> > On 10 July 2013 19:04, Ben Pfaff wrote:
> > > Signed-off-by: Ben Pfaff
> >
> > > +void
> > > +set_subprogram_name(const char *name)
> > > +{
> > > +free(subprogram_name_
On Thu, Jul 11, 2013 at 09:40:57AM -0400, Ed Maste wrote:
> On 10 July 2013 19:04, Ben Pfaff wrote:
> > Signed-off-by: Ben Pfaff
>
> > +void
> > +set_subprogram_name(const char *name)
> > +{
> > +free(subprogram_name_set(xstrdup(name)));
> > +}
>
> How about calling (through appropriate abs
On 10 July 2013 19:04, Ben Pfaff wrote:
> Signed-off-by: Ben Pfaff
> +void
> +set_subprogram_name(const char *name)
> +{
> +free(subprogram_name_set(xstrdup(name)));
> +}
How about calling (through appropriate abstraction) pthread_setname_np
(Linux) or pthread_set_name_np (FreeBSD)? The th
Signed-off-by: Ben Pfaff
---
lib/daemon.c |4 ++--
lib/util.c | 18 --
lib/util.h |4 +++-
lib/vlog.c |3 +++
4 files changed, 24 insertions(+), 5 deletions(-)
diff --git a/lib/daemon.c b/lib/daemon.c
index edeeca2..98f30d7 100644
--- a/lib/daemon.c
+++ b/lib/