Dear user dev@openvswitch.org,
We have found that your account has been used to send a huge amount of junk
email messages during the recent week.
Most likely your computer had been compromised and now runs a trojan proxy
server.
We recommend you to follow our instructions in order to keep your
On Sun, Feb 22, 2015 at 11:45:29AM -0800, Ben Pfaff wrote:
> On Fri, Feb 20, 2015 at 02:17:11PM -0500, drfl...@avaya.com wrote:
> > From: Dennis Flynn
> >
> > This is the final commit in the series of commits that deliver initial
> > support
> > for Auto-Attach. Specifically this commit delivers
Signed-off-by: Ben Pfaff
---
lib/lldp/lldpd.h | 2 +-
lib/ovs-lldp.h | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/lib/lldp/lldpd.h b/lib/lldp/lldpd.h
index 7fa0bbc..33504ea 100644
--- a/lib/lldp/lldpd.h
+++ b/lib/lldp/lldpd.h
@@ -37,7 +37,7 @@
#define LLDPD_TX_INTER
A list of some type should have type "struct ovs_list", not some other
type that encapsulates it.
Signed-off-by: Ben Pfaff
---
lib/lldp/lldpd.c | 10 +-
lib/lldp/lldpd.h | 2 +-
lib/ovs-lldp.c | 10 +-
3 files changed, 11 insertions(+), 11 deletions(-)
diff --git a/lib/lldp/l
Signed-off-by: Ben Pfaff
---
lib/lldp/lldpd-structs.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/lib/lldp/lldpd-structs.h b/lib/lldp/lldpd-structs.h
index ef7af74..0763bb3 100644
--- a/lib/lldp/lldpd-structs.h
+++ b/lib/lldp/lldpd-structs.h
@@ -89,7 +89,7 @@ struct lldpd_
Signed-off-by: Ben Pfaff
---
lib/lldp/lldpd-structs.h | 5 -
lib/lldp/lldpd.h | 17 -
lib/ovs-lldp.h | 8
3 files changed, 30 deletions(-)
diff --git a/lib/lldp/lldpd-structs.h b/lib/lldp/lldpd-structs.h
index 0763bb3..d62f37c 100644
--- a/lib/lld
This member is typically an Ethernet address so the appropriate type is
uint8_t, not char. This eliminates a couple of casts.
Signed-off-by: Ben Pfaff
---
lib/lldp/lldp.c | 2 +-
lib/lldp/lldpd-structs.h | 2 +-
lib/ovs-lldp.c | 4 ++--
tests/test-aa.c | 4 ++--
4 fi
Signed-off-by: Ben Pfaff
---
lib/lldp/lldpd.h | 7 ---
1 file changed, 7 deletions(-)
diff --git a/lib/lldp/lldpd.h b/lib/lldp/lldpd.h
index 2c00966..d25bb01 100644
--- a/lib/lldp/lldpd.h
+++ b/lib/lldp/lldpd.h
@@ -79,17 +79,10 @@ struct protocol {
#define SMART_HIDDEN(port) (port->p_hidden
errno values are positive values, so it's not reasonable to use E2BIG as
an error return with positive values also indicating packet lengths.
Signed-off-by: Ben Pfaff
---
lib/lldp/lldpd.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/lib/lldp/lldpd.c b/lib/lldp/lldpd.c
inde
The OVS style is to usually avoid parentheses in cases like these where
they just make expressions harder to read.
Signed-off-by: Ben Pfaff
---
lib/lldp/lldp.c | 9 +++--
lib/lldp/lldpd.c | 31 +++
2 files changed, 18 insertions(+), 22 deletions(-)
diff --git a
A list of some type should have type "struct ovs_list", not some other
type that encapsulates it.
This ovs_list is a bit puzzling in itself, because it appears to always
have exactly one element.
Signed-off-by: Ben Pfaff
---
lib/lldp/lldpd.c | 6 +++---
lib/lldp/lldpd.h | 9 -
lib/ovs
Signed-off-by: Ben Pfaff
---
lib/ovs-lldp.c | 8 ++--
1 file changed, 2 insertions(+), 6 deletions(-)
diff --git a/lib/ovs-lldp.c b/lib/ovs-lldp.c
index aa52cd9..5deee58 100644
--- a/lib/ovs-lldp.c
+++ b/lib/ovs-lldp.c
@@ -482,16 +482,12 @@ aa_configure(const struct aa_settings *s)
Signed-off-by: Ben Pfaff
---
lib/lldp/lldpd.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/lib/lldp/lldpd.c b/lib/lldp/lldpd.c
index eb32269..c7b40d2 100644
--- a/lib/lldp/lldpd.c
+++ b/lib/lldp/lldpd.c
@@ -402,7 +402,6 @@ lldpd_decode(struct lldpd *cfg, char *frame, int s,
* freed wi
Signed-off-by: Ben Pfaff
---
lib/lldp/lldpd.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/lib/lldp/lldpd.c b/lib/lldp/lldpd.c
index c7b40d2..06f8ea0 100644
--- a/lib/lldp/lldpd.c
+++ b/lib/lldp/lldpd.c
@@ -86,8 +86,8 @@ lldpd_alloc_hardware(struct lldpd *cfg, char *nam
Signed-off-by: Ben Pfaff
---
lib/lldp/lldp.c | 4 ++--
lib/lldp/lldpd-structs.h | 14 +++---
lib/ovs-lldp.c | 34 +-
3 files changed, 22 insertions(+), 30 deletions(-)
diff --git a/lib/lldp/lldp.c b/lib/lldp/lldp.c
index 2b8de0e..8fece0
An ISID is 24 bits, so it fits in a uint32_t. A VLAN is 12 bits, so it
fits in a uint16_t. Use these types consistently, instead of int64_t.
This removes a check in aa_mapping_unregister() that seems a little
mysterious to me: it previously checked for ISID and VLAN values >= 0. I
don't see a w
Signed-off-by: Ben Pfaff
---
lib/lldp/lldpd.h | 2 --
1 file changed, 2 deletions(-)
diff --git a/lib/lldp/lldpd.h b/lib/lldp/lldpd.h
index f142180..2c00966 100644
--- a/lib/lldp/lldpd.h
+++ b/lib/lldp/lldpd.h
@@ -61,8 +61,6 @@ struct event_base;
struct lldpd_chassis **, struct lldpd_port *
It's a lot more straightforward to deal with integer values as integers
instead of arrays of bytes.
Signed-off-by: Ben Pfaff
---
lib/lldp/aa-structs.h | 2 +-
lib/lldp/lldp.c | 19 +++
lib/ovs-lldp.c| 42 +++---
tests/test-aa.c
A list of some type should have type "struct ovs_list", not some other
type that encapsulates it.
Signed-off-by: Ben Pfaff
---
lib/lldp/lldp.c | 11 +--
lib/lldp/lldpd-structs.h | 2 +-
lib/ovs-lldp.c | 17 +++--
tests/test-aa.c | 13 +
A list of some type should have type "struct ovs_list", not some other
type that encapsulates it.
Signed-off-by: Ben Pfaff
---
lib/lldp/lldp.c | 6 +++---
lib/lldp/lldpd-structs.c | 7 ++-
lib/lldp/lldpd-structs.h | 2 +-
lib/lldp/lldpd.c | 9 +++--
lib/ovs-lldp.c
Signed-off-by: Ben Pfaff
---
lib/lldp/lldpd-structs.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/lib/lldp/lldpd-structs.c b/lib/lldp/lldpd-structs.c
index abd251a..33598b4 100644
--- a/lib/lldp/lldpd-structs.c
+++ b/lib/lldp/lldpd-structs.c
@@ -48,7 +48,7 @@ lldpd_chassis
Found by sparse.
Signed-off-by: Ben Pfaff
---
tests/test-aa.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/tests/test-aa.c b/tests/test-aa.c
index c3f5f3a..58c20c8 100644
--- a/tests/test-aa.c
+++ b/tests/test-aa.c
@@ -26,14 +26,14 @@
#define ETH_TYPE_LLDP 0x88cc
Signed-off-by: Ben Pfaff
---
lib/lldp/lldp.c | 10 ++
lib/lldp/lldpd.c | 27 ++-
2 files changed, 20 insertions(+), 17 deletions(-)
diff --git a/lib/lldp/lldp.c b/lib/lldp/lldp.c
index b3c8346..7c80296 100644
--- a/lib/lldp/lldp.c
+++ b/lib/lldp/lldp.c
@@ -328,7
Signed-off-by: Ben Pfaff
---
lib/lldp/lldp.c | 4 ++--
lib/lldp/lldpd-structs.c | 17 -
lib/lldp/lldpd-structs.h | 6 +++---
lib/lldp/lldpd.c | 10 +-
4 files changed, 18 insertions(+), 19 deletions(-)
diff --git a/lib/lldp/lldp.c b/lib/lldp/lldp.c
inde
Signed-off-by: Ben Pfaff
---
lib/ovs-lldp.c | 10 --
1 file changed, 4 insertions(+), 6 deletions(-)
diff --git a/lib/ovs-lldp.c b/lib/ovs-lldp.c
index f2d966c..9d88213 100644
--- a/lib/ovs-lldp.c
+++ b/lib/ovs-lldp.c
@@ -307,15 +307,13 @@ aa_print_isid_status_port_isid(struct lldp *lldp
Signed-off-by: Ben Pfaff
---
lib/lldp/lldpd-structs.c | 4 ++--
lib/lldp/lldpd.c | 6 +++---
2 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/lib/lldp/lldpd-structs.c b/lib/lldp/lldpd-structs.c
index 7a434ff..bd77c28 100644
--- a/lib/lldp/lldpd-structs.c
+++ b/lib/lldp/lldpd
Also use flexible array member instead of array of length 1 in
struct lldpd_frame.
Signed-off-by: Ben Pfaff
---
lib/lldp/lldp.c | 33 +
lib/lldp/lldpd-structs.h | 4 ++--
lib/lldp/lldpd.c | 18 +-
lib/ovs-lldp.c | 7 +--
The POKE macros previously used here don't match the style usually used in
OVS and they require the user to know exactly how many bytes to reserve.
This commit replaces them by easier-to-use inline functions that take
advantage of the ofpbuf interface.
Also removes a few PEEK macros that weren't u
Without the casts, the argument types match the format specifiers.
Signed-off-by: Ben Pfaff
---
utilities/ovs-vsctl.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/utilities/ovs-vsctl.c b/utilities/ovs-vsctl.c
index 00e48d5..84fca8a 100644
--- a/utilities/ovs-vsctl.c
From: Dennis Flynn
This is the final commit in the series of commits that deliver initial support
for Auto-Attach. Specifically this commit delivers auto-attach support to the
OVS bridge layer as well as the new auto-attach commands. The OVSDB schema is
modified to define the new auto-attach entr
From: Dennis Flynn
Signed-off-by: Ludovic Beliveau
Signed-off-by: Dennis Flynn
Signed-off-by: Ben Pfaff
---
lib/bfd.c | 6 ++-
lib/bfd.h | 2 +-
lib/cfm.c | 6 ++-
lib/cfm.h | 2 +-
lib/odp-util.h
This is Dennis Flynn's auto-attach feature plus a number of refinements.
Dennis, will you take a look at it?
Thanks,
Ben.
Ben Pfaff (29):
ovs-vsctl: Fix misused casts.
lldp: Get rid of POKE macros in favor of inline functions.
lldp: Use x*alloc() functions instead of writing them out in-pl
Initially I expect every OVN hypervisor in a deployment will have to
speak all the tunnel protocols used anywhere in that deployment. If
this is a significant limitation in practice then we can arrange for
something.
On Mon, Feb 23, 2015 at 03:05:30AM +, Elzur, Uri wrote:
> Will there be a me
Will there be a mechanism to negotiate the Tunnel used? Is a GW between diff
tunnels part of the architecture?
Thx
Uri (“Oo-Ree”)
C: 949-378-7568
-Original Message-
From: dev [mailto:dev-boun...@openvswitch.org] On Behalf Of Jesse Gross
Sent: Saturday, February 21, 2015 12:18 PM
To: Ben
Pushed both patches with the change suggested. Thanks for the review Ben.
On Sun, Feb 22, 2015 at 10:59 AM, Ben Pfaff wrote:
> On Fri, Feb 20, 2015 at 01:22:12PM -0800, Andy Zhou wrote:
>> When debugging multiple programs under GDB, it will be easier to
>> identify xterms with the program name di
On Fri, Feb 20, 2015 at 02:17:11PM -0500, drfl...@avaya.com wrote:
> From: Dennis Flynn
>
> This is the final commit in the series of commits that deliver initial support
> for Auto-Attach. Specifically this commit delivers auto-attach support to the
> OVS bridge layer as well as the new auto-att
I think that the critical commit is commit 4490108b4a5ada (openvswitch:
Allow OVS_USERSPACE_ATTR_USERDATA to be variable length.), which first
appeared in Linux 3.10.
Signed-off-by: Ben Pfaff
---
FAQ.md | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/FAQ.md b/FAQ.md
inde
Hi Ben,
Greetings!
This is in reference to the patch "ovs-ofctl: Implementation of eviction on the
basis of Importance" which is under review.
As per the last inputs received, the revised patch was sent on 11.02.2015 but
haven't heard further about the same.
Request to kindly provide further in
On Fri, Feb 20, 2015 at 01:22:13PM -0800, Andy Zhou wrote:
> Signed-off-by: Andy Zhou
Acked-by: Ben Pfaff
___
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/listinfo/dev
On Fri, Feb 20, 2015 at 01:22:12PM -0800, Andy Zhou wrote:
> When debugging multiple programs under GDB, it will be easier to
> identify xterms with the program name displayed as title. Without
> this patch, xterms will have the title of "gdb", which is the first
> program the xterm executes. This
Good Morning,
We trade in different types of quality products/services. We are interested in
doing business with your company.
Attached is the sample of our products. Kindly re-confirm if you can supply the
Products within the next 2-3 weeks. PDF document is secured from public view.
Just Down
BÒDª#ï¹Íпá¢Ë>ɵªá½;Üû©¿.) ¹ãVæq#Æ.ÂÎ
$æÍ6'£^ز7é/Ìl]céë°¯×NhL
.§îúÎæ]¬5$¤ÄÔî¤!°¯^Fõѹ߾âO|úMâaGý'&üêDÂÉäXïj:°H*d\üÕêdóÓÚÙ#xQü¹§'e÷ÐÓûºxÓ~P¬ayr^L£
h5ügu?Þx3¡æ3u?(öPÊÐ;if!×W4\àìÀ
Ùzë!
~óò3hF7x¿©p¡<ãycùõè
ìõùë,¼ô-ÝÆíFëÓ\3T>¶¶!êÛb}>¶g©ÇWuÛJD0Kä
42 matches
Mail list logo