Slightly simplify ofp10_match_to_string() by using ds_chomp()
rather than open-coding its logic.
Signed-off-by: Simon Horman
---
lib/ofp-print.c | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/lib/ofp-print.c b/lib/ofp-print.c
index 8dc7f06..d27d8a7 100644
--- a/lib/ofp-pr
Slightly simplify match_format() by using ds_chomp()
rather than open-coding its logic.
Signed-off-by: Simon Horman
---
lib/match.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/lib/match.c b/lib/match.c
index cbfd735..bd3b13d 100644
--- a/lib/match.c
+++ b/lib/match.c
If usable_protocols_bitwise and usable_protocols_cidr are equal
then it does not matter which one is returned. This leads to
a slight simplification of the selection logic.
Signed-off-by: Simon Horman
---
lib/meta-flow.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/lib/m
On Mon, Nov 03, 2014 at 05:14:05PM -0800, Ben Pfaff wrote:
> From: Jean Tourrilhes
>
> Signed-off-by: Jean Tourrilhes
Actually, you don't need this testcase if you modify your own
testcase as such :
https://github.com/jean2/openvswitch/commit/efdcb83abcaccf8d78be14d79f28358ea73f66c1
I decided that it was minor enough (a bug in ofproto/trace) to just
push the series and then send out another series with the bug fix:
http://openvswitch.org/pipermail/dev/2014-November/048173.html
http://openvswitch.org/pipermail/dev/2014-November/048175.html
http://openvsw
From: Jean Tourrilhes
Signed-off-by: Jean Tourrilhes
---
tests/ofproto-dpif.at | 23 +++
1 file changed, 23 insertions(+)
diff --git a/tests/ofproto-dpif.at b/tests/ofproto-dpif.at
index 58a2cf9..04c0b8b 100644
--- a/tests/ofproto-dpif.at
+++ b/tests/ofproto-dpif.at
@@ -1
I think this is new:
../lib/ovs-router.c:162:11: warning: incorrect type in assignment
(different base types)
../lib/ovs-router.c:162:11:expected restricted ovs_be32 [usertype]
../lib/ovs-router.c:162:11:got restricted ovs_be16
Thanks,
Ben.
Until now, ofproto/trace has looked up the flow itself. xlate_actions()
can do the flow lookup internally and, since that is what happens when a
packet arrives, having it do its own packet lookup makes a lot of sense.
I noticed this in connection with the actset_output field, which
xlate_actions(
It will be used in an upcoming commit.
Signed-off-by: Ben Pfaff
---
ofproto/ofproto-dpif-xlate.c | 11 +--
ofproto/ofproto-dpif-xlate.h |1 +
ofproto/ofproto-dpif.c | 15 +--
3 files changed, 19 insertions(+), 8 deletions(-)
diff --git a/ofproto/ofproto-dpif-xl
Dear all,
I implemented a following patch to accelerate Open vSwitch datapath.
Any comments are highly appreciated.
Thanks,
- Michio
From 944112a356c58f3e41a022a834bcc258ae0eafda Mon Sep 17 00:00:00 2001
From: Michio Honda
Date: Tue, 30 Sep 2014 16:44:11 +0200
Subject: [PATCH] Opportunistic acc
On Nov 3, 2014, at 2:03 PM, Ben Pfaff wrote:
> On Wed, Oct 29, 2014 at 03:12:02PM -0700, Jarno Rajahalme wrote:
>> 1. Flows with an explicit match on nw_frag, where the LATER bit is 1:
>> Prohibit setting transport header fields (port numbers) with
>> set_field or move, or using such a field
Thank for the review.
" Since you have declared $vmName as mandatory, is this check required?"
As I understand the "mandatory" parameter definition of PS means that the
parameter must be provided by the caller. If the parameter is not provided PS
prompts the use.
This is different than checking
Following patch adds support for userspace tunneling. Tunneling
needs three more component first is routing table which is configured by
caching kernel routes and second is ARP cache which build automatically
by snooping arp. And third is tunnel protocol table which list all
listening protocols whi
Thanks. I'll fold those in.
Jean Tourrilhes pointed out a possible bug in this patch, in the ONF
JIRA for EXT-233. I'm going to look at that before I apply this.
On Thu, Oct 30, 2014 at 04:06:40PM -0700, Jarno Rajahalme wrote:
> With the following changes (some due to master changing in the mea
On Mon, Nov 3, 2014 at 1:42 PM, Ben Pfaff wrote:
> On Mon, Nov 3, 2014 at 1:33 PM, Pravin Shelar wrote:
>> On Mon, Nov 3, 2014 at 12:31 PM, Ben Pfaff wrote:
>>> ip_hdr() and gre_hdr() might be avoided if the ofpbuf's header support
>>> were used.
>>>
>> ofpbuf header might not be set in all case
> +function Set-VMNetworkAdapterOVSPortDirect {
> +[CmdletBinding()]
> +param
> +(
> +[parameter(Mandatory=$true)]
> +[string]$vmName,
> +
> +[parameter(Mandatory=$true)]
> +[ValidateLength(1, 48)]
> +[string]$OVSPortName
> +)
> +process
>
On Mon, Nov 3, 2014 at 1:36 PM, Lorand Jakab wrote:
> Implementation of the pop_eth and push_eth actions in the kernel, and
> layer 3 flow support.
>
> Signed-off-by: Lorand Jakab
I'm happy with this at this point, thank you.
Ben reviewed the userspace portions before, I'll let him take a look
On Mon, Nov 03, 2014 at 01:52:17PM -0800, Ben Pfaff wrote:
> On Wed, Oct 29, 2014 at 03:12:00PM -0700, Jarno Rajahalme wrote:
> > Add transport port modifications to the existing frags handling test
> > case.
> >
> > This demonstrates incorrect behavior by not moving the destination
> > port numbe
On Wed, Oct 29, 2014 at 03:12:02PM -0700, Jarno Rajahalme wrote:
> 1. Flows with an explicit match on nw_frag, where the LATER bit is 1:
>Prohibit setting transport header fields (port numbers) with
>set_field or move, or using such a field as a source in a move.
>
> 2. Flows that wildcard
On Wed, Oct 29, 2014 at 03:12:01PM -0700, Jarno Rajahalme wrote:
> Transport ports are already cleared for lookup if need be, and they
> should be available for action processing, so do not clear them in
> xlate_actions().
>
> A drop flow takes care of dropping the packet, so no special case is
>
On Wed, Oct 29, 2014 at 03:12:00PM -0700, Jarno Rajahalme wrote:
> Add transport port modifications to the existing frags handling test
> case.
>
> This demonstrates incorrect behavior by not moving the destination
> port number to source port in normal mode for first fragment, as the
> transport
On Mon, Nov 3, 2014 at 1:33 PM, Pravin Shelar wrote:
> On Mon, Nov 3, 2014 at 12:31 PM, Ben Pfaff wrote:
>> ip_hdr() and gre_hdr() might be avoided if the ofpbuf's header support
>> were used.
>>
> ofpbuf header might not be set in all cases.
I think that ip_hdr() is used only in a function that
Implementation of the pop_eth and push_eth actions in the kernel, and
layer 3 flow support.
Signed-off-by: Lorand Jakab
---
datapath/actions.c| 85 ---
datapath/flow.c | 44 --
datapath/flow.h |
This commit relaxes the assumption that all packets have an Ethernet
header, and adds support for layer 3 flows. For each packet received on
the Linux kernel datapath the l2 and l3 members of struct ofpbuf are
intialized appropriately, and some functions now expect this (notably
flow_extract()), i
These actions will allow L2->L3 and L3->L2 switching, and are supposed
to be added to flows installed in the datapath transparently by
ovs-vswitchd.
Signed-off-by: Lorand Jakab
---
datapath/linux/compat/include/linux/openvswitch.h | 12 +
lib/dpif-netdev.c |
This series implements support for layer 3 ports, of which we have one example
so far, the LISP vport. LISP support is currently implemented with a hack, by
adding/removing the Ethernet header within the datapath/vport-lisp.c file. By
removing the assumption that all packets/flows have Ethernet h
Thanks for the quick turnaround Jesse. See inline.
On 11/3/14 7:46 PM, Jesse Gross wrote:
On Mon, Nov 3, 2014 at 6:31 AM, Lorand Jakab wrote:
diff --git a/datapath/flow.c b/datapath/flow.c
index a3c5d2f..fea26ae 100644
--- a/datapath/flow.c
+++ b/datapath/flow.c
@@ -458,28 +458,31 @@ static i
On Mon, Nov 3, 2014 at 12:31 PM, Ben Pfaff wrote:
> On Fri, Oct 24, 2014 at 09:43:39AM -0700, Ben Pfaff wrote:
>> On Thu, Oct 16, 2014 at 11:38:20AM -0700, Pravin B Shelar wrote:
>> > Following patch adds support for userspace tunneling. Tunneling
>> > needs three more component first is routing t
Thanks for the kind words. (I barely keep up myself, these days ;-)
On Mon, Nov 3, 2014 at 1:18 PM, roampune wrote:
> You guys are awesome as always! but with so many patches flying around
> everyday it is tough to keep up these days :(.
>
> On Fri, Oct 31, 2014 at 9:45 AM, Ben Pfaff wrote:
>>
>
You guys are awesome as always! but with so many patches flying around
everyday it is tough to keep up these days :(.
On Fri, Oct 31, 2014 at 9:45 AM, Ben Pfaff wrote:
> On Thu, Oct 30, 2014 at 11:01:32PM -0700, roampune wrote:
> > or maybe its time to move openvswitch.org to github.io like
> >
On Fri, Oct 24, 2014 at 09:43:39AM -0700, Ben Pfaff wrote:
> On Thu, Oct 16, 2014 at 11:38:20AM -0700, Pravin B Shelar wrote:
> > Following patch adds support for userspace tunneling. Tunneling
> > needs three more component first is routing table which is configured by
> > caching kernel routes an
struct cls_match 'list' member was recently changed to an rculist.
This allows classifier_find_rule_exactly() to be made lockless.
Since subtable's 'max_priority' member would still require a lock, we
no longer check it before calling find_equal(). This adds a hash table
lookup in cases where the
Previously, accurate iteration required writers to be excluded during
iteration. This patch adds an rculist to struct cls_subtable, and a
corresponding list node to struct cls_rule, which makes iteration more
straightforward, and allows the iterators to remain ignorant of the
internals of the cls_
Some struct cls_match and cls_subtable fields were already documented
of being const. Make them const and use CONST_CAST where appropriate
to initialize them.
This will help catch future errors modifying those fields after
initialization.
Signed-off-by: Jarno Rajahalme
---
lib/classifier-priva
Returning const struct cls_rule pointers from the classifier API helps
callers to remember that they should not modify the rules returned.
Signed-off-by: Jarno Rajahalme
---
lib/classifier.c| 103 ++-
lib/classifier.h| 25 ++-
Add asserts to make sure the containers within are already empty.
Signed-off-by: Jarno Rajahalme
---
lib/classifier.c | 10 +++---
1 file changed, 7 insertions(+), 3 deletions(-)
diff --git a/lib/classifier.c b/lib/classifier.c
index 657a953..36f3d20 100644
--- a/lib/classifier.c
+++ b/li
Acked-by: Ankur Sharma
From: Eitan Eliahu
Sent: Thursday, October 30, 2014 3:01 PM
To: Ankur Sharma
Subject: FW: [PATCH] WMI Script Support for setting Hyper-V friendly port name
from NOVA driver
-Original Message-
From: Eitan Eliahu [mailto:elia.
Thanks, applied to master.
On Mon, Nov 03, 2014 at 09:09:22AM -0800, Jarno Rajahalme wrote:
> LGTM,
>
> Sorry for letting this sit so long!
>
> Acked-by: Jarno Rajahalme
>
>
> On Oct 3, 2014, at 3:49 PM, Ben Pfaff wrote:
>
> > The ovs-atomic-i586 implementation of atomic operations can impl
We'll have meeting on 11/11.
Thanks,
-- Nithin
___
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/listinfo/dev
Update Hyper-V port properties on NDIS property port set callback.
Driver update the port friendly name in its internal table.
Signed-off-by: Eitan Eliahu
---
datapath-windows/ovsext/Oid.c | 4
1 file changed, 4 insertions(+)
diff --git a/datapath-windows/ovsext/Oid.c b/datapath-windows/ov
On Mon, Nov 3, 2014 at 6:31 AM, Lorand Jakab wrote:
> diff --git a/datapath/flow.c b/datapath/flow.c
> index a3c5d2f..fea26ae 100644
> --- a/datapath/flow.c
> +++ b/datapath/flow.c
> @@ -458,28 +458,31 @@ static int key_extract(struct sk_buff *skb, struct
> sw_flow_key *key)
> + /* Link lay
Hi Sorin,
Can you please provide some more details of the crash?
Either of following data would be helpful in review.
a. Repro steps.
b. Backtrace.
Thanks.
Regards,
Ankur
From: dev on behalf of Sorin Vinturis
Sent: Thursday, October 30, 2014 7:32 AM
To
LGTM,
Sorry for letting this sit so long!
Acked-by: Jarno Rajahalme
On Oct 3, 2014, at 3:49 PM, Ben Pfaff wrote:
> The ovs-atomic-i586 implementation of atomic operations can implement
> 64-bit atomics more efficiently when SSE is supported. XenServer runs only
> on 64-bit capable processor
Jarno, would you mind taking a look at this one?
On Fri, Oct 03, 2014 at 03:49:36PM -0700, Ben Pfaff wrote:
> The ovs-atomic-i586 implementation of atomic operations can implement
> 64-bit atomics more efficiently when SSE is supported. XenServer runs only
> on 64-bit capable processors, in 32-bi
On Mon, Nov 03, 2014 at 04:55:05PM +0530, hiteshi.ma...@tcs.com wrote:
> Kindly apply following 5 patches before applying patch for eviction:
> [PATCH 1/5] ovs-ofctl:To set importance of a rule for eviction(OF14)
> [PATCH 2/5] ovs-ofctl:Changes made to DESIGN and addedtest cases(OF14)
> [PA
On Mon, Nov 03, 2014 at 05:48:52PM +0530, Hiteshi Madan wrote:
>
> From: root
Please use a real name and email address.
> This commit enables the eviction mechanism on the basis of importance as
> per the openflow specification 1.4.
>
> ovs-ofctl mod-table evict
> Enable eviction on o
On Fri, Oct 31, 2014 at 5:46 PM, Ben Pfaff wrote:
> On Fri, Oct 31, 2014 at 04:53:00PM -0700, Jesse Gross wrote:
>> WORDS_BIGENDIAN is defined by configure so it is a more portable
>> way to test for endianness.
>>
>> Reported-by: Ben Pfaff
>> Signed-off-by: Jesse Gross
>
> Based on what I see ,
On 11/1/14 1:03 AM, Jesse Gross wrote:
On Thu, Oct 9, 2014 at 3:34 AM, Lori Jakab wrote:
On 9/12/14 12:26 AM, Jesse Gross wrote:
On Mon, Sep 8, 2014 at 5:43 AM, Lori Jakab wrote:
--- a/datapath/flow_netlink.c
+++ b/datapath/flow_netlink.c
@@ -1831,6 +1831,8 @@ static int __ovs_nla_copy_actio
Implementation of the pop_eth and push_eth actions in the kernel, and
layer 3 flow support.
Signed-off-by: Lorand Jakab
---
datapath/actions.c| 85 ---
datapath/flow.c | 45 +--
datapath/flow.h |
This commit relaxes the assumption that all packets have an Ethernet
header, and adds support for layer 3 flows. For each packet received on
the Linux kernel datapath the l2 and l3 members of struct ofpbuf are
intialized appropriately, and some functions now expect this (notably
flow_extract()), i
These actions will allow L2->L3 and L3->L2 switching, and are supposed
to be added to flows installed in the datapath transparently by
ovs-vswitchd.
Signed-off-by: Lorand Jakab
---
datapath/linux/compat/include/linux/openvswitch.h | 12 +
lib/dpif-netdev.c |
This series implements support for layer 3 ports, of which we have one example
so far, the LISP vport. LISP support is currently implemented with a hack, by
adding/removing the Ethernet header within the datapath/vport-lisp.c file. By
removing the assumption that all packets/flows have Ethernet h
Hi Team,
Kindly ignore previous Patch because that contains some garbage value due to
text editor. Please use
latest mail for the patch.
Thanks & Regards,
Hiteshi Madan
-"dev" wrote: -
To: dev@openvswitch.org
From: hiteshi.ma...@tcs.com
Sent by: "dev"
Date: 11/03/2014 05:03PM
Cc: de
Hi Team,
Kindly apply following 5 patches before applying patch for eviction:
[PATCH 1/5] ovs-ofctl:To set importance of a rule for eviction(OF14)
[PATCH 2/5] ovs-ofctl:Changes made to DESIGN and added test cases(OF14)
[PATCH 3/5] ovs-ofctl:Enhanced diff-flows & replace-flows(OF14)
[PATCH 4/5
From: root
This commit enables the eviction mechanism on the basis of importance as
per the openflow specification 1.4.
ovs-ofctl mod-table evict
Enable eviction on of . Eviction adds a mechanism
enabling the switch to automatically eliminate entries of lower
importance to make space for newe
55 matches
Mail list logo