Dutch Glow - Amish Wood Milk...100 Year Old Formula
Dutch Glow is a century old furniture polish that was created to clean, polish,
and nourish wood. Reveal wood's natural beauty and remove years of wax build
up. Don't ruin your furniture with past wax or silicone sprays
Learn More (Dutch Glow
Thx for the review, applied to master and branch-2.3
On Mon, Jul 7, 2014 at 8:15 PM, Joe Stringer wrote:
> On 8 July 2014 13:20, Alex Wang wrote:
>>
>> +/* Needs to check in case the socket pointer is changed in
>> between
>> + * of holding the locks. */
>
>
> Might be worth me
On 8 July 2014 13:20, Alex Wang wrote:
>
> +/* Needs to check in case the socket pointer is changed in between
> + * of holding the locks. */
Might be worth mentioning here that a known case is when the port is
deleted while handling an upcall from that port.
Acked-by: Joe Strin
From: Pravin B Shelar
Date: Mon, 30 Jun 2014 23:33:16 -0700
> A set of fixes for net.
> First bug is related flow-table management. Second one is in sample
> action. Third is related flow stats and last one add gre-err handler for ovs.
Pulled, thanks Pravin.
> Add an internal mutex to the struct cls_classifier, and reorganize
> classifier internal structures according to the user of each field,
> marking the fields that need to be protected by the mutex. This makes
> locking requirements easier to track, and may make lookup more memory
> efficient.
>
> Rename 'nbits' as 'n_bits' to be more consistent with other count-like
> fields.
>
> Signed-off-by: Jarno Rajahalme
Acked-by: YAMAMOTO Takashi
___
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/listinfo/dev
> cls_set_prefix_fields() now synchronizes explicitly with the readers,
> waiting them to finish using the old configuration before changing to
> the new configuration.
>
> Signed-off-by: Jarno Rajahalme
Acked-by: YAMAMOTO Takashi
___
dev mailing list
> The following patch will add the first external user.
>
> Signed-off-by: Jarno Rajahalme
Acked-by: YAMAMOTO Takashi
___
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/listinfo/dev
> Use cmap instead of hmap & hindex in classifier. Performance impact
> with current locking strategy is not yet tested. Later patches will
> introduce RCU into the classifier.
>
> Signed-off-by: Jarno Rajahalme
> Acked-by: Ben Pfaff
Acked-by: YAMAMOTO Takashi
___
> Hide the cursor from the classifier iteration users and move locking to
> the iterators. This will make following RCU changes simpler, as the call
> sites of the iterators need not be changed at that point.
>
> Signed-off-by: Jarno Rajahalme
Acked-by: YAMAMOTO Takashi
___
> Now that all the relevant classifier structures use RCU and internal
> mutual exclusion for modifications, we can remove the fat-rwlock and
> thus make the classifier lookups lockless.
>
> As the readers are operating concurrently with the writers, a
> concurrent reader may or may not see a new
Thanks, I applied this to master and branch-2.3.
On 8 July 2014 13:17, Ansis Atteka wrote:
> On Mon, Jul 7, 2014 at 6:01 PM, Joe Stringer
> wrote:
> > The previous 'grep' logic would occasionally catch unintended flows.
> > There's no reason to check for these flows separately, so combine the
This commit fixes a race between port deletion and flow miss handling.
More specifically, a port could be removed while handling the flow
miss from it. If the flow requires slow path action, the handler
thread will try querying a pid from port's sockets. Since the port
has been deleted, the query
On Mon, Jul 7, 2014 at 6:01 PM, Joe Stringer wrote:
> The previous 'grep' logic would occasionally catch unintended flows.
> There's no reason to check for these flows separately, so combine the
> two checks.
>
> Signed-off-by: Joe Stringer
> ---
> tests/ofproto-dpif.at |4 +---
> 1 file cha
The previous 'grep' logic would occasionally catch unintended flows.
There's no reason to check for these flows separately, so combine the
two checks.
Signed-off-by: Joe Stringer
---
tests/ofproto-dpif.at |4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/tests/ofproto-dpi
On Thu, Jul 3, 2014 at 1:23 PM, Ben Pfaff wrote:
> On Sun, Jun 29, 2014 at 08:37:25PM -0700, Ansis Atteka wrote:
>> From: Ansis
>
> Fix up the patch author?
>
>> The child process (the one being monitored) could die before it was able
>> to call fork_notify_startup() function. If such situation
The child process (the one being monitored) could die before it was able
to call fork_notify_startup() function. If such situation arises, then
parent process (the one monitoring child process) would also terminate
with a fatal log message:
...|EMER|fork child died before signaling startup (kille
Thanks, I added that change and pushed to branch-2.3.
A version of this series for master is available here:
http://mail.openvswitch.org/pipermail/dev/2014-July/042507.html
___
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/listinfo/
>
> This is for branch-2.3, I think.
>
> Acked-by: Ben Pfaff
>
Yes, thanks. I've pushed this to branch-2.3.
A version of this series for master is available here:
http://mail.openvswitch.org/pipermail/dev/2014-July/042507.html
___
dev mailing list
dev
If the datapath doesn't dump a flow for some reason, and the current
dump is expected to revalidate all flows in the datapath, then perform
revalidation for those flows by fetching them during the sweep phase.
If revalidation is not required, then leave the flow in the datapath and
don't revalidate
This is a rebase of the following series against master:
http://patchwork.openvswitch.org/patch/4895/
http://patchwork.openvswitch.org/patch/4891/
The way that revalidators handle dpif_flows is a bit different on master, so
this version has a different dpif_flow_get() interface from the version fo
Change the interface to allow implementations to pass back a buffer, and
allow callers to specify which of actions, mask, and stats they wish to
receive. This will be used in the next commit.
Signed-off-by: Joe Stringer
---
v4: Rebase against master.
v3: Set *bufp to NULL before calling ->flow_ge
Thanks, I adjusted the commit message and pushed to master:
Running the test in a tight loop could cause this test to fail after
about 5 runs, with some of the ports reporting "may_enable: false" in
the "ovs-appctl bond/show" output. This commit fixes the race condition
by waiting
I pushed this to master and branch-2.3.
On 8 July 2014 09:53, Joe Stringer wrote:
> Even better. Thanks!
>
> Acked-by: Joe Stringer
>
___
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/listinfo/dev
On Mon, Jul 07, 2014 at 01:16:59PM -0700, Jarno Rajahalme wrote:
> Use CRC32 intrinsics for hash computations when building for
> X86_64 with SSE4_2.
>
> Add a new hash_words64() and change hash_words() to be inlined when
> 'n_words' is a compile-time constant.
>
> Signed-off-by: Jarno Rajahalme
On Wed, Jul 02, 2014 at 03:00:16PM -0700, Ryan Wilson wrote:
> This fixes valgrind errors.
>
> Signed-off-by: Ryan Wilson
Applied, thanks!
___
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/listinfo/dev
Even better. Thanks!
Acked-by: Joe Stringer
___
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/listinfo/dev
Add an internal mutex to the struct cls_classifier, and reorganize
classifier internal structures according to the user of each field,
marking the fields that need to be protected by the mutex. This makes
locking requirements easier to track, and may make lookup more memory
efficient.
After this
cls_set_prefix_fields() now synchronizes explicitly with the readers,
waiting them to finish using the old configuration before changing to
the new configuration.
Signed-off-by: Jarno Rajahalme
---
v3: No change.
lib/classifier.c| 214 +--
li
Now that all the relevant classifier structures use RCU and internal
mutual exclusion for modifications, we can remove the fat-rwlock and
thus make the classifier lookups lockless.
As the readers are operating concurrently with the writers, a
concurrent reader may or may not see a new rule being a
Hide the cursor from the classifier iteration users and move locking to
the iterators. This will make following RCU changes simpler, as the call
sites of the iterators need not be changed at that point.
Signed-off-by: Jarno Rajahalme
---
v3: No change.
lib/classifier.c| 70 ++
Rename 'nbits' as 'n_bits' to be more consistent with other count-like
fields.
Signed-off-by: Jarno Rajahalme
---
v3: No change.
lib/classifier.c | 60 +++---
1 file changed, 30 insertions(+), 30 deletions(-)
diff --git a/lib/classifier.c b/lib
The following patch will add the first external user.
Signed-off-by: Jarno Rajahalme
---
v3: No change.
lib/ovs-rcu.c |3 +--
lib/ovs-rcu.h |4
2 files changed, 5 insertions(+), 2 deletions(-)
diff --git a/lib/ovs-rcu.c b/lib/ovs-rcu.c
index 050a2ef..a052d6c 100644
--- a/lib/ovs-r
Use cmap instead of hmap & hindex in classifier. Performance impact
with current locking strategy is not yet tested. Later patches will
introduce RCU into the classifier.
Signed-off-by: Jarno Rajahalme
Acked-by: Ben Pfaff
---
v3: No change, but will push this patch only with the rest of the se
Great, thanks.
On Mon, Jul 07, 2014 at 02:16:29PM -0700, Jarno Rajahalme wrote:
> This small change made the last patch of the original series not
> apply any more, I?ll send a rebased v3 series out in a moment to
> keep things simple. No other changes, so if reviews are underway,
> they should ap
This small change made the last patch of the original series not apply any
more, I’ll send a rebased v3 series out in a moment to keep things simple. No
other changes, so if reviews are underway, they should apply as-is.
Jarno
On Jul 7, 2014, at 1:40 PM, Jarno Rajahalme wrote:
> Thanks for
Pushed, thanks for the review!
Jarno
On Jul 7, 2014, at 9:26 AM, Ben Pfaff wrote:
> On Mon, Jun 30, 2014 at 08:17:21AM -0700, Jarno Rajahalme wrote:
>> Signed-off-by: Jarno Rajahalme
>
> Acked-by: Ben Pfaff
___
dev mailing list
dev@openvswitch.o
On Jul 7, 2014, at 9:47 AM, Ben Pfaff wrote:
> On Fri, Jul 04, 2014 at 07:21:18AM -0700, Jarno Rajahalme wrote:
>> After a quick analysis, in most cases the access to refcounted objects
>> is clearly protected either with an explicit lock/mutex, or RCU. there
>> are only a few places where I lef
Thanks for the reviews, series pushed with suggested changes (upto this patch),
Jarno
On Jul 7, 2014, at 9:47 AM, Ben Pfaff wrote:
> On Fri, Jul 04, 2014 at 07:21:19AM -0700, Jarno Rajahalme wrote:
>> This is a prerequisite step in making the classifier lookups lockless.
>> If taking a refere
Use CRC32 intrinsics for hash computations when building for
X86_64 with SSE4_2.
Add a new hash_words64() and change hash_words() to be inlined when
'n_words' is a compile-time constant.
Signed-off-by: Jarno Rajahalme
---
v2: Changed hash_words to be inlined only when 'n_words' is known to be a
This patch fixes two compile warnings introduced by commit
64b73291 ("util: create a copy of program_name"):
1. ../lib/util.c:457:5: error: passing argument 1 of 'free'
discards 'const' qualifier from pointer target type; And
2. ../lib/util.c:463:5: error: ISO C90 forbids mixed declarations
a
On Sun, Jul 6, 2014 at 3:37 PM, Joe Stringer wrote:
> I feel like this is easier to follow if there's only one #ifdef block.
Thanks for pointing this out. This can actually be factorized out even
more by taking out free(program_name) out of both #ifdefs. Will send
v2 patch soon.
>
> We could comb
On 7/7/14, 7:23 PM, Ben Pfaff wrote:
On Fri, Jun 27, 2014 at 04:21:54PM +0300, Lorand Jakab wrote:
This commit relaxes the assumption that all packets have an Ethernet
header, and adds support for layer 3 flows. For each packet received on
the Linux kernel datapath the l2 and l3 members of stru
On Fri, Jul 04, 2014 at 07:21:19AM -0700, Jarno Rajahalme wrote:
> This is a prerequisite step in making the classifier lookups lockless.
> If taking a reference fails, we do the lookup again, as a new (lower
> priority) rule may now match instead.
>
> Also remove unwildcarding dl_type and nw_frag
On Fri, Jul 04, 2014 at 07:21:18AM -0700, Jarno Rajahalme wrote:
> After a quick analysis, in most cases the access to refcounted objects
> is clearly protected either with an explicit lock/mutex, or RCU. there
> are only a few places where I left a call to ovs_refcount_unref().
> Upon closer analy
On Fri, Jul 04, 2014 at 07:21:17AM -0700, Jarno Rajahalme wrote:
> When a reference counted object is also RCU protected the deletion of
> the object's memory is always postponed. This allows
> memory_order_relaxed to be used also for unreferencing, as RCU
> quiescing provides a full memory barrie
On Fri, Jul 04, 2014 at 07:21:15AM -0700, Jarno Rajahalme wrote:
> Use explicit variants of atomic operations for the ovs_refcount to
> avoid the overhead of the default memory_order_seq_cst.
>
> Adding a reference requires no memory ordering, as the calling thread
> is already assumed to have pro
On Fri, Jul 04, 2014 at 07:21:16AM -0700, Jarno Rajahalme wrote:
> Add support for atomic compare_exchange operations.
>
> Signed-off-by: Jarno Rajahalme
Acked-by: Ben Pfaff
___
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/listi
Dear Sir/Madam
B&H King Mold Limited is a professional plastic injection mold maker in
Shenzhen China.
Please feel free to contact me for further details or send us your drawings for
a quote.
Best Regards
Nula Han
King Mold / Business Dept.
Tel: +86-755-89472535
__
Yes, Yamamoto-san's patch fixed warning by using CONST_CAST. I think
changing "program_name" type to "char*" could be a cleaner solution.
However, it does not address the second issue for branch-2.3 (ISO C90
forbids mixed declarations and code). This same issue is not present
in master though.
On
Yes, I figured it might be better pipeline the revision process to get things
through faster :-)
Jarno
On Jul 7, 2014, at 9:31 AM, Ben Pfaff wrote:
> It looks like you posted a v2 of just the beginning of the series also?
> I'll review those, then we can look at the rest of the series.
>
>
It looks like you posted a v2 of just the beginning of the series also?
I'll review those, then we can look at the rest of the series.
On Mon, Jun 30, 2014 at 04:40:06PM -0700, Jarno Rajahalme wrote:
> Just to be clear, this is a v2 on the patch 12/12 of the series, due to the
> batching changes
On Fri, Jul 04, 2014 at 06:03:53AM -0700, Jarno Rajahalme wrote:
>
> On Jul 3, 2014, at 2:26 PM, Ben Pfaff wrote:
>
> > On Mon, Jun 30, 2014 at 08:17:19AM -0700, Jarno Rajahalme wrote:
> >> Add support for atomic compare_exchange operations.
> >>
> >> Add ovs_refcount_try_ref(), which takes a r
On Mon, Jun 30, 2014 at 08:17:21AM -0700, Jarno Rajahalme wrote:
> Signed-off-by: Jarno Rajahalme
Acked-by: Ben Pfaff
___
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/listinfo/dev
On Fri, Jun 27, 2014 at 04:21:53PM +0300, Lorand Jakab wrote:
> These actions will allow L2->L3 and L3->L2 switching, and are supposed
> to be added to flows installed in the datapath transparently by
> ovs-vswitchd.
>
> Signed-off-by: Lorand Jakab
Looks good to me, needs approval of Jesse or Pr
On Fri, Jun 27, 2014 at 04:21:54PM +0300, Lorand Jakab wrote:
> This commit relaxes the assumption that all packets have an Ethernet
> header, and adds support for layer 3 flows. For each packet received on
> the Linux kernel datapath the l2 and l3 members of struct ofpbuf are
> intialized appropr
On 7/7/14, 7:03 PM, Ben Pfaff wrote:
On Fri, Jun 27, 2014 at 04:21:52PM +0300, Lorand Jakab wrote:
This series implements support for layer 3 ports, of which we have one example
so far, the LISP vport. LISP support is currently implemented with a hack, by
adding/removing the Ethernet header wi
On Fri, Jun 27, 2014 at 04:21:52PM +0300, Lorand Jakab wrote:
> This series implements support for layer 3 ports, of which we have one example
> so far, the LISP vport. LISP support is currently implemented with a hack, by
> adding/removing the Ethernet header within the datapath/vport-lisp.c file
I took a look at the patch. It's not necessary to submit a
pull-request.
The change seems reasonable to me. Will you submit a followup patch to
make use of the new statistics? I do not think it makes sense to apply
this until they are used.
On Fri, Jun 27, 2014 at 11:34:11AM -0700, Neil McKee
On Fri, Jul 04, 2014 at 12:37:12PM +1200, Joe Stringer wrote:
> Change the interface to allow implementations to pass back a buffer, and
> allow callers to specify which of actions, mask, and stats they wish to
> receive. This will be used in the next commit.
>
> Signed-off-by: Joe Stringer
> ---
On Fri, Jul 04, 2014 at 10:58:28AM +1200, Joe Stringer wrote:
> Occasionally, this test would fail, with some of the ports reporting
> "may_enable: false" in the bond/show output. This commit fixes the race
> condition by waiting for may_enable to be true for all bond ports.
>
> Signed-off-by: Joe
On Fri, Jul 04, 2014 at 11:55:30AM -0700, Jarno Rajahalme wrote:
>
> On Jun 12, 2014, at 1:31 PM, Ben Pfaff wrote:
>
> > On Wed, Jun 04, 2014 at 04:32:21PM -0700, Jarno Rajahalme wrote:
> >> Use CRC32 intrinsics for hash computations when building for
> >> X86_64 with SSE4_2.
> >>
> >> Signed-o
On Fri, Jul 04, 2014 at 12:33:03PM -0700, Ansis Atteka wrote:
> This patch fixes two compile warnings introduced by commit
> 64b73291 ("util: create a copy of program_name"):
> 1. ../lib/util.c:457:5: error: passing argument 1 of 'free'
>discards 'const' qualifier from pointer target type; And
63 matches
Mail list logo