This is great and I was not aware of this. Although I knew GCC and GDB
builds support build directories.
IMHO, It will be helpful to other developers as well.
On Thu, May 8, 2014 at 9:42 PM, Ben Pfaff wrote:
> On Fri, May 09, 2014 at 01:37:19PM +0900, YAMAMOTO Takashi wrote:
>> > On Fri, May 09,
When deleting a mask from the mask array, we always move the last entry
into its current location. Another approach can be NULL in its current
place, and periodically compact it.
The approach taken by this patch is more efficient during run time.
During look up, fast path packet don't have to skip
On Fri, May 09, 2014 at 01:37:19PM +0900, YAMAMOTO Takashi wrote:
> > On Fri, May 09, 2014 at 01:26:03PM +0900, YAMAMOTO Takashi wrote:
> >> sorry, i didn't know builddir can be different from srcdir.
> >
> > I guess not everyone builds that way but I like to have multiple
> > builddirs so that I
> On Fri, May 09, 2014 at 01:26:03PM +0900, YAMAMOTO Takashi wrote:
>> sorry, i didn't know builddir can be different from srcdir.
>
> I guess not everyone builds that way but I like to have multiple
> builddirs so that I can easily do both Clang and GCC builds off a single
> source tree.
sounds
On Fri, May 09, 2014 at 01:33:15PM +0900, YAMAMOTO Takashi wrote:
> > CC: YAMAMOTO Takashi
> > Signed-off-by: Ben Pfaff
>
> thanks!
>
> Reviewed-by: YAMAMOTO Takashi
Thank you!
Applied to master.
___
dev mailing list
dev@openvswitch.org
http://open
> CC: YAMAMOTO Takashi
> Signed-off-by: Ben Pfaff
thanks!
Reviewed-by: YAMAMOTO Takashi
> ---
> v1->v2: Add missing slash.
>
> vswitchd/automake.mk | 2 +-
> vtep/automake.mk | 2 +-
> 2 files changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/vswitchd/automake.mk b/vswitchd/aut
CC: YAMAMOTO Takashi
Signed-off-by: Ben Pfaff
---
v1->v2: Add missing slash.
vswitchd/automake.mk | 2 +-
vtep/automake.mk | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/vswitchd/automake.mk b/vswitchd/automake.mk
index fd291ef..a09605f 100644
--- a/vswitchd/automake
On Fri, May 09, 2014 at 01:26:03PM +0900, YAMAMOTO Takashi wrote:
> sorry, i didn't know builddir can be different from srcdir.
I guess not everyone builds that way but I like to have multiple
builddirs so that I can easily do both Clang and GCC builds off a single
source tree.
> > - (dot -T pl
sorry, i didn't know builddir can be different from srcdir.
> CC: YAMAMOTO Takashi
> Signed-off-by: Ben Pfaff
> ---
> vswitchd/automake.mk | 2 +-
> vtep/automake.mk | 2 +-
> 2 files changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/vswitchd/automake.mk b/vswitchd/automake.mk
> in
CC: YAMAMOTO Takashi
Signed-off-by: Ben Pfaff
---
vswitchd/automake.mk | 2 +-
vtep/automake.mk | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/vswitchd/automake.mk b/vswitchd/automake.mk
index fd291ef..a09605f 100644
--- a/vswitchd/automake.mk
+++ b/vswitchd/automake.
This was causing a mismatch between the odp flow key in an upcall
compared to the odp flow key that is serialised upon flow_dump.
Signed-off-by: Joe Stringer
---
lib/dpif-netdev.c | 21 +++--
tests/ofproto-dpif.at | 116 -
2 files change
This implements an "optimistic concurrent cuckoo hash", a single-writer,
multiple-reader hash table data structure. The point of this data
structure is performance, so this commit message focuses on performance.
I tested the performance of cmap with the test-cmap utility included in
this commit.
Signed-off-by: Ben Pfaff
---
lib/dpif-netdev.c | 163 +++--
1 file changed, 82 insertions(+), 81 deletions(-)
diff --git a/lib/dpif-netdev.c b/lib/dpif-netdev.c
index 55712dd..b682876 100644
--- a/lib/dpif-netdev.c
+++ b/lib/dpif-netdev.c
@@ -32,6
v1->v2: Essentially rewrite the cmap code. Address all of Jarno's
comments. Remove hash value from cmap_node. Use RCU to chain together
cmap_nodes. Simplify hash calculation. Rename *_locked to *_protected to
be consistent with ovs-rcu. Add lots of comments to cmap_insert() and the
functions
Signed-off-by: Ben Pfaff
---
lib/ovs-rcu.h |2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/lib/ovs-rcu.h b/lib/ovs-rcu.h
index 4b451b2..e525307 100644
--- a/lib/ovs-rcu.h
+++ b/lib/ovs-rcu.h
@@ -117,7 +117,7 @@
* Use ovsrcu_get(TYPE, VAR) to read an RCU-protected pointer,
Thanks, I'll push this in a minute.
On Thu, May 08, 2014 at 12:50:39PM -0700, Andy Zhou wrote:
> Acked-by: Andy Zhou
>
> On Thu, May 8, 2014 at 12:41 PM, Ben Pfaff wrote:
> > Reported-by: Jarno Rajahalme
> > Signed-off-by: Ben Pfaff
> > ---
> > lib/util.h |2 --
> > 1 file changed, 2 del
On Fri, May 02, 2014 at 11:42:46AM -0700, Jarno Rajahalme wrote:
>
> On May 1, 2014, at 5:14 PM, Ben Pfaff wrote:
>
> > Signed-off-by: Ben Pfaff
Thanks.
I fixed the OVS_REQUIRES annotations that you pointed out.
> > static int
> > get_port_by_name(struct dp_netdev *dp,
> > c
Thanks for the review. Pushed to master.
On Thu, May 8, 2014 at 4:14 PM, Ben Pfaff wrote:
> On Thu, May 08, 2014 at 04:05:55PM -0700, Andy Zhou wrote:
>> Visual studio supports zero-size array within a struct or union,
>> but has to be the last element. GCC does not have this restriction.
>>
>>
On Thu, May 08, 2014 at 04:05:55PM -0700, Andy Zhou wrote:
> Visual studio supports zero-size array within a struct or union,
> but has to be the last element. GCC does not have this restriction.
>
> Commits 644cfd84772eb7d8 and 6fdaa45a6f6c9 make use of 0 size array.
> Remove them so that visual
Visual studio supports zero-size array within a struct or union,
but has to be the last element. GCC does not have this restriction.
Commits 644cfd84772eb7d8 and 6fdaa45a6f6c9 make use of 0 size array.
Remove them so that visual studio can compile them as well.
Reported-by: Gurucharan Shetty
Sig
Signed-off-by: Daniele Di Proietto
---
utilities/ovs-dev.py | 19 +++
1 file changed, 19 insertions(+)
diff --git a/utilities/ovs-dev.py b/utilities/ovs-dev.py
index 7a4425f..814a9d0 100755
--- a/utilities/ovs-dev.py
+++ b/utilities/ovs-dev.py
@@ -224,6 +224,12 @@ def run():
libintel_dpdk.a refuses to link with libopenvswitch unless -ldl is used
this could probably be fixed also by using -Wl,-whole-archive
Signed-off-by: Daniele Di Proietto
---
This could probably be fixed also by using -Wl,-whole-archive
---
acinclude.m4 | 6 +++---
1 file changed, 3 insertions(+),
On Mon, May 5, 2014 at 8:18 AM, Ben Pfaff wrote:
> On Thu, Apr 24, 2014 at 05:34:09PM -0700, Andy Zhou wrote:
>> Visual studio supports zero-size array within a struct or union,
>> but has to be the last element. GCC does not have this restriction.
>>
>> Commits 644cfd84772eb7d8 and 6fdaa45a6f6c9
Works for me
Daniele
2014-05-07 14:14 GMT-07:00 Ethan Jackson :
> Daniele, could you please review this?
>
> Ethan
>
> On Wed, May 7, 2014 at 1:39 PM, Ben Pfaff wrote:
> > On Wed, May 07, 2014 at 01:36:49PM -0700, Ethan Jackson wrote:
> >> Signed-off-by: Ethan Jackson
> >
> > I'll leave this
Thanks Ben, it's useful to know that this could be regular behaviour. I
dropped this patch and I plan to drop the patch which warns in this case
instead.
As Alex mentioned, I dug deeper and found a better solution.
On 9 May 2014 06:41, Alex Wang wrote:
> Hey Ben,
>
> FYI, Joe changed the implem
On Fri, Apr 11, 2014 at 4:29 PM, Jarno Rajahalme wrote:
> Masked set action allows more megaflow wildcarding. Masked set action
> is now supported for all writeable key types, except for the tunnel
> key.
The logic for the tunnel restriction is that it is always cleared at
the start of the pipel
Acked-by: Andy Zhou
On Thu, May 8, 2014 at 12:41 PM, Ben Pfaff wrote:
> Reported-by: Jarno Rajahalme
> Signed-off-by: Ben Pfaff
> ---
> lib/util.h |2 --
> 1 file changed, 2 deletions(-)
>
> diff --git a/lib/util.h b/lib/util.h
> index 743b9fe..4d0ba76 100644
> --- a/lib/util.h
> +++ b/li
Reported-by: Jarno Rajahalme
Signed-off-by: Ben Pfaff
---
lib/util.h |2 --
1 file changed, 2 deletions(-)
diff --git a/lib/util.h b/lib/util.h
index 743b9fe..4d0ba76 100644
--- a/lib/util.h
+++ b/lib/util.h
@@ -151,8 +151,6 @@ is_pow2(uintmax_t x)
#define CACHE_LINE_SIZE 64
BUILD_ASSERT_
On Fri, May 02, 2014 at 11:23:34AM -0700, Jarno Rajahalme wrote:
> On May 1, 2014, at 5:14 PM, Ben Pfaff wrote:
>
> > The results show:
> >
> >- Insertion is generally 3x to 5x faster in an hmap.
> >
> >- Iteration is generally about 3x faster in a cmap.
> >
> >- Search and mutatio
On Thu, May 08, 2014 at 08:45:25PM +0200, Thomas Graf wrote:
> A user may set LimitNOFILE through systemd or other means to set
> the maximum number of open file descriptors. Only modify the ulimit
> if not already set to a higher value by the user.
>
> Signed-off-by: Thomas Graf
Seems reasonabl
Hey Ben,
FYI, Joe changed the implementation to:
http://openvswitch.org/pipermail/dev/2014-May/039790.html
Thanks for pointing this out, this actually reminds me of the similar issue
in another project.
Thanks,
Alex Wang,
On Thu, May 8, 2014 at 11:31 AM, Ben Pfaff wrote:
> On Mon, May 05, 20
A user may set LimitNOFILE through systemd or other means to set
the maximum number of open file descriptors. Only modify the ulimit
if not already set to a higher value by the user.
Signed-off-by: Thomas Graf
---
utilities/ovs-ctl.in | 5 -
1 file changed, 4 insertions(+), 1 deletion(-)
di
On Mon, May 05, 2014 at 11:17:23AM +1200, Joe Stringer wrote:
> Previously, it was possible to open a netdevice as one type, then
> proceed to open it as a different type without first closing it. This
> would result in the original device and netdev class being used rather
> than the new one.
>
>
On Wed, May 07, 2014 at 02:02:21PM -0700, Andy Zhou wrote:
> Acked-by: Andy Zhou
>
> How about fold in the following changes as well?
That's good, thanks. I made the same change in the TRY_LOCK_FUNCTION
macro too.
I'll push this in a minute.
> diff --git a/lib/ovs-thread.c b/lib/ovs-thread.c
I forgot. Thanks for the reminder. I've done it now.
On Wed, May 07, 2014 at 02:11:23PM -0700, Andy Zhou wrote:
> I assume you will back port this to branch-2.2
>
> On Wed, May 7, 2014 at 1:13 PM, Ben Pfaff wrote:
> > On Wed, May 07, 2014 at 01:01:56PM -0700, Andy Zhou wrote:
> >> On Wed, May
On Thu, May 08, 2014 at 02:07:03PM +0300, Alexandru Copot wrote:
> On Thu, May 8, 2014 at 9:56 AM, Ben Pfaff wrote:
> > Signed-off-by: Ben Pfaff
> > ---
> > build-aux/extract-ofp-msgs | 1 +
> > include/openflow/openflow-1.4.h| 41 +++-
> > include/openflow/openflow-common
Dear Manager ,
Industry Ltd has specialized in LED Torches /Headlights and Bicycle Lamp
products and so on .
More than 98% of our products are exported and marketed all over the
world ,especially in Europe , North America ,Australia and South America
market and so on. Our clients include
On Thu, May 8, 2014 at 1:54 AM, Suresh Kumar Reddy Reddygari
wrote:
>
>
>> -Original Message-
>> From: Jesse Gross [mailto:je...@nicira.com]
>> Sent: Friday, May 02, 2014 11:33 PM
>> To: Suresh Kumar Reddy Reddygari
>> Cc: dev@openvswitch.org
>> Subject: Re: [ovs-dev] MacVTap support in OV
On Thu, May 8, 2014 at 3:04 AM, balaj...@freescale.com
wrote:
> Hi Jesse,
>
> IMHO, MacVTap support in OVS will give a performance boost for the VM traffic.
Why?
___
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/listinfo/dev
On Thu, May 8, 2014 at 9:56 AM, Ben Pfaff wrote:
> Signed-off-by: Ben Pfaff
> ---
> build-aux/extract-ofp-msgs | 1 +
> include/openflow/openflow-1.4.h| 41 +++-
> include/openflow/openflow-common.h | 3 +-
> lib/ofp-msgs.h | 14 ++--
> lib/ofp-util.
Hi Jesse,
IMHO, MacVTap support in OVS will give a performance boost for the VM traffic.
Regards,
Balaji.P
> -Original Message-
> From: dev [mailto:dev-boun...@openvswitch.org] On Behalf Of Jesse Gross
> Sent: Friday, May 02, 2014 11:33 PM
> To: Suresh Kumar Reddy Reddygari
> Cc: dev@ope
> -Original Message-
> From: Jesse Gross [mailto:je...@nicira.com]
> Sent: Friday, May 02, 2014 11:33 PM
> To: Suresh Kumar Reddy Reddygari
> Cc: dev@openvswitch.org
> Subject: Re: [ovs-dev] MacVTap support in OVS
>
> On Fri, May 2, 2014 at 3:04 AM, Suresh Kumar Reddy Reddygari
> wrote:
42 matches
Mail list logo