v1->v2: Essentially rewrite the cmap code.  Address all of Jarno's
comments.  Remove hash value from cmap_node.  Use RCU to chain together
cmap_nodes.  Simplify hash calculation.  Rename *_locked to *_protected to
be consistent with ovs-rcu.  Add lots of comments to cmap_insert() and the
functions it calls.  Miscellaneous documentation improvements and
refactoring.

Ben Pfaff (2):
  cmap: New module for cuckoo hash table.
  dpif-netdev: Use cmap for ports.

 lib/automake.mk   |    2 +
 lib/cmap.c        |  798 +++++++++++++++++++++++++++++++++++++++++++++++++++++
 lib/cmap.h        |  196 +++++++++++++
 lib/dpif-netdev.c |  163 +++++------
 tests/automake.mk |    2 +
 tests/test-cmap.c |  453 ++++++++++++++++++++++++++++++
 6 files changed, 1533 insertions(+), 81 deletions(-)
 create mode 100644 lib/cmap.c
 create mode 100644 lib/cmap.h
 create mode 100644 tests/test-cmap.c

-- 
1.7.10.4

_______________________________________________
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/listinfo/dev

Reply via email to