Add missing return statement.
Signed-off-by: Pravin B Shelar
---
datapath/linux/compat/include/linux/skbuff.h |3 ++-
1 files changed, 2 insertions(+), 1 deletions(-)
diff --git a/datapath/linux/compat/include/linux/skbuff.h
b/datapath/linux/compat/include/linux/skbuff.h
index 9868a98..79b
On Wed, Dec 4, 2013 at 5:19 PM, Pravin Shelar wrote:
> On Wed, Dec 4, 2013 at 4:58 PM, Jesse Gross wrote:
>> On Wed, Dec 4, 2013 at 4:36 PM, Pravin Shelar wrote:
>>> On Wed, Dec 4, 2013 at 4:23 PM, Jesse Gross wrote:
On Wed, Dec 4, 2013 at 3:42 PM, Pravin Shelar wrote:
> On Wed, Dec 4
On Wed, Dec 04, 2013 at 05:01:11PM -0800, Ben Pfaff wrote:
> On Thu, Dec 05, 2013 at 09:51:39AM +0900, Simon Horman wrote:
> > On Wed, Dec 04, 2013 at 04:44:17PM -0800, Ben Pfaff wrote:
> > > On Thu, Dec 05, 2013 at 08:58:49AM +0900, Simon Horman wrote:
> > > > On Wed, Dec 04, 2013 at 01:24:29PM -0
Acked-by: Ethan Jackson
On Wed, Dec 4, 2013 at 4:47 PM, Ben Pfaff wrote:
> This should behave the same as before but the code reads more naturally to
> me this way.
>
> Signed-off-by: Ben Pfaff
> ---
> vswitchd/bridge.c |5 ++---
> 1 file changed, 2 insertions(+), 3 deletions(-)
>
> diff
On Wed, Dec 4, 2013 at 4:58 PM, Jesse Gross wrote:
> On Wed, Dec 4, 2013 at 4:36 PM, Pravin Shelar wrote:
>> On Wed, Dec 4, 2013 at 4:23 PM, Jesse Gross wrote:
>>> On Wed, Dec 4, 2013 at 3:42 PM, Pravin Shelar wrote:
On Wed, Dec 4, 2013 at 1:08 PM, Jesse Gross wrote:
> On Fri, Nov 22,
On Thu, Dec 05, 2013 at 09:51:39AM +0900, Simon Horman wrote:
> On Wed, Dec 04, 2013 at 04:44:17PM -0800, Ben Pfaff wrote:
> > On Thu, Dec 05, 2013 at 08:58:49AM +0900, Simon Horman wrote:
> > > On Wed, Dec 04, 2013 at 01:24:29PM -0800, Ben Pfaff wrote:
> > > > On Thu, Nov 21, 2013 at 12:46:42PM +0
On Wed, Dec 4, 2013 at 4:36 PM, Pravin Shelar wrote:
> On Wed, Dec 4, 2013 at 4:23 PM, Jesse Gross wrote:
>> On Wed, Dec 4, 2013 at 3:42 PM, Pravin Shelar wrote:
>>> On Wed, Dec 4, 2013 at 1:08 PM, Jesse Gross wrote:
On Fri, Nov 22, 2013 at 1:20 PM, Pravin B Shelar
wrote:
> diff
On Wed, Dec 04, 2013 at 04:44:17PM -0800, Ben Pfaff wrote:
> On Thu, Dec 05, 2013 at 08:58:49AM +0900, Simon Horman wrote:
> > On Wed, Dec 04, 2013 at 01:24:29PM -0800, Ben Pfaff wrote:
> > > On Thu, Nov 21, 2013 at 12:46:42PM +0900, Simon Horman wrote:
> > > > The aim of this patch is to support p
This should behave the same as before but the code reads more naturally to
me this way.
Signed-off-by: Ben Pfaff
---
vswitchd/bridge.c |5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)
diff --git a/vswitchd/bridge.c b/vswitchd/bridge.c
index 6ce7d2b..0f4cf2c 100644
--- a/vswitchd/br
On Thu, Dec 05, 2013 at 08:58:49AM +0900, Simon Horman wrote:
> On Wed, Dec 04, 2013 at 01:24:29PM -0800, Ben Pfaff wrote:
> > On Thu, Nov 21, 2013 at 12:46:42PM +0900, Simon Horman wrote:
> > > The aim of this patch is to support provide infrastructure for
> > > verification
> > > of VLAN actions
Thanks for the review. Pushed to master.
On Wed, Dec 4, 2013 at 3:45 PM, Ben Pfaff wrote:
> On Wed, Dec 04, 2013 at 10:04:49PM -0800, Andy Zhou wrote:
> > Remove mf_random_value() which does not have any user now.
> >
> > Signed-off-by: Andy Zhou
>
> Acked-by: Ben Pfaff
>
___
On Wed, Dec 4, 2013 at 4:23 PM, Jesse Gross wrote:
> On Wed, Dec 4, 2013 at 3:42 PM, Pravin Shelar wrote:
>> On Wed, Dec 4, 2013 at 1:08 PM, Jesse Gross wrote:
>>> On Fri, Nov 22, 2013 at 1:20 PM, Pravin B Shelar wrote:
diff --git a/datapath/flow.c b/datapath/flow.c
index 57eb6b5..435
On Wed, Dec 4, 2013 at 3:42 PM, Pravin Shelar wrote:
> On Wed, Dec 4, 2013 at 1:08 PM, Jesse Gross wrote:
>> On Fri, Nov 22, 2013 at 1:20 PM, Pravin B Shelar wrote:
>>> diff --git a/datapath/flow.c b/datapath/flow.c
>>> index 57eb6b5..4353a4f 100644
>>> --- a/datapath/flow.c
>>> +++ b/datapath/f
On Wed, Dec 04, 2013 at 01:24:29PM -0800, Ben Pfaff wrote:
> On Thu, Nov 21, 2013 at 12:46:42PM +0900, Simon Horman wrote:
> > The aim of this patch is to support provide infrastructure for verification
> > of VLAN actions after an mpls_push action for OpenFlow1.3. This supplements
> > existing sup
There's no need to obtain the ifindex, because RTM_GETLINK is happy to take
the interface name. There's no need to do a full nl_policy_parse(),
because we only need a single attribute.
Signed-off-by: Ben Pfaff
---
lib/netdev-linux.c | 53 +---
1
On Wed, Dec 04, 2013 at 08:18:22AM -0800, Ben Pfaff wrote:
> On Wed, Dec 04, 2013 at 06:13:58PM +0900, Simon Horman wrote:
> > On Wed, Dec 04, 2013 at 06:08:17PM +0900, Simon Horman wrote:
> > > On Mon, Dec 02, 2013 at 01:21:28PM -0800, Ben Pfaff wrote:
> > > > On Mon, Dec 02, 2013 at 11:41:11AM +0
The OVS kernel module requires 2.6.32 or later, so there's no reason for
userspace to support older kernels. This commit removes the special
fallback code for retrieving Linux netdev stats in pre-2.6.19 kernels,
which should no longer be useful.
Signed-off-by: Ben Pfaff
---
lib/netdev-linux.c |
On Wed, Dec 04, 2013 at 10:04:49PM -0800, Andy Zhou wrote:
> Remove mf_random_value() which does not have any user now.
>
> Signed-off-by: Andy Zhou
Acked-by: Ben Pfaff
___
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/listinfo/d
On Wed, Dec 4, 2013 at 1:08 PM, Jesse Gross wrote:
> On Fri, Nov 22, 2013 at 1:20 PM, Pravin B Shelar wrote:
>> diff --git a/datapath/datapath.c b/datapath/datapath.c
>> index d0a8595..41f2f8b 100644
>> --- a/datapath/datapath.c
>> +++ b/datapath/datapath.c
>> @@ -750,6 +744,7 @@ static int ovs_f
Remove mf_random_value() which does not have any user now.
Signed-off-by: Andy Zhou
---
lib/meta-flow.c | 109 ---
lib/meta-flow.h |2 -
2 files changed, 111 deletions(-)
diff --git a/lib/meta-flow.c b/lib/meta-flow.c
index 9aaef6e..bc972
On Wed, Dec 4, 2013 at 1:48 PM, Thomas Graf wrote:
> On 12/04/2013 07:08 PM, Ben Pfaff wrote:
>> if one can come up with a
>> good heuristic to decide which sockets should be mmaped. One place
>> one could start would be to mmap the sockets that correspond to
>> physical ports.
>
>
> That sounds
On 12/04/2013 07:08 PM, Ben Pfaff wrote:
On Wed, Dec 04, 2013 at 06:20:53PM +0100, Thomas Graf wrote:
How about we limit the number of mmaped sockets to a configurable
maximum that defaults to 16 or 32?
Maybe you mean that we should only mmap some of the sockets that we
create. If so, this ap
Yes, I'm good with this patch. thx
On Wed, Dec 4, 2013 at 1:37 PM, Ben Pfaff wrote:
> On Mon, Nov 25, 2013 at 11:31:14AM -0800, Alex Wang wrote:
> > LGTM, one comment below,
> >
> >
> >
> > > -if ((dpif->epoll_fd >= 0) == enable) {
> > > -return 0;
> > > -}
> > > -
> > > -if
On Mon, Nov 25, 2013 at 11:31:14AM -0800, Alex Wang wrote:
> LGTM, one comment below,
>
>
>
> > -if ((dpif->epoll_fd >= 0) == enable) {
> > -return 0;
> > -}
> > -
> > -if (!enable) {
> > -destroy_channels(dpif);
> > -} else {
> > -struct dpif_port_dump po
On Wed, Dec 4, 2013 at 11:26 AM, Pravin B Shelar wrote:
> Following patch improves rxhash calculation, It is taken from
> upstream Linux kernel code.
> From kernel 3.8, skb_get_rxhash() can handle hardware generated
> l4-rxhash. Therefore compat skb_get_rxhash() is not used on
> kernel 3.8 or new.
On Thu, Nov 21, 2013 at 12:46:42PM +0900, Simon Horman wrote:
> The aim of this patch is to support provide infrastructure for verification
> of VLAN actions after an mpls_push action for OpenFlow1.3. This supplements
> existing support for verifying these actions for pre-OpenFlow1.3.
>
> In OpenF
On Wed, Dec 4, 2013 at 11:26 AM, Pravin B Shelar wrote:
> Rather than using complete flow hash, we can use skb->rxhash for
> calculating source port. Similar calculation is done by vxlan.
>
> Signed-off-by: Pravin B Shelar
Acked-by: Jesse Gross
___
de
On Fri, Nov 22, 2013 at 1:20 PM, Pravin B Shelar wrote:
> diff --git a/datapath/datapath.c b/datapath/datapath.c
> index d0a8595..41f2f8b 100644
> --- a/datapath/datapath.c
> +++ b/datapath/datapath.c
> @@ -750,6 +744,7 @@ static int ovs_flow_cmd_new_or_set(struct sk_buff *skb,
> struct genl_info
One more thing. There is no BRCOMPAT in master. So that will have to go.
On Wed, Dec 4, 2013 at 1:04 PM, Gurucharan Shetty wrote:
> On Wed, Dec 4, 2013 at 12:12 PM, Flavio Leitner wrote:
>> On Wed, Dec 04, 2013 at 10:27:10AM -0800, Gurucharan Shetty wrote:
>>> On Mon, Dec 2, 2013 at 5:13 PM, Fla
On Wed, Dec 4, 2013 at 12:12 PM, Flavio Leitner wrote:
> On Wed, Dec 04, 2013 at 10:27:10AM -0800, Gurucharan Shetty wrote:
>> On Mon, Dec 2, 2013 at 5:13 PM, Flavio Leitner wrote:
>> > There is a chicken and egg issue where common OVS
>> > configuration uses a controller which is only accessible
On Wed, Dec 04, 2013 at 10:27:10AM -0800, Gurucharan Shetty wrote:
> On Mon, Dec 2, 2013 at 5:13 PM, Flavio Leitner wrote:
> > There is a chicken and egg issue where common OVS
> > configuration uses a controller which is only accessible
> > via the network. So starting OVS before network.target
>
Following patch improves rxhash calculation, It is taken from
upstream Linux kernel code.
>From kernel 3.8, skb_get_rxhash() can handle hardware generated
l4-rxhash. Therefore compat skb_get_rxhash() is not used on
kernel 3.8 or new.
Signed-off-by: Pravin B Shelar
Reviewed-by: Thomas Graf
---
v1
Some distribution kernel has backported skb->rxhash (e.g. RHEL)
Following patch allows use precalculated rxhash.
Signed-off-by: Pravin B Shelar
Reviewed-by: Thomas Graf
Acked-by: Jesse Gross
---
acinclude.m4 |1 +
datapath/linux/compat/flow_dissector.c
Rather than using complete flow hash, we can use skb->rxhash for
calculating source port. Similar calculation is done by vxlan.
Signed-off-by: Pravin B Shelar
---
datapath/vport-lisp.c | 15 ++-
1 files changed, 10 insertions(+), 5 deletions(-)
diff --git a/datapath/vport-lisp.c b
Thanks. Pushed to the master with %#"PRIx32" as suggested.
On Wed, Dec 4, 2013 at 7:57 AM, Ben Pfaff wrote:
> On Wed, Dec 04, 2013 at 12:39:49AM -0800, Andy Zhou wrote:
> > Refactor to remove some duplicated logic in match_format()
> > implemenation and make the output more uniform.
> >
> > Sig
On Wed, Dec 4, 2013 at 11:15 AM, Ben Pfaff wrote:
> On Wed, Dec 04, 2013 at 10:22:47AM -0800, Gurucharan Shetty wrote:
>> On Mon, Dec 2, 2013 at 5:13 PM, Flavio Leitner wrote:
>> > Include byte compiled files to speed up the execution,
>> > to avoid spurious SELinux AVC denials and also to make
>
On Wed, Dec 04, 2013 at 10:22:47AM -0800, Gurucharan Shetty wrote:
> On Mon, Dec 2, 2013 at 5:13 PM, Flavio Leitner wrote:
> > Include byte compiled files to speed up the execution,
> > to avoid spurious SELinux AVC denials and also to make
> > rpm happy when checking for unpackaged files:
> >
> >
On Wed, Dec 04, 2013 at 10:28:10AM -0800, Jarno Rajahalme wrote:
> On Dec 3, 2013, at 2:58 PM, Ben Pfaff wrote:
> > Bugs (?)
> >
> >
> > I think the intent is that the 'prefix' member of struct trie_node is
> > stored "left justified", so that the first bit of the prefix is
> > shifted i
On Tue, Dec 03, 2013 at 03:53:27PM -0800, Jarno Rajahalme wrote:
>
> On Dec 3, 2013, at 9:11 AM, Ben Pfaff wrote:
> > The first precedent is for naming fields by their NXM or OXM names. I
> > seem to recall that I did it that way because those names are already
> > standardized (in the ONF docum
On Tue, Nov 26, 2013 at 8:55 PM, Jesse Gross wrote:
> On Tue, Nov 19, 2013 at 1:50 PM, Pravin B Shelar wrote:
>> diff --git a/datapath/linux/compat/include/linux/jump_label.h
>> b/datapath/linux/compat/include/linux/jump_label.h
>> new file mode 100644
>> index 000..8eaf776
>> --- /dev/null
On Wed, Dec 04, 2013 at 10:27:10AM -0800, Gurucharan Shetty wrote:
> > --- a/rhel/etc_sysconfig_network-scripts_ifdown-ovs
> > +++ b/rhel/etc_sysconfig_network-scripts_ifdown-ovs
> > @@ -34,7 +34,15 @@ if [ ! -x ${OTHERSCRIPT} ]; then
> > OTHERSCRIPT="/etc/sysconfig/network-scripts/ifdown-eth"
On Mon, Dec 2, 2013 at 5:13 PM, Flavio Leitner wrote:
> There is a chicken and egg issue where common OVS
> configuration uses a controller which is only accessible
> via the network. So starting OVS before network.target
> would break those configurations.
>
> However, the network doesn't come up
Ben,
Thanks for your review!
On Dec 3, 2013, at 2:58 PM, Ben Pfaff wrote:
> Here are some preliminary comments. I think I'd like a v5, if you're
> OK with that.
>
No problem :-)
>
> Bugs (?)
>
>
> I think the intent is that the 'prefix' member of struct trie_node is
> stored "lef
On Mon, Dec 2, 2013 at 5:13 PM, Flavio Leitner wrote:
> Include byte compiled files to speed up the execution,
> to avoid spurious SELinux AVC denials and also to make
> rpm happy when checking for unpackaged files:
>
> RPM build errors:
> Installed (but unpackaged) file(s) found:
>/usr/sh
On Wed, Dec 04, 2013 at 06:20:53PM +0100, Thomas Graf wrote:
> On 12/04/2013 05:33 PM, Ben Pfaff wrote:
> >If I'm doing the calculations correctly, this mmaps 8 MB per ring-based
> >Netlink socket on a system with 4 kB pages. OVS currently creates one
> >Netlink socket for each datapath port. Wit
or maybe fewer frames per ring. The 8MB per ring uniformly set on each port
could be a rigid setting.
Ideally the ring size should be a function of the need, which is the amount
of netlink traffic for the port using that socket.
Kais
On Wed, Dec 4, 2013 at 9:20 AM, Thomas Graf wrote:
> On 12/0
On 12/04/2013 05:33 PM, Ben Pfaff wrote:
If I'm doing the calculations correctly, this mmaps 8 MB per ring-based
Netlink socket on a system with 4 kB pages. OVS currently creates one
Netlink socket for each datapath port. With 1000 ports (a moderate
number; we sometimes test with more), that is
On Tue, Dec 03, 2013 at 12:19:02PM +0100, Thomas Graf wrote:
> Based on the initial patch by Cong Wang posted a couple of months
> ago.
>
> This is the user space counterpart needed for the kernel patch
> '[PATCH net-next 3/8] openvswitch: Enable memory mapped Netlink i/o'
>
> Allows the kernel t
On Wed, Dec 04, 2013 at 06:11:24PM +0900, Simon Horman wrote:
> On Mon, Dec 02, 2013 at 01:20:19PM -0800, Ben Pfaff wrote:
> > This form makes it obvious that an OpenFlow 1.1 implementation is missing.
> >
> > Signed-off-by: Ben Pfaff
>
> Reviewed-by: Simon Horman
>
> FWIW, I prefer this style
On Wed, Dec 04, 2013 at 06:13:58PM +0900, Simon Horman wrote:
> On Wed, Dec 04, 2013 at 06:08:17PM +0900, Simon Horman wrote:
> > On Mon, Dec 02, 2013 at 01:21:28PM -0800, Ben Pfaff wrote:
> > > On Mon, Dec 02, 2013 at 11:41:11AM +0900, Simon Horman wrote:
> > > > I am wondering if you would like m
On Wed, Dec 04, 2013 at 12:39:49AM -0800, Andy Zhou wrote:
> Refactor to remove some duplicated logic in match_format()
> implemenation and make the output more uniform.
>
> Signed-off-by: Andy Zhou
I would just use %#"PRIx32" instead of the logic that prints the 0x only
if the output is more th
V4:
1. update abstract table-features to bitmap
2. update ofproto, reduce copy when reply table features.
3. Move max_table_feature to oftable.
V3:
1. Delete variable OFPIT13_END, use OFPIT13_METER directly.
2. Fix implement, restructure with macro.
3. Add comments that describe table-
V4:
Add bitmap_count1 function to count all 1 bits.
---
lib/bitmap.c | 15 +++
lib/bitmap.h |1 +
2 files changed, 16 insertions(+), 0 deletions(-)
diff --git a/lib/bitmap.c b/lib/bitmap.c
index ac568e9..7dd5a0f 100644
--- a/lib/bitmap.c
+++ b/lib/bitmap.c
@@ -92,3 +92,18 @@ b
v4:
Add enums of ofp13_action_type and make them work.
V3:
Add func to get instruction/action name by OpenFlow instruction type directly.
---
include/openflow/openflow-1.3.h | 20 ++--
lib/ofp-actions.c | 19 +++
lib/ofp-actions.h
V4:
1. Delete duplication code.
2. Add new acts in *.def.
3. Update abstract table-features to bitmap.
4. Make decode_openflow13_props more general.
5. Update tests. Correct the wriable oxms.
V3:
1. Update names of functions/macros to make them meaningful.
2. Fix codingstyle.
3. Re
v4:
Implement abstract bitmap for table feature properties.
Make prop functions more general.
Remove duplicated code, use existed implement.
Squash some patches.
v1 to v3:
This patch is to implement table features GET msg in openflow 1.3.
The spec says:
If the request body contain
V4:
No change.
V3:
No change.
V2:
No change
V1:
Now the cli we implement is very crude. Maybe it could
display better.
Signed-off-by: Alexander Wu
Reviewed-by: Simon Horman
---
utilities/ovs-ofctl.c | 17 +
1 files changed, 17 insertions(+), 0 deletions(-)
diff -
On Wed, Nov 27, 2013 at 09:12:30AM +0900, Simon Horman wrote:
> On Tue, Nov 26, 2013 at 07:33:47AM -0800, Ben Pfaff wrote:
> > On Tue, Nov 26, 2013 at 05:08:04PM +0900, Simon Horman wrote:
> > > On Thu, Nov 21, 2013 at 12:46:41PM +0900, Simon Horman wrote:
> > > > Hi,
> > > >
> > > > This series i
On Wed, Dec 04, 2013 at 06:08:17PM +0900, Simon Horman wrote:
> On Mon, Dec 02, 2013 at 01:21:28PM -0800, Ben Pfaff wrote:
> > On Mon, Dec 02, 2013 at 11:41:11AM +0900, Simon Horman wrote:
> > > I am wondering if you would like me to add support for matching on
> > > in_phy_port, which appears to b
On Mon, Dec 02, 2013 at 01:20:20PM -0800, Ben Pfaff wrote:
> Signed-off-by: Ben Pfaff
Reviewed-by: Simon Horman
> ---
> DESIGN | 47
> +++
> include/openflow/openflow-1.1.h |7 +-
> lib/ofp-util.c | 41 +
On Mon, Dec 02, 2013 at 01:20:19PM -0800, Ben Pfaff wrote:
> This form makes it obvious that an OpenFlow 1.1 implementation is missing.
>
> Signed-off-by: Ben Pfaff
Reviewed-by: Simon Horman
FWIW, I prefer this style.
> ---
> lib/ofp-util.c | 183
> ++---
On 12/04/2013 02:54 AM, Zhuangyuxin wrote:
> In this patch, each frame takes 16k mem. For sockets used for upcall, does it
> make more sense to calculate frame size based on MTU of the netdev on the
> port?
I assume you mean max(MTU) over all ports? We would have to replace the
ring after each M
On Mon, Dec 02, 2013 at 01:21:28PM -0800, Ben Pfaff wrote:
> On Mon, Dec 02, 2013 at 11:41:11AM +0900, Simon Horman wrote:
> > I am wondering if you would like me to add support for matching on
> > in_phy_port, which appears to be optional. I am quite happy to do so, and
> > indeed I have most of
Refactor to remove some duplicated logic in match_format()
implemenation and make the output more uniform.
Signed-off-by: Andy Zhou
---
lib/dynamic-string.h |8 +
lib/match.c | 84 +++--
tests/ofproto-dpif.at |6 ++--
3 files c
64 matches
Mail list logo