Re: [ovs-dev] [PATCH] util: fix a printf format

2013-11-26 Thread Jesse Gross
On Tue, Nov 26, 2013 at 9:25 PM, YAMAMOTO Takashi wrote: > revert a mistake in commit 34582733. > ("Avoid printf type modifiers not supported by MSVC C runtime library.") > > Signed-off-by: YAMAMOTO Takashi Applied, thanks. ___ dev mailing list dev@ope

Re: [ovs-dev] [PATCH] util: fix a printf format

2013-11-26 Thread Ben Pfaff
Oops, thanks for finding this. I'm on vacation but I hope that someone will apply this soon. On Nov 27, 2013 12:26 AM, "YAMAMOTO Takashi" wrote: > revert a mistake in commit 34582733. > ("Avoid printf type modifiers not supported by MSVC C runtime library.") > > Signed-off-by: YAMAMOTO Takashi >

[ovs-dev] [PATCH] util: fix a printf format

2013-11-26 Thread YAMAMOTO Takashi
revert a mistake in commit 34582733. ("Avoid printf type modifiers not supported by MSVC C runtime library.") Signed-off-by: YAMAMOTO Takashi --- lib/util.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/lib/util.c b/lib/util.c index faa2cab..53c3849 100644 --- a/lib/util.c

Re: [ovs-dev] [PATCH] ofproto: Add OF1.4 elements to enum ofp_table_config

2013-11-26 Thread Simon Horman
On Tue, Nov 26, 2013 at 01:47:06PM -0800, Jarno Rajahalme wrote: > > On Nov 25, 2013, at 11:34 PM, Simon Horman wrote: > > > Add elements to enum ofp_table_config for table mod bits > > defined in OpenFlow1.4. > > > > Also tidy up the indentation of existing elements. > > > > Signed-off-by: Si

[ovs-dev] [PATCH v2] dpif-netdev: Remove unnecessary parameters from dp_netdev_port_input()

2013-11-26 Thread Simon Horman
The skb_priority, pkt_mark and tunl parameters of dp_netdev_port_input() are always passed as 0, 0 and NULL respectively. So rather than passing these values to dp_netdev_port_input() just use them directly. Signed-off-by: Simon Horman --- lib/dpif-netdev.c | 10 -- 1 file changed, 4 ins

Re: [ovs-dev] [PATCH] dpif-netdev: Remove unnecessary parameters from dp_netdev_execute_actions

2013-11-26 Thread Simon Horman
On Tue, Nov 26, 2013 at 07:34:18AM -0800, Jarno Rajahalme wrote: > > > On Nov 25, 2013, at 10:49 PM, Simon Horman wrote: > > > > The skb_priority, pkt_mark and tunl parameters dp_netdev_execute_actions > > I guess you meant dp_netdev_port_input... > > Conceptually I think this change is right,

Re: [ovs-dev] [PATCH 2/3] datapath: Add compile time check for rxhash

2013-11-26 Thread Jesse Gross
On Tue, Nov 19, 2013 at 1:50 PM, Pravin B Shelar wrote: > Some distribution kernel has backported skb->rxhash (e.g. RHEL) > Following patch allows use precalculated rxhash. > > Signed-off-by: Pravin B Shelar Acked-by: Jesse Gross ___ dev mailing list

Re: [ovs-dev] [PATCH 1/3] datapath: Improve compat rxhash functionality.

2013-11-26 Thread Jesse Gross
On Tue, Nov 19, 2013 at 1:50 PM, Pravin B Shelar wrote: > diff --git a/datapath/linux/compat/include/linux/jump_label.h > b/datapath/linux/compat/include/linux/jump_label.h > new file mode 100644 > index 000..8eaf776 > --- /dev/null > +++ b/datapath/linux/compat/include/linux/jump_label.h > +

[ovs-dev] Adding a payload to OF packet

2013-11-26 Thread Anu Mercian
Hi everyone, I am trying to see ways I can attach a payload to an openflow packet, for example OF packet-in message, such that I can parse it at the controller. Is there anyway to do this? In which module of openvswitch can this be set. For example, I would like to add a command in the payload,

Re: [ovs-dev] [PATCH 2/2] util: Make popcount() handle 64-bit integers, not separate popcount64().

2013-11-26 Thread Jarno Rajahalme
>> On Nov 18, 2013, at 1:19 PM, Ben Pfaff wrote: >> >> This also restores use, in practice, of the optimized implementation of >> population count. (As the comment on popcount32() says, this version is >> 2x faster than __builtin_popcount().) >> I just tested the builtin popcountll with -marc

Re: [ovs-dev] [PATCH v2.51 0/5] MPLS actions and matches

2013-11-26 Thread Simon Horman
On Tue, Nov 26, 2013 at 07:33:47AM -0800, Ben Pfaff wrote: > On Tue, Nov 26, 2013 at 05:08:04PM +0900, Simon Horman wrote: > > On Thu, Nov 21, 2013 at 12:46:41PM +0900, Simon Horman wrote: > > > Hi, > > > > > > This series implements MPLS actions and matches based on work by > > > Ravi K, Leo Alte

Re: [ovs-dev] Support for in_phy_port

2013-11-26 Thread Simon Horman
On Mon, Nov 25, 2013 at 10:48:36PM -0800, Ben Pfaff wrote: > On Tue, Nov 26, 2013 at 03:46:23PM +0900, Simon Horman wrote: > > On Mon, Nov 25, 2013 at 05:24:23PM -0800, Ben Pfaff wrote: > > > On Mon, Nov 25, 2013 at 05:22:47PM -0800, Jesse Gross wrote: > > > > On Mon, Nov 25, 2013 at 4:04 PM, Simon

Re: [ovs-dev] [tcpdump 1/5] byte-order: Make uint32_byteswap() available regardless of endianness.

2013-11-26 Thread Jarno Rajahalme
LGTM, and maybe it’s not worth trying to use a GCC builtin for this. Acked-by: Jarno Rajahalme Jarno On Nov 22, 2013, at 1:37 PM, Ben Pfaff wrote: > pcap_read() can use it whether we're big-endian or not. > > Signed-off-by: Ben Pfaff > --- > lib/byte-order.h |4 +--- > lib/pcap-file.c

Re: [ovs-dev] [PATCH] ofproto: Add OF1.4 elements to enum ofp_table_config

2013-11-26 Thread Jarno Rajahalme
On Nov 25, 2013, at 11:34 PM, Simon Horman wrote: > Add elements to enum ofp_table_config for table mod bits > defined in OpenFlow1.4. > > Also tidy up the indentation of existing elements. > > Signed-off-by: Simon Horman > --- > include/openflow/openflow-common.h | 15 +++ > 1 fil

[ovs-dev] [PATCH v4 4/6] lib/util: Rename ctz() as ctz32().

2013-11-26 Thread Jarno Rajahalme
ctz() returns 32 for zero input, and we already have ctz64(), so it makes sense to rename ctz() as ctz32(). Signed-off-by: Jarno Rajahalme --- lib/packets.c |2 +- lib/util.h|6 +++--- tests/test-util.c | 16 3 files changed, 12 insertions(+), 12 deletions(

[ovs-dev] [PATCH v4 5/6] lib/util: Add clz32() and clz64().

2013-11-26 Thread Jarno Rajahalme
Count leading zeroes using builtin if available. Make log_2_floor() use raw_clz() and inline log_2_floor() and log_2_ceil(). Signed-off-by: Jarno Rajahalme --- lib/util.c| 65 + lib/util.h| 44 ++

[ovs-dev] [PATCH v4 3/6] tests/ofproto-dpif.at: Avoid testing with incomplete TCP packets.

2013-11-26 Thread Jarno Rajahalme
Use nw_proto values that generate less debug logging due to parsing errors. Signed-off-by: Jarno Rajahalme --- tests/ofproto-dpif.at | 42 +- 1 file changed, 21 insertions(+), 21 deletions(-) diff --git a/tests/ofproto-dpif.at b/tests/ofproto-dpif.at in

[ovs-dev] [PATCH v4 1/6] dpif-netdev: Do not check mask if it doesn't exist.

2013-11-26 Thread Jarno Rajahalme
Ofproto always provides a valid pointer to a mask, but the mask length is zero when megaflows are disabled. Check the mask length before checking the mask, as the check can fail otherwise. Signed-off-by: Jarno Rajahalme --- lib/dpif-netdev.c |2 +- 1 file changed, 1 insertion(+), 1 deletion

[ovs-dev] [PATCH v4 2/6] lib/flow: Add IPv6 support for flow_compose().

2013-11-26 Thread Jarno Rajahalme
Add the missing code for generating IPv6 packets for testing purposes. Also make flow_compose() set the l4 and l7 pointers more consistently with flow_extract(). Signed-off-by: Jarno Rajahalme --- lib/flow.c| 94 + lib/packets.c

[ovs-dev] [PATCH v4 0/6] Classifier: Track address prefixes

2013-11-26 Thread Jarno Rajahalme
Revision addressing Ben's review comments. Jarno Rajahalme (6): dpif-netdev: Do not check mask if it doesn't exist. lib/flow: Add IPv6 support for flow_compose(). tests/ofproto-dpif.at: Avoid testing with incomplete TCP packets. lib/util: Rename ctz() as ctz32(). lib/util: Add clz32() an

[ovs-dev] ★ Dev, Sohaib Ayub left a message for you

2013-11-26 Thread Sohaib Ayub
Sohaib Ayub left a message for you Its sender and content will be shown only to you and you can delete it at any time. You can instantly reply to it, using the message exchange system. To find out what was written to you, just follow this link: http://eu1.badoo.com/0349602085/in/zEVf9DuuU2A/?lan

[ovs-dev] [PATCH v2] lib: More intuitive syntax for TCP flags matching.

2013-11-26 Thread Jarno Rajahalme
Allow TCP flags match specification with symbolic flag names. TCP flags are optionally specified as a string of flag names, each preceded by '+' when the flag must be one, or '-' when the flag must be zero. Any flags not explicitly included are wildcarded. The existing hex syntax is still allowe

Re: [ovs-dev] [PATCH] lib: More intuitive syntax for TCP flags matching.

2013-11-26 Thread Jarno Rajahalme
Thanks for the review Ben! New patch coming up, some non-essential commentary below. Jarno On Nov 25, 2013, at 3:24 PM, Ben Pfaff wrote: > On Tue, Nov 19, 2013 at 04:43:47PM -0800, Jarno Rajahalme wrote: >> Allow TCP flags match specification with symbolic flag names. TCP >> flags are optio

Re: [ovs-dev] Autoconf limits on Windows

2013-11-26 Thread Ben Pfaff
On Tue, Nov 26, 2013 at 10:46:36AM +, Alessandro Pilotti wrote: > > > On 26/nov/2013, at 08:10, "Ben Pfaff" wrote: > > > > Since you're OK with manual updates, I'm happy in principle with having > > IDE-related files in the repository as long as they are not unreasonably > > large. But ther

Re: [ovs-dev] [PATCH] dpif-netdev: Remove unnecessary parameters from dp_netdev_execute_actions

2013-11-26 Thread Jarno Rajahalme
> On Nov 25, 2013, at 10:49 PM, Simon Horman wrote: > > The skb_priority, pkt_mark and tunl parameters dp_netdev_execute_actions I guess you meant dp_netdev_port_input... Conceptually I think this change is right, except maybe for tunnel parameters, depending on how tunneling is implemented o

Re: [ovs-dev] [PATCH v2.51 0/5] MPLS actions and matches

2013-11-26 Thread Ben Pfaff
On Tue, Nov 26, 2013 at 05:08:04PM +0900, Simon Horman wrote: > On Thu, Nov 21, 2013 at 12:46:41PM +0900, Simon Horman wrote: > > Hi, > > > > This series implements MPLS actions and matches based on work by > > Ravi K, Leo Alterman, Yamahata-san and Joe Stringer. > > > > This series provides thre

Re: [ovs-dev] Autoconf limits on Windows

2013-11-26 Thread Alessandro Pilotti
> On 26/nov/2013, at 08:10, "Ben Pfaff" wrote: > > Since you're OK with manual updates, I'm happy in principle with having > IDE-related files in the repository as long as they are not unreasonably > large. But there's something weird going on. Why would special files > would be needed for syn

Re: [ovs-dev] [PATCH v2.51 0/5] MPLS actions and matches

2013-11-26 Thread Simon Horman
On Thu, Nov 21, 2013 at 12:46:41PM +0900, Simon Horman wrote: > Hi, > > This series implements MPLS actions and matches based on work by > Ravi K, Leo Alterman, Yamahata-san and Joe Stringer. > > This series provides three changes > > * Patches 1 - 3 > > Provide user-space support for the VLA