Re: [ovs-dev] [PATCH 3/4] ofproto-dpif: Push statistics less frequently.

2013-04-01 Thread Ethan Jackson
Thanks for the reviews, I'll merge this series shortly. Ethan On Mon, Apr 1, 2013 at 3:54 PM, Ben Pfaff wrote: > On Mon, Apr 01, 2013 at 03:50:22PM -0700, Ethan Jackson wrote: >> > Currently, I think, we push stats at least once a second. This >> > reduces that to at least once every two second

Re: [ovs-dev] [PATCH 3/4] ofproto-dpif: Push statistics less frequently.

2013-04-01 Thread Ben Pfaff
On Mon, Apr 01, 2013 at 03:50:22PM -0700, Ethan Jackson wrote: > > Currently, I think, we push stats at least once a second. This > > reduces that to at least once every two seconds, I think. Does > > pushing once a second reduce performance? > > It basically wipes out the benefit entirely. If

[ovs-dev] [netdev v2 0/4] refactor netdev code to make more sense

2013-04-01 Thread Ben Pfaff
This is the second posting of this series. The first version started at http://openvswitch.org/pipermail/dev/2013-March/026055.html Changes v1->v2: - Initial two patches dropped because they have been applied. - Fixed merge conflicts against current master. Ben Pfaff (4): netdev: Factor re

[ovs-dev] [netdev v2 3/4] Rename superclass members to 'up'.

2013-04-01 Thread Ben Pfaff
--- lib/netdev-bsd.c | 24 lib/netdev-dummy.c | 18 +- lib/netdev-linux.c | 38 +++--- lib/netdev-vport.c |8 4 files changed, 44 insertions(+), 44 deletions(-) diff --git a/lib/netdev-bsd.c b/lib/netdev

[ovs-dev] [netdev v2 1/4] netdev: Factor restoring flags into new "struct netdev_saved_flags".

2013-04-01 Thread Ben Pfaff
This gets rid of the only per-instance data in "struct netdev", which will make it possible to merge "struct netdev_dev" into "struct netdev" in a later commit. Signed-off-by: Ben Pfaff --- lib/dpif-netdev.c |6 ++- lib/netdev-dummy.c|5 +- lib/netdev-linux.c| 22 +++ l

[ovs-dev] [netdev v2 2/4] netdev: Add new "struct netdev_rx" for capturing packets from a netdev.

2013-04-01 Thread Ben Pfaff
Separating packet capture from "struct netdev" means that there is no remaining per-"struct netdev" state, which will allow us to get rid of "struct netdev_dev" (by renaming it to "struct netdev"). Signed-off-by: Ben Pfaff --- lib/dpif-netdev.c | 13 ++- lib/netdev-bsd.c | 309 ++

Re: [ovs-dev] [PATCH 3/4] ofproto-dpif: Push statistics less frequently.

2013-04-01 Thread Ethan Jackson
> Currently, I think, we push stats at least once a second. This > reduces that to at least once every two seconds, I think. Does > pushing once a second reduce performance? It basically wipes out the benefit entirely. If you feel that this approach is risky, I'd prefer to skip the patch entire

Re: [ovs-dev] [netdev 2/6] netdev: Remove netdev_is_open(), which has no users.

2013-04-01 Thread Ben Pfaff
Thanks, I applied patches 1 and 2 to master. The rest still need review, but they are slightly stale so I will repost them. On Fri, Mar 22, 2013 at 01:21:01PM -0700, Ethan Jackson wrote: > Acked-by: Ethan Jackson > > > > On Fri, Mar 15, 2013 at 3:55 PM, Ben Pfaff wrote: > > > Signed-off-by:

Re: [ovs-dev] [PATCH 2/4] ofproto-dpif: Run fast internally.

2013-04-01 Thread Ben Pfaff
On Mon, Apr 01, 2013 at 03:36:16PM -0700, Ethan Jackson wrote: > Here's an incremental. Thanks, looks good. ___ dev mailing list dev@openvswitch.org http://openvswitch.org/mailman/listinfo/dev

Re: [ovs-dev] [PATCH 2/4] ofproto-dpif: Run fast internally.

2013-04-01 Thread Ethan Jackson
Here's an incremental. --- ofproto/ofproto-dpif.c | 19 +-- 1 file changed, 9 insertions(+), 10 deletions(-) diff --git a/ofproto/ofproto-dpif.c b/ofproto/ofproto-dpif.c index 5fd20f0..30ef5f9 100644 --- a/ofproto/ofproto-dpif.c +++ b/ofproto/ofproto-dpif.c @@ -1121,21 +1121,19

Re: [ovs-dev] [PATCH 1/4] ofproto-dpif: Systematically push stats upon request.

2013-04-01 Thread Ben Pfaff
On Mon, Apr 01, 2013 at 03:29:14PM -0700, Ethan Jackson wrote: > Here's an incremental which I think should address your concerns. Yes, that's fine, thanks. ___ dev mailing list dev@openvswitch.org http://openvswitch.org/mailman/listinfo/dev

Re: [ovs-dev] [PATCH 1/4] ofproto-dpif: Systematically push stats upon request.

2013-04-01 Thread Ethan Jackson
Here's an incremental which I think should address your concerns. --- ofproto/ofproto-dpif.c |7 +++ 1 file changed, 7 insertions(+) diff --git a/ofproto/ofproto-dpif.c b/ofproto/ofproto-dpif.c index 69d59fc..0b16bfa 100644 --- a/ofproto/ofproto-dpif.c +++ b/ofproto/ofproto-dpif.c @@ -50

Re: [ovs-dev] [PATCH 4/4] ofproto: Increase default flow-eviction-threshold.

2013-04-01 Thread Ben Pfaff
On Sun, Mar 31, 2013 at 06:22:59PM -0700, Ethan Jackson wrote: > The flow-eviction-threshold presents a trade off between the > expense of maintaining large numbers of datapath flows, and the > benefit of avoid unnecessary flow misses. In some large Open > vSwitch deployments, we've seen the previ

Re: [ovs-dev] [PATCH 3/4] ofproto-dpif: Push statistics less frequently.

2013-04-01 Thread Ben Pfaff
On Sun, Mar 31, 2013 at 06:22:58PM -0700, Ethan Jackson wrote: > The most natural place to push facet statistics is in > update_stats() where they're pulled from the datapath. However, > under load, update_stats() can be called as many as 10 times per > second causing us to push statistics so freq

Re: [ovs-dev] [PATCH 2/4] ofproto-dpif: Run fast internally.

2013-04-01 Thread Ben Pfaff
On Sun, Mar 31, 2013 at 06:22:57PM -0700, Ethan Jackson wrote: > ofproto-dpif is responsible for quite a few book keeping tasks in > addition to handling flow misses. Many of these tasks (flow > expiration, flow revalidation, etc) can take many hundreds of > milliseconds, during which no misses ca

Re: [ovs-dev] [PATCH 1/4] ofproto-dpif: Systematically push stats upon request.

2013-04-01 Thread Ben Pfaff
On Sun, Mar 31, 2013 at 06:22:56PM -0700, Ethan Jackson wrote: > Commit bf1e8ff (ofproto-dpif: Push statistics in rule_get_stats()), > started down the road towards pushing stats on demand, but it > didn't go quite far enough. First, it neglected to push stats in > port_get_stats() and mirror_get_

Re: [ovs-dev] [bug15637 3/5] jsonrpc-server: Disconnect connections that queue too much data.

2013-04-01 Thread Ben Pfaff
I applied these first three commits to master. On Mon, Apr 01, 2013 at 10:17:15AM -0700, Justin Pettit wrote: > Looks good. > > --Justin > > > On Mar 27, 2013, at 2:44 PM, Ben Pfaff wrote: > > > Consider this situation: > > > >* OVSDB client A executes transactions very quickly for a lon

Re: [ovs-dev] [bug15637 1/5] json: New function json_serialized_length().

2013-04-01 Thread Ben Pfaff
On Mon, Apr 01, 2013 at 09:41:19AM -0700, Justin Pettit wrote: > On Mar 27, 2013, at 2:44 PM, Ben Pfaff wrote: > > > +static size_t > > +json_string_serialized_length(const char *string) > > +{ > > +size_t length; > > +uint8_t c; > > + > > +/* "" */ > > +length = 2; > > I think t

Re: [ovs-dev] [PATCH] test suite : add sFlow test

2013-04-01 Thread Ben Pfaff
On Mon, Apr 01, 2013 at 01:01:35PM -0700, Ben Pfaff wrote: > On Mon, Apr 01, 2013 at 12:41:49PM -0700, Neil Mckee wrote: > > On reflection, it's better if the sflow-test.c file just has the same > > Apache license as the other files in the tests directory. So I think the > > header should just

Re: [ovs-dev] [PATCH] test suite : add sFlow test

2013-04-01 Thread Ben Pfaff
On Mon, Apr 01, 2013 at 12:41:49PM -0700, Neil Mckee wrote: > On reflection, it's better if the sflow-test.c file just has the same Apache > license as the other files in the tests directory. So I think the header > should just be: > > /*

Re: [ovs-dev] [PATCH] test suite : add sFlow test

2013-04-01 Thread Neil Mckee
On reflection, it's better if the sflow-test.c file just has the same Apache license as the other files in the tests directory. So I think the header should just be: /*

Re: [ovs-dev] [PATCH] rhel: Add depmod.d conf file for rhel6 kmod package.

2013-04-01 Thread Ben Pfaff
On Sat, Mar 30, 2013 at 06:41:54PM -0700, Gurucharan Shetty wrote: > It looks like for Centos6.4, there is an upstream openvswitch > kernel module already installed. When we try to install kmod-openvswitch > package from this tree's pre-1.10 branches, we get the following warning: > "brcompat.ko ne

Re: [ovs-dev] [bug15637 3/5] jsonrpc-server: Disconnect connections that queue too much data.

2013-04-01 Thread Justin Pettit
Looks good. --Justin On Mar 27, 2013, at 2:44 PM, Ben Pfaff wrote: > Consider this situation: > >* OVSDB client A executes transactions very quickly for a long time. > >* OVSDB client B monitors the tables that A modifies, but (either > because B is connected over a slow network

Re: [ovs-dev] [bug15637 2/5] ovsdb-data: New functions for predicting serialized length of data.

2013-04-01 Thread Justin Pettit
Looks good. --Justin On Mar 27, 2013, at 2:44 PM, Ben Pfaff wrote: > These will be used for the first time in an upcoming commit. > > Signed-off-by: Ben Pfaff > --- > lib/ovsdb-data.c | 93 +++- > lib/ovsdb-data.h |6 +++- > tests/test-

Re: [ovs-dev] [bug15637 1/5] json: New function json_serialized_length().

2013-04-01 Thread Justin Pettit
On Mar 27, 2013, at 2:44 PM, Ben Pfaff wrote: > +static size_t > +json_string_serialized_length(const char *string) > +{ > +size_t length; > +uint8_t c; > + > +/* "" */ > +length = 2; I think this length represents the surrounding quotes, but until I looked at json_serialize_str

Re: [ovs-dev] [PATCH v2.23] datapath: Add basic MPLS support to kernel

2013-04-01 Thread Jesse Gross
On Sun, Mar 31, 2013 at 8:45 PM, Simon Horman wrote: > On Fri, Mar 29, 2013 at 07:02:27PM -0700, Jesse Gross wrote: >> On Wed, Mar 27, 2013 at 10:44 PM, Simon Horman wrote: >> > On Thu, Mar 21, 2013 at 04:50:03PM +0900, Simon Horman wrote: >> >> Allow datapath to recognize and extract MPLS labels

[ovs-dev] twenty two

2013-04-01 Thread Nick Robinson
"There are people in the world that seem to be alive. They breathe, walk, talk and live. However, they are indeed taken prisoner by the world, kept in bondage by life and smitten by the events. For staying alive, they belittle themselves so much so that they