Re: [ovs-dev] [PATCH] ovs-vsctl: Try connecting only once for active connections by default.

2013-03-15 Thread Ben Pfaff
On Fri, Mar 15, 2013 at 04:23:34PM -0700, Ansis Atteka wrote: > >> On Fri, Mar 15, 2013 at 1:37 PM, Ben Pfaff wrote: > >> > Until now, ovs-vsctl has kept trying to the database server until it > >> > succeeded or the timeout expired (if one was specified with --timeout). > >> > This meant that if

Re: [ovs-dev] [PATCH] ovs-vsctl: Try connecting only once for active connections by default.

2013-03-15 Thread Ansis Atteka
On Fri, Mar 15, 2013 at 4:14 PM, Ben Pfaff wrote: > On Fri, Mar 15, 2013 at 02:46:05PM -0700, Ansis Atteka wrote: >> On Fri, Mar 15, 2013 at 1:37 PM, Ben Pfaff wrote: >> > Until now, ovs-vsctl has kept trying to the database server until it >> > succeeded or the timeout expired (if one was specif

Re: [ovs-dev] [PATCH] ovs-vsctl: Try connecting only once for active connections by default.

2013-03-15 Thread Ben Pfaff
On Fri, Mar 15, 2013 at 02:46:05PM -0700, Ansis Atteka wrote: > On Fri, Mar 15, 2013 at 1:37 PM, Ben Pfaff wrote: > > Until now, ovs-vsctl has kept trying to the database server until it > > succeeded or the timeout expired (if one was specified with --timeout). > > This meant that if ovsdb-server

Re: [ovs-dev] [PATCH] ovs-vsctl: Try connecting only once for active connections by default.

2013-03-15 Thread Ansis Atteka
On Fri, Mar 15, 2013 at 2:46 PM, Ansis Atteka wrote: > On Fri, Mar 15, 2013 at 1:37 PM, Ben Pfaff wrote: >> Until now, ovs-vsctl has kept trying to the database server until it >> succeeded or the timeout expired (if one was specified with --timeout). >> This meant that if ovsdb-server wasn't run

[ovs-dev] HAVE A GOOD EVENING FROM B.H

2013-03-15 Thread MR B . H
Good evening my Friend, Hope you are having a good day? i sent you and email last year discussing a viable project with you on investment related issues. please let me know if you got my last mail with the details of the project sent from (mrg.l...@yahoo.co.uk) Thank you. Brian _

[ovs-dev] [netdev 4/6] netdev: Add new "struct netdev_rx" for capturing packets from a netdev.

2013-03-15 Thread Ben Pfaff
Separating packet capture from "struct netdev" means that there is no remaining per-"struct netdev" state, which will allow us to get rid of "struct netdev_dev" (by renaming it to "struct netdev"). Signed-off-by: Ben Pfaff --- lib/dpif-netdev.c | 13 ++- lib/netdev-bsd.c | 309 ++

[ovs-dev] [netdev 5/6] Rename superclass members to 'up'.

2013-03-15 Thread Ben Pfaff
--- lib/netdev-bsd.c | 24 lib/netdev-dummy.c | 18 +- lib/netdev-linux.c | 38 +++--- lib/netdev-vport.c |8 4 files changed, 44 insertions(+), 44 deletions(-) diff --git a/lib/netdev-bsd.c b/lib/netdev

[ovs-dev] [netdev 2/6] netdev: Remove netdev_is_open(), which has no users.

2013-03-15 Thread Ben Pfaff
Signed-off-by: Ben Pfaff --- lib/netdev.c |8 lib/netdev.h |2 -- 2 files changed, 0 insertions(+), 10 deletions(-) diff --git a/lib/netdev.c b/lib/netdev.c index 77080ea..156984a 100644 --- a/lib/netdev.c +++ b/lib/netdev.c @@ -320,14 +320,6 @@ netdev_close(struct netdev *netde

[ovs-dev] [netdev 1/6] netdev: Remove netdev_exists(), which has no users.

2013-03-15 Thread Ben Pfaff
Signed-off-by: Ben Pfaff --- lib/netdev.c | 21 - lib/netdev.h |1 - 2 files changed, 0 insertions(+), 22 deletions(-) diff --git a/lib/netdev.c b/lib/netdev.c index e338d7c..77080ea 100644 --- a/lib/netdev.c +++ b/lib/netdev.c @@ -320,27 +320,6 @@ netdev_close(struct n

[ovs-dev] [netdev 3/6] netdev: Factor restoring flags into new "struct netdev_saved_flags".

2013-03-15 Thread Ben Pfaff
This gets rid of the only per-instance data in "struct netdev", which will make it possible to merge "struct netdev_dev" into "struct netdev" in a later commit. Signed-off-by: Ben Pfaff --- lib/dpif-netdev.c |6 ++- lib/netdev-dummy.c|5 +- lib/netdev-linux.c| 22 +++ l

[ovs-dev] [netdev 0/6] refactor netdev code to make more sense

2013-03-15 Thread Ben Pfaff
The existence of "struct netdev" and "struct netdev_dev" has been a source of confusion for a long time. This series eliminates the latter. I think the result makes a lot more sense. Ben Pfaff (6): netdev: Remove netdev_exists(), which has no users. netdev: Remove netdev_is_open(), which has

Re: [ovs-dev] [PATCH] ipsec: unset IPSEC_MARK flag from skb_mark after tunnel packet is decapsulated

2013-03-15 Thread Jesse Gross
On Fri, Mar 15, 2013 at 2:10 PM, Ansis Atteka wrote: > On Thu, Mar 14, 2013 at 4:23 PM, Jesse Gross wrote: >> On Thu, Mar 14, 2013 at 2:27 PM, Ansis Atteka wrote: >>> After tunnel packet is unencapsulated we should unset IPsec flag from >>> skb_mark. >>> >>> Otherwise, IPsec policies would be ap

Re: [ovs-dev] [PATCH 3/4] Move execute_set_action to lib/odp-util.c

2013-03-15 Thread Jesse Gross
On Fri, Mar 15, 2013 at 7:27 AM, Simon Horman wrote: > Move execute_set_action from lib/dpif-netedev.c to lib/odp-util.c > > This is in preparation for using execute_set_action() > in lib/odp-util.c to handle recirculation/ > > Signed-off-by: Simon Horman > > packet.c might be a better place for

Re: [ovs-dev] [PATCH 2/4] Remove encal_dl_type from struct flow

2013-03-15 Thread Jesse Gross
On Fri, Mar 15, 2013 at 7:27 AM, Simon Horman wrote: > There were plans to use this in conjunction with inner/outer flows, > however that plan has been changed in favour of using recirculation. > This leaves us with the current usage. > > encal_dl_type is currently only used to allow decoding of p

Re: [ovs-dev] [PATCH 1/4] Revert "flow: Split flow_extract"

2013-03-15 Thread Jesse Gross
On Fri, Mar 15, 2013 at 7:27 AM, Simon Horman wrote: > It was planned to use this code to allow further processing of packets, a > second pass done when constructing a flow. Instead it is now planned to > use recirculation to address the problems that secondary processing aimed > to resolve. As

Re: [ovs-dev] [PATCH] ovs-vsctl: Try connecting only once for active connections by default.

2013-03-15 Thread Ansis Atteka
On Fri, Mar 15, 2013 at 1:37 PM, Ben Pfaff wrote: > Until now, ovs-vsctl has kept trying to the database server until it > succeeded or the timeout expired (if one was specified with --timeout). > This meant that if ovsdb-server wasn't running, then ovs-vsctl would hang. > The result was that almo

[ovs-dev] [PATCH] INSTALL: Admit that only GNU make works.

2013-03-15 Thread Ben Pfaff
I promised some time ago to take a look at fixing the behavior of the Makefiles with non-GNU make, but it doesn't realistically seem that I will. CC: Ed Maste Signed-off-by: Ben Pfaff --- INSTALL | 11 ++- 1 files changed, 6 insertions(+), 5 deletions(-) diff --git a/INSTALL b/INSTAL

[ovs-dev] Procés de selecció OBERT

2013-03-15 Thread La Lluna en un Cove
"La Lluna en un Cove · Revista de Relats en Català" convoca un nou procés de selecció Visita la web oficial de "La Lluna en un Cove" i informa-te'n. Clau de cerca: la lluna en un cove revista de relats en català Nova secció: "Una imatge, un text" "La Lluna en un Cove" us proposa un interes

Re: [ovs-dev] [PATCH] ipsec: unset IPSEC_MARK flag from skb_mark after tunnel packet is decapsulated

2013-03-15 Thread Ansis Atteka
On Thu, Mar 14, 2013 at 4:23 PM, Jesse Gross wrote: > On Thu, Mar 14, 2013 at 2:27 PM, Ansis Atteka wrote: >> After tunnel packet is unencapsulated we should unset IPsec flag from >> skb_mark. >> >> Otherwise, IPsec policies would be applied one more time on internal >> interfaces, if there is on

Re: [ovs-dev] [PATCH] ovs-dpctl: New add-flow, mod-flow, del-flow commands.

2013-03-15 Thread Ben Pfaff
Thanks for the review. I applied this to master. On Fri, Mar 15, 2013 at 12:56:03PM -0700, Andy Zhou wrote: > This looks good. Thanks for resending it. > > > On Fri, Mar 15, 2013 at 12:32 PM, Ben Pfaff wrote: > > > Signed-off-by: Ben Pfaff > > --- > > utilities/ovs-dpctl.8.in | 57 +++

[ovs-dev] [PATCH] ovs-vsctl: Try connecting only once for active connections by default.

2013-03-15 Thread Ben Pfaff
Until now, ovs-vsctl has kept trying to the database server until it succeeded or the timeout expired (if one was specified with --timeout). This meant that if ovsdb-server wasn't running, then ovs-vsctl would hang. The result was that almost every ovs-vsctl invocation in scripts specified a timeou

Re: [ovs-dev] [PATCH] ovs-dpctl: New add-flow, mod-flow, del-flow commands.

2013-03-15 Thread Andy Zhou
This looks good. Thanks for resending it. On Fri, Mar 15, 2013 at 12:32 PM, Ben Pfaff wrote: > Signed-off-by: Ben Pfaff > --- > utilities/ovs-dpctl.8.in | 57 +++- > utilities/ovs-dpctl.c| 128 > -- > 2 files changed, 166 inse

Re: [ovs-dev] [PATCH] datapath: Remove old patch interface definitions.

2013-03-15 Thread Jesse Gross
On Fri, Mar 15, 2013 at 12:36 PM, Pravin Shelar wrote: > On Fri, Mar 15, 2013 at 10:48 AM, Jesse Gross wrote: >> Patch ports have been completely moved to userspace at this point >> but one part of the interface remained. It's no longer used by >> either userspace or kernel so this deletes it. >

Re: [ovs-dev] [PATCH] datapath: Remove old patch interface definitions.

2013-03-15 Thread Pravin Shelar
On Fri, Mar 15, 2013 at 10:48 AM, Jesse Gross wrote: > Patch ports have been completely moved to userspace at this point > but one part of the interface remained. It's no longer used by > either userspace or kernel so this deletes it. > > Signed-off-by: Jesse Gross Looks good. Acked-by: Pravin

[ovs-dev] [PATCH] ovs-dpctl: New add-flow, mod-flow, del-flow commands.

2013-03-15 Thread Ben Pfaff
Signed-off-by: Ben Pfaff --- utilities/ovs-dpctl.8.in | 57 +++- utilities/ovs-dpctl.c| 128 -- 2 files changed, 166 insertions(+), 19 deletions(-) diff --git a/utilities/ovs-dpctl.8.in b/utilities/ovs-dpctl.8.in index b1b2570..2

[ovs-dev] [PATCH] datapath: Remove old patch interface definitions.

2013-03-15 Thread Jesse Gross
Patch ports have been completely moved to userspace at this point but one part of the interface remained. It's no longer used by either userspace or kernel so this deletes it. Signed-off-by: Jesse Gross --- include/linux/openvswitch.h |9 - 1 file changed, 9 deletions(-) diff --git

[ovs-dev] [PATCH net-next 5/5] openvswitch: Allow OVS_USERSPACE_ATTR_USERDATA to be variable length.

2013-03-15 Thread Jesse Gross
From: Ben Pfaff Until now, the optional OVS_USERSPACE_ATTR_USERDATA attribute had to be exactly 64 bits long, if it was present. However, 64 bits is not enough space to associate as much information with a flow as would be convenient for some userspace features now under development. This commi

[ovs-dev] [PATCH net-next 3/5] linux/openvswitch.h: Make OVSP_LOCAL 32-bit.

2013-03-15 Thread Jesse Gross
From: Jarno Rajahalme OVS ports are now 32-bit, so OVSP_LOCAL should be too. (Internally, kernel module still keeps port numbers 16-bit, though.) Signed-off-by: Jarno Rajahalme Signed-off-by: Jesse Gross --- include/linux/openvswitch.h |2 +- 1 file changed, 1 insertion(+), 1 deletion(-)

[ovs-dev] [PATCH net-next 2/5] openvswitch: Avoid useless holes in struct vport

2013-03-15 Thread Jesse Gross
From: Thomas Graf Having the 16bit port_no in between a set of pointers creates an unwanted and useless hole in the struct. Signed-off-by: Thomas Graf Signed-off-by: Jesse Gross --- net/openvswitch/vport.h |4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/net/openvswi

[ovs-dev] [PATCH net-next 1/5] openvswitch: Use eth_mac_addr() instead of duplicating it

2013-03-15 Thread Jesse Gross
From: Thomas Graf bonus: if we ever are to use IFF_LIVE_ADDR_CHANGE for anything further than to check availability in eth_mac_addr(), Open vSwitch will be ready for that. Signed-off-by: Thomas Graf Signed-off-by: Jesse Gross --- net/openvswitch/vport-internal_dev.c | 14 ++ 1 f

[ovs-dev] [PATCH net-next 4/5] openvswitch: Change ENOENT return value to ENODEV in lookup_vport().

2013-03-15 Thread Jesse Gross
From: Jarno Rajahalme This reduces the number of valid "no such device" error values that need special attention by the caller. Userspace code will need to keep on checking for both ENODEV and ENOENT as long as older kernel modules are around. Signed-off-by: Jarno Rajahalme Signed-off-by: Jess

[ovs-dev] [GIT net-next] Open vSwitch

2013-03-15 Thread Jesse Gross
A couple of minor enhancements for net-next/3.10. The largest is an extension to allow variable length metadata to be passed to userspace with packets. There is a merge conflict in net/openvswitch/vport-internal_dev.c: A existing commit modifies internal_dev_mac_addr() and a new commit deletes it

Re: [ovs-dev] [PATCH v2] debian, rhel, xenserver: Ability to collect ovs-ctl logs.

2013-03-15 Thread Gurucharan Shetty
On Fri, Mar 15, 2013 at 8:53 AM, Ben Pfaff wrote: > On Thu, Mar 14, 2013 at 01:54:01PM -0700, Gurucharan Shetty wrote: >> We use ovs-ctl from startup scripts to start, stop, restart, >> force-reload-kmod OVS daemons. ovs-ctl gives quite a descriptive >> o/p while running the above commands. But th

Re: [ovs-dev] [PATCH] Declare the version as "1.9.1".

2013-03-15 Thread Justin Pettit
On Mar 15, 2013, at 8:26 AM, Ben Pfaff wrote: > On Thu, Mar 14, 2013 at 05:29:27PM -0700, Justin Pettit wrote: >> Signed-off-by: Justin Pettit > > Looks good to me, thanks. Thanks. I pushed this to branch-1.9. --Justin ___ dev mailing list dev@o

Re: [ovs-dev] [PATCH v2] debian, rhel, xenserver: Ability to collect ovs-ctl logs.

2013-03-15 Thread Ben Pfaff
On Thu, Mar 14, 2013 at 01:54:01PM -0700, Gurucharan Shetty wrote: > We use ovs-ctl from startup scripts to start, stop, restart, > force-reload-kmod OVS daemons. ovs-ctl gives quite a descriptive > o/p while running the above commands. But the o/p goes to stdout. > Sometimes, this output is quite

Re: [ovs-dev] [PATCH] ovs-ofctl: Improve description of mod_nw_tos action.

2013-03-15 Thread Ben Pfaff
On Fri, Mar 15, 2013 at 08:35:15AM -0700, Jesse Gross wrote: > On Fri, Mar 15, 2013 at 8:25 AM, Ben Pfaff wrote: > > Reported-by: Murphy McCauley > > Signed-off-by: Ben Pfaff > > --- > > utilities/ovs-ofctl.8.in |6 +++--- > > 1 file changed, 3 insertions(+), 3 deletions(-) > > Looks good.

Re: [ovs-dev] [PATCH] ovs-ofctl: Improve description of mod_nw_tos action.

2013-03-15 Thread Jesse Gross
On Fri, Mar 15, 2013 at 8:25 AM, Ben Pfaff wrote: > Reported-by: Murphy McCauley > Signed-off-by: Ben Pfaff > --- > utilities/ovs-ofctl.8.in |6 +++--- > 1 file changed, 3 insertions(+), 3 deletions(-) Looks good. ___ dev mailing list dev@openvsw

Re: [ovs-dev] [PATCH] Declare the version as "1.9.1".

2013-03-15 Thread Ben Pfaff
On Thu, Mar 14, 2013 at 05:29:27PM -0700, Justin Pettit wrote: > Signed-off-by: Justin Pettit Looks good to me, thanks. ___ dev mailing list dev@openvswitch.org http://openvswitch.org/mailman/listinfo/dev

[ovs-dev] [PATCH] ovs-ofctl: Improve description of mod_nw_tos action.

2013-03-15 Thread Ben Pfaff
Reported-by: Murphy McCauley Signed-off-by: Ben Pfaff --- utilities/ovs-ofctl.8.in |6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/utilities/ovs-ofctl.8.in b/utilities/ovs-ofctl.8.in index e7d9cfb..3cc618d 100644 --- a/utilities/ovs-ofctl.8.in +++ b/utilities/ovs-ofc

Re: [ovs-dev] [PATCH] lib: Rename lib/pcap.h to avoid inclusion conflicts.

2013-03-15 Thread Ben Pfaff
On Fri, Mar 15, 2013 at 02:19:31AM -0700, Stephane A. Sezer wrote: > From: "Stephane A. Sezer" > > lib/pcap.h has a name that conflicts with /usr/include/pcap.h. When one > wants to include pcap.h from libpcap (i.e.: the one from /usr/include), one > may end up with pcap.h from openvswitch. > >

[ovs-dev] [PATCH 2/4] Remove encal_dl_type from struct flow

2013-03-15 Thread Simon Horman
There were plans to use this in conjunction with inner/outer flows, however that plan has been changed in favour of using recirculation. This leaves us with the current usage. encal_dl_type is currently only used to allow decoding of packets used in the test suite. However, this is a bit of a fudg

[ovs-dev] [PATCH 0/4] Packet Recirculation

2013-03-15 Thread Simon Horman
Hi, This series is my first attempt at implementing packet recirculation. The first three patches are preparatory patches to user-space code that could be considered for merging. The last patch implements recirculation, modifying ovs-vswtichd, library code, and the user-space and kernel datapath

[ovs-dev] [PATCH 1/4] Revert "flow: Split flow_extract"

2013-03-15 Thread Simon Horman
It was planned to use this code to allow further processing of packets, a second pass done when constructing a flow. Instead it is now planned to use recirculation to address the problems that secondary processing aimed to resolve. As a result there are no longer plans to use flow_extract_l3_onwa

[ovs-dev] [PATCH 3/4] Move execute_set_action to lib/odp-util.c

2013-03-15 Thread Simon Horman
Move execute_set_action from lib/dpif-netedev.c to lib/odp-util.c This is in preparation for using execute_set_action() in lib/odp-util.c to handle recirculation/ Signed-off-by: Simon Horman packet.c might be a better place for execute_set_action() but I'm unsure if accessing struct ovs_key_eth

Re: [ovs-dev] [GIT net] Open vSwitch

2013-03-15 Thread David Miller
From: Jesse Gross Date: Thu, 14 Mar 2013 17:15:00 -0700 > A few different bug fixes, including several for issues with userspace > communication that have gone unnoticed up until now. These are intended > for net/3.9. Pulled, thanks. ___ dev mailing l

[ovs-dev] [PATCH] lib: Rename lib/pcap.h to avoid inclusion conflicts.

2013-03-15 Thread Stephane A. Sezer
From: "Stephane A. Sezer" lib/pcap.h has a name that conflicts with /usr/include/pcap.h. When one wants to include pcap.h from libpcap (i.e.: the one from /usr/include), one may end up with pcap.h from openvswitch. This change renames this header to pcap-file.h and updates all references to this