On Thu, Mar 22, 2012 at 5:19 PM, Pravin B Shelar wrote:
> Fixed according to comments from Jesse.
> v1-v2:
> - Fixed version check of supported kernels.
> - Included linux version.h
> - Defined dst_get_neighbour_noref() as macro.
>
> --8<--cut here-
On Thu, Mar 22, 2012 at 3:00 PM, wrote:
> Ok thanks will wait for Jesse's inputs on kernel code. Sent latest patch in
> our automated unit-test discussion.
Please don't wait for me. I'm not planning on reviewing the code
further until the points that I mentioned before have been addressed.
___
Looks good to me.
Ethan
On Thu, Mar 22, 2012 at 13:24, Ben Pfaff wrote:
> Commit 1bf2c9096858 (idl: Generalize special case boolean exception.)
> changed the IDL to do dynamic allocation with (x)malloc() for optional
> booleans, but it didn't add the corresponding calls to free(). This
> commit
Fixed according to comments from Jesse.
v1-v2:
- Fixed version check of supported kernels.
- Included linux version.h
- Defined dst_get_neighbour_noref() as macro.
--8<--cut here-->8--
Signed-off-by: Pravin B Shelar
---
dat
Thanks so much. That was a really fast turnaround.
On Thu, Mar 22, 2012 at 03:56:00PM -0700, Mehak Mahajan wrote:
> The changes allow the user to specify a separate dscp value for the
> controller connection and the manager connection. The value will take
> effect on resetting the connections. If
On Thu, Mar 22, 2012 at 2:08 PM, wrote:
> Hi Jesse,
>
> Please note that I work in labs environment and I volunteer my time for this
> and I have very limited resources to test. I have done testing related to
> complete mpls actions via the test-program written which is in
> tests/test-mpls.c.
Fixed according to comments from Ben.
v2-v3:
- Fixed min mtu for non-internal devices.
- Fixed update_mtu() comment.
v1-v2:
- Do not allow larger mtu on internal device compared to
non internal devices..
--8<--cut here-->8--
In
On Thu, Mar 22, 2012 at 4:17 PM, Ben Pfaff wrote:
> On Thu, Mar 22, 2012 at 11:34:34AM -0700, Pravin B Shelar wrote:
>> Fixed according to comments from Ben.
>> v1-v2:
>> - Do not allow larger mtu on internal device compared to
>> non internal devices.
>>
>> --8<---
On Thu, Mar 22, 2012 at 03:47:00PM -0700, Ben Pfaff wrote:
> On Fri, Mar 23, 2012 at 07:40:24AM +0900, Simon Horman wrote:
> > On Thu, Mar 22, 2012 at 10:07:06AM -0700, Ben Pfaff wrote:
> > > On Thu, Mar 22, 2012 at 03:43:35PM +0900, Simon Horman wrote:
> > > > Make the name and description members
On Thu, Mar 22, 2012 at 04:17:42PM -0700, Ethan Jackson wrote:
> The CONTROLLER action assumed that all Ethernet frames stored their
> Ethernet Type in the two bytes succeeding the source and
> destination addresses. This turns out not to be true for 802.2 LLC
> frames, potentially causing an asse
The CONTROLLER action assumed that all Ethernet frames stored their
Ethernet Type in the two bytes succeeding the source and
destination addresses. This turns out not to be true for 802.2 LLC
frames, potentially causing an assertion failure. This patch
solves the issue by skipping the assertion i
On Thu, Mar 22, 2012 at 11:34:34AM -0700, Pravin B Shelar wrote:
> Fixed according to comments from Ben.
> v1-v2:
> - Do not allow larger mtu on internal device compared to
>non internal devices.
>
> --8<--cut here-->8--
>
> Internal de
On Fri, Mar 23, 2012 at 07:40:24AM +0900, Simon Horman wrote:
> On Thu, Mar 22, 2012 at 10:07:06AM -0700, Ben Pfaff wrote:
> > On Thu, Mar 22, 2012 at 03:43:35PM +0900, Simon Horman wrote:
> > > Make the name and description members of struct stress_option
> > > const as they are used to store cons
On Thu, Mar 22, 2012 at 03:10:33PM -0700, Ben Pfaff wrote:
> On Mon, Mar 19, 2012 at 09:54:45AM +0900, Simon Horman wrote:
> > This adds some more enum and struct definitions to
> > include/openflow/openflow-1.2.h. They were omitted from the patch that
> > created that file as they do not seem to b
On Thu, Mar 22, 2012 at 10:07:06AM -0700, Ben Pfaff wrote:
> On Thu, Mar 22, 2012 at 03:43:35PM +0900, Simon Horman wrote:
> > Make the name and description members of struct stress_option
> > const as they are used to store constant strings.
> >
> > Signed-off-by: Simon Horman
>
> With this pat
On Mon, Mar 19, 2012 at 09:54:45AM +0900, Simon Horman wrote:
> This adds some more enum and struct definitions to
> include/openflow/openflow-1.2.h. They were omitted from the patch that
> created that file as they do not seem to be in keeping with
> the treatment of Open Flow 1.1 in include/openf
On Mon, Mar 19, 2012 at 09:54:44AM +0900, Simon Horman wrote:
> This is a first pass at adding include/openflow/openflow-1.2.h to
> include enum and struct definitions for Open Flow 1.2 that
> are not already covered by Open Flow 1.1.
>
> Signed-off-by: Simon Horman
It looks mostly OK on a skim.
Ok thanks will wait for Jesse's inputs on kernel code. Sent latest patch in our
automated unit-test discussion.
-Original Message-
From: Ben Pfaff [mailto:b...@nicira.com]
Sent: Thursday, March 22, 2012 11:03 AM
To: Kerur, Ravi
Cc: dev@openvswitch.org
Subject: Re: MPLS important comment
On Thu, Mar 22, 2012 at 10:37 AM, Jesse Gross wrote:
> On Wed, Mar 21, 2012 at 5:13 PM, Ansis Atteka wrote:
> > diff --git a/datapath/datapath.c b/datapath/datapath.c
> > index d64fc32..aa5be89 100644
> > --- a/datapath/datapath.c
> > +++ b/datapath/datapath.c
> > @@ -1885,7 +1885,7 @@ static in
Hi Jesse,
Please note that I work in labs environment and I volunteer my time for this
and I have very limited resources to test. I have done testing related to
complete mpls actions via the test-program written which is in
tests/test-mpls.c. I have done basic vlan/mpls integration testing as w
Commit 1bf2c9096858 (idl: Generalize special case boolean exception.)
changed the IDL to do dynamic allocation with (x)malloc() for optional
booleans, but it didn't add the corresponding calls to free(). This
commit fixes the problem.
Bug #10357.
Reported-by: Paul Ingram
Reported-by: Krishna Mir
On Thu, Mar 22, 2012 at 11:03 AM, Ben Pfaff wrote:
> Sorry. I cannot accept half-finished code. I especially cannot take
> changes to the datapath without Jesse's approval, and I don't have
> that yet.
I've been hoping that things would settle down a little bit before
really taking a look at it
> If I fold in the following (basically dropping all the "const"s) it
> compiles warning-free for me and the generated code is prettier. What
> do you think?
Strange, I could have sworn I tried that when I originally wrote the patch. At
any rate works for me. I'll merge it that with this Increm
On Thu, Mar 22, 2012 at 11:11 AM, Daniele Milani wrote:
> I think I could try the first solution. Can you explain me how do I
> create the port used by dnsmasq?
>
> For example, is it correct to execute
> # ovs-vsctl add-port virbr1 port2 tag=2
> to create a port for the vLan whose tag is 2 named
On Thu, Mar 22, 2012 at 11:11 AM, Jesse Gross wrote:
> On Wed, Mar 21, 2012 at 5:08 PM, Pravin B Shelar wrote:
>> diff --git a/datapath/datapath.c b/datapath/datapath.c
>> index d64fc32..401e774 100644
>> --- a/datapath/datapath.c
>> +++ b/datapath/datapath.c
>> @@ -62,8 +62,8 @@
>> #include "vp
On Thu, Mar 22, 2012 at 11:32:06AM -0700, Ethan Jackson wrote:
> Sure here it is. (Rebased against master).
Thanks a lot.
If I fold in the following (basically dropping all the "const"s) it
compiles warning-free for me and the generated code is prettier. What
do you think?
Thanks,
Ben.
diff -
Fixed according to comments from Ben.
v1-v2:
- Do not allow larger mtu on internal device compared to
non internal devices.
--8<--cut here-->8--
Internal device mtu does not influence mtu of other internal devices.
So skip MTU update to
Sure here it is. (Rebased against master).
---
ovsdb/ovsdb-idlc.in | 48
vswitchd/bridge.c | 208 +--
2 files changed, 152 insertions(+), 104 deletions(-)
diff --git a/ovsdb/ovsdb-idlc.in b/ovsdb/ovsdb-idlc.in
index 089bc23..8df11
On Thu, Mar 22, 2012 at 10:56 AM, Ben Pfaff wrote:
> On Thu, Mar 22, 2012 at 10:54:20AM -0700, Pravin B Shelar wrote:
>> get_status actually returns driver information, so get_drv_info()
>> is better name.
>>
>> Signed-off-by: Pravin B Shelar
>
> Looks good to me, thank you.
Thanks,
I pushed pat
On Wed, Mar 21, 2012 at 5:08 PM, Pravin B Shelar wrote:
> diff --git a/datapath/datapath.c b/datapath/datapath.c
> index d64fc32..401e774 100644
> --- a/datapath/datapath.c
> +++ b/datapath/datapath.c
> @@ -62,8 +62,8 @@
> #include "vport-internal_dev.h"
>
> #if LINUX_VERSION_CODE < KERNEL_VERSI
I think I could try the first solution. Can you explain me how do I create the
port used by dnsmasq?
For example, is it correct to execute
# ovs-vsctl add-port virbr1 port2 tag=2
to create a port for the vLan whose tag is 2 named "port2"?
Daniele Milani
Date: Thu, 22 Mar 2012 10:54:21 -0700
On Tue, Mar 13, 2012 at 08:13:11PM +0100, ravi.ke...@telekom.com wrote:
> Thanks again Ben. Comments inline
Why don't you quote in a normal way, with some kind of indentation?
These markers are hard to spot.
Most of your responses make perfect sense to me. Thanks.
Can you post your current pa
On Thu, Mar 22, 2012 at 10:54:20AM -0700, Pravin B Shelar wrote:
> get_status actually returns driver information, so get_drv_info()
> is better name.
>
> Signed-off-by: Pravin B Shelar
Looks good to me, thank you.
___
dev mailing list
dev@openvswitch.
On Wed, Mar 14, 2012 at 06:17:46PM +0100, ker...@telekom.de wrote:
> We don't put unfinished code into our repository. You can make your
> life easier, though, a couple of ways. First, there's no need to
> merge or rebase often. You don't even have to do it before sending
> out a revised patch,
get_status actually returns driver information, so get_drv_info()
is better name.
Signed-off-by: Pravin B Shelar
---
lib/netdev-dummy.c|2 +-
lib/netdev-linux.c| 10 +-
lib/netdev-provider.h |6 +++---
lib/netdev-vport.c|8
lib/netdev.c |6
On Wed, Mar 21, 2012 at 5:13 PM, Ansis Atteka wrote:
> diff --git a/datapath/datapath.c b/datapath/datapath.c
> index d64fc32..aa5be89 100644
> --- a/datapath/datapath.c
> +++ b/datapath/datapath.c
> @@ -1885,7 +1885,7 @@ static int ovs_vport_cmd_set(struct sk_buff *skb,
> struct genl_info *info)
Looks good to me. Thanks.
--Justin
On Mar 22, 2012, at 10:20 AM, Ben Pfaff wrote:
> Commit 24e81092a1 (debian: Bring Debian packaging in-line with new file
> locations) introduced an ambiguous "--t" option invoking ovs-appctl, so
> ovs-vswitchd and ovsdb-server were not reopening their log fil
Thanks,
I pushed patch to master.
On Thu, Mar 22, 2012 at 9:18 AM, Jesse Gross wrote:
> On Wed, Mar 21, 2012 at 4:33 PM, Pravin B Shelar wrote:
>> Following patch fixes compilation error on older kernel.
>>
>> Signed-off-by: Pravin B Shelar
>
> Oops, I guess I put it in the wrong place.
>
> Ack
Commit 24e81092a1 (debian: Bring Debian packaging in-line with new file
locations) introduced an ambiguous "--t" option invoking ovs-appctl, so
ovs-vswitchd and ovsdb-server were not reopening their log files following
log rotation. This fixes the problem by correct the option name.
Reported-by:
Oh, sorry, I must have done something stupid, adding the "const" after
the ** doesn't make much sense.
Would you mind posting the whole revised patch again with the
incremental folded in? I want to figure out where I went wrong.
Thanks,
Ben.
On Wed, Mar 21, 2012 at 05:23:15PM -0700, Ethan Jack
On Thu, Mar 22, 2012 at 03:43:35PM +0900, Simon Horman wrote:
> Make the name and description members of struct stress_option
> const as they are used to store constant strings.
>
> Signed-off-by: Simon Horman
With this patch, I get from GCC:
../lib/process.h:26: note: expected ‘char **’ bu
On Thu, Mar 22, 2012 at 04:58:53PM +0900, Simon Horman wrote:
> On Tue, Mar 20, 2012 at 10:28:02AM -0700, Ben Pfaff wrote:
> > On Tue, Mar 20, 2012 at 11:43:38AM +0900, Simon Horman wrote:
> > > On Mon, Mar 19, 2012 at 02:31:36PM -0700, Ben Pfaff wrote:
> > > > On Mon, Mar 19, 2012 at 09:54:43AM +0
Thank you for implementing this feature!
On Tue, Mar 20, 2012 at 01:35:02PM -0700, Mehak Mahajan wrote:
> From: root
To get rid of this, run
git commit --amend --author='Mehak Mahajan '
and then exit the editor that it invokes to allow you to edit the
commit message.
> The changes allo
On Wed, Mar 21, 2012 at 4:33 PM, Pravin B Shelar wrote:
> Following patch fixes compilation error on older kernel.
>
> Signed-off-by: Pravin B Shelar
Oops, I guess I put it in the wrong place.
Acked-by: Jesse Gross
___
dev mailing list
dev@openvswitc
Thanks, I pushed this to master, branch-1.[456].
On Thu, Mar 22, 2012 at 12:04:34AM -0700, Justin Pettit wrote:
> That interface-reconfigure script is always causing us trouble. I'm
> guessing you got its MD5 checksum correct, so it looks good to me.
>
> Thanks,
>
> --Justin
>
>
> On Mar 21,
Dear all,
I have the following situation:
-I replaced the standard bridge driver with the Open vSwitch one;
-I started a NAT-network on Libvirt (bridge name virbr1);
-I started a Virtual Machine (VM1) on Libvirt, and I tagged his interface
(vnet0) with tag=2;
-if I run "# ovs-vsctl show" I obtain
On Tue, Mar 20, 2012 at 10:28:02AM -0700, Ben Pfaff wrote:
> On Tue, Mar 20, 2012 at 11:43:38AM +0900, Simon Horman wrote:
> > On Mon, Mar 19, 2012 at 02:31:36PM -0700, Ben Pfaff wrote:
> > > On Mon, Mar 19, 2012 at 09:54:43AM +0900, Simon Horman wrote:
[snip]
> > > Second, in a few cases OF1.2 s
That interface-reconfigure script is always causing us trouble. I'm guessing
you got its MD5 checksum correct, so it looks good to me.
Thanks,
--Justin
On Mar 21, 2012, at 5:13 PM, Ben Pfaff wrote:
> Somehow we forgot to put the md5sums for 5.6-SP2 so users were getting
> scary error message
48 matches
Mail list logo