This patch changes behavior a bit in the case where (wc &
FWW_NW_PROTO), the old code would ignore FWW_TP_SRC and its
compatriots. Was this change intentional?
Ethan
On Fri, Jan 27, 2012 at 17:18, Ben Pfaff wrote:
> Signed-off-by: Ben Pfaff
> ---
> lib/nx-match.c | 175
> +++
Looks good.
Ethan
On Fri, Jan 27, 2012 at 17:18, Ben Pfaff wrote:
> Every piece of code that may need to change whenever struct flow or struct
> flow_wildcards changes, but might easily get overlooked, should have a
> build assertion on the value of FLOW_WC_SEQ, but these functions did not.
>
>
Before I read this patch I have a high level question.
We currently publish the duration which is the number of seconds since
the rule has been created. It seems like the API would be more
consistent and conceptually cleaner, if similarly we published the
number of seconds since modified, and the
Looks good,
Ethan
On Wed, Feb 1, 2012 at 16:35, Ben Pfaff wrote:
> The ofctl_strip shell function was introduced a little while ago. It makes
> test results easier to read, in my opinion, by removing uninteresting
> bits. This commit adopts ofctl_strip throughout the tests.
>
> This is useful
Looks good,
Ethan
On Fri, Jan 27, 2012 at 12:49, Ben Pfaff wrote:
> Suggestion #9347.
> Suggested-by: Alan Shieh
> Signed-off-by: Ben Pfaff
> ---
> NEWS | 3 +++
> lib/table.c | 43 ++-
> lib/table.h |
Looks good,
Ethan
On Fri, Jan 27, 2012 at 12:49, Ben Pfaff wrote:
> Signed-off-by: Ben Pfaff
> ---
> lib/table.man | 2 +-
> ovsdb/ovsdb-client.1.in | 4
> 2 files changed, 5 insertions(+), 1 deletions(-)
>
> diff --git a/lib/table.man b/lib/table.man
> index 70ef778..a8f1
Looks good,
Ethan
On Thu, Jan 26, 2012 at 15:50, Ben Pfaff wrote:
> We try to have such a size check every protocol structure.
>
> Signed-off-by: Ben Pfaff
> ---
> include/openflow/nicira-ext.h | 1 +
> 1 files changed, 1 insertions(+), 0 deletions(-)
>
> diff --git a/include/openflow/nicir
Looks good,
Ethan
On Thu, Jan 26, 2012 at 15:50, Ben Pfaff wrote:
> I think that this was just an oversight.
>
> Signed-off-by: Ben Pfaff
> ---
> tests/automake.mk | 2 ++
> 1 files changed, 2 insertions(+), 0 deletions(-)
>
> diff --git a/tests/automake.mk b/tests/automake.mk
> index 9ae4c
Looks good,
Ethan
On Thu, Jan 26, 2012 at 15:50, Ben Pfaff wrote:
> Some commands weren't mentioned. The "invalid_ttl" option to "monitor"
> was missing.
>
> Signed-off-by: Ben Pfaff
> ---
> utilities/ovs-ofctl.c | 5 -
> 1 files changed, 4 insertions(+), 1 deletions(-)
>
> diff --git
Looks good,
Ethan
On Thu, Jan 26, 2012 at 15:50, Ben Pfaff wrote:
> ---
> vswitchd/vswitch.xml | 40 +++-
> 1 files changed, 23 insertions(+), 17 deletions(-)
>
> diff --git a/vswitchd/vswitch.xml b/vswitchd/vswitch.xml
> index 8c506e4..4b99b99 100644
> ---
Looks good,
Ethan
On Wed, Jan 18, 2012 at 11:30, Ben Pfaff wrote:
> I always assumed that macros would generate better code. I was wrong. The
> generated code was identical with inline functions, with GCC version 4.4.5.
>
> Signed-off-by: Ben Pfaff
> ---
> lib/hash.c | 12 ++--
> l
Doesn't matter at all, but seems like we'd want to use the range
49152–65535 as that's the IANA recommendation for this sort of thing.
Looks good,
Ethan
On Mon, Jan 30, 2012 at 14:00, Ben Pfaff wrote:
> A few tests need a random TCP port on which to listen for connections.
> Until now, the tests
Looks good,
Ethan
On Fri, Jan 27, 2012 at 12:50, Ben Pfaff wrote:
> This eliminates a kluge that was duplicated in three different daemons.
>
> Signed-off-by: Ben Pfaff
> ---
> lib/daemon.c | 36 ++--
> lib/daemon.h | 3 ++-
> ovsdb/ovsdb-
On Wed, Feb 01, 2012 at 04:57:35PM -0800, Justin Pettit wrote:
> On Feb 1, 2012, at 2:58 PM, Ben Pfaff wrote:
>
> > +xvu = row.external_ids.get("xs-vif-uuid")
> > +if xvu:
> > +iface_id = (new_iface_ids.get(xvu)
> > +or iface_ids.
On Feb 1, 2012, at 2:58 PM, Ben Pfaff wrote:
> +xvu = row.external_ids.get("xs-vif-uuid")
> +if xvu:
> +iface_id = (new_iface_ids.get(xvu)
> +or iface_ids.get(xvu)
> +or get_iface_id(row.name, xvu))
Do
Looks good,
Ethan
On Wed, Feb 1, 2012 at 16:35, Ben Pfaff wrote:
> When handle_flow_miss() handled a packet, it failed to update the rule's
> last-used time. The change to flow_push_stats() fixes the problem.
>
> The change to rule_execute() deletes code that becomes redundant after the
> chang
When handle_flow_miss() handled a packet, it failed to update the rule's
last-used time. The change to flow_push_stats() fixes the problem.
The change to rule_execute() deletes code that becomes redundant after the
change to flow_push_stats().
A test case introduced in an upcoming commit fails w
The "learn" action is useful for MAC learning, but until now there has been
no way to find out through OpenFlow how much time remains before a MAC
learning entry (a learned flow) expires. This commit adds that ability.
Feature #7193.
Signed-off-by: Ben Pfaff
---
NEWS |
The ofctl_strip shell function was introduced a little while ago. It makes
test results easier to read, in my opinion, by removing uninteresting
bits. This commit adopts ofctl_strip throughout the tests.
This is useful in an upcoming commit that adds additional fields that
should also be strippe
The first commit in this series fixes a bug in tracking the idle time
of flows.
Ben Pfaff (3):
ofproto-dpif: Update last-used time of initial rule in
handle_flow_miss().
tests: Use ofctl_strip consistently.
Add information about time left before timeouts to flow dumps.
NEWS
Thanks for the reviews. I pushed this to master, branch-1.4, branch-1.5.
On Tue, Jan 31, 2012 at 06:16:54PM -0800, Ethan Jackson wrote:
> May as well set the minInteger in the documentation to 15. Otherwise
> looks good.
>
> Ethan
>
> On Tue, Jan 24, 2012 at 13:44, Ben Pfaff wrote:
> > NICS-1
Thanks, I pushed this to master.
On Wed, Feb 01, 2012 at 02:20:36PM -0800, Justin Pettit wrote:
> Looks good.
>
> --Justin
>
>
> On Feb 1, 2012, at 1:35 PM, Ben Pfaff wrote:
>
> > Signed-off-by: Ben Pfaff
> > ---
> > utilities/ovs-ofctl.8.in |2 +-
> > 1 files changed, 1 insertions(+), 1 d
When XAPI moves an interface from one bridge to another, the vif script
removes the vif from one bridge and adds it to (possibly) a different
bridge in a single transaction. The new record does not have an iface-id
initially (because the vif script never adds the iface-id initially) but
it has the
Looks good.
--Justin
On Feb 1, 2012, at 1:35 PM, Ben Pfaff wrote:
> Signed-off-by: Ben Pfaff
> ---
> utilities/ovs-ofctl.8.in |2 +-
> 1 files changed, 1 insertions(+), 1 deletions(-)
>
> diff --git a/utilities/ovs-ofctl.8.in b/utilities/ovs-ofctl.8.in
> index e9e2e6f..0699d69 100644
> ---
On Wed, Feb 01, 2012 at 10:28:18AM -0800, Ben Pfaff wrote:
> On Tue, Jan 31, 2012 at 06:00:33PM -0800, Ethan Jackson wrote:
> > I'm surprised that the Flow_Table configuration went into the database
> > instead of being implemented as OpenFlow extensions. Naively, to me it
> > seems like a bit of a
Signed-off-by: Ben Pfaff
---
utilities/ovs-ofctl.8.in |2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/utilities/ovs-ofctl.8.in b/utilities/ovs-ofctl.8.in
index e9e2e6f..0699d69 100644
--- a/utilities/ovs-ofctl.8.in
+++ b/utilities/ovs-ofctl.8.in
@@ -1014,7 +1014,7 @@ uni
On Tue, Jan 31, 2012 at 06:00:33PM -0800, Ethan Jackson wrote:
> I'm surprised that the Flow_Table configuration went into the database
> instead of being implemented as OpenFlow extensions. Naively, to me it
> seems like a bit of a layering violation. Can you please briefly
> explain your thinkin
Thank you. I pushed this to master.
On Tue, Jan 31, 2012 at 11:58:56PM -0800, Justin Pettit wrote:
> Looks good.
>
> --Justin
>
>
> On Jan 31, 2012, at 12:56 PM, Ben Pfaff wrote:
>
> > These are useful hints, in these cases, that the caller retains ownership
> > of the passed-in packets.
> >
Hello
i am rechel
I guess you will not be surprise to receive my
mail? i saw your profile and it sound well.I will like us to exchange
good relationship.I am rechel by name,No kid and never marry.so i hope
we can be good friend i hope both of us can make it together.so reply
me at (rechelm
This February we've got some unmissible offers across our entire display
products range. See below for a taste of the prices we can offer you. To buy
visit www.whitelightdisplay.co.uk or alternatively, call us on 024 76 460674 to
discuss your requirements
Quality Range, Superb Value, Express D
JeanneBouilloud.JPG [<1Mo <1min @512kb/s]
-
http://dlfiles002.123envoi.com/get.php?cen=1850-84431-447b86f6&cfr=125394-2e9d
---
Fichier(s) envoyé(s) avec http://www.123envoi.com
Solution pour fichiers volumineux.
Essayez le gratuitement ! (http://www.123envoi.com/telechargement.php)
L'expédi
Looks good.
--Justin
On Jan 31, 2012, at 12:56 PM, Ben Pfaff wrote:
> These are useful hints, in these cases, that the caller retains ownership
> of the passed-in packets.
>
> Signed-off-by: Ben Pfaff
> ---
> lib/dpif.c |2 +-
> lib/dpif.h |4 ++--
> ofproto/ofpr
32 matches
Mail list logo