Re: [ovs-dev] adding my own .c file

2011-12-21 Thread Ben Pfaff
I stand by my previous statement. On Thu, Dec 22, 2011 at 12:19:16PM +0530, shiva m wrote: > Hi, > > Correct me if i am wrong. There is no patch, i added shiva.c to ofproto > folder which uses OVS1.2.2 functions. For eg: my shiva.c file looks like > > void test_dpif() > > { > const struct

Re: [ovs-dev] adding my own .c file

2011-12-21 Thread shiva m
Hi, Correct me if i am wrong. There is no patch, i added shiva.c to ofproto folder which uses OVS1.2.2 functions. For eg: my shiva.c file looks like void test_dpif() { const struct dpif_flow_stats *stats; struct dpif_flow_dump dump; struct dpif *dpif; VLOG_INFO("test_dpif execut

Re: [ovs-dev] adding my own .c file

2011-12-21 Thread Ben Pfaff
We have tried. You do not understand our suggestions (e.g. "send a patch") well enough to follow them. Please find a friend or colleague with more experience in software development to help you out. On Thu, Dec 22, 2011 at 11:04:51AM +0530, shiva m wrote: > Hi, > > I added one independent file

[ovs-dev] Get the Mates Rate (40-90% local deals)

2011-12-21 Thread Mates Rate (SG)
Title: MR Burger View this email as Webpage If you haven't done so already, click to confirm your interest in receiving email campaigns from us. Email . Why Join Us? "Mates Rate" offers great deals to do, see, and eat at 40% to 90% regular retail prices

Re: [ovs-dev] adding my own .c file

2011-12-21 Thread shiva m
Hi, I added one independent file but its not compiling with OVS1.2.2. OVS1.2.2 is compiling properly but it ignoring my file .c, it not generating .o file. Could any one please help me out in this issue, what changes i need to make to compile my file with OVS1.2.2? Regards, Shiva On Wed, Dec 21

[ovs-dev] [PATCH 2/3] tunnel: move rt_genid to compatibility code.

2011-12-21 Thread Pravin B Shelar
Signed-off-by: Pravin B Shelar --- datapath/linux/compat/include/net/dst.h | 22 ++ datapath/tunnel.c |2 +- datapath/tunnel.h | 14 -- 3 files changed, 23 insertions(+), 15 deletions(-) diff --git a/datapath/lin

[ovs-dev] [PATCH 1/3] datapath: Rearrange destroy dp.

2011-12-21 Thread Pravin B Shelar
Following patch allows unregister_netdevice() destroy dp. Signed-off-by: Pravin B Shelar --- datapath/datapath.c | 72 +--- datapath/datapath.h |6 +++- datapath/dp_notify.c |7 +++- datapath/vport-internal_dev.c |6 +

[ovs-dev] [PATCH 3/3] datapath: Implement flow table re-hashing.

2011-12-21 Thread Pravin B Shelar
Resending this patch as net-namespace patches depends on it. --8<--cut here-->8-- Following patch introduces a timer based event to rehash flow-hash table. It makes finding collisions difficult to for an attacker. Suggested-by: Herbert Xu Signed-o

[ovs-dev] [PATCH 2/3] datapath: Fix OVS compat workqueue support.

2011-12-21 Thread Pravin B Shelar
Resending this patch as net-namespace patches depends on it. --8<--cut here-->8- Signed-off-by: Pravin B Shelar --- datapath/datapath.c |9 +- datapath/linux/Modules.mk |3 +- datapath/linux

[ovs-dev] [PATCH 1/3] datapath: Add genl_exec().

2011-12-21 Thread Pravin B Shelar
Resending this patch as net-namespace patches depends on it. --8<--cut here-->8- genl_lock is not exported from older kernel. Following patch add genl_exec() which can run any function (passed as arg) with genl_lock held. Signed-off-by: Pravin B Sh

Re: [ovs-dev] [PATCH] dpif-netdev: Fix UDP checksum calculation.

2011-12-21 Thread Jesse Gross
On Wed, Dec 21, 2011 at 11:43 AM, Ben Pfaff wrote: > Jesse, don't we have the same bug in the datapath?  I don't see any > special case for a zero UDP checksum there either. Hmm, it does look like we have the same problem. ___ dev mailing list dev@openv

[ovs-dev] [gmane.linux.network] [PATCH 3/3] netlink: wake up netlink listeners sooner

2011-12-21 Thread Ben Pfaff
I wonder whether this would help OVS in some cases. Start of forwarded message Path: news.gmane.org!not-for-mail From: Stephen Hemminger Newsgroups: gmane.linux.network Subject: [PATCH 3/3] netlink: wake up netlink listeners sooner Date: Wed, 21 Dec 2011

Re: [ovs-dev] [PATCH] flow: Rename 'priority' to 'skb_priority'.

2011-12-21 Thread Ben Pfaff
Thanks. I added that to the commit log and pushed. On Wed, Dec 21, 2011 at 03:51:35PM -0800, Justin Pettit wrote: > Looks good. We should be on the lookout for a less Linux-specific name, but > it seems fine for now. > > --Justin > > > On Dec 21, 2011, at 3:40 PM, Ben Pfaff wrote: > > > Thi

Re: [ovs-dev] [PATCH] flow: Rename 'priority' to 'skb_priority'.

2011-12-21 Thread Justin Pettit
Looks good. We should be on the lookout for a less Linux-specific name, but it seems fine for now. --Justin On Dec 21, 2011, at 3:40 PM, Ben Pfaff wrote: > This priority's mean is completely different from the priority of an > OpenFlow rule, so it is confusing for it to have the same name. >

[ovs-dev] [PATCH] flow: Rename 'priority' to 'skb_priority'.

2011-12-21 Thread Ben Pfaff
This priority's mean is completely different from the priority of an OpenFlow rule, so it is confusing for it to have the same name. Signed-off-by: Ben Pfaff --- lib/classifier.c |2 +- lib/flow.c | 12 +++- lib/flow.h |2 +- lib/odp-util.c

[ovs-dev] [bug 7550 9/9] ovs-ofctl: Support all OFPPC_* flags in "mod-port" command.

2011-12-21 Thread Ben Pfaff
Signed-off-by: Ben Pfaff --- NEWS |2 + utilities/ovs-ofctl.8.in | 53 + utilities/ovs-ofctl.c| 49 +++-- 3 files changed, 68 insertions(+), 36 deletions(-) diff --git a/NEWS b/NEWS in

[ovs-dev] [bug 7550 8/9] ofproto-dpif: Implement flow table misses as special OpenFlow rules.

2011-12-21 Thread Ben Pfaff
Until now, Open vSwitch has never set up kernel flows for packets that miss in the OpenFlow flow table. This is more or less acceptable behavior for packets that should be sent to the controller, since every packet in such flows must go to userspace anyway, but it is not good for packets that arri

[ovs-dev] [bug 7550 7/9] New action NXAST_CONTROLLER.

2011-12-21 Thread Ben Pfaff
This action makes it possible for an OpenFlow action to send a packet to the OpenFlow controller with OFPR_NO_MATCH as the reason. There are multiple reasons this is useful: - It makes it possible to implement flow table misses as OpenFlow flows internally without inventing a special case a

[ovs-dev] [bug 7550 6/9] odp-util: Add reason to controller cookie.

2011-12-21 Thread Ben Pfaff
For some time, it's been a goal to set up a kernel flow in all of the cases where we can. One place where OVS currently falls short is in flows that miss in the OpenFlow table. All of these packets currently go to userspace. This commit takes one step toward setting up kernel flows for these cas

[ovs-dev] [bug 7550 5/9] odp-util: Change user_action_cookie from struct to union.

2011-12-21 Thread Ben Pfaff
This will make it easier to use a convenient set of members for each possible format, instead of being stuck with a single layout. An upcoming commit will add a new member to the 'controller' case. Signed-off-by: Ben Pfaff --- lib/odp-util.c | 35 +++-

[ovs-dev] [bug 7550 4/9] ofproto-dpif: Remove "clog" feature.

2011-12-21 Thread Ben Pfaff
It's not actually useful, since it's not used in the unit tests, but it makes implementing an upcoming feature harder. Signed-off-by: Ben Pfaff --- ofproto/ofproto-dpif.c | 63 +--- 1 files changed, 1 insertions(+), 62 deletions(-) diff --git a/ofpr

[ovs-dev] [bug 7550 3/9] ofproto: Implement "hidden" and "readonly" OpenFlow tables.

2011-12-21 Thread Ben Pfaff
A "hidden" table is one that OpenFlow operations affect only if the table_id is explicitly specified, that is, operations that affect all tables ignore it. A "read-only" table is one that OpenFlow operations are not allowed to modify. I intend to use these flags in an upcoming commit for implemen

[ovs-dev] [bug 7550 2/9] ofproto: Make ofproto ->construct() function initialize tables.

2011-12-21 Thread Ben Pfaff
If the ->construct() function initializes the OpenFlow tables itself, then it can conveniently do implementation-specific configuration of those tables afterward. There isn't any such configuration to do yet; an upcoming commit will add some. Signed-off-by: Ben Pfaff --- ofproto/ofproto-dpif.c

[ovs-dev] [bug 7550 1/9] ofproto: Encapsulate classifier tables in new "struct oftable".

2011-12-21 Thread Ben Pfaff
So far, each OpenFlow table has just been a classifier. Upcoming commits will add more data for each OpenFlow table, so this commit encapsulates the struct classifier in a higher-level structure to provide a good place to keep that data. Signed-off-by: Ben Pfaff --- ofproto/ofproto-dpif.c |

[ovs-dev] [bug 7550 0/9] Add kernel flows for OpenFlow flow table misses

2011-12-21 Thread Ben Pfaff
Until now, OpenFlow flow table misses always caused kernel flow tables misses, because kernel flow entries were never set up for them. This series changes that. This has several possible benefits: * sFlow correctness - currently these packets are counted but not sampled. * Better visibility an

[ovs-dev] Hello!

2011-12-21 Thread marcy
Hello!  My name is miss Marcy Albert,i want us to be friends i don't know how you will feel about it,please you can write to me (marcyalb...@yahoo.com) i'm sorry if i am embarrassing you, i shall explain all about myself including my pictures. yours in miss Marcy.___

Re: [ovs-dev] Statistics Collection Performance Impact

2011-12-21 Thread Ben Pfaff
On Wed, Dec 21, 2011 at 05:54:18PM +0900, Simon Horman wrote: > On Mon, Dec 12, 2011 at 09:46:44AM -0800, Ben Pfaff wrote: > > On Sun, Dec 11, 2011 at 11:20:50AM +0900, Simon Horman wrote: > > > sorry for the long delay. I finally had a stab at implementing this idea > > > but as yet it does not se

Re: [ovs-dev] [PATCH] dpif-netdev: Fix UDP checksum calculation.

2011-12-21 Thread Ben Pfaff
Jesse, don't we have the same bug in the datapath? I don't see any special case for a zero UDP checksum there either. Ethan, your fix looks fine, thanks. On Wed, Dec 21, 2011 at 11:27:59AM -0800, Ethan Jackson wrote: > dpif-netdev incorrectly calculated the UDP checksum when modifying > source a

Re: [ovs-dev] [PATCH] NEWS: Fix typo in entry for 1.3.0.

2011-12-21 Thread Ben Pfaff
OK, done. On Wed, Dec 21, 2011 at 11:20:57AM -0800, Justin Pettit wrote: > It probably should go in branch-1.4, too. > > --Justin > > > On Dec 21, 2011, at 11:12 AM, Ben Pfaff wrote: > > > Thanks, I pushed this to mster and branch-1.3. > > > > On Wed, Dec 21, 2011 at 11:08:28AM -0800, Justin

[ovs-dev] [PATCH] dpif-netdev: Fix UDP checksum calculation.

2011-12-21 Thread Ethan Jackson
dpif-netdev incorrectly calculated the UDP checksum when modifying source and destination ports. Signed-off-by: Ethan Jackson --- lib/dpif-netdev.c | 20 +++- 1 files changed, 15 insertions(+), 5 deletions(-) diff --git a/lib/dpif-netdev.c b/lib/dpif-netdev.c index 2c416e3..74

Re: [ovs-dev] [PATCH] NEWS: Fix typo in entry for 1.3.0.

2011-12-21 Thread Justin Pettit
It probably should go in branch-1.4, too. --Justin On Dec 21, 2011, at 11:12 AM, Ben Pfaff wrote: > Thanks, I pushed this to mster and branch-1.3. > > On Wed, Dec 21, 2011 at 11:08:28AM -0800, Justin Pettit wrote: >> Looks good. >> >> --Justin >> >> >> On Dec 21, 2011, at 11:01 AM, Ben Pfaf

Re: [ovs-dev] [PATCH] NEWS: Fix typo in entry for 1.3.0.

2011-12-21 Thread Ben Pfaff
Thanks, I pushed this to mster and branch-1.3. On Wed, Dec 21, 2011 at 11:08:28AM -0800, Justin Pettit wrote: > Looks good. > > --Justin > > > On Dec 21, 2011, at 11:01 AM, Ben Pfaff wrote: > > > --- > > NEWS |4 ++-- > > 1 files changed, 2 insertions(+), 2 deletions(-) > > > > diff --git

Re: [ovs-dev] [PATCH] NEWS: Fix typo in entry for 1.3.0.

2011-12-21 Thread Justin Pettit
Looks good. --Justin On Dec 21, 2011, at 11:01 AM, Ben Pfaff wrote: > --- > NEWS |4 ++-- > 1 files changed, 2 insertions(+), 2 deletions(-) > > diff --git a/NEWS b/NEWS > index 8db27bf..eae3a97 100644 > --- a/NEWS > +++ b/NEWS > @@ -68,8 +68,8 @@ v1.3.0 - 09 Dec 2011 > via "ip_frag

[ovs-dev] [PATCH] NEWS: Fix typo in entry for 1.3.0.

2011-12-21 Thread Ben Pfaff
--- NEWS |4 ++-- 1 files changed, 2 insertions(+), 2 deletions(-) diff --git a/NEWS b/NEWS index 8db27bf..eae3a97 100644 --- a/NEWS +++ b/NEWS @@ -68,8 +68,8 @@ v1.3.0 - 09 Dec 2011 via "ip_frag" in ovs-ofctl). - New ovs-ofctl "get-frags" and "set-frags" commands to get and s

[ovs-dev] patches overdue for review

2011-12-21 Thread Ben Pfaff
The following patches from last month still need to be reviewed. docs: New 'man-pdf' Makefile target to generate PDF versions of manpages. [1/2] ovsdb-data: Short-circuit ovsdb_datum_includes_all() in trivial case. [2/2] ovs-vsctl: Add set relational operators to "find" command. ovsdb-tool: Use ty

Re: [ovs-dev] [PATCH] vswitchd: fix "imlicit declaration of function" build warning.

2011-12-21 Thread Ansis Atteka
Thanks. I fixed subject line and pushed to the master. On Wed, Dec 21, 2011 at 10:05 AM, Ben Pfaff wrote: > On Wed, Dec 21, 2011 at 10:04:03AM -0800, Ansis Atteka wrote: > > Included stream.h header file for connmgr.c and bridge.c files. > > > > Signed-off-by: Ansis Atteka > > Reported-by: Ben

Re: [ovs-dev] [PATCH] vswitchd: fix "imlicit declaration of function" build warning.

2011-12-21 Thread Ben Pfaff
On Wed, Dec 21, 2011 at 10:04:03AM -0800, Ansis Atteka wrote: > Included stream.h header file for connmgr.c and bridge.c files. > > Signed-off-by: Ansis Atteka > Reported-by: Ben Pfaff s/imlicit/implicit/ in the subject line and the rest looks good to me. Thank you. ___

[ovs-dev] [PATCH] vswitchd: fix "imlicit declaration of function" build warning.

2011-12-21 Thread Ansis Atteka
Included stream.h header file for connmgr.c and bridge.c files. Signed-off-by: Ansis Atteka Reported-by: Ben Pfaff --- ofproto/connmgr.c |1 + vswitchd/bridge.c |1 + 2 files changed, 2 insertions(+), 0 deletions(-) diff --git a/ofproto/connmgr.c b/ofproto/connmgr.c index 1c55b67..6caa

Re: [ovs-dev] compiler warnings

2011-12-21 Thread Ben Pfaff
But you can make it the default on your own system by configuring an Autoconf "config.site" file as described here: http://www.gnu.org/savannah-checkouts/gnu/autoconf/manual/autoconf-2.68/html_node/Site-Defaults.html#Site-Defaults On Tue, Dec 20, 2011 at 2:26 PM, Ben Pfaff wrote: > Please don't d

Re: [ovs-dev] unix socket whitelist limits a controller to one bridge

2011-12-21 Thread Ben Pfaff
On Wed, Dec 21, 2011 at 07:08:07PM +0900, Jari Sundell wrote: > On Wed, Dec 21, 2011 at 2:38 AM, Ben Pfaff wrote: > > On Tue, Dec 20, 2011 at 06:28:17PM +0900, Jari Sundell wrote: > >> A while ago whitelisting of some pathnames were made for controller > >> communication using unix sockets, howeve

[ovs-dev] openvswitch_1.3.0-1_amd64.changes ACCEPTED into unstable

2011-12-21 Thread Debian FTP Masters
Accepted: openvswitch-brcompat_1.3.0-1_amd64.deb to main/o/openvswitch/openvswitch-brcompat_1.3.0-1_amd64.deb openvswitch-common_1.3.0-1_amd64.deb to main/o/openvswitch/openvswitch-common_1.3.0-1_amd64.deb openvswitch-controller_1.3.0-1_amd64.deb to main/o/openvswitch/openvswitch-controlle

Re: [ovs-dev] unix socket whitelist limits a controller to one bridge

2011-12-21 Thread Jari Sundell
On Wed, Dec 21, 2011 at 2:38 AM, Ben Pfaff wrote: > On Tue, Dec 20, 2011 at 06:28:17PM +0900, Jari Sundell wrote: >> A while ago whitelisting of some pathnames were made for controller >> communication using unix sockets, however these are tied to the >> bridge/switch name. Afaict, that makes it d

Re: [ovs-dev] adding my own .c file

2011-12-21 Thread shiva m
Thank you for your reply. I changed to "ofproto.h" still it giving same compilation error. It seems its not generating shiva.o file, could you please let me know why its not generating .o files for my independent .c files. Please help me in this regard Thanks & Regards, Shiva On Wed, Dec 21,