Re: [ovs-dev] [PATCH net-next 4/4] net: Add Open vSwitch kernel components.

2011-11-18 Thread John Fastabend
On 11/18/2011 3:12 PM, Jesse Gross wrote: > Open vSwitch is a multilayer Ethernet switch targeted at virtualized > environments. In addition to supporting a variety of features > expected in a traditional hardware switch, it enables fine-grained > programmatic extension and flow-based control of t

Re: [ovs-dev] [PATCH] ofp-util: Support OFPP_LOCAL in enqueue actions.

2011-11-18 Thread Ben Pfaff
OK, that's good enough for me. I've been thinking of creating a section in the ovs-vswitchd manpage that describes Open vSwitch interpretations of the OpenFlow text, in places where it's not entirely clear. Would you mind starting it out, by adding a sentence or so that mentions our interpretatio

Re: [ovs-dev] [PATCH] ofp-util: Support OFPP_LOCAL in enqueue actions.

2011-11-18 Thread Ethan Jackson
I suppose it depends on how you interpret the term physical port. It certainly isn't a nic, but it does have a linux device which I assume you can attach linux QoS to. In that sense, it is more of a physical port then OFPP_NONE, or OFPP_FLOOD. I don't think we should take a strict interpretation

Re: [ovs-dev] [PATCH] ofp-util: Support OFPP_LOCAL in enqueue actions.

2011-11-18 Thread Ben Pfaff
On Fri, Nov 18, 2011 at 07:03:38PM -0800, Ethan Jackson wrote: > According to the specification the enqueue action should refer to > "a valid physical port", or OFPP_IN_PORT. It would be strange to > attach a queueing discipline to the local port, but I see no reason > to restrict it. Is OFPP_LOC

[ovs-dev] [PATCH] ofp-util: Support OFPP_LOCAL in enqueue actions.

2011-11-18 Thread Ethan Jackson
According to the specification the enqueue action should refer to "a valid physical port", or OFPP_IN_PORT. It would be strange to attach a queueing discipline to the local port, but I see no reason to restrict it. --- lib/ofp-util.c |3 ++- 1 files changed, 2 insertions(+), 1 deletions(-) d

Re: [ovs-dev] [PATCH net-next 4/4] net: Add Open vSwitch kernel components.

2011-11-18 Thread David Miller
From: Stephen Hemminger Date: Fri, 18 Nov 2011 17:09:17 -0800 (PST) > >> On Fri, Nov 18, 2011 at 3:23 PM, Stephen Hemminger >> wrote: >> > On Fri, 18 Nov 2011 15:12:18 -0800 >> > Jesse Gross wrote: >> > >> >> +             write_seqcount_begin(&stats->seqlock); >> >> +             stats->tx_pa

Re: [ovs-dev] [PATCH net-next 4/4] net: Add Open vSwitch kernel components.

2011-11-18 Thread Stephen Hemminger
> On Fri, Nov 18, 2011 at 3:23 PM, Stephen Hemminger > wrote: > > On Fri, 18 Nov 2011 15:12:18 -0800 > > Jesse Gross wrote: > > > >> +             write_seqcount_begin(&stats->seqlock); > >> +             stats->tx_packets++; > >> +             stats->tx_bytes += sent; > >> +             write_s

Re: [ovs-dev] [PATCH net-next 4/4] net: Add Open vSwitch kernel components.

2011-11-18 Thread Jesse Gross
On Fri, Nov 18, 2011 at 3:23 PM, Stephen Hemminger wrote: > On Fri, 18 Nov 2011 15:12:18 -0800 > Jesse Gross wrote: > >> +             write_seqcount_begin(&stats->seqlock); >> +             stats->tx_packets++; >> +             stats->tx_bytes += sent; >> +             write_seqcount_end(&stats-

Re: [ovs-dev] [PATCH net-next 4/4] net: Add Open vSwitch kernel components.

2011-11-18 Thread Stephen Hemminger
On Fri, 18 Nov 2011 15:12:18 -0800 Jesse Gross wrote: > + write_seqcount_begin(&stats->seqlock); > + stats->tx_packets++; > + stats->tx_bytes += sent; > + write_seqcount_end(&stats->seqlock); There is a u64_stats_sync set of macros for this. It has

[ovs-dev] [PATCH net-next 3/4] vlan: Move vlan_set_encap_proto() to vlan header file

2011-11-18 Thread Jesse Gross
From: Pravin B Shelar Open vSwitch needs this function for vlan handling. Signed-off-by: Pravin B Shelar Signed-off-by: Jesse Gross --- include/linux/if_vlan.h | 34 ++ net/8021q/vlan_core.c | 33 - 2 files changed, 34 inse

[ovs-dev] [PATCH net-next 2/4] genetlink: Add lockdep_genl_is_held().

2011-11-18 Thread Jesse Gross
From: Pravin B Shelar Open vSwitch uses genl_mutex locking to protect datapath data-structures like flow-table, flow-actions. Following patch adds lockdep_genl_is_held() which is used for rcu annotation to prove locking. Signed-off-by: Pravin B Shelar Signed-off-by: Jesse Gross --- include/li

[ovs-dev] [PATCH net-next 1/4] genetlink: Add genl_notify()

2011-11-18 Thread Jesse Gross
From: Pravin B Shelar Open vSwitch uses Generic Netlink interface for communication between userspace and kernel module. genl_notify() is used for sending notification back to userspace. genl_notify() is analogous to rtnl_notify() but uses genl_sock instead of rtnl. Signed-off-by: Pravin B Shel

[ovs-dev] [GIT PULL net-next] Open vSwitch

2011-11-18 Thread Jesse Gross
This series of patches proposes the Open vSwitch kernel components for upstream. Open vSwitch has existed as a separate project for several years and we now believe it to be mature enough for inclusion. The actual functionality is described more fully in the commit that adds the kernel code. The

Re: [ovs-dev] [PATCH] datapath: Better handle vlan packets sent to userspace.

2011-11-18 Thread Jesse Gross
On Fri, Nov 18, 2011 at 1:57 PM, Ben Pfaff wrote: > On Thu, Nov 17, 2011 at 04:05:00PM -0800, Jesse Gross wrote: >> We no longer clone packets that are sent via the userspace action >> because placing them in Netlink attributes makes a copy so we >> generally don't touch the original.  The one exc

Re: [ovs-dev] [PATCH] datapath: Better handle vlan packets sent to userspace.

2011-11-18 Thread Ben Pfaff
On Thu, Nov 17, 2011 at 04:05:00PM -0800, Jesse Gross wrote: > We no longer clone packets that are sent via the userspace action > because placing them in Netlink attributes makes a copy so we > generally don't touch the original. The one exception to this is > accelerated vlan tags, which are cur

Re: [ovs-dev] [PATCH] packaging: Fix Xen and RH packaging error that was introduced with ovs-test utility

2011-11-18 Thread Ethan Jackson
Ah ok sounds good, thanks. Ethan On Fri, Nov 18, 2011 at 13:54, Ansis Atteka wrote: > This diff alone does not give full context of this patch (there is an rm > command before my added lines). So by "not including" I meant that these > files are removed just before the actual RPM packaging is do

Re: [ovs-dev] [PATCH] packaging: Fix Xen and RH packaging error that was introduced with ovs-test utility

2011-11-18 Thread Ansis Atteka
This diff alone does not give full context of this patch (there is an rm command before my added lines). So by "not including" I meant that these files are removed just before the actual RPM packaging is done. I tested this patch with rpmbuild on Ubuntu. Thanks, Ansis On Fri, Nov 18, 2011 at 1:4

Re: [ovs-dev] [ofproto-dpif 4/5] ofproto-dpif: Improperly handled OFPP_ALL action.

2011-11-18 Thread Ethan Jackson
Thanks for the reviews, I've pushed this series. Ethan On Fri, Nov 18, 2011 at 13:45, Ben Pfaff wrote: > On Fri, Nov 18, 2011 at 11:23:33AM -0800, Ethan Jackson wrote: >> Here is an incremental.  This causes very minor changes to the next patch in >> the series.  I'll resend that too, although I

Re: [ovs-dev] [PATCH] packaging: Fix Xen and RH packaging error that was introduced with ovs-test utility

2011-11-18 Thread Ethan Jackson
> On Fri, Nov 18, 2011 at 01:34:36PM -0800, Ansis Atteka wrote: >> My previous ovs-test utility commit broke Xen and RH packaging. >> This commit will address this issue by not including any ovs-test related >> files into those two packages. Did you mean "by including" instead of "by not including

Re: [ovs-dev] [ofproto-dpif 4/5] ofproto-dpif: Improperly handled OFPP_ALL action.

2011-11-18 Thread Ben Pfaff
On Fri, Nov 18, 2011 at 11:23:33AM -0800, Ethan Jackson wrote: > Here is an incremental. This causes very minor changes to the next patch in > the series. I'll resend that too, although I'm not sure it needs review > again. Looks good to me. ___ dev m

Re: [ovs-dev] [PATCH] datapath: Fix unaligned access when storing stats.

2011-11-18 Thread Ben Pfaff
On Fri, Nov 18, 2011 at 01:39:37PM -0800, Jesse Gross wrote: > On Fri, Nov 18, 2011 at 1:36 PM, Ben Pfaff wrote: > > On Fri, Nov 18, 2011 at 11:08:08AM -0800, Jesse Gross wrote: > >> Both datapath and vport stats contain 64-bit members in a struct > >> but we write them directly in Netlink attribu

Re: [ovs-dev] [PATCH] packaging: Fix Xen and RH packaging error that was introduced with ovs-test utility

2011-11-18 Thread Ben Pfaff
On Fri, Nov 18, 2011 at 01:34:36PM -0800, Ansis Atteka wrote: > My previous ovs-test utility commit broke Xen and RH packaging. > This commit will address this issue by not including any ovs-test related > files into those two packages. Looks good to me (assuming you tested it in some way). Thank

Re: [ovs-dev] [PATCH] datapath: Fix unaligned access when storing stats.

2011-11-18 Thread Jesse Gross
On Fri, Nov 18, 2011 at 1:36 PM, Ben Pfaff wrote: > On Fri, Nov 18, 2011 at 11:08:08AM -0800, Jesse Gross wrote: >> Both datapath and vport stats contain 64-bit members in a struct >> but we write them directly in Netlink attributes which only >> guarantee 32-bit alignment.  This causes problems o

Re: [ovs-dev] [PATCH] datapath: Fix unaligned access when storing stats.

2011-11-18 Thread Ben Pfaff
On Fri, Nov 18, 2011 at 11:08:08AM -0800, Jesse Gross wrote: > Both datapath and vport stats contain 64-bit members in a struct > but we write them directly in Netlink attributes which only > guarantee 32-bit alignment. This causes problems on RISC > architectures that care about alignment so this

[ovs-dev] [PATCH] packaging: Fix Xen and RH packaging error that was introduced with ovs-test utility

2011-11-18 Thread Ansis Atteka
My previous ovs-test utility commit broke Xen and RH packaging. This commit will address this issue by not including any ovs-test related files into those two packages. --- rhel/openvswitch.spec.in |2 ++ xenserver/openvswitch-xen.spec |2 ++ 2 files changed, 4 insertions(+), 0 delet

Re: [ovs-dev] [PATCH upstream] net-ovs: move vlan_set_encap_proto() to vlan header ile

2011-11-18 Thread Jesse Gross
On Fri, Nov 18, 2011 at 1:15 PM, Pravin B Shelar wrote: > OVS need this function for vlan handling. > > Signed-off-by: Pravin B Shelar I updated the commit message to reflect the fact that this patch doesn't specifically relate to Open vSwitch, moved the function to be closer to others, and appl

[ovs-dev] [PATCH upstream] net-ovs: move vlan_set_encap_proto() to vlan header ile

2011-11-18 Thread Pravin B Shelar
OVS need this function for vlan handling. Signed-off-by: Pravin B Shelar --- include/linux/if_vlan.h | 34 ++ net/8021q/vlan_core.c | 33 - 2 files changed, 34 insertions(+), 33 deletions(-) diff --git a/include/linux/if_vlan

Re: [ovs-dev] [PATCH v3] datapath: Fix pop_vlan().

2011-11-18 Thread Pravin Shelar
On Fri, Nov 18, 2011 at 11:46 AM, Jesse Gross wrote: > On Fri, Nov 18, 2011 at 11:37 AM, Pravin B Shelar wrote: >> Following patch fixes bug in pop_vlan code by updating ethernet >> header len. >> >> Signed-off-by: Pravin B Shelar > > Acked-by: Jesse Gross > Thanks, Pushed to master. > Can you

Re: [ovs-dev] [PATCH v3] datapath: Fix pop_vlan().

2011-11-18 Thread Jesse Gross
On Fri, Nov 18, 2011 at 11:37 AM, Pravin B Shelar wrote: > Following patch fixes bug in pop_vlan code by updating ethernet > header len. > > Signed-off-by: Pravin B Shelar Acked-by: Jesse Gross Can you also provide the patch to make vlan_set_encap_proto() available upstream? __

[ovs-dev] [PATCH v3] datapath: Fix pop_vlan().

2011-11-18 Thread Pravin B Shelar
Fixed according to comments from Jesse. --8<--cut here-->8-- Following patch fixes bug in pop_vlan code by updating ethernet header len. Signed-off-by: Pravin B Shelar --- datapath/actions.c| 13 - datapath/l

[ovs-dev] [ofproto-dpif 5/5] ofproto-dpif: Simplify output action composition.

2011-11-18 Thread Ethan Jackson
This is version of the patch incorporates changes required by modifications to previous patches in the series. force_compose_output_action() changed slightly, I don't think it needs review again. Also, Ben, I'll write up a patch that unit tests this in the next day or so. Justin is blocking on th

Re: [ovs-dev] [ofproto-dpif 4/5] ofproto-dpif: Improperly handled OFPP_ALL action.

2011-11-18 Thread Ethan Jackson
Here is an incremental. This causes very minor changes to the next patch in the series. I'll resend that too, although I'm not sure it needs review again. --- ofproto/ofproto-dpif.c | 26 ++ 1 files changed, 14 insertions(+), 12 deletions(-) diff --git a/ofproto/ofpro

Re: [ovs-dev] [ofproto-dpif 3/5] ofproto-dpif: Enqueue incorrectly calls add_output_action().

2011-11-18 Thread Ethan Jackson
> I wonder if we should use "sparse" annotations to make this stuff harder > to get wrong. Yah, I've been thinking about that for some time. I'd like to have an ofp_port and an odp_port type which would have the added benefit of making the code easier to read. Ethan _

[ovs-dev] [PATCH] datapath: Fix unaligned access when storing stats.

2011-11-18 Thread Jesse Gross
Both datapath and vport stats contain 64-bit members in a struct but we write them directly in Netlink attributes which only guarantee 32-bit alignment. This causes problems on RISC architectures that care about alignment so this computes the stats on the stack and then memcpy's them. Signed-off-

[ovs-dev] Is me judy from www.deb.at

2011-11-18 Thread petjudy211
Hello sweetie My name is Judy, i am 25yrs old, i'm a free minded, open hearted girl, i like to take life as easy as i could, i'm one of the few that still believes in friendship,love, trust and signs,it will be my sincere pleasure to be your friend if you don't mind, i hope you will not take my