Reviewed-by: Nicholas Pratte
On Mon, Oct 28, 2024 at 1:51 PM Luca Vizzarro wrote:
>
> The introduction of TestSuiteSpec adds auto-discovery of test suites,
> which are also automatically imported. This causes double imports as the
> runner loads the test suites. This changes the
Noted, I appreciate the insight!
On Tue, Oct 29, 2024 at 8:56 AM Luca Vizzarro wrote:
>
> On 01/10/2024 21:45, Nicholas Pratte wrote:
> > The code you have here makes sense, and I like the implementation as
> > it removes a lot of fluff in DTSRunner. I know Jurja mentioned
Reviewed-by: Nicholas Pratte
On Thu, Oct 10, 2024 at 2:42 PM Dean Marx wrote:
>
> Fix optional verify argument in set_forward_mode
> method in testpmd shell class.
>
> Bugzilla ID: 1410
> Fixes: fc0f7dc47ee3 ("dts: add testpmd shell params")
>
> Signed-off-by:
Reviewed-by: Nicholas Pratte
On Mon, Oct 28, 2024 at 1:51 PM Luca Vizzarro wrote:
>
> Pydantic models are not treated the same way as dataclasses by autodoc.
> As a consequence the docstrings need to be applied directly to each
> field. Otherwise the generated API documentatio
, inserting a one second delay in the callback function
will suffice.
Bugzilla ID: 1573
Signed-off-by: Nicholas Pratte
---
dts/framework/testbed_model/traffic_generator/scapy.py | 9 ++---
1 file changed, 6 insertions(+), 3 deletions(-)
diff --git a/dts/framework/testbed_model/traffic_generator
Reviewed-by: Nicholas Pratte
On Mon, Oct 28, 2024 at 1:51 PM Luca Vizzarro wrote:
>
> As part of configuration validation and deserialization improvements,
> this adds pydantic as a project dependency. Pydantic is a library that
> caters to all of the aforementioned needs, while i
Reviewed-by: Nicholas Pratte
On Mon, Oct 28, 2024 at 1:51 PM Luca Vizzarro wrote:
>
> Currently there is a lack of a definition which identifies all the test
> suites available to test. This change intends to simplify the process to
> discover all the test suites and idenfity them
, inserting a one second delay in the callback function
will suffice.
Bugzilla ID: 1573
Signed-off-by: Nicholas Pratte
---
.../testbed_model/traffic_generator/scapy.py | 11 +++
1 file changed, 7 insertions(+), 4 deletions(-)
diff --git a/dts/framework/testbed_model
It took me a second to appreciate what the goal of separating this is,
but it makes complete sense to me now. This was an oversight on my end
as well when I was working on the config changes in once of the
patches I was assigned. Interestingly enough, I ran into a similar
problem with circular depe
Reviewed-by: Nicholas Pratte
On Mon, Oct 28, 2024 at 1:51 PM Luca Vizzarro wrote:
>
> This change brings in pydantic in place of warlock. Pydantic offers
> a built-in model validation system in the classes, which allows for
> a more resilient and simpler code. As a consequence of
Definitely a set in the right direction here!
Just a small typo, but otherwise:
Reviewed-by: Nicholas Pratte
> --- a/doc/guides/tools/dts.rst
> +++ b/doc/guides/tools/dts.rst
> @@ -204,9 +204,10 @@ node, and then run the tests with the newly built
> binaries.
>
Reviewed-by: Nicholas Pratte
On Mon, Oct 28, 2024 at 1:51 PM Luca Vizzarro wrote:
>
> Since pydantic has completely replaced warlock, there is no more need to
> keep it as a dependency. This removes it.
>
> Signed-off-by: Luca Vizzarro
> Reviewed-by: Paul Szczepanek
> -
On Mon, Oct 28, 2024 at 1:51 PM Luca Vizzarro wrote:
>
> Currently there is a lack of a definition which identifies all the test
> suites available to test. This change intends to simplify the process to
> discover all the test suites and idenfity them.
Noticed this in the corner of my eye. 'iden
I understand Juraj's concern about the dependencies assuming this
change was to stay in its own isolated patch in the log. That aside,
this is pretty straightforward, and I have confidence in the judgement
of whatever decision is made between the two of you.
Reviewed-by: Nicholas Pratte
O
I think Juraj's comments here make sense, it probably would make sense
to separate this in-conjunction with Juraj's decorator patch and use
it as a dependency. From what I can understand, the changes offered
here make sense to me.
Reviewed-by: Nicholas Pratte
--
*Let
Hi Luca! See my comments below, thanks!
On Thu, Aug 22, 2024 at 12:40 PM Luca Vizzarro wrote:
>
> This change brings in Pydantic in place of Warlock. Pydantic offers
> a built-in model validation system in the classes, which allows for
> a more resilient and simpler code. As a consequence of this
Maybe you could provide some insight? I'll make
sure to analyse this deeper in my own time as well. Beyond that:
Reviewed-by: Nicholas Pratte
On Thu, Aug 22, 2024 at 12:40 PM Luca Vizzarro wrote:
>
> The introduction of TestSuiteSpec adds auto-discovery of test suites,
> which are
Seems straightforward. There are actually some intersections here
between my currently-existing config changes and some of the trimming
you provide here which simplifies my upcoming series when I rebase it
to use this series.
Reviewed-by: Nicholas Pratte
On Thu, Aug 22, 2024 at 12:40 PM Luca
Reviewed-by: Nicholas Pratte
Hi Luca, this looks good to me! The only thing that needs to be fixed
is the attributes component of the docstring for EalParams in eal.py.
Aside from that:
Reviewed-by: Nicholas Pratte
On Thu, Nov 7, 2024 at 9:00 AM Luca Vizzarro wrote:
>
> Make the "ports" attribute of
Hi Luca, nice work!
See my small comment below/ I ran some local tests and everything
seems to be working fine, so other than that minor fix I pointed out,
the rest should be all set!
> +"""The DPDK device blocklisting test suite.
> +
> +This testing suite ensures tests the port blocklisting fun
Code looks good. I ran some tests on my end and did not run into the
NULL test suite issue that Dean ran into. I'm guessing Dean ran into
an error changing up the code because the patch file wouldn't apply.
Reviewed-by: Nicholas Pratte
Tested-by: Nicholas Pratte
Thanks Luca!
Reviewed-by: Nicholas Pratte
On Tue, Jan 7, 2025 at 9:13 AM Luca Vizzarro wrote:
>
> There are some PMDs that in order to set a scatter-offload-compatible
> MTU size, they need to have started at least once since the startup of
> testpmd. This fixes the behaviour of th
>
> The start and stop could be grouped by forwarding sections:
>
>set_mtu()
>
>start()
>assess()
>assess()
>stop()
>
>set_mtu()
>...
Alright, I'll fix that real quick!
Forwarding restarts in the run-time MTU adjustment test case have been
explicitly added, given that the 'requires_forwarding_restart' decorator
from a previous patch was removed.
Signed-off-by: Nicholas Pratte
---
dts/tests/TestSuite_mtu.py | 13 -
1 file changed, 12
This implementation conflicts with other bug fixes implemented in
earlier patches. The decorator was devised as a mean to make suite
writing a bit simpler, semantically, but the addition of this adds too
many complications for it to be worth implementing.
Signed-off-by: Nicholas Pratte
---
dts
out this issue and its potential
side-effects.
Nicholas Pratte (2):
dts: remove 'requires_forwarding_restart' from framework
dts: rework run-time MTU adjustment test case
dts/framework/remote_session/testpmd_shell.py | 26 +--
dts/tests/TestSu
Hi Luca, nice work! See comments below.
>
>
> +class LinkPortIdentifier(NamedTuple):
> +"""A tuple linking test run node type to port name."""
> +
> +node_type: Literal["sut", "tg"]
> +port_name: str
> +
> +
> +class PortLinkConfig(FrozenModel):
> +"""A link between the ports of t
My bad! I'll fix that real quick.
On Mon, Feb 3, 2025 at 11:51 AM Luca Vizzarro wrote:
>
> On 03/02/2025 16:38, Nicholas Pratte wrote:
> > --- a/dts/tests/TestSuite_mtu.py
> > +++ b/dts/tests/TestSuite_mtu.py
> > @@ -164,22 +164,33 @@ def test_runtime_mtu
Reviewed-by: Nicholas Pratte
On Mon, Feb 3, 2025 at 10:17 AM Luca Vizzarro wrote:
>
> Change the Topology model to add further flexility in its usage as a
> standalone entry point to test suites.
>
> Signed-off-by: Luca Vizzarro
> ---
> dts/framework/testbed_m
This makes sense to me!
Reviewed-by: Nicholas Pratte
On Mon, Feb 3, 2025 at 10:17 AM Luca Vizzarro wrote:
>
> In an effort to improve separation of concerns, make the TestRunConfig
> class responsible for processing the configured test suites. Moreover,
> give TestSuiteConfig a
Forwarding restarts in the run-time MTU adjustment test case have been
explicitly added, given that the 'requires_forwarding_restart' decorator
from a previous patch was removed.
Signed-off-by: Nicholas Pratte
---
dts/tests/TestSuite_mtu.py | 8 +++-
1 file changed, 7 insert
time implementing this.
Arguably, it also makes sense to have these mechanics (such as
forwarding restarts) written explicitly within the test suites.
Thank you Luca for pointing out this issue and its potential
side-effects.
Nicholas Pratte (2):
dts: remove 'requires_forwarding_restart&
This implementation conflicts with other bug fixes implemented in
earlier patches. The decorator was devised as a mean to make suite
writing a bit simpler, semantically, but the addition of this adds too
many complications for it to be worth implementing.
Signed-off-by: Nicholas Pratte
---
dts
27;stdout'
buffered pipes is a result of the context manager's cleanup process.
Explicit calls to close the 'stdin' buffered pipe is needless and this
is done via a 'Channel.close()' within Paramiko. The following patch
corrects these issues.
Bugz
Reviewed-by: Nicholas Pratte
On Wed, Jan 15, 2025 at 9:19 AM Luca Vizzarro wrote:
>
> From: Nicholas Pratte
>
> The 'arch' attribute in the conf.yaml is unnecessary, as this can be
> readily discovered directly from any given node.
>
> Bugzilla ID: 1360
>
Reviewed-by: Nicholas Pratte
On Wed, Jan 15, 2025 at 9:19 AM Luca Vizzarro wrote:
>
> From: Nicholas Pratte
>
> The build options configuration contained redundant fields that were not
> in use, and there is no future scope for their use.
>
> Bugzilla ID: 1360
>
&
Reviewed-by: Nicholas Pratte
On Wed, Jan 15, 2025 at 9:19 AM Luca Vizzarro wrote:
>
> From: Nicholas Pratte
>
> To further the simplification of the user configuration, use_first_core
> can be inferred from the lcores. If the user explicitly includes the
> core 0 in the lco
Reviewed-by: Nicholas Pratte
On Fri, Jan 24, 2025 at 6:39 AM Luca Vizzarro wrote:
>
> From: Nicholas Pratte
>
> Rework 'lcores' and 'memory_channels' into a new 'dpdk_config'
> subsection in an effort to make these attributes SUT specific; the
>
for cleaner, easier to read code.
Signed-off-by: Nicholas Pratte
---
dts/framework/remote_session/testpmd_shell.py | 26 ++-
1 file changed, 25 insertions(+), 1 deletion(-)
diff --git a/dts/framework/remote_session/testpmd_shell.py
b/dts/framework/remote_session/testpmd_shell.py
n any case, it doesn't hurt to keep this patch in the
series.
Reviewed-by: Nicholas Pratte
On Fri, Jan 24, 2025 at 6:39 AM Luca Vizzarro wrote:
>
> From: Nicholas Pratte
>
> To further the simplification of the user configuration, use_first_core
> can be inferred from the
Thank you for addressing this. Great work!
Reviewed-by: Nicholas Pratte
On Fri, Jan 24, 2025 at 6:39 AM Luca Vizzarro wrote:
>
> The current handling of the configuration loading is inconsistent. After
> the whole configuration is loaded, if there are any CLI or environment
> o
14 PM Patrick Robb wrote:
>
>
>
> On Fri, Jan 17, 2025 at 9:58 AM Nicholas Pratte wrote:
>>
>> -@requires_started_ports
>>
>> +@requires_forwarding_restart
>> @requires_stopped_ports
>> def set_port_mtu(self, port_id: int, mtu: int, ve
tment options within the ethdev api.
Bugzilla ID: 1421
Signed-off-by: Nicholas Pratte
Signed-off-by: Alex Chapman
---
dts/tests/TestSuite_mtu_update_fwding.py | 278 +++
1 file changed, 278 insertions(+)
create mode 100644 dts/tests/TestSuite_mtu_update_fwding.py
di
insightful.
inbox.dpdk.org/dev/0f4866fc-b76d-cf83-75e8-86326c028...@intel.com/
inbox.dpdk.org/dev/20211018134854.1258938-5-ferruh.yi...@intel.com/
inbox.dpdk.org/dev/e2554b78-cdda-aa33-ac6d-59a543a10...@intel.com/
Nicholas Pratte (2):
dts: add fwd restart decorator to rx capabilities
dts: add mtu
Reviewed-by: Nicholas Pratte
On Fri, Jan 24, 2025 at 6:39 AM Luca Vizzarro wrote:
>
> From: Nicholas Pratte
>
> The build options configuration contained redundant fields that were not
> in use, and there is no future scope for their use.
>
> Bugzilla ID: 1360
>
&
Reviewed-by: Nicholas Pratte
On Fri, Jan 24, 2025 at 6:39 AM Luca Vizzarro wrote:
>
> From: Nicholas Pratte
>
> The 'arch' attribute in the conf.yaml is unnecessary, as this can be
> readily discovered directly from any given node.
>
> Bugzilla ID: 1360
>
This is great! Before Jeremy left, he suggested going a step further
and putting the config in a directory of its own, potentially offering
more flexibility. Something we could consider looking into in the
future, if there is time.
Reviewed-by: Nicholas Pratte
On Fri, Jan 24, 2025 at 6:39 AM
Nice touch!
Reviewed-by: Nicholas Pratte
On Fri, Jan 24, 2025 at 6:39 AM Luca Vizzarro wrote:
>
> The configuration requires the user to explicitly set the requested test
> suites in the files. Sometimes we want to run all the test suites and
> don't want to manually specify a
e
> - added new comment in the configuration example file to indicate
> that all test suites are run if none are specified
>
> Luca Vizzarro (3):
> dts: handle CLI overrides in the configuration
> dts: split configuration file
> dts: run all test suites by default
>
>
Thank you for the feedback, see my comments below!
>> +current_mtu = testpmd_shell.show_port_info(0).mtu
>> +self.verify(current_mtu is not None, "Error grabbing testpmd MTU
>> value.")
>> +if current_mtu and (
>> +current_mtu >= STANDARD_MTU + VENDOR_AGNOSTIC
reorientation of the code prevents this, and
allows for easier error assessment.
Signed-off-by: Nicholas Pratte
---
dts/framework/testbed_model/linux_session.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/dts/framework/testbed_model/linux_session.py
b/dts/framework
for cleaner, easier to read code.
Signed-off-by: Nicholas Pratte
---
dts/framework/remote_session/testpmd_shell.py | 26 ++-
1 file changed, 25 insertions(+), 1 deletion(-)
diff --git a/dts/framework/remote_session/testpmd_shell.py
b/dts/framework/remote_session/testpmd_shell.py
tment options within the ethdev api.
Bugzilla ID: 1421
Signed-off-by: Nicholas Pratte
Signed-off-by: Alex Chapman
---
dts/tests/TestSuite_mtu_update_fwding.py | 278 +++
1 file changed, 278 insertions(+)
create mode 100644 dts/tests/TestSuite_mtu_update_fwding.py
di
.com/
inbox.dpdk.org/dev/20211018134854.1258938-5-ferruh.yi...@intel.com/
inbox.dpdk.org/dev/e2554b78-cdda-aa33-ac6d-59a543a10...@intel.com/
Nicholas Pratte (2):
dts: add fwd restart decorator to rx capabilities
dts: add mtu update and jumbo frames test suite
dts/framework/remote_session/te
Definitely much easier to read, in a general sense, with these changes.
Reviewed-by: Nicholas Pratte
On Wed, Feb 12, 2025 at 11:46 AM Luca Vizzarro wrote:
>
> Add a new context module which holds the runtime context. The new
> context will describe the current scenario and aid u
Reviewed-by: Nicholas Pratte
On Mon, Feb 3, 2025 at 10:17 AM Luca Vizzarro wrote:
>
> Add a new module which defines the global runtime status of DTS and the
> distinct execution stages and steps.
>
> Signed-off-by: Luca Vizzarro
> ---
> doc/api/dts/framework.status.rst
Right off the bat, I like this organization a lot more. Definitely a
lot easier to navigate the code.
Reviewed-by: Nicholas Pratte
On Wed, Feb 12, 2025 at 11:46 AM Luca Vizzarro wrote:
>
> Remove the distinction between SUT and TG nodes for configuration
> purposes. As DPDK and th
This definitely cleans things up a lot!
Reviewed-by: Nicholas Pratte
> @@ -217,9 +218,7 @@ def get_supported_capabilities(
> )
> if cls.capabilities_to_check:
> capabilities_to_check_map = cls._get_decorated_capabilities_map()
> -wi
201 - 259 of 259 matches
Mail list logo