[PATCH] dts: fix DPDK git tarball cast bug

2024-07-19 Thread Alex Chapman
7dbd ("dts: constrain DPDK source argument") Signed-off-by: Alex Chapman Reviewed-by: Jack Bond-Preston Reviewed-by: Luca Vizzarro Reviewed-by: Paul Szczepanek --- Hello, Sending this fix to a bug that i discovered. Best Regards, Alex --- .mailmap | 1 + dts/frame

Issue in testpmd when using RSS Flows with Mellanox NICs

2024-07-31 Thread Alex Chapman
Hello maintainers, I am currently facing issues when creating RSS flows using testpmd. When using the following flow on an intel NIC, it works as expected, using the reta table to redirect ipv4-udp packets to the correct queue. flow create 0 ingress pattern eth / ipv4 / udp / end actions

[PATCH] app/testpmd: add L4 port to verbose output

2024-08-15 Thread Alex Chapman
To help distinguish packets we want to add more identifiable information and print port number for all packets. This will make packet metadata more uniform as previously it only printed port number for encapsulated packets. Bugzilla-ID: 1517 Signed-off-by: Alex Chapman Reviewed-by: Luca

Re: [PATCH v1 0/2] dts: port over checksum offload suite

2024-08-19 Thread Alex Chapman
Hi Dean, I went over the test suite and it looks really solid, but noticed you didn't update the `conf_yaml_schema.json`, is there any reason for this? On 8/16/24 15:20, Dean Marx wrote: Port over checksum hardware offload testing suite from old DTS. The suite verifies the ability of the PMD

Re: [PATCH v1 2/2] dts: checksum offload test suite

2024-08-19 Thread Alex Chapman
Hi Dean, Just though I would point out a few things. On 8/16/24 15:20, Dean Marx wrote: +def send_packet_and_verify( Should this not be `send_packets_and_verify(` as the argument is `packet_list`. +isL4 = any( +VerboseOLFlag.RTE_MBUF_F_RX_L4_CKSUM_GOOD in packet.ol

Re: [PATCH v7 4/4] test-pmd: add more packet verbose decode options

2024-08-20 Thread Alex Chapman
Hi Stephen, I have gone through your patch series and the hexdump option would be quite valuable for use in DTS. However I am currently facing the issue of distinguishing noise packets from intentional packets within the verbose output. Prior to your patch, the intention was to use the Layer

[PATCH] dts: add RSS functions to testpmd

2024-08-21 Thread Alex Chapman
commands without any further changes. Signed-off-by: Alex Chapman Reviewed-by: Luca Vizzarro --- dts/framework/remote_session/testpmd_shell.py | 84 ++- 1 file changed, 83 insertions(+), 1 deletion(-) diff --git a/dts/framework/remote_session/testpmd_shell.py b/dts/fram

Re: [RFC PATCH v3 2/2] dts: Initial Implementation For Jumbo Frames Test Suite

2024-08-28 Thread Alex Chapman
Hi, Ive been looking into the MTU terminology and would just like to clarify some naming conventions and doc strings. On 7/26/24 15:13, Nicholas Pratte wrote: +IP_HEADER_LEN = 20 +ETHER_STANDARD_FRAME = 1500 +ETHER_JUMBO_FRAME_MTU = 9000 For these constants, I am confused why one is "FRAME"

[PATCH] dts: add RSS functions to testpmd

2024-08-29 Thread Alex Chapman
commands without any further changes. Signed-off-by: Alex Chapman Reviewed-by: Luca Vizzarro --- dts/framework/remote_session/testpmd_shell.py | 84 ++- 1 file changed, 83 insertions(+), 1 deletion(-) diff --git a/dts/framework/remote_session/testpmd_shell.py b/dts/fram

Re: [RFC PATCH v3 0/2] Initial Implementation For Jumbo Frames

2024-09-19 Thread Alex Chapman
Hey Nick, After going through this test suite (jumbo frames) and mtu update, it seems as though mtu update contains all of the test cases of jumbo frames and more. To reduce the amount of maintenance and code duplication, it would make sense to remove this test suite and supercede it with mt