On 1/14/25 8:50 AM, Ariel Otilibili wrote:
pthread_mutex_init always returns 0. The other mutex functions
return 0 on success and a non-zero error code on error.
Link: https://man7.org/linux/man-pages/man3/pthread_mutex_lock.3.html
Bugzilla ID: 1586
Cc: Maxime Coquelin
Cc: Chenbo Xia
Signe
Hi,
As discussed on slack, please find details of meeting for feature arc
discussion
==
Date and time: 16th Jan 2025 (Thursday) 12:00 PM (UTC + 1)
Join Zoom Meeting
Password:
267382
Meeting URL:
https://marvell.zoom.us/j/97204271800?pwd=qR8Tc5WawaYdw8CTP2DK6bA4EEXR2J.1&from=addon
Join
Hi Stephen,
On Monday, January 13, 2025 20:11 CET, Stephen Hemminger
wrote:
> On Sun, 12 Jan 2025 21:20:15 +0100
> Ariel Otilibili wrote:
>
>
>
> LGTM
> Series-Acked-by: Stephen Hemminger
Thanks for having looked into the series. Herewith a new version, I addressed
your feedback,
https://
Hi, Morten
> Question 1:
> Please confirm that the mbuf's pinned external buffer's refcnt is supposed to
> be 1 when an mbuf is returned to the mempool?
...
> + rte_mbuf_ext_refcnt_read(m->shinfo) == 1)));
I think we can add this extra check and neglect the light performance im
Dear Maintainers,
I wanted to follow up this patch series that I submitted a week ago. It
is currently listed as being in an 'under review' status on the patch
worker. A week has now passed, and I have not received any feedback
May I kindly ask if there is any additional information or clarifica
On 2025/1/11 1:20, Stephen Hemminger wrote:
> This will make it slower for many platforms.
> GCC will unroll a loop of fixed small size, which is what we want.
Do you mean to replace option with a macro?
But most of prefetch_offset are used with the nb_rx, So using macros is the
same as using o
On 2025/1/11 1:19, Stephen Hemminger wrote:
> On Fri, 10 Jan 2025 17:37:15 +0800
> Dengdui Huang wrote:
>
>> +#define DEFAULT_PREFECH_OFFSET 4
>
> Spelling
I made a mistake. I'll fix it for the next version.
14/01/2025 02:50, lihuisong (C):
> 在 2025/1/13 21:14, Thomas Monjalon 写道:
> > 13/01/2025 13:47, lihuisong (C):
> >> 在 2025/1/13 20:30, Thomas Monjalon 写道:
> >>> 13/01/2025 13:05, lihuisong (C):
> 在 2025/1/13 19:23, lihuisong (C) 写道:
> > 在 2025/1/13 18:57, Thomas Monjalon 写道:
> >> 13/01
14/01/2025 03:05, Jie Hai:
> Hi, Stephen Hemminger,
>
> On 2025/1/9 1:02, Stephen Hemminger wrote:
> > On Wed, 8 Jan 2025 10:46:32 +0800
> > Jie Hai wrote:
> >
> >> From: Jie Hai
> >> To: , , , Aman
> >> Singh
> >> CC: , ,
> >> ,
> >> Subject: [PATCH] app/testpmd: add ipv6 extension heade
14/01/2025 13:13, lihuisong (C):
> 在 2025/1/14 19:13, Thomas Monjalon 写道:
> > As explained above, we should not do allow much API from RTE_ETH_EVENT_NEW.
> > rte_eth_dev_socket_id() is reasonnable.
> > Functions rte_eth_dev_owner_*() are fine.
> > Others functions should be called only after probin
This patch modifies format specifier in debug prints to match to the
change of time variables from 64 bit to 32 bit.
Fixes: d980a401b137 ("net/i40e/base: add NVM acquire with custom timeout")
Fixes: ba90329a5eb3 ("net/i40e/base: fix invalid log format characters")
Cc: sta...@dpdk.org
Signed-off-b
Hi Konstantin, thank you very much for your question!
I have modified the __rte_ring_rts_v2_update_tail function(See at the
bottom)and it works properly when
using your test command in my local environment(KVM). The local environment
parameters are as follows:
Architecture:x86_64
C
From: Dawid Zielinski
Add interface for sending ACI command for setting port
identification LED on E610.
Signed-off-by: Dawid Zielinski
Signed-off-by: Yuan Wang
---
drivers/net/ixgbe/base/ixgbe_e610.c | 29
drivers/net/ixgbe/base/ixgbe_e610.h | 1 +
drivers
From: Lukasz Krakowiak
The return value of ixgbe_get_fw_tsam_mode function may be a large integer
that does not match the desired bool type.
Fixes: 316637762a5f (net/ixgbe/base: enable E610 device)
Cc: sta...@dpdk.org
Signed-off-by: Lukasz Krakowiak
Signed-off-by: Yuan Wang
---
drivers/net/i
Update the ixgbe driver to the lastest version of the snapshot.
Dan Nowlin (1):
net/ixgbe/base: add missing buffer copy
Dawid Zielinski (2):
net/ixgbe/base: add interface for LED control on E610
net/ixgbe/base: Add capability for OROM recovery update
Karol Kolacinski (2):
net/ixgbe/base:
From: Karol Kolacinski
Add "Set PTP by PHY" (0x0634) ACI command.
Add a new PTP by PHY capability (0x0097).
This command allows configuring PTP timestamping on PHY or MAC.
Add 2 PTP by PHY registers:
PROXY_TX_TS (XGMII_SPARE_REG[0])
PROXY_STS (XGMII_SPARE_REG[1])
Signed-off-by: Karol Kolacinski
From: Piotr Kwapulinski
2.5 and 5 Gbps link speeds must be excluded from the auto-negotiation set
used during driver initialization due to compatibility issues with
certain switches. Those issues do not exist in case of E610 2.5G SKU
device (0x57b1).
Fixes: c6cb313da739 (net/ixgbe/base: add link
From: Dawid Zielinski
Added new capability informing about OROM recovery update.
Signed-off-by: Dawid Zielinski
Signed-off-by: Yuan Wang
---
drivers/net/ixgbe/base/ixgbe_e610.c | 3 +++
drivers/net/ixgbe/base/ixgbe_type_e610.h | 3 +++
2 files changed, 6 insertions(+)
diff --git a/drive
From: Dan Nowlin
Add missing buffer copy in ixgbe_aci_send_cmd_sc().
In ixgbe_aci_send_cmd_sc() there is code to retry aq commands for
certain commands. To achieve this the function makes a copy of the
original ixgbe_aci_desc structure and allocates memory to store an
original copy of the comman
Update README with the date of when the lastest snapshot was generated.
Signed-off-by: Yuan Wang
---
drivers/net/ixgbe/base/README | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/net/ixgbe/base/README b/drivers/net/ixgbe/base/README
index a6429fef19..8693c4ebc1 100644
From: Krzysztof Galazka
E610 adapters report overheating using a FW event. Add opcode
and event structure to properly handle such events.
Signed-off-by: Krzysztof Galazka
Signed-off-by: Yuan Wang
---
drivers/net/ixgbe/base/ixgbe_type_e610.h | 25
1 file changed, 25 in
From: Karol Kolacinski
Add max_drift_thresh parameter to ixgbe_get_ptp_by_phy() to allow
passing maxDriftThreshold parameter from the response.
Signed-off-by: Karol Kolacinski
Signed-off-by: Yuan Wang
---
drivers/net/ixgbe/base/ixgbe_e610.c | 5 -
drivers/net/ixgbe/base/ixgbe_e610.h | 3 +
Hello Maxime,
On Tuesday, January 14, 2025 09:48 CET, Maxime Coquelin
wrote:
>
>
> On 1/14/25 8:50 AM, Ariel Otilibili wrote:
>
> Reviewed-by: Maxime Coquelin
>
Thanks!
Have a good day,
Ariel
> Thanks,
> Maxime
>
在 2025/1/14 19:13, Thomas Monjalon 写道:
14/01/2025 02:50, lihuisong (C):
在 2025/1/13 21:14, Thomas Monjalon 写道:
13/01/2025 13:47, lihuisong (C):
在 2025/1/13 20:30, Thomas Monjalon 写道:
13/01/2025 13:05, lihuisong (C):
在 2025/1/13 19:23, lihuisong (C) 写道:
在 2025/1/13 18:57, Thomas Monjalon 写
From: Piotr Kwapulinski
Current value of IXGBE_SUBDEV_ID_E610_VF_HV (0x0001) causes the conflict
with real e610 subsystem device ID. This causes the TX hung of driver
running in VM. Update this value to 0x00FF to resolve conflict.
Fixes: 659e36767e77 (net/ixgbe/base: add E610 VF HV macro)
Cc: st
On Tue, Jan 14, 2025 at 10:44 AM Zhichao Zeng wrote:
>
> This patch modifies format specifier in debug prints to match to the
> change of time variables from 64 bit to 32 bit.
I am missing something... this is reverting a valid change.
If anything needs to be changed.. PRIu32 should be used in t
https://bugs.dpdk.org/show_bug.cgi?id=1615
Bug ID: 1615
Summary: Arissa Seah
Product: techboard
Version: unspecified
Hardware: All
OS: All
Status: UNCONFIRMED
Severity: normal
Priority: Normal
08/01/2025 02:41, Huichao Cai:
> Hi,Thomas
> This patch adds a field to the ABI structure.I have added the
> suppress_type
> field in the file libabigail.abignore, but "ci/github-robot: Build" still
> reported
> an error, could you please advise on how to fill in the suppress_type field?
You
On Mon, Jan 13, 2025 at 01:30:12PM -0800, Andre Muezerie wrote:
> On Fri, Jan 10, 2025 at 05:14:05PM -0800, Stephen Hemminger wrote:
> > On Fri, 10 Jan 2025 12:22:22 -0800
> > Andre Muezerie wrote:
> >
> > > diff --git a/lib/eal/meson.build b/lib/eal/meson.build
> > > index e1d6c4cf17..352db049e9
On Tue, 14 Jan 2025 08:07:52 -0800
Stephen Hemminger wrote:
> On Tue, 14 Jan 2025 17:22:08 +0800
> huangdengdui wrote:
>
> > On 2025/1/11 1:20, Stephen Hemminger wrote:
> > > This will make it slower for many platforms.
> > > GCC will unroll a loop of fixed small size, which is what we want.
On Tue, Jan 14, 2025 at 08:21:13AM -0800, Andre Muezerie wrote:
> Error reported:
> ../lib/net/net_crc_sse.c:49:17: error: call to undeclared function
> '_mm_clmulepi64_si128'; ISO C99 and later do not support implicit
> function declarations [-Wimplicit-function-declaration]
>
> The fix is to rem
Error reported:
../lib/net/net_crc_sse.c:49:17: error: call to undeclared function
'_mm_clmulepi64_si128'; ISO C99 and later do not support implicit
function declarations [-Wimplicit-function-declaration]
The fix is to remove the unnecessary ifdef around the inclusion of
header file immintrin.h. T
When putting an mbuf back into its mempool, there are certain requirements
to the mbuf. Specifically, some of its fields must be initialized.
These requirements are in fact invariants about free mbufs, held in
mempools, and thus also apply when allocating an mbuf from a mempool.
With this in mind,
On Tue, 14 Jan 2025 04:53:51 +
Gagandeep Singh wrote:
> Hi,
>
> > -Original Message-
> > From: Stephen Hemminger
> > Sent: Monday, January 13, 2025 10:10 PM
> > To: Gagandeep Singh
> > Cc: dev@dpdk.org
> > Subject: Re: [PATCH] eal: add worker threads cleanup in rte_eal_cleanup()
>
mbuf: add fast free bulk function
When putting an mbuf back into its mempool, there are certain requirements
to the mbuf. Specifically, some of its fields must be initialized.
These requirements are in fact invariants about free mbufs, held in
mempools, and thus also apply when allocating an mbuf
On Tue, 14 Jan 2025 17:22:08 +0800
huangdengdui wrote:
> On 2025/1/11 1:20, Stephen Hemminger wrote:
> > This will make it slower for many platforms.
> > GCC will unroll a loop of fixed small size, which is what we want.
>
> Do you mean to replace option with a macro?
> But most of prefetch_of
On Thu, 26 Dec 2024 10:41:44 -0800
Andre Muezerie wrote:
> Removed unused variables and added MSVC specific compiler flag to
> ignore warnings about unused variables, like is being done for
> other compilers.
>
> Signed-off-by: Andre Muezerie
> ---
> drivers/net/ice/base/ice_switch.c | 2 --
On Thu, 9 Jan 2025 07:31:32 +
Tomasz Duszynski wrote:
> >> From: Tomasz Duszynski
> >> To: , Stephen Hemminger ,
> >"Pascal Mazon"
> >> CC: , Tomasz Duszynski
> >> Subject: [PATCH] net/tap: fix compilation issues if HAVE_TCA_FLOWER is
> >> missing
> >> Date: Wed, 8 Jan 2025 13:10:11 +
On Thu, 26 Dec 2024 11:37:04 +0800
Junlong Wang wrote:
> V6:
> - Remove unnecessary __rte_packed in the virtqueue structure and others.
> - Remove Some blank before or after log message,
> and remove some end with period in log message.
>
> V5:
> - Simplify the notify_data part in the
The dts framework checks for total hugepages of a specific size on a
system without first checking if such hugepages are supported. This
results in unhelpful error messages, since attempting to grab
information from a file/directory that does not exist creates undefined
behavior. This quick reorien
This patch modifies format specifier in debug prints to match to the
change of time variables from 64 bit to 32 bit.
Fixes: d980a401b137 ("net/i40e/base: add NVM acquire with custom timeout")
Cc: sta...@dpdk.org
Signed-off-by: Zhichao Zeng
Signed-off-by: Jaroslaw Ilgiewicz
---
drivers/net/i40e
On 2025/1/10 1:03, Stephen Hemminger wrote:
> On Thu, 9 Jan 2025 15:43:12 +0800
> huangdengdui wrote:
>
>> On 2025/1/9 0:57, Stephen Hemminger wrote:
>>> On Wed, 8 Jan 2025 10:40:43 +0800
>>> Jie Hai wrote:
>>>
On 2024/12/31 1:55, Stephen Hemminger wrote:
> On Mon, 30 Dec 2024 14
It was a common pattern to have "GCC diagnostic ignored" pragmas
sprinkled over the code and only activate these pragmas for certain
compilers (gcc and clang). Clang supports GCC's pragma for
compatibility with existing source code, so #pragma GCC diagnostic
and #pragma clang diagnostic are synonym
It was a common pattern to have "GCC diagnostic ignored" pragmas
sprinkled over the code and only activate these pragmas for certain
compilers (gcc and clang). Clang supports GCC's pragma for
compatibility with existing source code, so #pragma GCC diagnostic
and #pragma clang diagnostic are synonym
It was a common pattern to have "GCC diagnostic ignored" pragmas
sprinkled over the code and only activate these pragmas for certain
compilers (gcc and clang). Clang supports GCC's pragma for
compatibility with existing source code, so #pragma GCC diagnostic
and #pragma clang diagnostic are synonym
It was a common pattern to have "GCC diagnostic ignored" pragmas
sprinkled over the code and only activate these pragmas for certain
compilers (gcc and clang). Clang supports GCC's pragma for
compatibility with existing source code, so #pragma GCC diagnostic
and #pragma clang diagnostic are synonym
On 2025/1/15 0:39, Morten Brørup wrote:
> mbuf: add fast free bulk function
>
> When putting an mbuf back into its mempool, there are certain requirements
> to the mbuf. Specifically, some of its fields must be initialized.
>
> These requirements are in fact invariants about free mbufs, held in
On Mon, 6 Jan 2025 17:35:08 +0200
Tudor Cornea wrote:
> This allows us to control the algorithm used to spread traffic between
> sockets, adding more fine grained control. If the user does not
> specify a fanout mode, the PMD driver will default to
> PACKET_FANOUT_HASH.
>
> Signed-off-by: Tudor
This patch avoids warnings like the ones below emitted by MSVC:
1)
../drivers/net/ice/base/ice_flg_rd.c(71): warning C4334: '<<':
result of 32-bit shift implicitly converted to 64 bits
(was 64-bit shift intended?)
2)
../drivers/net/ice/ice_dcf_sched.c(177): warning C4018: '>=':
signed
On Tue, Jan 14, 2025 at 10:41:53AM -0800, Stephen Hemminger wrote:
> On Mon, 6 Jan 2025 13:16:55 -0800
> Andre Muezerie wrote:
>
> > This patch avoids warnings like the ones below emitted by MSVC:
> >
> > 1)
> > ../drivers/net/ice/base/ice_flg_rd.c(71): warning C4334: '<<':
> > result of 32
On Wed, Jan 08, 2025 at 09:20:27AM +, Bruce Richardson wrote:
> On Tue, Jan 07, 2025 at 06:46:48PM -0800, Andre Muezerie wrote:
> > On Mon, Jan 06, 2025 at 11:00:15AM +, Bruce Richardson wrote:
> > > On Fri, Jan 03, 2025 at 01:26:34PM -0800, Andre Muezerie wrote:
> > > > On Fri, Jan 03, 202
The rte_eth_dev_socket_id() and rte_eth_dev_owner_*() can be used after
allocating an ethdev. So this patch relaxes the conditions for using them.
Fixes: 7dcd73e37965 ("drivers/bus: set device NUMA node to unknown by default")
Fixes: 53ef1b34776b ("ethdev: add sanity checks in control APIs")
Cc: s
I've had some issues when I add the verification of the port id in the
event callback, which are discussed in another patch series[1]. So this
series clarify something about RTE_ETH_EVENT_NEW based on the previous
discussion.
[1]
https://patches.dpdk.org/project/dpdk/cover/20250113025521.32703-1-
If application verify the validity of the port id or configure this port in
the new event callback, application may happen to the port id is invalid.
Actually, when application receive a new event from one port, the port is
not fully probed and is just in allocated state. Application doesn't need
On Mon, 6 Jan 2025 13:16:55 -0800
Andre Muezerie wrote:
> This patch avoids warnings like the ones below emitted by MSVC:
>
> 1)
> ../drivers/net/ice/base/ice_flg_rd.c(71): warning C4334: '<<':
> result of 32-bit shift implicitly converted to 64 bits
> (was 64-bit shift intended?)
>
>
Added MSVC specific compiler flag to ignore warnings about unused
variables, like is being done for other compilers.
Signed-off-by: Andre Muezerie
---
drivers/net/ice/base/meson.build | 16 ++---
drivers/net/qede/base/meson.build | 57 +--
2 files changed, 43 ins
Removed unused variables and added MSVC specific compiler flag to
ignore warnings about unused variables, like is being done for
other compilers.
Andre Muezerie (2):
drivers/common: remove unused variables and add MSVC compiler flag
drivers/net: add MSVC compiler flag for unused variables
dr
Removed unused variables and added MSVC specific compiler flag to
ignore warnings about unused variables, like is being done for
other compilers.
Signed-off-by: Andre Muezerie
---
drivers/common/idpf/base/meson.build | 13 ++---
drivers/common/idpf/idpf_common_rxtx.c | 2 --
d
Hi David
Thanks for your comments, will submit v2 patch.
Regards
Zhichao
> -Original Message-
> From: David Marchand
> Sent: Tuesday, January 14, 2025 9:15 PM
> To: Zeng, ZhichaoX
> Cc: dev@dpdk.org; sta...@dpdk.org; Ilgiewicz, Jaroslaw
> ; Stokes, Ian ;
> Richardson, Bruce ; Midde Aji
Hello Stephen,
On Tuesday, January 14, 2025 19:47 CET, Stephen Hemminger
wrote:
> On Fri, 13 Dec 2024 22:41:55 +0100
> Ariel Otilibili wrote:
>
> > Coverity issue: 38
> > Fixes: a62ec90522a ("net/sfc: add port representors infrastructure")
> > Cc: Andrew Rybchenko
> > Cc: sta...@dpdk.org
On Tue, 14 Jan 2025 13:08:28 -0800
Andre Muezerie wrote:
> >
> > Patches to base driver need to be avoided if at all possible.
> > Please resubmit without that part
>
> Thanks for the information. I sent out a v3 for this series.
> It does contain _coding style issues_ for preexisting code.
>
On Tue, 14 Jan 2025 20:54:51 +0100
"Ariel Otilibili-Anieli" wrote:
> Hello Stephen,
>
> On Tuesday, January 14, 2025 19:47 CET, Stephen Hemminger
> wrote:
>
> > On Fri, 13 Dec 2024 22:41:55 +0100
> > Ariel Otilibili wrote:
> >
> > > Coverity issue: 38
> > > Fixes: a62ec90522a ("net/sf
62 matches
Mail list logo