On Fri, Feb 16, 2024 at 1:33 AM Tyler Retzlaff
wrote:
>
> ping
>
> i'd like to see this change go in asap since it is pre-requisite to
> turning on -Wvla which explicitly caught use of non-constant expressions
> in the RTE_BUILD_BUG_ON() hiding bugs.
That was the last thing I applied yesterday.
I
> From: Stephen Hemminger [mailto:step...@networkplumber.org]
> Sent: Friday, 16 February 2024 04.36
>
> EAL logtype should be reserved for EAL library.
> This example is already using printf() so just print
> errors to stderr.
>
> Signed-off-by: Stephen Hemminger
> Acked-by: Huisong Li
> ---
> From: Stephen Hemminger [mailto:step...@networkplumber.org]
> Sent: Friday, 16 February 2024 04.05
>
> On Thu, 11 Jan 2024 23:38:07 +0100
> Morten Brørup wrote:
>
> > > From: Stephen Hemminger [mailto:step...@networkplumber.org]
> > > Sent: Thursday, 11 January 2024 20.55
> > >
> > > On Thu, 1
On Thu, Jan 18, 2024 at 5:53 PM Stephen Hemminger
wrote:
>
> This series fixes a couple places where expressions that could not
> be evaluated as constant early in compiler passes were used.
> Then converts RTE_BUILD_BUG_ON() with static_assert.
>
> static_assert() is more picky about the expressi
The previous code incorrectly parsed the VLAN ID and priority.
If the 16-bits of VLAN ID and priority/CFI on the wire was
0123456789ABCDEF the code parsed it as 456789ABCDEF3012. There
were macros defined to handle this conversion but they were not
used.
Fixes: 4e9c73e96e83 ("net/netvsc: add Hype
On Wed, Feb 14, 2024 at 8:36 AM David Marchand
wrote:
> > I'm okay with the change being merged but if there is concern I can drop
> > this patch from the series.
>
> At least, we can't merge it in the current form.
>
> If libabigail gets a fix quickly, DPDK CI will still need a released version.
Tyler explained in v1:
"""
As requested from previous rejected series this series applies the
__extension__ keyword to all statement expressionsin DPDK.
"""
Changes since v1:
- rebased,
- added two cleanups before Tyler patch,
--
David Marchand
David Marchand (2):
eal: add helper to skip wh
Reduce code duplication by providing a simple inline helper.
Signed-off-by: David Marchand
Acked-by: Tyler Retzlaff
---
app/graph/utils.c | 13 ++--
app/test-eventdev/parser.c | 14 -
app/test-eventdev/parser.h | 8 -
app
Use newly introduced macro.
Signed-off-by: David Marchand
---
drivers/net/bnxt/bnxt_ethdev.c | 12 +---
drivers/net/qede/base/bcm_osal.h | 6 ++
drivers/raw/ifpga/base/osdep_rte/osdep_generic.h | 11 ++-
3 files changed, 5 insertions(+), 24
From: Tyler Retzlaff
Add __extension__ keyword to gcc statement expression extensions.
Signed-off-by: Tyler Retzlaff
Reviewed-by: Ruifeng Wang
---
drivers/bus/fslmc/mc/fsl_mc_sys.h | 6 ++--
drivers/common/cnxk/roc_io.h | 6 ++--
drivers/common/cnxk/roc_platform
On Fri, Feb 16, 2024 at 11:25 AM David Marchand
wrote:
>
> Reduce code duplication by providing a simple inline helper.
>
> Signed-off-by: David Marchand
> Acked-by: Tyler Retzlaff
I forgot to mention:
Changes since v1:
- renamed helper as per Bruce suggestion,
--
David Marchand
Use a multi-word bitset to track which services are mapped to which
lcores, allowing the RTE_SERVICE_NUM_MAX compile-time constant to be >
64.
Replace array-of-bytes service-currently-active flags with a more
compact multi-word bitset-based representation, reducing memory
footprint somewhat.
Sign
Add test suite to exercise .
RFC v4:
* Fix signed char issue in test cases. (Stephen Hemminger)
* Add test cases for logic operations.
* Use the unit test suite runner helper.
Signed-off-by: Mattias Rönnblom
---
app/test/meson.build | 1 +
app/test/test_bitset.c | 870 +++
To reduce flow migration overhead, replace the array-based
representation of which set of ports are bound to a particular queue
by a multi-word bitset.
Signed-off-by: Mattias Rönnblom
---
drivers/event/dsw/dsw_evdev.c | 34 +++---
drivers/event/dsw/dsw_evdev.h | 3 ++
On Fri, Feb 16, 2024 at 11:27:10AM +0100, David Marchand wrote:
> On Fri, Feb 16, 2024 at 11:25 AM David Marchand
> wrote:
> >
> > Reduce code duplication by providing a simple inline helper.
> >
> > Signed-off-by: David Marchand
> > Acked-by: Tyler Retzlaff
>
> I forgot to mention:
>
> Change
Introduce a set of functions and macros that operate on sets of bits,
kept in arrays of 64-bit words.
RTE bitset is designed for bitsets which are larger than what fits in
a single machine word (i.e., 64 bits). For very large bitsets, the
API may be a more appropriate choice.
RFC v4:
* Add func
On 2/15/2024 6:12 PM, Alan Elder wrote:
> The previous code incorrectly parsed the VLAN ID and priority.
> If the 16-bits of VLAN ID and priority/CFI on the wire was
> 0123456789ABCDEF the code parsed it as 456789ABCDEF3012. There
> were macros defined to handle this conversion but they were not
>
On 2/16/2024 9:43 AM, Alan Elder wrote:
> The previous code incorrectly parsed the VLAN ID and priority.
> If the 16-bits of VLAN ID and priority/CFI on the wire was
> 0123456789ABCDEF the code parsed it as 456789ABCDEF3012. There
> were macros defined to handle this conversion but they were not
>
When configuring RX queues, the default port configuration was used,
even though it was modified before. This results in the
'relax-rx-offload' not being respected for RX queues.
This commit uses 'rte_eth_dev_conf_get()' to obtain the device
configuration structure instead.
Fixes: 4b01cabfb0 ("exa
Any review please?
07/02/2024 16:33, Abdullah Ömer Yamaç:
> This patch introduce a new API to get the hidden key count in the hash
> table if the rcu qsbr is enabled. When using rte_hash_count with rcu
> qsbr enabled, it will return the number of elements that are not in the
> free queue. Unless
Any review please?
If maintainers agree with the idea, we should announce the ABI change.
23/10/2023 10:29, Abdullah Ömer Yamaç:
> From: Abdullah Ömer Yamaç
>
> In some use cases inserting data with the same key shouldn't be
> overwritten. We use a new flag in this patch to disable overwriting
On 2/16/2024 3:47 AM, Kumara Parameshwaran wrote:
> In heavy-weight mode GRO which is based on timer, the GRO packets
> will not be flushed in spite of timer expiry if there is no packet
> in the current poll. If timer mode GRO is enabled the
> rte_gro_timeout_flush API should be invoked.
>
> Fixe
Use rte_mempool_virt2iova(), which uses arithmetic based on the mempool
state, rather than rte_mem_virt2iova(), which uses syscalls to look at
the proc filesystem. This speeds up pool create by more than 90%.
Signed-off-by: Andrew Boyer
---
lib/cryptodev/rte_cryptodev.c | 2 +-
1 file changed, 1
On Fri, Feb 16, 2024 at 11:25 AM David Marchand
wrote:
>
> Tyler explained in v1:
> """
> As requested from previous rejected series this series applies the
> __extension__ keyword to all statement expressionsin DPDK.
> """
>
> Changes since v1:
> - rebased,
> - added two cleanups before Tyler pat
This patch series adds support to net/ionic for using UIO platform devices
as DPDK vdevs. This is used by client applications which run directly on
the AMD Pensando family of devices.
The UIO code is implemented in a new common code library so that it can
be shared with the upcoming crypto/ionic d
Move definitions that will be shared by net/ionic and crypto/ionic.
Add the code used for discovering UIO vdevs.
Signed-off-by: Andrew Boyer
---
MAINTAINERS | 1 +
drivers/common/ionic/ionic_common.h | 41 +++
drivers/common/ionic/ionic_common_uio.c
These barriers are duplicated by the barriers inside
rte_write64(). Remove them to improve performance.
Signed-off-by: Neel Patel
Signed-off-by: Andrew Boyer
---
drivers/net/ionic/ionic_main.c| 1 -
drivers/net/ionic/ionic_rxtx_sg.c | 1 -
drivers/net/ionic/ionic_rxtx_simple.c | 1 -
Add support for running DPDK applications directly on AMD Pensando
embedded HW. The platform exposes the device BARs through UIO. The
UIO code in the common/ionic library walks the sysfs filesystem
to identify the relevant BARs and map them into process memory.
The SoCs are named 'Capri' and 'Elba
> From: Andrew Boyer [mailto:andrew.bo...@amd.com]
> Sent: Friday, 16 February 2024 18.04
>
> Use rte_mempool_virt2iova(), which uses arithmetic based on the mempool
> state, rather than rte_mem_virt2iova(), which uses syscalls to look at
> the proc filesystem. This speeds up pool create by more t
On Fri, 16 Feb 2024 09:29:47 +0100
Morten Brørup wrote:
> > From: Stephen Hemminger [mailto:step...@networkplumber.org]
> > Sent: Friday, 16 February 2024 04.05
> >
> > On Thu, 11 Jan 2024 23:38:07 +0100
> > Morten Brørup wrote:
> >
> > > > From: Stephen Hemminger [mailto:step...@networkplum
On Fri, 16 Feb 2024 09:29:47 +0100
Morten Brørup wrote:
> The system requirements in the Getting Started Guide [1] says:
>
> Kernel version >= 4.14
> The kernel version required is based on the oldest long term stable kernel
> available at kernel.org when the DPDK version is in development.
> C
On 2/16/2024 5:07 PM, Andrew Boyer wrote:
> This patch series adds support to net/ionic for using UIO platform devices
> as DPDK vdevs. This is used by client applications which run directly on
> the AMD Pensando family of devices.
>
> The UIO code is implemented in a new common code library so th
On Fri, Feb 16, 2024 at 09:02:29AM +0100, David Marchand wrote:
> On Fri, Feb 16, 2024 at 1:33 AM Tyler Retzlaff
> wrote:
> >
> > ping
> >
> > i'd like to see this change go in asap since it is pre-requisite to
> > turning on -Wvla which explicitly caught use of non-constant expressions
> > in the
On Fri, Feb 16, 2024 at 11:14:27AM +0100, David Marchand wrote:
> On Wed, Feb 14, 2024 at 8:36 AM David Marchand
> wrote:
> > > I'm okay with the change being merged but if there is concern I can drop
> > > this patch from the series.
> >
> > At least, we can't merge it in the current form.
> >
>
> On 2/10/2024 10:42 AM, Chaoyong He wrote:
> > From: Long Wu
> >
> > Add a interface to check if a device is a representor.
> >
> > Signed-off-by: Long Wu
> > Reviewed-by: Chaoyong He
> > Reviewed-by: Peng Zhang
>
> <...>
>
> > @@ -156,6 +156,12 @@ static const uint32_t nfp_net_link_speed_nf
> On Sat, Feb 10, 2024 at 11:42 AM Chaoyong He
> wrote:
> >
> > This patch series aims to add support of partial offload for NFP PMD.
>
> Partial offload is not a DPDK thing.
> I guess you are referring to OVS partial offload.
> If so, it is better to make it clear so that reviewers and other tha
Add the support of UDP fragmentation offload feature.
Signed-off-by: Chaoyong He
Reviewed-by: Long Wu
Reviewed-by: Peng Zhang
---
drivers/common/nfp/nfp_common_ctrl.h | 1 +
drivers/net/nfp/nfd3/nfp_nfd3_dp.c | 7 ++-
drivers/net/nfp/nfdk/nfp_nfdk_dp.c | 8 +---
drivers/net/nfp/nfp
37 matches
Mail list logo