Hi Maxime,
> -Original Message-
> From: Maxime Coquelin
> Sent: Friday, June 18, 2021 10:04 PM
> To: dev@dpdk.org; david.march...@redhat.com; Xia, Chenbo
>
> Cc: Maxime Coquelin
> Subject: [PATCH v6 7/7] vhost: convert inflight data to DPDK allocation API
>
> Inflight metadata are all
> -Original Message-
> From: Maxime Coquelin
> Sent: Friday, June 18, 2021 10:04 PM
> To: dev@dpdk.org; david.march...@redhat.com; Xia, Chenbo
>
> Cc: Maxime Coquelin
> Subject: [PATCH v6 5/7] vhost: improve NUMA reallocation
>
> This patch improves the numa_realloc() function by makin
> -Original Message-
> From: Maxime Coquelin
> Sent: Friday, June 18, 2021 10:04 PM
> To: dev@dpdk.org; david.march...@redhat.com; Xia, Chenbo
>
> Cc: Maxime Coquelin
> Subject: [PATCH v6 6/7] vhost: allocate all data on same node as virtqueue
>
> This patch saves the NUMA node the vir
> -Original Message-
> From: stable On Behalf Of Xueming Li
> Sent: Sunday, June 13, 2021 8:52 PM
> Cc: dev@dpdk.org; xuemi...@nvidia.com; ma...@nvidia.com; sta...@dpdk.org;
> Viacheslav Ovsiienko ; Maxime Coquelin
>
> Subject: [dpdk-stable] [PATCH] vdpa/mlx5: fix TSO offload without CSUM
On Thu, Jun 24, 2021 at 12:35 PM Kinsella, Ray wrote:
>
> Hi Nicolas
>
> The following bbdev experimental symbols are present in both v21.05 and
> v19.11 release. These symbols should be considered for promotion to stable as
> part of the v22 ABI in DPDK 21.11, as they have been experimental for
On Thu, Jun 24, 2021 at 12:33 PM Kinsella, Ray wrote:
>
> Hi Fiona & Ashish,
>
> The following compressdev experimental symbols are present in both v21.05 and
> v19.11 release. These symbols should be considered for promotion to stable as
> part of the v22 ABI in DPDK 21.11, as they have been ex
On 6/22/2021 4:50 PM, Ray Kinsella wrote:
> Update to ABI MAINTAINERS.
>
> Signed-off-by: Ray Kinsella
> ---
> MAINTAINERS | 1 -
> 1 file changed, 1 deletion(-)
>
> diff --git a/MAINTAINERS b/MAINTAINERS
> index 5877a16971..dab8883a4f 100644
> --- a/MAINTAINERS
> +++ b/MAINTAINERS
> @@ -117,7
2021-06-24 17:27 (UTC-0700), Narcisa Ana Maria Vasile:
> From: Narcisa Vasile
>
> Fix count_cpu() to ensure it iterates through all the CPUs in a set.
> count_cpu() iterates through the CPUs in the set 's' and counts the
> selected ones.
>
> Previously, it was incorrectly using the number of CPU
On 25/06/2021 08:49, David Marchand wrote:
> On Thu, Jun 24, 2021 at 12:33 PM Kinsella, Ray wrote:
>>
>> Hi Fiona & Ashish,
>>
>> The following compressdev experimental symbols are present in both v21.05
>> and v19.11 release. These symbols should be considered for promotion to
>> stable as p
This patch enables the ETS-based Tx QoS for IAVF. Kernel tool is used to
configure ETS first. DCF is used to set bandwidth limit for VFs of each
TC. IAVF is supported to query QoS capability and set queue TC mapping.
Traffic Management API is utilized to configure the QoS hierarchy
scheduler tree.
This patch adds new virtchnl opcodes and structures for QoS
configuration, which includes:
1. VIRTCHNL_VF_OFFLOAD_TC, to negotiate the capability supporting QoS
configuration. If VF and PF both have this flag, then the ETS-based QoS
offload function is supported.
2. VIRTCHNL_OP_DCF_CONFIG_BW, DCF i
In the adminq command query port ETS function, the root node teid is
needed. However, for DCF, the root node is not initialized, which will
cause error when we refer to the variable. In this patch, we will check
whether the root node is available or not first.
Signed-off-by: Ting Xu
---
drivers/
When link status changes, DCF will receive virtchnl PF event message.
Add support to handle this event, change link status and update link
info.
Signed-off-by: Ting Xu
---
drivers/net/ice/ice_dcf.h| 6
drivers/net/ice/ice_dcf_ethdev.c | 54 ++--
drivers/
This patch supports the ETS-based QoS configuration. It enables the DCF
to configure bandwidth limits for each VF VSI of different TCs. A
hierarchy scheduler tree is built with port, TC and VSI nodes.
Signed-off-by: Qiming Yang
Signed-off-by: Ting Xu
---
drivers/net/ice/ice_dcf.c| 6 +
This patch added the support for VF to config the ETS-based Tx QoS,
including querying current QoS configuration from PF and config queue TC
mapping. PF QoS is configured in advance and the queried info is
provided to the user for future usage. VF queues are mapped to different
TCs in PF through vi
> > int n = txq->tx_rs_thresh;
> > int32_t i = 0, j = 0;
> > const int32_t k = RTE_ALIGN_FLOOR(n, RTE_I40E_TX_MAX_FREE_BUF_SZ);
> > const int32_t m = n % RTE_I40E_TX_MAX_FREE_BUF_SZ; struct rte_mbuf
> > *free[RTE_I40E_TX_MAX_FREE_BUF_SZ];
> >
> > For FAST_FREE_MODE:
> >
> > if (k) {
> > for
get_hugepage_dir() was implemented in such a way that a --huge-dir option
had to exactly match the mountpoint, but there's no reason for this
restriction. Fix the implementation to allow a sub-directory within a
suitable hugetlbfs mountpoint to be specified.
Signed-off-by: John Levon
---
lib/eal
> -Original Message-
> From: Stephen Hemminger
> Sent: Friday, June 25, 2021 12:34 PM
> To: Xueming(Steven) Li
> Cc: NBU-Contact-Thomas Monjalon ; dev@dpdk.org; Parav
> Pandit ; Ray Kinsella
> ; Neil Horman
> Subject: Re: [dpdk-dev] [RFC] bus/auxiliary: introduce auxiliary bus
>
> O
Hi Maxime,
> -Original Message-
> From: stable On Behalf Of Xia, Chenbo
> Sent: Friday, June 25, 2021 10:56 AM
> To: Maxime Coquelin ; dev@dpdk.org;
> david.march...@redhat.com
> Cc: sta...@dpdk.org
> Subject: Re: [dpdk-stable] [PATCH v6 4/7] vhost: fix NUMA reallocation
> with multiqueue
Adds common devargs key definition for "bus", "class" and "driver".
Acked-by: Thomas Monjalon
Signed-off-by: Xueming Li
---
drivers/common/mlx5/mlx5_common.h | 2 --
drivers/common/mlx5/mlx5_common_pci.c | 2 +-
drivers/common/sfc_efx/sfc_efx.c| 7 +++
drivers/common/sfc_
Auxiliary bus [1] provides a way to split function into child-devices
representing sub-domains of functionality. Each auxiliary device
represents a part of its parent functionality.
Auxiliary device is identified by unique device name, sysfs path:
/sys/bus/auxiliary/devices/
Devargs legacy synt
On 23-Jun-21 10:52 AM, Ananyev, Konstantin wrote:
On 22-Jun-21 10:13 AM, Ananyev, Konstantin wrote:
Currently, we expect that only one callback can be active at any given
moment, for a particular queue configuration, which is relatively easy
to implement in a thread-safe way. However, we'r
25/06/2021 05:26, Xueming(Steven) Li:
> From: Thomas Monjalon
> > 23/06/2021 02:03, Xueming Li:
> > > +static int
> > > +auxiliary_parse(const char *name, void *addr) {
> > > + struct rte_auxiliary_driver *drv = NULL;
> > > + const char **out = addr;
> > > +
> > > + /* Allow dummy name to prevent
On 6/2/2021 1:46 PM, Ilya Maximets wrote:
> On 6/1/21 4:28 PM, Ivan Malov wrote:
>> Hi Ilya,
>>
>> Thank you for reviewing the proposal at such short notice. I'm afraid that
>> prior discussions overlook the simple fact that the whole problem is not
>> limited to just VF representors. Action PORT
Hi Ferruh, all,
Let's please discuss another approach to setting KNI link status before
making this API stable:
http://patches.dpdk.org/project/dpdk/patch/20190925093623.18419-1-iryz...@nfware.com/
I explained the problem with the current implementation there.
More than that, using ioctl approach
This patchset introduces several changes related to PMD power management:
- Changed monitoring intrinsics to use callbacks as a comparison function, based
on previous patchset [1] but incorporating feedback [2] - this hopefully will
make it possible to add support for .get_monitor_addr in virt
Previously, the semantics of power monitor were such that we were
checking current value against the expected value, and if they matched,
then the sleep was aborted. This is somewhat inflexible, because it only
allowed us to check for a specific value.
This commit replaces the comparison with a us
Implement support for .get_monitor_addr in AF_XDP driver.
Signed-off-by: Anatoly Burakov
---
Notes:
v2:
- Rewrite using the callback mechanism
drivers/net/af_xdp/rte_eth_af_xdp.c | 33 +
1 file changed, 33 insertions(+)
diff --git a/drivers/net/af_xdp/rte_e
Use RTM and WAITPKG instructions to perform a wait-for-writes similar to
what UMWAIT does, but without the limitation of having to listen for
just one event. This works because the optimized power state used by the
TPAUSE instruction will cause a wake up on RTM transaction abort, so if
we add the a
Currently, we expect that only one callback can be active at any given
moment, for a particular queue configuration, which is relatively easy
to implement in a thread-safe way. However, we're about to add support
for multiple queues per lcore, which will greatly increase the
possibility of various
Use the new multi-monitor intrinsic to allow monitoring multiple ethdev
Rx queues while entering the energy efficient power state. The multi
version will be used unconditionally if supported, and the UMWAIT one
will only be used when multi-monitor is not supported by the hardware.
Signed-off-by: A
Currently, there is a hard limitation on the PMD power management
support that only allows it to support a single queue per lcore. This is
not ideal as most DPDK use cases will poll multiple queues per core.
The PMD power management mechanism relies on ethdev Rx callbacks, so it
is very difficult
Currently, l3fwd-power enforces the limitation of having one queue per
lcore. This is no longer necessary, so remove the limitation, and always
mark the last queue in qconf as the power save queue.
Signed-off-by: Anatoly Burakov
---
examples/l3fwd-power/main.c | 39 +++---
On Wed, Jun 23, 2021 at 10:17 AM Nithin Dabilpuram
wrote:
>
> This patchset adds support for Marvell CN106XX SoC based on 'common/cnxk'
> driver. In future, CN9K a.k.a octeontx2 will also be supported by same
> driver when code is ready and 'net/octeontx2' will be deprecated.
Series applied to
From: Jerin Jacob
Resigning my maintainership for ARM v8 architecture.
Signed-off-by: Jerin Jacob
---
Resigning due to not getting enough quality time to review arm64 architecture
patches.
Unlike those days where arm64 architecture started with Cavium HW,
Now arm64 architecture is quite matur
On Wed, May 12, 2021 at 2:46 PM Tejasree Kondoj wrote:
>
> Adding support for Inline IPsec without DEV_TX_OFFLOAD_MBUF_FAST_FREE.
>
> Signed-off-by: Tejasree Kondoj
Reviewed-by: Jerin Jacob
Updated the git comments and
Applied to dpdk-next-net-mrvl/for-next-net. Thanks
> ---
> drivers/net/
> >>
> >> On 22-Jun-21 10:13 AM, Ananyev, Konstantin wrote:
> >>>
> Currently, we expect that only one callback can be active at any given
> moment, for a particular queue configuration, which is relatively easy
> to implement in a thread-safe way. However, we're about to add suppo
On 6/8/2021 1:39 PM, Andrew Rybchenko wrote:
> On 6/8/21 3:29 PM, Olivier Matz wrote:
>> Hi Ferruh, Andrew,
>>
>> On Tue, Jun 08, 2021 at 01:23:33PM +0300, Andrew Rybchenko wrote:
>>> On 4/30/21 6:42 PM, Ferruh Yigit wrote:
On 4/27/2021 2:57 PM, Olivier Matz wrote:
> Since commit d5df2ae04
Add support for runtime Rx and Tx queue setup. This will allow
Rx/Tx queue setup after the interface is started.
Signed-off-by: Ajit Khaparde
---
drivers/net/bnxt/bnxt_ethdev.c | 2 ++
drivers/net/bnxt/bnxt_hwrm.c | 46 --
drivers/net/bnxt/bnxt_hwrm.h | 3 ++
dr
This patchset adds runtime queue setup support.
Ajit Khaparde (2):
net/bnxt: add support for runtime queue setup
net/bnxt: fix ring alloc and free logic
drivers/net/bnxt/bnxt_ethdev.c | 2 +
drivers/net/bnxt/bnxt_hwrm.c | 181 +
drivers/net/bnxt/bnxt_hwrm.
Fix handling of ring alloc and free logic to fix check for invalid ring and
context IDs. This also avoids code duplication.
Fixes: 6133f207970c ("net/bnxt: add Rx queue create/destroy")
Fixes: 51c87ebafc7d ("net/bnxt: add Tx queue create/destroy")
Signed-off-by: Ajit Khaparde
Reviewed-by: Somnat
Hi, all
I analyzed the current DPAM DMA driver and drew this summary in conjunction
with the previous discussion, and this will as a basis for the V2
implementation.
Feedback is welcome, thanks
dpaa2_qdma:
[probe]: mainly obtains the number of hardware queues.
[dev_configure]: has follow
42 matches
Mail list logo