Hi Alexander,
I guess that the test-pmd part will be available later right?
> -Original Message-
> From: Alexander Kozyrev
> Sent: Friday, January 8, 2021 8:33 AM
> Subject: [PATCH] ethdev: introduce generic copy rte flow action
>
> Implement a generic copy flow API to allow copying of
When NVM API version is 1.7 or above adminq operation to set TPID is
set as supported. This cause using adminq instead of registers.
For SFP_I_X722 FW4.16, reported NVM API version is 1.8, and this cause
adminq operation to set as supported but it is not supported on FW4.16
Additional check added f
PMD validates the rss action in the sample sub-actions list,
then translate into rdma-core action and it will be used for sample
path destination.
If the RSS action both in sample sub-actions list and original flow,
the rss level and rss type in the sample sub-actions list should be
consistent wit
Support rss action in the sample sub-actions list.
The examples for the sample flow use case and result as below:
set sample_actions 0 mark id 0x12 / rss queues 0 1 2 3 end / end
flow create 0 ingress group 1 pattern eth / end actions
sample ratio 1 index 0 / jump group 2 / end
This flow will
Currently the sample flow only supports Queue action in NIC-Rx domain.
This patchset adds the RSS action support in the sample sub-actions list.
The examples for the sample flow with RSS action and result as below:
set sample_actions 0 mark id 0x12 / rss queues 0 1 2 3 end / end
flow cr
Add descrption about RSS action will be supported in the Sample
action in MLX5 PMD.
Signed-off-by: Jiawei Wang
---
doc/guides/nics/mlx5.rst | 1 +
doc/guides/rel_notes/release_21_02.rst | 5 +
2 files changed, 6 insertions(+)
diff --git a/doc/guides/nics/mlx5.rst b/doc/guides/
Hi Olivier,
> -Original Message-
> From: Olivier Matz
> Sent: Wednesday, January 6, 2021 3:34 PM
> To: dev@dpdk.org
> Cc: andrew.rybche...@oktetlabs.ru; konstantin.anan...@intel.com;
> m...@smartsharesystems.com; Ali Alnubani ;
> ajitkhapa...@gmail.com; sta...@dpdk.org; Ajit Khaparde
>
>
Correct, Ori. We'll soon send the testpmd part and pmd draft.
Regards,
Asaf Penso
>-Original Message-
>From: dev On Behalf Of Ori Kam
>Sent: Sunday, January 10, 2021 10:01 AM
>To: Alexander Kozyrev ; dev@dpdk.org
>Cc: Slava Ovsiienko ; NBU-Contact-Thomas
>Monjalon ; ferruh.yi...@intel.co
Hi,
> -Original Message-
> From: Zhang, Qi Z
> Sent: Saturday, January 9, 2021 3:01 AM
> Subject: RE: [dpdk-dev] [dpdk-dev v2 1/2] ethdev: add new tunnel type for
> ecpri
>
>
>
> > -Original Message-
> > From: Thomas Monjalon
> > Subject: Re: [dpdk-dev] [dpdk-dev v2 1/2] ethd
Hi,
> -Original Message-
> From: Shiri Kuzin
> Sent: Thursday, January 7, 2021 10:39 AM
> Subject: [PATCH v3 1/8] lib/librte_ethdev: introduce GENEVE header TLV option
> item
>
> The Geneve tunneling protocol is designed to allow the
> user to specify some data context on the packet.
> T
Update function mlx5_devx_cmd_query_hca_attr() to add the
reg_c_preserve bit query.
The stored metadata in register C may be lost in NIC Tx and
FDB egress while doing one one of the following operations:
- packet encapsulation.
- packet mirroring (multiple processing paths).
- packet sampling (
mlx5 E-Switch mirroring is implemented as multiple destination array in
one steering table. The array currently supports only port ID as
destination actions.
This patch adds the jump action support to the array as one of
destination.
The packets can be mirrored to the port and jump to next table i
MLX5 E-Switch mirroring is implemented as multiple destination array in
one steering table. The array currently supports only port ID as
destination actions.
This patchset adds the below supports for MLX5 PMD driver:
- Supports the metadata register Cx preserve capability query.
- Supports the
While there's the modify action and sample action with ratio=1
in the E-Switch flow, and modify action is after the sample
action, means that the modify should only impact on after sample.
MLX5 PMD will monitor the above case and split the E-Switch flow
into two sub flows, smiliar as sample flow di
The sampling feature introduces the scale flow group with factor,
then the scaled table value can be used for the normal path table
due to this table be created implicitly.
But if the input group value already be scaled, for example the
group value of sampling suffix flow, then use 'skip_scale" fl
Updates the description in MLX5 PMD and release note.
Adds the new supports for E-switch mirroring and jump in one flow,
and header modify one port in E-switch mirroring.
Signed-off-by: Jiawei Wang
---
doc/guides/nics/mlx5.rst | 2 ++
doc/guides/rel_notes/release_21_02.rst | 6
Up to this commit the regex application used one QP which was assigned a
number of jobs, each with a different segment of a file to parse. This
commit adds support for multiple QPs assignments. All QPs will be
assigned the same number of jobs, with the same segments of file to
parse. It will enabl
This patchset enhances the regex application to support multi Q with multi
cores.
v1: Initial release.
v2: Update documentation (testregex.rst).
v3: fix an error in commit "app/regex: support performance measurements per QP"
The following line triggered an error with PPC compiler:
error:
Function rte_pktmbuf_pool_create() is moved from init_port() routine to
run_regex() routine. Looking forward on multi core support - init_port()
will be called only once as part of application startup while mem pool
creation should be called multiple times (per core).
Signed-off-by: Ophir Munk
Ac
Up to this commit the input data file was read from scratch for each QP,
which is redundant. Starting from this commit the data file is read only
once at startup. Each QP will clone the data.
Signed-off-by: Ophir Munk
Acked-by: Ori Kam
---
app/test-regex/main.c | 63
Up to this commit measuring the parsing elapsed time and Giga bits per
second performance was done on the aggregation of all QPs (per core).
This commit separates the time measurements per individual QP.
Signed-off-by: Ophir Munk
Acked-by: Ori Kam
---
app/test-regex/main.c | 34
Up to this commit the regex application was running with multiple QPs on
a single core. This commit adds the option to specify a number of cores
on which multiple QPs will run.
A new parameter 'nb_lcores' was added to configure the number of cores:
--nb_lcores .
If not configured the number of cor
Performance measurement (elapsed time and Gbps) are based on Linux
clock() API. The resolution is improved by replacing the clock() API
with rte_rdtsc_precise() API.
Signed-off-by: Ophir Munk
Acked-by: Ori Kam
---
app/test-regex/main.c | 31 +--
1 file changed, 13 in
> -Original Message-
> From: Thomas Monjalon
> Sent: Friday, January 8, 2021 11:09 AM
> To: Ophir Munk
> Cc: dev@dpdk.org; Ori Kam
> Subject: Re: [dpdk-dev] [PATCH v2 5/6] app/regex: support performance
> measurements per QP
>
> 20/12/2020 11:41, Ophir Munk:
> > Up to this commit meas
Hi,
> -Original Message-
> From: dev On Behalf Of Lijun Ou
> Sent: Friday, January 8, 2021 11:46 AM
> To: ferruh.yi...@intel.com; wenzhuo...@intel.com; beilei.x...@intel.com;
> bernard.iremon...@intel.com
> Cc: dev@dpdk.org
> Subject: [dpdk-dev] [RFC] app/testpmd: support multi-process
>
Previously, the identification of hairpin queue was done using
mlx5_rxq_get_type() function.
Recent patch replaced it with use of mlx5_rxq_get_hairpin_conf(),
and check of the return value conf != NULL.
The case of return value is NULL (queue is not hairpin) was not handled.
As result, non-hairpin
Signed-off-by: Asaf Penso
---
doc/guides/contributing/patches.rst | 52 +
1 file changed, 52 insertions(+)
diff --git a/doc/guides/contributing/patches.rst
b/doc/guides/contributing/patches.rst
index 4e9140b..849fe6d 100644
--- a/doc/guides/contributing/patch
10/01/2021 12:16, Ophir Munk:
>
> > -Original Message-
> > From: Thomas Monjalon
> > Sent: Friday, January 8, 2021 11:09 AM
> > To: Ophir Munk
> > Cc: dev@dpdk.org; Ori Kam
> > Subject: Re: [dpdk-dev] [PATCH v2 5/6] app/regex: support performance
> > measurements per QP
> >
> > 20/12/2
Acked-by: Min Hu (Connor)
在 2020/11/19 19:58, Ferruh Yigit 写道:
'retval' is already defined in the function scope, removing the 'retval'
in the block scope.
Fixes: 112891cd27e5 ("net/bonding: add dedicated HW queues for LACP control")
Cc: sta...@dpdk.org
Signed-off-by: Ferruh Yigit
---
Cc: to
> -邮件原件-
> 发件人: Pavan Nikhilesh Bhagavatula
> 发送时间: 2021年1月8日 18:58
> 收件人: Feifei Wang ; jer...@marvell.com; Harry
> van Haaren
> 抄送: dev@dpdk.org; nd ; Honnappa Nagarahalli
> ; sta...@dpdk.org; Ruifeng Wang
> ; nd ; nd ; nd
>
> 主题: RE: [RFC PATCH v1 4/6] app/eventdev: add release barr
Hi Maxime,
> -Original Message-
> From: Maxime Coquelin
> Sent: Tuesday, December 22, 2020 12:15 AM
> To: dev@dpdk.org; Xia, Chenbo ; amore...@redhat.com;
> david.march...@redhat.com; olivier.m...@6wind.com
> Cc: Maxime Coquelin
> Subject: [PATCH 1/3] net/virtio: remove reference to virt
> -Original Message-
> From: oulijun
> Sent: Saturday, January 9, 2021 10:16 AM
> To: Ruifeng Wang ; Wei Hu (Xavier)
> ; Min Hu (Connor) ;
> Yisen Zhuang ; Huisong Li
> ; Chengchang Tang
> ; Chengwen Feng
>
> Cc: dev@dpdk.org; vladimir.medved...@intel.com; jer...@marvell.com;
> hemant.ag
> -Original Message-
> From: oulijun
> Sent: Saturday, January 9, 2021 10:12 AM
> To: Honnappa Nagarahalli ; Ruifeng Wang
> ; Wei Hu (Xavier) ;
> Min Hu (Connor) ; Yisen Zhuang
> ; Huisong Li ;
> Chengchang Tang ; Chengwen Feng
>
> Cc: dev@dpdk.org; vladimir.medved...@intel.com; jer...@m
Hi Maxime,
> -Original Message-
> From: Maxime Coquelin
> Sent: Tuesday, December 22, 2020 12:15 AM
> To: dev@dpdk.org; Xia, Chenbo ; amore...@redhat.com;
> david.march...@redhat.com; olivier.m...@6wind.com
> Cc: Maxime Coquelin
> Subject: [PATCH 2/3] net/virtio: allocate fake mbuf in Rx
Hi Maxime,
> -Original Message-
> From: Maxime Coquelin
> Sent: Tuesday, December 22, 2020 12:15 AM
> To: dev@dpdk.org; Xia, Chenbo ; amore...@redhat.com;
> david.march...@redhat.com; olivier.m...@6wind.com
> Cc: Maxime Coquelin
> Subject: [PATCH 3/3] net/virtio: pack virtuqueue struct
> -Original Message-
> From: Honnappa Nagarahalli
> Sent: Saturday, January 9, 2021 7:58 AM
> To: Ruifeng Wang ; jer...@marvell.com; Ruifeng
> Wang ; Jan Viktorin ;
> Bruce Richardson
> Cc: dev@dpdk.org; vladimir.medved...@intel.com;
> hemant.agra...@nxp.com; nd ; Honnappa Nagarahalli
>
On Mon, Jan 11, 2021 at 8:31 AM Ruifeng Wang wrote:
>
>
> > -Original Message-
> > From: Honnappa Nagarahalli
> > Sent: Saturday, January 9, 2021 7:58 AM
> > To: Ruifeng Wang ; jer...@marvell.com; Ruifeng
> > Wang ; Jan Viktorin ;
> > Bruce Richardson
> > Cc: dev@dpdk.org; vladimir.medve
> -Original Message-
> From: Ding, Xuan
> Sent: Friday, January 8, 2021 4:39 PM
> To: Zhang, Qi Z ; Wu, Jingjing ;
> Xing, Beilei
> Cc: dev@dpdk.org; Wang, Haiyue ; Guo, Jia
> ; Su, Simei ; Yan, Zhirun
> ; Ding, Xuan
> Subject: [PATCH] net/ice: refactor PF RSS
>
> This patch refactor
Hi Maxime,
> -Original Message-
> From: Maxime Coquelin
> Sent: Tuesday, December 22, 2020 12:15 AM
> To: dev@dpdk.org; Xia, Chenbo ; amore...@redhat.com;
> david.march...@redhat.com; olivier.m...@6wind.com
> Cc: Maxime Coquelin
> Subject: [PATCH 2/3] net/virtio: allocate fake mbuf in Rx
> -Original Message-
> From: Maxime Coquelin
> Sent: Friday, January 8, 2021 5:42 PM
> To: dev@dpdk.org; sta...@dpdk.org; Xia, Chenbo ;
> amore...@redhat.com; jasow...@redhat.com; david.march...@redhat.com
> Cc: Maxime Coquelin
> Subject: [PATCH v3 1/2] net/virtio: fix missing backend fea
Async enqueue offloads large copies to DMA devices, and small copies
are still performed by the CPU. However, it requires users to get
enqueue completed packets by rte_vhost_poll_enqueue_completed(), even
if they are completed by the CPU when rte_vhost_submit_enqueue_burst()
returns. This design in
This patch removes unnecessary check and function calls, and it changes
appropriate types for internal variables and fixes typos.
Signed-off-by: Jiayu Hu
Tested-by: Yinan Wang
---
lib/librte_vhost/rte_vhost_async.h | 8
lib/librte_vhost/virtio_net.c | 16
2 files
Async enqueue offloads large copies to DMA devices, and small copies
are still performed by the CPU. However, it requires users to get
enqueue completed packets by rte_vhost_poll_enqueue_completed(), even
if they are completed by the CPU when rte_vhost_submit_enqueue_burst()
returns. This design in
Refactor the vhost sample code. Add ioat ring space count and check
in ioat callback, optimize vhost data path for batch enqueue, replace
rte_atomicNN_xxx to atomic_XXX and refactor vhost async data path.
---
v8:
* rebased codes
v7:
* fixed rte_ioat_completed_ops() fail handler issue
v6:
* adj
Add ioat ring space count and check, if ioat ring space is not enough
for the next async vhost packet enqueue, then just return to prevent
enqueue failure. Add rte_ioat_completed_ops() fail handler.
Signed-off-by: Cheng Jiang
Reviewed-by: Jiayu Hu
---
examples/vhost/ioat.c | 24 +---
Change the vm2vm data path to batch enqueue for better performance.
Support latest async vhost API, refactor vhost async data path,
replace rte_atomicNN_xxx to atomic_XXX and clean some codes.
Signed-off-by: Cheng Jiang
Reviewed-by: Jiayu Hu
---
examples/vhost/ioat.h | 2 +-
examples/vhost/ma
46 matches
Mail list logo