10/02/2020 07:32, Matan Azrad:
> From: Thomas Monjalon
>
> > Replace checking against 65535 limit,
> > with a simpler form using RTE_MIN and UINT16_MAX macros.
> >
> > Signed-off-by: Thomas Monjalon
> > ---
>
> No more misusing of *_MAX \ RTE_MIN\RTE_MAX in the mlx PMDs?
Sorry I don't understa
On 01/29, Sexton, Rory wrote:
>>
>> Subject: [PATCH v3] net/i40e: fix i40e flow director merge
>>
>> Merge of ESP and L2TP code in i40e_fdir.c added checks on cus_pctype->index
>> which caused flow creation for ESP to fail.
>>
>> Added fill_ipv4_function()
>> Refactored code to have one path fo
10/02/2020 09:52, Thomas Monjalon:
> 10/02/2020 07:32, Matan Azrad:
> > From: Thomas Monjalon
> >
> > > Replace checking against 65535 limit,
> > > with a simpler form using RTE_MIN and UINT16_MAX macros.
> > >
> > > Signed-off-by: Thomas Monjalon
> > > ---
> >
> > No more misusing of *_MAX \ R
The header file rte_config.h is always included by make or meson.
If required in an exported API header file, it must be included
in the public header file for external applications.
In the internal files, explicit include of rte_config.h is useless,
and can be removed.
Signed-off-by: Thomas Monja
From: Thomas Monjalon
> 10/02/2020 09:52, Thomas Monjalon:
> > 10/02/2020 07:32, Matan Azrad:
> > > From: Thomas Monjalon
> > >
> > > > Replace checking against 65535 limit, with a simpler form using
> > > > RTE_MIN and UINT16_MAX macros.
> > > >
> > > > Signed-off-by: Thomas Monjalon
> > > > -
From: Thomas Monjalon
> Subject: [PATCH] build: remove redundant config include
>
> The header file rte_config.h is always included by make or meson.
> If required in an exported API header file, it must be included in the public
> header file for external applications.
> In the internal files,
> -Original Message-
> From: Kusztal, ArkadiuszX
> Sent: Friday, January 31, 2020 7:29 AM
> To: dev@dpdk.org
> Cc: akhil.go...@nxp.com; Trahe, Fiona ; Kusztal,
> ArkadiuszX
>
> Subject: [PATCH] crypto/qat: fix missing release note for dual thread feature
>
> This commit fixes missing
> -Original Message-
> From: Kusztal, ArkadiuszX
> Sent: Friday, January 31, 2020 7:29 AM
> To: dev@dpdk.org
> Cc: akhil.go...@nxp.com; Trahe, Fiona ; Kusztal,
> ArkadiuszX
>
> Subject: [PATCH] crypto/qat: fix not included release note for coalescing
> feature
>
> This patch fixes n
On Mon, Feb 10, 2020 at 10:54 AM Thomas Monjalon wrote:
>
> The header file rte_config.h is always included by make or meson.
> If required in an exported API header file, it must be included
> in the public header file for external applications.
> In the internal files, explicit include of rte_co
Move symbols added in 20.02 release to DPDK_20.0.1 ABI.
Fixes: d06551535a09 ("common/octeontx2: add security capability routine")
Fixes: 3fe4d07d1678 ("crypto/octeontx2: enable CPT to share QP with ethdev")
Fixes: f44e71637755 ("net/octeontx2: add security session operations")
Signed-off-by: Anoo
The function mlx5_glue_init was doing three things:
- initialize logs
- load glue library if in dlopen mode
- initialize glue layer
They are split in three functions for clarity.
The config option RTE_IBVERBS_LINK_DLOPEN is not used anymore
outside of make and meson files.
The variable storages of the same name are merged together
if compiled with -fcommon. This is the default.
This default behaviour allows to declare a variable in a header file
and share the variable in every .o binaries thanks to merge at link-time.
In the case of dlopen linking of the glue librar
In GCC 10, -fno-common will be the default.
There are 2 ways of solving issues:
- add -fcommon
- stop allocating variables in .h files
In this patchset, the variables are declared extern,
because it is cleaner anyway.
Thomas Monjalon (3):
common/mlx5: split glue initialization
common/mlx
The variable storages of the same name are merged together
if compiled with -fcommon. This is the default.
This default behaviour allows to declare a variable in a header file
and share the variable in every .o binaries thanks to merge at link-time.
In the case of dlopen linking of the glue librar
The fill queue addresses should start at the beginning of the mempool
object instead of the beginning of the mbuf. This is because the umem
frame headroom includes the mp hdrobj size. Starting at this point
ensures AF_XDP doesn't write past the available room in the frame, in
the case of larger pac
The previous frame size calculation incorrectly used
mb_pool->private_data_size and didn't include mb_pool->header_size.
Instead of performing a manual calculation, use the
rte_mempool_calc_obj_size API to determine the frame size.
The previous frame headroom calculation also incorrectly used
mb_p
This series introduces some fixes for the zero copy path of the AF_XDP.
In zero copy, the mempool objects are mapped directly into the AF_XDP UMEM.
Below depicts the layout of an object in a mempool.
+-++--+--+-+-+
| mp | struct | mbuf | mbuf | XDP |
The maximum MTU for af_xdp zero copy is equal to the page size less the
frame overhead introduced by AF_XDP (XDP HR = 256) and DPDK (frame headroom
= 320). The patch updates this value to reflect this.
This change also makes it possible to remove unneeded constants for both
zero-copy and copy mode
The glue shared library name was created by the common class FMT name,
driver_name_fmt = 'rte_common_@0@', which is not correlated with
LIB_GLUE_BASE = 'librte_pmd_mlx5_glue.so'.
This causes the dynamic linkage of the glue library to fail what
remained mlx5 drivers outside the PCI driver list.
Th
On 2/7/2020 6:08 PM, Stephen Hemminger wrote:
> If application is using link state interrupt, the correct link state
> needs to be filled in when device is started. This is similar to
> how virtio updates link information.
>
> Fixes: 4e9c73e96e83 ("net/netvsc: add Hyper-V network device")
> Cc: st
Hi,
> -Original Message-
> From: dev On Behalf Of Matan Azrad
> Sent: Sunday, February 9, 2020 5:19 PM
> To: Slava Ovsiienko
> Cc: dev@dpdk.org; sta...@dpdk.org
> Subject: [dpdk-dev] [PATCH] net/mlx5: fix xcapsulation validation
>
> The encapsulation and decapsulation actions are divide
On Mon, Feb 10, 2020 at 10:53:34AM +0100, Thomas Monjalon wrote:
> The header file rte_config.h is always included by make or meson.
> If required in an exported API header file, it must be included
> in the public header file for external applications.
> In the internal files, explicit include of
On 2019-11-09 04:01, Zhang, Qi Z wrote:
>
>> -Original Message-
>> From: Thomas Monjalon
>> Sent: Saturday, November 9, 2019 3:49 AM
>> To: Kevin Traynor
>> Cc: Zhang, Xiao ; dev@dpdk.org; Xing, Beilei
>> ; Zhang, Qi Z ; Stokes, Ian
>> ; sta...@dpdk.org; Andrew Rybchenko
>> ; Yigit, Ferru
On 2/9/2020 5:02 PM, Viacheslav Ovsiienko wrote:
> The testpmd application in txonly forwarding mode has an option
> to generate the packet flows by varying the destination IP address.
> The patch increments the IP for each packet sent, this improves
> the entropy and RSS distibution on the peer re
> -Original Message-
> From: Aaron Conole
> Sent: Tuesday, February 4, 2020 2:51 PM
> To: David Marchand
> Cc: Van Haaren, Harry ; dev
> Subject: Re: [RFC] service: stop lcore threads before 'finalize'
>
> David Marchand writes:
>
> > On Fri, Jan 17, 2020 at 9:17 AM David Marchand
> >
Hi Somnath,
Reformating the mails, to keep with the inner-posting (mixing top-posting and
inner-posting
makes it hard to follow). See the end of the mail.
On Wed, Feb 5, 2020 at 2:47 PM Gaetan Rivet wrote:
On 05/02/2020 09:52, Somnath Kotur wrote:
Hello Gaetan,
On Tue, Feb 4, 2020 at 3:
On Mon, Feb 10, 2020 at 3:16 PM Van Haaren, Harry
wrote:
> I haven't easily reproduced this yet - so I'll investigate a way to
> reproduce with close to 100% rate, then we can identify the root cause
> and actually get a clean fix. If you have pointers to reproduce easily,
> please let me know.
-
On Tue, Feb 4, 2020 at 9:32 PM Gaetan Rivet wrote:
>
> On 04/02/2020 16:06, Thomas Monjalon wrote:
> > 04/02/2020 13:43, Gaetan Rivet:
> >> On 04/02/2020 12:07, Thomas Monjalon wrote:
> >>> 04/02/2020 11:03, Gaetan Rivet:
> On 03/02/2020 23:21, Thomas Monjalon wrote:
> > 03/02/2020 06:16,
On 10/02/2020 15:34, Gaetan Rivet wrote:
Hi Somnath,
Reformating the mails, to keep with the inner-posting (mixing top-posting and
inner-posting
makes it hard to follow). See the end of the mail.
[...]
Any updates on this ?
My thoughts on this are just as I'd suspected / suggested earlier
From: Viacheslav Ovsiienko
> To provide the better PCIe bandwidth utilization the ConnectX-4LX NIC
> supports the multi-packet write (MPW) sessions allowing to pack multiple
> packets into one descriptor (WQE). This is legacy feature and it has some
> limitations on the packets and data descript
10/02/2020 15:51, Jerin Jacob:
> On Tue, Feb 4, 2020 at 9:32 PM Gaetan Rivet wrote:
> >
> > On 04/02/2020 16:06, Thomas Monjalon wrote:
> > > 04/02/2020 13:43, Gaetan Rivet:
> > >> On 04/02/2020 12:07, Thomas Monjalon wrote:
> > >>> 04/02/2020 11:03, Gaetan Rivet:
> > On 03/02/2020 23:21, Tho
Almost all usages of __attribute__ keyword are replaced
by a macro (existing or new) with prefix __rte_.
It makes code more consistent and will help changing
compiler behaviour, or adapting to new compilers,
in a central place.
Kernel and BPF files cannot use macros from rte_common.h.
Some rare at
There is a macro RTE_FINI for destructors,
which is now used where appropriate for consistency.
The destructor function mlx5_pmd_socket_uninit does not need
to be declared separately in mlx5.h.
Signed-off-by: Thomas Monjalon
---
drivers/net/mlx5/mlx5.h| 1 -
drivers/net/mlx5/mlx5_socket
There is a macro RTE_INIT for constructors,
which is now used where appropriate for consistency.
Signed-off-by: Thomas Monjalon
---
app/test-bbdev/main.h | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/app/test-bbdev/main.h b/app/test-bbdev/main.h
index 23b4d58a53..836f6d6e
The macros RTE_MARKER and __rte_cache_aligned can be used
for consistency for describing MEMIF_CACHELINE_ALIGN_MARK.
Signed-off-by: Thomas Monjalon
---
drivers/net/memif/memif.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/net/memif/memif.h b/drivers/net/memif/memi
The keyword alignas can be replaced with __rte_aligned macro
for consistency and allow compilers compatibility control.
The macro __rte_cache_aligned is a shortcut including __rte_aligned
and RTE_CACHE_LINE_SIZE constant.
Signed-off-by: Thomas Monjalon
---
drivers/common/mlx5/mlx5_glue.c | 4 ++
There is a macro __rte_noinline, preventing function to be inlined,
which is now used where appropriate for consistency.
Signed-off-by: Thomas Monjalon
---
drivers/common/dpaax/compat.h | 2 +-
drivers/net/dpaa2/dpaa2_rxtx.c | 4 ++--
lib/librte_eal/common/include/rte_co
There is a macro __rte_always_inline, forcing functions to be inlined,
which is now used where appropriate for consistency.
Signed-off-by: Thomas Monjalon
---
app/test-eventdev/test_order_atq.c | 2 +-
app/test-eventdev/test_order_common.h | 4 ++--
app/test-eventdev/test_
There is a common macro __rte_aligned for alignment,
which is now used where appropriate for consistency.
Signed-off-by: Thomas Monjalon
---
drivers/bus/dpaa/base/qbman/qman.c | 2 +-
drivers/bus/dpaa/include/fsl_bman.h | 2 +-
drivers/bus/dpaa/include/fsl_qman.h
The new macro __rte_cold, for compiler hinting,
is now used where appropriate for consistency.
Signed-off-by: Thomas Monjalon
---
drivers/net/bnxt/bnxt_rxtx_vec_sse.c | 2 +-
drivers/net/fm10k/fm10k_ethdev.c | 4 +-
drivers/net/fm10k/fm10k_rxtx_vec.c | 12 ++---
drivers
The new macro __rte_used, forcing symbol to be generated,
is now used where appropriate for consistency.
Signed-off-by: Thomas Monjalon
---
lib/librte_eal/common/eal_common_options.c | 2 +-
lib/librte_eal/common/include/rte_common.h | 5 +
lib/librte_eal/common/inc
The new macro __rte_hot, for compiler hinting,
is now used where appropriate for consistency.
Signed-off-by: Thomas Monjalon
---
drivers/common/cpt/cpt_common.h | 4 --
drivers/common/cpt/cpt_ucode.h| 2 +-
drivers/common/cpt/cpt_ucode_asym.h | 4 +-
dr
The keyword __attribute__ will emit a warning,
because it is preferred to use or define a common __rte macro.
The centralized macros may help to control or workaround some compilers.
Signed-off-by: Thomas Monjalon
---
devtools/checkpatches.sh | 8
1 file changed, 8 insertions(+)
diff -
The new macro __rte_noreturn, for compiler hinting,
is now used where appropriate for consistency.
Signed-off-by: Thomas Monjalon
---
doc/guides/sample_app_ug/flow_classify.rst | 2 +-
doc/guides/sample_app_ug/l3_forward_power_man.rst | 2 +-
doc/guides/sample_app_ug/performan
The new macro __rte_format_printf, for compiler hinting,
is now used where appropriate for consistency.
Signed-off-by: Thomas Monjalon
---
lib/librte_cmdline/cmdline.h| 3 ++-
lib/librte_eal/common/include/rte_common.h | 8 +++-
lib/librte_eal/common/include/rte_debug.h |
On Mon, Feb 10, 2020 at 8:57 PM Thomas Monjalon wrote:
>
> 10/02/2020 15:51, Jerin Jacob:
> > On Tue, Feb 4, 2020 at 9:32 PM Gaetan Rivet wrote:
> > >
> > > On 04/02/2020 16:06, Thomas Monjalon wrote:
> > > > 04/02/2020 13:43, Gaetan Rivet:
> > > >> On 04/02/2020 12:07, Thomas Monjalon wrote:
> >
In current version, we are setting the ports
using portmask. With portmask, we can use only
upto 64 ports. This portlist option enables the user
to use more than 64 ports.
Now we can specify the ports in 2 different ways
- Using portmask (-p [0x]nnn): mask must be in hex format
- Using portlist i
Hi, Sorry for late response.
Yes this is the enhancement for powerpc. Observations on our power8/9
the __ppc_get_timebase calls __builtin_ppc_get_timebase () which is
result in calling the mftb instruction
__ppc_get_timebase():
mftb rA
this instruction on a 64-bit implementation cop
On 2/10/20 8:20 AM, Thomas Monjalon wrote:
There is a common macro __rte_aligned for alignment,
which is now used where appropriate for consistency.
Signed-off-by: Thomas Monjalon
Reviewed-by: David Christensen
On 2/10/20 8:20 AM, Thomas Monjalon wrote:
The new macro __rte_cold, for compiler hinting,
is now used where appropriate for consistency.
Signed-off-by: Thomas Monjalon
Reviewed-by: David Christensen
Fixes: edd2fafbc0b8 ("kni: allocate memory dynamically for each device")
Cc: iryz...@nfware.com
Cc: sta...@dpdk.org
Signed-off-by: Scott Wasson
---
lib/librte_kni/rte_kni.c | 14 +++---
1 files changed, 7 insertions(+), 7 deletions(-)
diff --git a/lib/librte_kni/rte_kni.c b/lib/librte
On 2/6/2020 7:14 PM, Pallavi Kadam wrote:
> This patchset includes additional functionalities for Windows EAL
> to support command-line parsing feature and some EAL common code
> on Windows.
>
> This patchset can be applied to windpdk-next-dev branch in the draft repo.
>
> v8 changes:
> Fixed
On 2/10/20 8:20 AM, Thomas Monjalon wrote:
> There is a macro RTE_INIT for constructors, which is now used where
> appropriate for consistency.
>
> Signed-off-by: Thomas Monjalon
Acked-by: Nic Chautru
On 2/6/2020 7:14 PM, Pallavi Kadam wrote:
> This patchset includes additional functionalities for Windows EAL
> to support command-line parsing feature and some EAL common code
> on Windows.
>
> This patchset can be applied to windpdk-next-dev branch in the draft repo.
>
> v8 changes:
> Fixed
The libibverbs (and libmlx4/5) can be statically embedded
in the shared PMD library, or in the application with the static PMD.
It was supported with make build system in
commit 2c0dd7b69fb0 ("config: add static linkage of mlx dependency").
The same feature is enabled with meson when using pkg-con
The shell script options-ibverbs-static.sh was used with make
in forcing static linkage of ibverbs libraries.
When choosing to link with a static dependency in meson,
the generated .pc file will not force such static linkage.
The solution will rely on using this script in meson.
If linking with l
If ibverbs_link is static and the application choose to link DPDK
as static libraries, both PMD and ibverbs libraries must be linked
as static libraries. And the dependencies of ibverbs (netlink) must
still be linked as shared libraries.
Unfortunately, meson forget about the static requirement for
This is the follow-up of the feature I added one year ago:
static linkage of libibverbs in mlx PMDs.
The first implementation was focused on "make".
This second round does the same with "meson".
With the meson option ibverbs_link, only the mode "shared"
was working correctly.
This patchset adds th
If ibverbs_link is dlopen, the PMD and application should not
be linked with ibverbs, but the glue library is.
Unfortunately the ibverbs dependency was exported in the
variable ext_deps, so there were overlinking.
It is fixed by not exporting the dependency in ext_deps,
and recreating a limited de
The name of the variable pmd_dlopen is confusing because
it can be understood as true if the PMD is dlopen,
whereas it means the ibverbs glue layer is a dlopen library.
That's why it is renamed dlopen_ibverbs.
Signed-off-by: Thomas Monjalon
---
drivers/common/mlx5/meson.build | 8
drive
Fix the time of check time of use warning in example code.
Ignore the errno of unlink failure. There are two situations.
The first one is that file doesn't exist the unlink fails and
it's ok to ignore. The second one is that unlink fails to remove
file but the next bind() would fail too.
Coverity
On 02/06, Haiyue Wang wrote:
>The new symbols should be in ABI version 20.0.1.
>
>Fixes: 89214fe915b8 ("net/iavf/base: move to drivers common directory")
>
>Signed-off-by: Haiyue Wang
>---
> drivers/common/iavf/rte_common_iavf_version.map | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
>d
Hi, Gavin
Please help add the Fixes tag and cc stable.
Thanks,
Xiaolong
On 02/08, Gavin Hu wrote:
>To keep ordering of mixed accesses, rte_cio is sufficient.
>The rte_io barrier is overkill.[1]
>
>[1] http://inbox.dpdk.org/dev/CALBAE1M-ezVWCjqCZDBw+MMDEC4O9
>qf0kpn89emdgdajepk...@mail.gmail.com
Subject is too long, should be something like:
doc: split recommended mapping table
On 02/04, Chen, Zhaoyan wrote:
>Split recommended mapping table for X710/XL710/XXV710 and X722,
>since they have different firmware version.
>
>Signed-off-by: Chen, Zhaoyan
DPDK convention for the SoB should be:
On Mon, Feb 10, 2020 at 8:04 PM Gaetan Rivet wrote:
>
> Hi Somnath,
>
> Reformating the mails, to keep with the inner-posting (mixing top-posting and
> inner-posting
> makes it hard to follow). See the end of the mail.
>
>
> >> On Wed, Feb 5, 2020 at 2:47 PM Gaetan Rivet wrote:
> >>>
> >>> On 05
This patch fixes (Logically dead code ) coverity issue.
Coverity issue: 353624
Fixes: ba7b12dd64e4 ("net/ixgbe: fix link up in FreeBSD")
Signed-off-by: Shougang Wang
---
drivers/net/ixgbe/ixgbe_ethdev.c | 11 ++-
1 file changed, 6 insertions(+), 5 deletions(-)
diff --git a/drivers/net/
66 matches
Mail list logo