Wednesday, April 18, 2018 9:43 AM, Nélio Laranjeiro:
> Subject: Re: [dpdk-dev] [PATCH 1/2] net/mlx5: fix alignment of Memory
> Region
>
> On Tue, Apr 17, 2018 at 11:39:13AM -0700, Yongseok Koh wrote:
> > The memory region is [start, end), so if the memseg of 'end' isn't
> > allocated yet, the retu
Friday, April 13, 2018 6:01 PM, Xueming Li:
> Subject: [dpdk-dev] [PATCH] net/mlx5: fix invalid flow item check
>
> This patch fixed invalid flow item check.
>
> Fixes: 4f1a88e3f9b0 ("net/mlx5: standardize on negative errno values")
> Cc: nelio.laranje...@6wind.com
>
> Signed-off-by: Xueming Li
Hi Konstantin
From: Ananyev, Konstantin, Tuesday, April 17, 2018 2:00 PM
> Hi Matan,
> > Hi Konstantin
> > From: Ananyev, Konstantin, Tuesday, April 17, 2018 12:23 PM
> > > > Actually you say that the whitelist\blacklist mechanism is not
> > > > good enough
> > > and the binding workarounds it.
>
Prior to this commit IP/UDP/TCP checksum offload calculations
were skipped in case of a multi segments packet.
This commit enables TAP checksum calculations for multi segments
packets.
The only restriction is that the first segment must contain
headers of layers 3 (IP) and 4 (UDP or TCP)
Signed-of
v1:
- Initial release
v2:
- Fixing cksum errors
- TCP segment size refers to TCP payload size (not including l2,l3,l4 headers)
This patch implements TAP TSO (TSP segmentation offload) in SW.
It uses dpdk library librte_gso.
Dpdk librte_gso library segments large TCP payloads (e.g. 64K bytes)
int
This commit implements TCP segmentation offload in TAP.
librte_gso library is used to segment large TCP payloads (e.g. packets
of 64K bytes size) into smaller MTU size buffers.
By supporting TSO offload capability in software a TAP device can be used
as a failsafe sub device and be paired with anot
Hi Ferruh:
> -Original Message-
> From: Yigit, Ferruh
> Sent: Friday, April 20, 2018 7:30 PM
> To: Zhang, Qi Z ; tho...@monjalon.net; Ananyev,
> Konstantin
> Cc: dev@dpdk.org; Xing, Beilei ; Wu, Jingjing
> ; Lu, Wenzhuo
> Subject: Re: [dpdk-dev] [PATCH v6 2/3] app/testpmd: add command fo
From: Qi Zhang
v7:
- update default.ini and i40e.ini.
- rename runtime_queue_setup_capa to dev_capa for generic.
- testpmd queue setup command be moved to "ports" command group.
- remove ring_size and offload from queue setup command in testpmd.
- enable per queue config in testpmd.
- enable que
It's not possible to setup a queue when the port is started
because of a check in ethdev layer. New capability flags are
added in order to relax this check for devices which support
queue setup in runtime. The functions rte_eth_[rx|tx]_queue_setup
will raise an error only if the port is started and
Add command to change specific queue's ring size configure,
the new value will only take effect after command that restart
the device(port stop /port start ) or command
that setup the queue(port rxq setup) at runtime.
Signed-off-by: Qi Zhang
---
app/test-pmd/cmdline.c | 10
Each queue has independent configure information in rte_port.
Base on this, we are able to add new commands to configure
different queues with different value.
Signed-off-by: Qi Zhang
---
app/test-pmd/cmdline.c | 8 ++--
app/test-pmd/config.c | 48 ++-
app/test-pmd/testpm
Add new command to setup queue, rte_eth_[rx|tx]_queue_setup will
be called corresponsively.
Signed-off-by: Qi Zhang
---
v7:
- remove ring_size and offload paramters and move to "ports" commmand
group.
v6:
- fix error message for rx_free_thresh check.
v5:
- fix command description.
v4:
- fix
From: Qi Zhang
Expose the runtime queue configuration capability and enhance
i40e_dev_[rx|tx]_queue_setup to handle the situation when
device already started.
Signed-off-by: Qi Zhang
Acked-by: Konstantin Ananyev
---
v7:
- update i40e.ini
v5:
- fix first tx queue check.
v4:
- fix rx/tx conf
Large TCP packets which are marked with PKT_TX_TCP_SEG flag are
segmented and the flag is cleared in the resulting segments, however,
the segments checksum is not updated. It is therefore required to set
the PKT_TX_TCP_CKSUM flag in each TCP segment in order to mark for the
sending driver the need
Hello Jiayu,
I wonder why librte_gso only supports TCP GSO above IPv4.
Can you please explain why TCP GSO is not supported above IPv6?
Are there plans to support it?
Regards,
Ophir
Hi Ferruh, Thomas,
Please note that this patch should be merged before the net/tap TSO patches:
https://dpdk.org/dev/patchwork/patch/38666/
https://dpdk.org/dev/patchwork/patch/38667/
Regards,
Ophir
> -Original Message-
> From: Ophir Munk
> Sent: Sunday, April 22, 2018 5:21 PM
> To: dev@
Hi Ferruh,
I am not able to apply your patch on next-net/master branch.
I am failing to apply it both on latest commit or just before 22-Mar-18
(commit's date).
$ git am dpdk-dev-net-tap-remove-queue-specific-offload-support.patch
Applying: net/tap: remove queue specific offload support
error: p
Hi Pavan,
The patchset http://dpdk.org/ml/archives/dev/2018-April/094928.html is causing
a compilation error on QUALCOMM ARM with RHEL7.5 and gcc version 4.8.5:
"""
/download/dpdk-next-net-mlx/drivers/event/octeontx/timvf_worker.c: In function
'timvf_timer_arm_burst_sp':
/download/dpdk-next-net
Hi,
19/03/2018 13:23, Ravi Kumar:
> --- a/config/common_base
> +++ b/config/common_base
> @@ -529,6 +529,11 @@ CONFIG_RTE_LIBRTE_PMD_CRYPTO_SCHEDULER_DEBUG=n
> CONFIG_RTE_LIBRTE_PMD_NULL_CRYPTO=y
>
> #
> +# Compile PMD for AMD CCP crypto device
> +#
> +CONFIG_RTE_LIBRTE_PMD_CCP=n
Why is it di
Hi,
I am doing some late comments because I have a quick look when trying
to pull next-crypto in master branch.
Unfortunately, it doesn't met the basic quality criterias.
19/03/2018 13:23, Ravi Kumar:
> Signed-off-by: Ravi Kumar
> ---
> config/common_base | 1 +
> drivers/c
Hi,
04/04/2018 16:05, KamilX Chalupnik:
> From: "Chalupnik, KamilX"
The above line will appear as the author name in Git.
Please make sure it is the same as the Signed-off-by line.
Usually, we use FirstName LastName, without any comma.
> Update the documentation describing Wireless Basband Dev
From: Shahed Shaikh
This change adds a new option to "port config" command to
add udp tunnel port for VXLAN and GENEVE tunneling protocols.
This command can be extended for other tunneling protocols
listed in "enum rte_eth_tunnel_type" as and when needed.
usage:
port config udp_tunnel_port add|
Hi Zijie,
21/03/2018 12:06, Zijie Pan:
> +/*
> + * Placeholder for accessing plugin module eeprom
> + */
I think you missed a "*" to make it a doxygen comment.
> +struct rte_dev_module_info {
> + uint32_t type; /**< Type of plugin module eeprom */
> + uint32_t eeprom_len; /**< Length of
12/04/2018 19:27, Ferruh Yigit:
> On 3/28/2018 12:16 PM, Matan Azrad wrote:
> > Ethernet devices which are grouped by bonding PMD, aka slaves, are
> > sharing the same queues and RSS configurations and their Rx burst
> > functions must be managed by the bonding PMD according to the bonding
> > arch
21/03/2018 00:20, Gaetan Rivet:
> Introduce new rte_devargs accessor allowing to iterate over all
> rte_devargs pertaining to a bus.
This patch can be merged with previous one.
21/03/2018 00:20, Gaetan Rivet:
> Initially, rte_devargs was meant to be populated once and sometimes
> accessed, then never emptied.
>
> With the new hotplug functionality having better standing, new usage
> appeared with repeated addition of devices and their subsequent removal.
>
> Exposing de
21/03/2018 00:20, Gaetan Rivet:
> /**
> * Add a device to the user device list
> *
> - * For PCI devices, the format of arguments string is "PCI_ADDR" or
> - * "PCI_ADDR,key=val,key2=val2,...". Examples: "08:00.1", ":5:00.0",
> - * "04:00.0,arg=val".
> + * The format is
> *
> - * For vir
21/03/2018 00:20, Gaetan Rivet:
> Cleanup the rte_devargs API.
>
> This is a continuous process.
> The previous version of this patchset was dependent on changes
> on the PCI bus and the rte_bus library. Not all these changes were
> integrated. This patchset has thus been limited to elements that
28/03/2018 13:17, Neil Horman:
> On Wed, Mar 28, 2018 at 10:10:07AM +0200, Gaëtan Rivet wrote:
> > On Tue, Mar 27, 2018 at 07:53:46PM -0400, Neil Horman wrote:
> > > On Tue, Mar 27, 2018 at 08:48:01PM +, Richardson, Bruce wrote:
> > > > From: Gaëtan Rivet [mailto:gaetan.ri...@6wind.com]
> > > >
15/04/2018 17:07, Gaetan Rivet:
> This patchset introduces a new EAL API for querying devices,
> filtered by arbitrary properties.
>
> The following elements are introduced to this end:
>
> * A new object, "rte_class", is used to describe
>the device class abstraction layer (eth, crypto, ...
Wenzhuo, Declan,
Any comment or ack, please?
28/03/2018 13:17, Matan Azrad:
> Testpmd allows to create and control bonding devices by run time
> command lines using the bonding PMD API.
>
> Some bonding device slaves operations(close, stop, etc) should not be
> used by the application and must be
12/03/2018 18:53, Ferruh Yigit:
> Which per port offloads are enabled is not clear. Printing offloads
> values at forwarding start.
>
> CRC strip offload value was printed in more verbose manner, it is
> removed since Rx/Tx offload values covers it and printing only CRC one
> can cause confusion.
This patch has been forgotten.
Review please?
24/02/2018 04:26, Jianfeng Tan:
> In some cases, we don't want to lock all memory.
>
> Add an option --no-mlockall to avoid lock all memory.
>
> Cc: wenzhuo...@intel.com
> Cc: jingjing...@intel.com
>
> Signed-off-by: Jianfeng Tan
> > In case of application build with shared library mode unless option '-d' is
> > passed, poll mode driver for devices is not initialized. Notifying the user
> > just
> > after rte_eal_init is pro active way of intimating the user.
> >
> > Signed-off-by: Vipin Varghese
> > ---
> > + if (rte_
28/02/2018 18:11, Bruce Richardson:
> When building using make, the Makefile in the build directory contained
> the name of the build directory to be passed as an "O=" parameter to
> the DPDK SDK makefiles. Unfortunately, this meant that the compilation
> would always fail if the build directory wa
10/04/2018 17:44, David Hunt:
> On FreeBSD, make defconfig generates the config as "defconfig_x86_64-bsdapp-",
> which does not resolve to any known config file.
>
> This fix starts by introducing a 'compiler' variable which is set by executing
> "${CC} --version" and pulling out the name of the c
09/04/2018 10:51, Kovacevic, Marko:
> > Signed-off-by: Jerin Jacob
> > ---
> > doc/guides/prog_guide/rawdev.rst | 2 +-
> > 1 file changed, 1 insertion(+), 1 deletion(-)
>
> Acked-by: Marko Kovacevic
Applied, thanks
22/04/2018 05:03, Rami Rosen:
> This patch fixes a trivial typo in the programmer's guide.
>
> Fixes: 1733be6d3147 ("doc: new eal multi-pthread feature")
>
> Signed-off-by: Rami Rosen
Applied, thanks
22/04/2018 05:03, Rami Rosen:
> This patch fixes a trivial typo in the programmer's guide.
>
> Fixes: 1733be6d3147 ("doc: new eal multi-pthread feature")
>
> Signed-off-by: Rami Rosen
Applied, thanks
20/04/2018 11:34, Pavan Nikhilesh:
> Fixes: 26cb0a72412f ("doc: add octeontx platform guide")
> Fixes: 48191dde6acf ("doc: add octeontx mempool guide")
>
> Signed-off-by: Pavan Nikhilesh
> Acked-by: Marko Kovacevic
Applied, thanks
20/04/2018 12:31, Nipun Gupta:
> Signed-off-by: Nipun Gupta
> ---
> doc/guides/rel_notes/release_18_05.rst | 8
> 1 file changed, 8 insertions(+)
Please merge this patch in the previous one.
> +* **Added DPAA2 QDMA Driver (in rawdev).**
> +
> + The DPAA2 QDMA is an implementation of t
20/04/2018 12:30, Nipun Gupta:
> This patch set introduces DPAA2 based QDMA device driver.
>
> It provide means to initiate a DMA transaction from CPU.
> The initiated DMA is performed without CPU being involved
> in the actual DMA transaction.
3 comments:
1/ Please compile this driver with meso
There was no review or ack for this patch.
It will be merged soon if no comment.
29/01/2018 11:29, Olivier Matz:
> The code to convert IPv4 and IPv6 address strings into a binary format
> (inet_ntop) was included in the cmdline library because the DPDK was
> historically compiled in environments w
Hi Ophir,
Comparing with IPv6, IPv4 is used more widely used and more popular.
Therefore, when proposed the GSO library, we just planned to support
IPv4.
Do you have any usage scenarios that depend on IPv6?
Thanks,
Jiayu
> -Original Message-
> From: Ophir Munk [mailto:ophi...@mellanox.co
Fix logical/alphabetical ordering, spacing, and syntax typo.
Fixes: 8fb3b2576025 ("maintainers: call out subtree committers")
Cc: pablo.de.lara.gua...@intel.com
Signed-off-by: Thomas Monjalon
---
MAINTAINERS | 48 +---
1 file changed, 25 insertions(+)
Hi,
Please find an update of the release status, inline below.
13/04/2018 00:01, Thomas Monjalon:
> The integration deadline is passed by one week, and the first
> release candidate is still far from being ready.
> This time it is really, really late.
> We will try to do this RC1 on the 20th of A
Hi Ophir,
In the GSO design, the GSO library doesn't care about checksums, which
means it doesn't check if input packets have correct checksums, and it
doesn't do any checksum related work for the output GSO segments. It
depends on the callers to use HW or SW checksum calculation for output
packet
>-Original Message-
>From: Gujjar, Abhinandan S [mailto:abhinandan.guj...@intel.com]
>Sent: 20 April 2018 21:01
>To: Verma, Shally ; Jacob, Jerin
>; hemant.agra...@nxp.com;
>akhil.go...@nxp.com; dev@dpdk.org
>Cc: De Lara Guarch, Pablo ; Doherty, Declan
>; Vangati, Narender
>; Rao, Nikhi
Hi Pavan
In the recently merged patches, SPDX for few files is not on
first line. for e.g. "drivers/event/octeontx/timvf_worker.c"
/*
* SPDX-License-Identifier: BSD-3-Clause
* Copyright(c) 2017 Cavium, Inc
*/
Please fix that.
Regards,
Hemant
Tuesday, April 17, 2018 12:02 PM, Nelio Laranjeiro:
> Subject: [dpdk-dev] [PATCH v3 0/2] net/mlx5: fix flow director mask
>
> Flow director mask as been mistakenly removed from mlx5 PMD. This series
> brings it back.
>
> Changes in v3:
>
> Let flow API handle the mask from the user.
>
> Change
Hi Shally,
> -Original Message-
> From: Verma, Shally [mailto:shally.ve...@cavium.com]
> Sent: Monday, April 23, 2018 10:44 AM
> To: Gujjar, Abhinandan S ; Jacob, Jerin
> ; hemant.agra...@nxp.com;
> akhil.go...@nxp.com; dev@dpdk.org
> Cc: De Lara Guarch, Pablo ; Doherty, Declan
> ; Vangati
Hi Nelio,
Small comments before I merge.
Wednesday, April 18, 2018 4:50 PM, Nelio Laranjeiro:
> Subject: [dpdk-dev] [PATCH v2 3/3] net/mlx5: implement multicast add list
> devop
>
> Signed-off-by: Nelio Laranjeiro
> ---
> drivers/net/mlx5/mlx5.c | 2 ++
> drivers/net/mlx5/mlx5.h |
>On 4/18/2018 6:17 PM, Ferruh Yigit wrote:
>> On 4/17/2018 9:04 PM, Pavan Nikhilesh wrote:
>>> Due to missing cacheline_aligned definition compiler treats it as
>>> a global variable replace it with proper cache alignment macro.
>>>
>>> Fixes: 9e890103267e ("net/axgbe: add Rx/Tx setup")
>>>
>>
From: Qi Zhang
v4:
- Change to OpenFlow complied TTL actions
- Change to OpenFlow complied VLAN/MPLS actions.
- typos fix.
- Remove generic field_set action since, couple opens not closed (should we move
to dedicate filed modification actions?)
v3:
- remove patch for port action and enhanced
Add Openflow complied VLAN and MPLS actions.
RTE_FLOW_ACTION_OF_VLAN_POP - pop a VLAN header.
RTE_FLOW_ACTION_OF_VLAN_PUSH - push a VLAN header.
RTE_FLOW_ACTION_OF_VLAN_VID_SET - set VLAN id.
RTE_FLOW_ACTION_OF_VLAN_PCP_SET - set VLAN priority.
RTE_FLOW_ACTION_OF_MPLS_POP - pop a MPLS header.
RTE_
Add new protocol header match support as below
RTE_FLOW_ITEM_TYPE_ARP_IPV4
- matches an IPv4 ARP header
RTE_FLOW_ITEM_TYPE_IPV6_EXT
- matches an IPv6 extension header with any type.
RTE_FLOW_ITEM_TYPE_ICMP6
- matches an ICMPv6 header followed by any message body.
RTE_FLOW_I
Add OpenFlow complied TTL change actions.
RTE_FLOW_ACTIOn_OF_MPLS_TTL_SET - set MPLS TTL.
RTE_FLOW_ACTION_OF_MLPS_TTL_DEC - decrement MPLS TTL.
RTE_FLOW_ACTIOn_OF_IP_TTL_SET - set IP TTL.
RTE_FLOW_ACTION_OF_IP_TTL_DEC - decrement IP TTL.
RTE_FLOW_ACTION_OF_TTL_COPY_OUT - copy TTL outwards.
RTE_FLO
>Hi,
>
>19/03/2018 13:23, Ravi Kumar:
>> --- a/config/common_base
>> +++ b/config/common_base
>> @@ -529,6 +529,11 @@ CONFIG_RTE_LIBRTE_PMD_CRYPTO_SCHEDULER_DEBUG=n
>> CONFIG_RTE_LIBRTE_PMD_NULL_CRYPTO=y
>>
>> #
>> +# Compile PMD for AMD CCP crypto device # CONFIG_RTE_LIBRTE_PMD_CCP=n
>
>Why is
On 4/20/2018 6:44 PM, Jerin Jacob wrote:
-Original Message-
Date: Fri, 20 Apr 2018 17:04:36 +0530
From: Akhil Goyal
To: "Gujjar, Abhinandan S" ,
"jerin.ja...@caviumnetworks.com" ,
"hemant.agra...@nxp.com" , "dev@dpdk.org"
CC: "De Lara Guarch, Pablo" , "Doherty,
Declan" , "Vangati,
>Hi,
>
>I am doing some late comments because I have a quick look when trying to pull
>next-crypto in master branch.
>Unfortunately, it doesn't met the basic quality criterias.
>
>
>19/03/2018 13:23, Ravi Kumar:
>> Signed-off-by: Ravi Kumar
>> ---
>> config/common_base | 1 +
> -Original Message-
> From: Akhil Goyal [mailto:akhil.go...@nxp.com]
> Sent: Monday, April 23, 2018 12:09 PM
> To: Jerin Jacob
> Cc: Gujjar, Abhinandan S ;
> hemant.agra...@nxp.com; dev@dpdk.org; De Lara Guarch, Pablo
> ; Doherty, Declan
> ; Vangati, Narender
> ; Rao, Nikhil ; Eads, Gag
61 matches
Mail list logo