Re: [dpdk-dev] [PATCH] devtools: add script to find duplicated includes

2017-07-15 Thread Thomas Monjalon
14/07/2017 20:43, Wiles, Keith: > > On Jul 14, 2017, at 1:39 PM, Wiles, Keith wrote: > >> On Jul 14, 2017, at 12:07 PM, Thomas Monjalon wrote: > >> +cd $(dirname $(readlink -m $0))/.. > > > > I tried the script it works, but I am concerned about the ‘cd’ above as it > > does all of the the repo

[dpdk-dev] [PATCH] devtools: speed up maintainers check

2017-07-15 Thread Thomas Monjalon
There is a huge speed improvement when forcing Unicode to be disabled in this script. In my test, it is improved from 13s to 6s. Signed-off-by: Thomas Monjalon --- devtools/check-maintainers.sh | 3 +++ 1 file changed, 3 insertions(+) diff --git a/devtools/check-maintainers.sh b/devtools/check-

[dpdk-dev] [PATCH v2] devtools: add script to find duplicated includes

2017-07-15 Thread Thomas Monjalon
Based on Stephen's idea (originally implemented in a Perl script), this is a shell script to find duplicated includes in a file. It looks for all the .c and .h files of the git repository. It is fast enough because automatically well parallelized. Suggested-by: Stephen Hemminger Signed-off-by: T

Re: [dpdk-dev] [PATCH v2 3/4] cryptodev: rework PMD init to not require rte_vdev.h

2017-07-15 Thread De Lara Guarch, Pablo
Hi > -Original Message- > From: Jan Blunck [mailto:jblu...@gmail.com] On Behalf Of Jan Blunck > Sent: Wednesday, July 12, 2017 8:59 PM > To: dev@dpdk.org > Cc: Doherty, Declan ; De Lara Guarch, Pablo > > Subject: [PATCH v2 3/4] cryptodev: rework PMD init to not require > rte_vdev.h > > T

Re: [dpdk-dev] [PATCH v2 13/15] devargs: pass busname argument when parsing

2017-07-15 Thread Gaëtan Rivet
On Fri, Jul 14, 2017 at 05:12:11PM -0400, Jan Blunck wrote: > Let the rte_eal_devargs_parse() function explicitly take a "busname" > argument that is validated. > > Now that the busname is known and validated at parse time the validity of > the device name is checked for all device types when they

[dpdk-dev] [PATCH v4 1/8] vdev: implement plug operation

2017-07-15 Thread Gaetan Rivet
This method must be implemented to allow using a unified, generic API to hotplug devices, including virtual ones. VDEV devices actually exist unattached after performing a scan on the rte_devargs list. As such it makes sense to be able to perform a device hotplug afterward. Finally, missing this

[dpdk-dev] [PATCH v4 0/8] fix hotplug API

2017-07-15 Thread Gaetan Rivet
Sending those fixes as separate patches as they stand on their own. This series improves usability of the hotplug API and fixes a few issues with existing implementations. The hotplug API can be tested with the fail-safe PMD[1]. Its documentation describes how to declare slaves and how to use it.

[dpdk-dev] [PATCH v4 3/8] devargs: introduce insert function

2017-07-15 Thread Gaetan Rivet
Some buses will operate either in whitelist or blacklist mode. This mode is currently passed down by the rte_eal_devargs_add function with the devtype argument. When inserting devices using the hotplug API, the implicit assumption is that this device is being whitelisted, meaning that it is explic

[dpdk-dev] [PATCH v4 2/8] devargs: introduce removal function

2017-07-15 Thread Gaetan Rivet
Hotplug support introduces the possibility of removing devices from the system. Allocated resources must be freed. Extend the rte_devargs API to allow freeing allocated resources. This API is experimental and bound to change. It is currently designed as a symetrical to rte_eal_devargs_add(), but

[dpdk-dev] [PATCH v4 4/8] eal: fix hotplug add / remove

2017-07-15 Thread Gaetan Rivet
The hotplug API requires a few properties that were not previously explicitly enforced: - Idempotency, two consecutive scans should result in the same state. - Upon returning, internal devices are now allocated and available through the new `find_device` operator, meaning that they should

[dpdk-dev] [PATCH v4 5/8] pci: use given name as generic name

2017-07-15 Thread Gaetan Rivet
When an application requests the use of a PCI device, it can currently interchangeably use either the longform DomBDF format (:00:00.0) or the shorter BDF format (00:00.0). When a device is inserted via the hotplug API, it must first be scanned and then will be identified by its name using `fi

[dpdk-dev] [PATCH v4 8/8] bus: remove useless plug parameter

2017-07-15 Thread Gaetan Rivet
The prior scan should link the relevant rte_devargs to the newly allocated rte_device. As such, it is useless to pass device arguments to the plug callback. Those arguments are available within the devargs field of the rte_device structure. Fixes: 7c8810f43f6e ("bus: introduce device plug/unplug")

[dpdk-dev] [PATCH v10 00/11] introduce fail-safe PMD

2017-07-15 Thread Gaetan Rivet
This PMD intercepts and manages Ethernet device removal events issued by slave PMDs and re-initializes them transparently when brought back so that existing applications do not need to be modified to benefit from true hot-plugging support. The stacked PMD approach shares many similarities with the

[dpdk-dev] [PATCH v4 6/8] pci: fix generic driver pointer on probe error

2017-07-15 Thread Gaetan Rivet
The field is set but never resetted on error. This marks the device as being attached while it is not, and forbid further attempts to hotplug it. Fixes: 7917d5f5ea46 ("pci: initialize generic driver pointer") Cc: sta...@dpdk.org Signed-off-by: Gaetan Rivet --- lib/librte_eal/common/eal_common_p

[dpdk-dev] [PATCH v4 7/8] pci: fix hotplug operations

2017-07-15 Thread Gaetan Rivet
The device handle is already known and does not have to be infered from the PCI address. The relevant helpers are already available within the PCI bus to avoid searching for a handle already known. Additionally, rte_memcpy.h was erroneously included. Fixes: 00e62aae69c0 ("bus/pci: implement plug/

[dpdk-dev] [PATCH v10 02/11] ethdev: count devices consistently

2017-07-15 Thread Gaetan Rivet
Make the rte_eth_dev_count() return the number of available devices even after some are detached by the hotplug API or put in a deferred state. Signed-off-by: Gaetan Rivet --- lib/librte_ether/rte_ethdev.c | 16 +--- lib/librte_ether/rte_ethdev.h | 13 ++--- 2 files changed,

[dpdk-dev] [PATCH v10 01/11] ethdev: add deferred intermediate device state

2017-07-15 Thread Gaetan Rivet
This device state means that the device is managed externally, by whichever party has set this state (PMD or application). Note: this new device state is only an information. The related device structure and operators are still valid and can be used normally. It is however made private by device

[dpdk-dev] [PATCH v10 04/11] net/failsafe: add plug-in support

2017-07-15 Thread Gaetan Rivet
Periodically check for the existence of a device. If a device has not been initialized and exists on the system, then it is probed and configured. The configuration process strives to synchronize the states between the plugged-in sub-device and the fail-safe device. Signed-off-by: Gaetan Rivet A

[dpdk-dev] [PATCH v10 03/11] net/failsafe: add fail-safe PMD

2017-07-15 Thread Gaetan Rivet
Introduce the fail-safe poll mode driver initialization and enable its build infrastructure. This PMD allows for applications to benefit from true hot-plugging support without having to implement it. It intercepts and manages Ethernet device removal events issued by slave PMDs and re-initializes

[dpdk-dev] [PATCH v10 05/11] net/failsafe: add flexible device definition

2017-07-15 Thread Gaetan Rivet
Add the "exec" device type. The parameters given to this type of device will be executed in a shell. The output of this command is then used as a definition for a device. That command can be re-interpreted if the related device is not plugged-in. It allows for a device definition to react to syste

[dpdk-dev] [PATCH v10 06/11] net/failsafe: support flow API

2017-07-15 Thread Gaetan Rivet
Signed-off-by: Gaetan Rivet Acked-by: Olga Shern --- doc/guides/nics/features/failsafe.ini | 1 + drivers/net/failsafe/Makefile | 1 + drivers/net/failsafe/failsafe.c | 1 + drivers/net/failsafe/failsafe_eal.c | 1 + drivers/net/failsafe/failsafe_ether.c | 70 +

[dpdk-dev] [PATCH v10 07/11] net/failsafe: support offload capabilities

2017-07-15 Thread Gaetan Rivet
Signed-off-by: Gaetan Rivet Acked-by: Olga Shern --- doc/guides/nics/features/failsafe.ini | 6 ++ drivers/net/failsafe/failsafe_ops.c | 131 +- 2 files changed, 135 insertions(+), 2 deletions(-) diff --git a/doc/guides/nics/features/failsafe.ini b/doc/guide

[dpdk-dev] [PATCH v10 11/11] net/failsafe: support flow API isolation mode

2017-07-15 Thread Gaetan Rivet
Signed-off-by: Gaetan Rivet --- drivers/net/failsafe/failsafe_ether.c | 34 +++-- drivers/net/failsafe/failsafe_flow.c| 29 drivers/net/failsafe/failsafe_private.h | 4 3 files changed, 65 insertions(+), 2 deletions(-) diff --g

[dpdk-dev] [PATCH v10 08/11] net/failsafe: add fast burst functions

2017-07-15 Thread Gaetan Rivet
Signed-off-by: Gaetan Rivet Acked-by: Olga Shern --- drivers/net/failsafe/failsafe_private.h | 8 +++ drivers/net/failsafe/failsafe_rxtx.c| 123 ++-- 2 files changed, 111 insertions(+), 20 deletions(-) diff --git a/drivers/net/failsafe/failsafe_private.h b/dri

[dpdk-dev] [PATCH v10 09/11] net/failsafe: support device removal

2017-07-15 Thread Gaetan Rivet
Listen to INTR_RMV events issued by slaves. Add atomic flags on slave queues to detect use of slave bursts function. If a removal is detected, set the recollection flag on this slave. During a slave upkeep round, if its recollection flag is set and its burst functions are not in use by any thread,

[dpdk-dev] [PATCH v10 10/11] net/failsafe: support link status change event

2017-07-15 Thread Gaetan Rivet
Signed-off-by: Gaetan Rivet --- doc/guides/nics/features/failsafe.ini | 1 + drivers/net/failsafe/failsafe.c | 1 + drivers/net/failsafe/failsafe_ether.c | 18 ++ drivers/net/failsafe/failsafe_ops.c | 23 +++ drivers/net/failsafe/failsafe_priv

[dpdk-dev] [PATCH] devargs: restore rte_devtype API

2017-07-15 Thread Gaetan Rivet
Revert "devargs: make device types generic" This commit broke the rte_devargs API by changing the meaning of the rte_devtype enum. Restore the previous API, unit tests and function calls. Introduce parallel enum that acts as translation between previous API and current structures. Restoring the

Re: [dpdk-dev] [PATCH v2 00/15] devargs fixes

2017-07-15 Thread Thomas Monjalon
14/07/2017 23:11, Jan Blunck: > The changes to enum rte_devtype that got merged into 17.08-rc1 are breaking > API without prior notice. This series is reworking the rte_devargs changes > in a way hopefully compliant to the new failover PMD and still keeping API > compatible with earlier releases. >

Re: [dpdk-dev] [PATCH v2] igb_uio: issue FLR during open and release of device file

2017-07-15 Thread Gregory Etelson
Hello Shijith, Please add the patch to uio_pci_generic.c file in Linux kernel We experience similar faults with NVMe devices On Wednesday, 12 July 2017 06:40:55 IDT Tan, Jianfeng wrote: > > > -Original Message- > > From: Shijith Thotton [mailto:shijith.thot...@caviumnetworks.com] > > S