Using explicit enum instead of ambiguous integer value
Signed-off-by: Nicolas Chautru
---
app/test-bbdev/test_bbdev_perf.c | 16 -
app/test-bbdev/test_bbdev_vector.c | 16 -
drivers/baseband/acc100/rte_acc100_pmd.c | 42 +++-
Minor change suggested by Tom Rix in earlier review.
Avoiding magic number for code_block_mode and use explicit enum at bbdev level.
PMDs updated in same commit.
Nicolas Chautru (1):
bbdev: adding explicit enum for code block mode
app/test-bbdev/test_bbdev_perf.c | 16 --
On 2/19/2021 5:25 PM, Kathleen Capella wrote:
The iol-testing warning on this patch seems to be unrelated to the patch.
Yep, it looks unrelated, spdk build is failing, I tried to trigger build again,
please check after some time if status changes.
On February 9, 2021 10:40 AM, Kathleen Cap
On 11/26/2020 2:46 PM, Elad Nachman wrote:
This patch leverages on Stephen Hemminger's 64106 patch from Dec 2019,
and fixes the issues reported by Ferruh and Igor:
A. KNI sync lock is being locked while rtnl is held.
If two threads are calling kni_net_process_request() ,
then the first one wil t
When file truncation fails, the log message attempts to print a path of
file we failed to truncate, but this path was never set to anything and,
what's worse, was uninitialized. Fix it by passing path from the caller.
Fixes: c44d09811b40 ("eal: add shared indexed file-backed array")
Cc: sta...@dpd
I have been without power and offline all week.
Will try and get back next week
On Mon, Nov 23, 2020, 2:19 PM Stephen Hemminger
wrote:
> When doing rte_eth_dev_get_supported_ptypes on netvsc device
> the values reported are incorrect if VF is not present.
>
> If no VF is present the device uses
The iol-testing warning on this patch seems to be unrelated to the patch.
On February 9, 2021 10:40 AM, Kathleen Capella wrote
> The tx_queue member of the fwd_lcore struct is unused as it is already part
> of the fwd_stream
> structure. Deleting helps improve code readability.
> Signed-off-by
The purpose of this patch is to update the l3fwd user guide to include
the changes proposed in this patchset.
Signed-off-by: Conor Walsh
---
doc/guides/sample_app_ug/l3_forward.rst | 103 ++--
1 file changed, 95 insertions(+), 8 deletions(-)
diff --git a/doc/guides/sample_ap
This patch implements the Forwarding Information Base (FIB) library
in l3fwd using the function calls and infrastructure introduced in
the previous patch.
Signed-off-by: Conor Walsh
---
examples/l3fwd/l3fwd_fib.c | 475 -
1 file changed, 469 insertions(+), 6 d
The purpose of this commit is to add the necessary function calls
and supporting infrastructure to allow the Forwarding Information Base
(FIB) library to be integrated into the l3fwd sample app.
The flag '-F' has been added to the applications options to allow
the user to specify that l3fwd uses FI
To prevent code duplication from the addition of lookup methods
the routes specified in lpm should be moved to a common header.
Signed-off-by: Conor Walsh
---
examples/l3fwd/l3fwd_common_route.h | 48 +++
examples/l3fwd/l3fwd_lpm.c | 74 +++--
2 f
The IPv6 subnets used were not within the 2001:200::/48 subnet
Changed to 2001:200:0:{0-7}::/64 where 0-7 is the port ID
Fixes: 37afe381bde4 ("examples/l3fwd: use reserved IP addresses")
Signed-off-by: Conor Walsh
---
examples/l3fwd/l3fwd_lpm.c | 26 --
1 file changed, 1
Currently the l3fwd sample app supports LPM and EM lookup methods this
patchset implements the FIB library as another lookup method for l3fwd.
The flag '-F' has been added to the applications options to allow
the user to use this lookup method.
---
v3: add support for NEON, PPC 64 and machines th
Make the pipeline instruction quanta configurable at build time.
Signed-off-by: Cristian Dumitrescu
---
examples/pipeline/thread.c | 11 ++-
1 file changed, 10 insertions(+), 1 deletion(-)
diff --git a/examples/pipeline/thread.c b/examples/pipeline/thread.c
index 6ac27e4eb..bf11e6144 10
bnxt_alloc_hwrm_rings() was duplicating a snippet of code that was
already present in bnxt_alloc_hwrm_rx_ring() with just one line/function
invocation missing. Add that line and replace the snippet of code
with a call to bnxt_hwrm_alloc_rx_ring
Signed-off-by: Somnath Kotur
---
drivers/net/bnxt/b
Juraj Linkeš writes:
> Instead of using the older platform, use only the newer Graviton2
> environment in Travis CI.
Can you expand on this a bit. Why should we need to use the newer
environment? What problems will occur by using the older environment?
I'm not against the change, but I don't
On 11/3/2020 8:28 AM, Steve Yang wrote:
When set follow sample rule's ratio equal to one, its behavior is same
as mirror-rule, so we can use "flow create * pattern * actions sample *"
to replace old "set port * mirror-rule *" command now.
The example of mirror rule command mapping to flow manage
On 11/3/2020 8:28 AM, Steve Yang wrote:
Define the sample filter parser for mirror, it will divide to two phases,
the one is sample attributions pattern parsing, and the mirror config
will be filled in according to pattern type VF/PF/VLAN when sample ratio
is 1.
The another is sample action parsi
On 11/3/2020 8:28 AM, Steve Yang wrote:
Define the sample filter parser for mirror, it will divide to two phases,
the one is sample attributions pattern parsing, and the mirror config
will be filled in according to pattern type VF/PF/VLAN when sample ratio
is 1.
The another is sample action parsi
> From: Rasesh Mody
> Sent: Friday, February 19, 2021 3:44 PM
>
> Hi,
>
> This patch series adds support for new HW while modifying existing driver to
> continue supporting previous HWs.
> Highlights of changes:
> - Registers, HW specific and initialization updates for new HW
> - FW upgrade
>
On 18-Feb-21 6:56 PM, hamidreza Kheirabadi wrote:
Hi,
I'd like to change my dpdk-based application from a pure C to C++ version.
Can anybody help me with a sample cmake or Makefile?
Is there any performance degradation when compiling apps with g++ instead
of gcc?
Regards
Hi,
We have documente
Updating the docs to elaborate on the stable release
characteristics and better document the current practice
about new features in stable releases.
Signed-off-by: Kevin Traynor
---
v2: Send to right dev list this time. Fix typo.
---
doc/guides/contributing/stable.rst | 33
Ping……
Any comments about this?
Thanks,
On Wed, Feb 10, 2021 at 1:20 PM Li Feng wrote:
>
> By default, the dpdk log is out to stdout/stderr and syslog.
> The rte_openlog_stream could set an external FILE* stream, but it asks
> the
> consumer to give it a FILE* pointer.
> For C++ or other languag
I believe this is the last patch in the series that needs some more review. I
implemented both an allowlist and a blocklist, so please let me know if this
would be usable. There's only the implementation, the actual allow/blocklists
would have to be added by maintainers/SoC owners.
There's also
Removed #ifdef LINUX_REMOVE, #ifndef LINUX_REMOVE, TODO comments
and TBD comments. Lots of TODOs and TBDs are not relevant.
Signed-off-by: Rasesh Mody
Signed-off-by: Igor Russkikh
---
drivers/net/qede/base/bcm_osal.c| 1 -
drivers/net/qede/base/bcm_osal.h| 3 --
driver
This patch adds PMD support for new hardware (adding new PCI IDs)
50xxx family of Marvell fastlinq adapters. The PMD version is
updated to 3.0.0.1.
Signed-off-by: Rasesh Mody
Signed-off-by: Igor Russkikh
---
drivers/net/qede/qede_debug.c | 3 +--
drivers/net/qede/qede_ethdev.c | 8 +++-
This patch changes the DMA page chain allocation and free mechanism
used for fast path resources. It introduces addr_shadow() structure to
maintain virtual address and DMA mapping. The ecore_chain_params() is
used to maintain all the DMA page chain parameters.
Signed-off-by: Rasesh Mody
Signed-of
The patch includes OS abstracted changes required to support new
hardware and the new feature supported by it. It also adds new bit
ops to RTE library.
Signed-off-by: Rasesh Mody
Signed-off-by: Igor Russkikh
---
drivers/net/qede/base/bcm_osal.c| 2 +-
drivers/net/qede/base/bcm_osal.h|
Hi,
This patch series adds support for new HW while modifying
existing driver to continue supporting previous HWs.
Highlights of changes:
- Registers, HW specific and initialization updates for new HW
- FW upgrade
- Base driver upgrade, other optimizations and cleanup
The new 50xxx family of M
From: Dapeng Yu
Currently, if requested MTU is bigger than mbuf size and scattered
receive is not enabled, setting MTU to that value fails.
This patch allows setting this special MTU when device is stopped,
because scattered_rx will be re-configured during next port start
and driver may enable s
From: Dapeng Yu
Currently, if requested MTU is bigger than mbuf size and scattered
receive is not enabled, setting MTU to that value fails.
This patch allows setting this special MTU when device is stopped,
because scattered_rx will be re-configured during next port start
and driver may enable s
> -Original Message-
> From: Juraj Linkeš
> Sent: Friday, February 19, 2021 3:34 PM
> To: tho...@monjalon.net; david.march...@redhat.com;
> acon...@redhat.com; maicolgabr...@hotmail.com
> Cc: dev@dpdk.org; Ruifeng Wang ; Honnappa
> Nagarahalli ; Juraj Linkeš
>
> Subject: [PATCH v2] ci: up
> -Original Message-
> From: Bruce Richardson
> Sent: Wednesday, January 6, 2021 3:43 PM
> To: David Christensen
> Cc: Juraj Linkeš ; tho...@monjalon.net;
> honnappa.nagaraha...@arm.com; dev@dpdk.org
> Subject: Re: [RFC PATCH v2] build: add platform meson option
>
> On Tue, Jan 05, 202
Tested-by: Huang, ZhiminX
Regards,
HuangZhiMin
> -Original Message-
> From: dev On Behalf Of Alvin Zhang
> Sent: Friday, February 19, 2021 1:14 PM
> To: Zhang, Qi Z
> Cc: dev@dpdk.org; Zhang, AlvinX ;
> sta...@dpdk.org
> Subject: [dpdk-dev] [PATCH] net/ice: fix VLAN filter with PF
>
From: Dapeng Yu
Currently, if requested MTU is bigger than mbuf size and scattered
receive is not enabled, setting MTU to that value fails.
This patch allows setting this special MTU when device is stopped,
because scattered_rx will be re-configured during next port start
and driver may enable s
On 2/9/2021 2:51 PM, Ferruh Yigit wrote:
On 1/29/2021 3:18 AM, 谢华伟(此时此刻) wrote:
From: "huawei.xhw"
With IO BAR, we get PIO(programmed IO) address.
With MMIO BAR, we get mapped virtual address.
We distinguish PIO(Programmed IO) and MMIO(memory mapped IO) by their address
like how kernel does.
On 12/22/2020 8:00 AM, Andrew Rybchenko wrote:
If sub-devices support RSS hash offload, the offload should be
reported by the failsafe device since handling is transparent
from failsafe point of view.
Fixes: 5d308972954c ("ethdev: add mbuf RSS update as an offload")
Cc: sta...@dpdk.org
Signed-o
On Thu, 18 Feb 2021 14:12:53 +0800, Li Feng wrote:
> By default, the dpdk log is out to stdout/stderr and syslog.
> The rte_openlog_stream could set an external FILE* stream, but it
> asks the consumer to give it a FILE* pointer.
> For C++ or other languages, it's hard to get a libc FILE*.
>
> Sup
38 matches
Mail list logo