The iol-testing warning on this patch seems to be unrelated to the patch. On February 9, 2021 10:40 AM, Kathleen Capella wrote > The tx_queue member of the fwd_lcore struct is unused as it is already part > of the fwd_stream > structure. Deleting helps improve code readability.
> Signed-off-by: Kathleen Capella <kathleen.cape...@arm.com> > Reviewed-by: Honnappa Nagarahalli <honnappa.nagaraha...@arm.com> > Acked-by: Thomas Monjalon <tho...@monjalon.net> > --- > app/test-pmd/testpmd.h | 1 - > 1 file changed, 1 deletion(-) > diff --git a/app/test-pmd/testpmd.h b/app/test-pmd/testpmd.h index > 5f2316210..f805f1b4d 100644 > --- a/app/test-pmd/testpmd.h > +++ b/app/test-pmd/testpmd.h > @@ -247,7 +247,6 @@ struct fwd_lcore { > streamid_t stream_idx; /**< index of 1st stream in "fwd_streams" */ > streamid_t stream_nb; /**< number of streams in "fwd_streams" */ > lcoreid_t cpuid_idx; /**< index of logical core in CPU id table */ > - queueid_t tx_queue; /**< TX queue to send forwarded packets */ > volatile char stopped; /**< stop forwarding when set */ > }; > -- > 2.17.1