Instead of using the older platform, use only the newer Graviton2
environment in Travis CI.
Signed-off-by: Juraj Linkeš
---
.travis.yml | 26 --
1 file changed, 16 insertions(+), 10 deletions(-)
diff --git a/.travis.yml b/.travis.yml
index 6a2181299f..7ed982ac07 100644
-
The macro flag DEV_RX_OFFLOAD_VLAN_FILTER is used to enable/disable
Rx VLAN filter, but not Tx VLAN filter. Therefore, Tx VLAN filter
should not be enabled/disabled in function ice_vsi_config_vlan_filter
called after checking DEV_RX_OFFLOAD_VLAN_FILTER flag.
In addition, the kernel driver doesn't
The macro flag DEV_RX_OFFLOAD_VLAN_FILTER is used to enable/disable
Rx VLAN filter, but not Tx VLAN filter. Therefore, Tx VLAN filter
should not be enabled/diabled in function ice_vsi_config_vlan_filter
called after checking DEV_RX_OFFLOAD_VLAN_FILTER flag.
In addition, the kernel driver doesn't e
This patch fixes unchecked return value for rte_vhost_get_mem_table(),
which is reported by coverity.
Coverity issue: 364233
Fixes: ca059fa5e290 ("examples/vhost: demonstrate the new generic APIs")
Cc: sta...@dpdk.org
Signed-off-by: Chenbo Xia
---
examples/vhost/virtio_net.c | 8 +++-
1 fil
The purpose of the event dispatcher is primarily to decouple different
parts of an application (e.g., processing pipeline stages), which
share the same underlying event device.
The event dispatcher replaces the conditional logic (often, a switch
statement) that typically follows an event device de
bnxt_rx_queue_count_op() incorrectly returns the number of
filled but unprocessed completion queue entries instead of
the number of filled but unprocessed received packet
completions. Fix by properly accounting for the number of
completion ring entries used by the various received packet
completion
On Wed, Feb 17, 2021 at 2:49 AM Thomas Monjalon wrote:
> 17/02/2021 11:37, Ferruh Yigit:
> > On 2/17/2021 5:57 AM, Asaf Penso wrote:
> > > From: Ferruh Yigit
> > >> On 2/7/2021 10:52 AM, Asaf Penso wrote:
> > >>> In http://doc.dpdk.org/guides/nics/overview.html, table 1.1 lists
> all
> > >>> sup
Avoid race with unregister interrupt handler if interrupt
source has some active callbacks at the moment, use wrapper
around rte_intr_callback_unregister() to check for -EAGAIN
return value and to loop until rte_intr_callback_unregister()
succeeds.
Signed-off-by: Renata Saiakhova
Acked-by: Anatol
For pci_vfio, while removing the device by rte_dev_remove(),
pci_vfio_disable_notifier() will call rte_intr_callback_unregister(),
which may return -EAGAIN, if an interrupt source (kernel) has some active
callbacks right now. As a result, the callback (req notifier) can be never
unregistered,
and
On Thu, 18 Feb 2021 10:53:54 -0800, Ranjit Menon wrote:
> > +
> > + if (get_device_pci_address(dev_info, &device_info_data,
> > &addr) != 0)
> > + continue;
> > +
> > + if (rte_pci_ignore_device(&addr))
> > + c
Avoid race with unregister interrupt hanlder if interrupt
source has some active callbacks at the moment, use wrapper
around rte_intr_callback_unregister() to check for -EAGAIN
return value and to loop until rte_intr_callback_unregister()
succeeds.
Signed-off-by: Renata Saiakhova
Acked-by: Anatol
For pci_vfio, while removing the device by rte_dev_remove(),
pci_vfio_disable_notifier() will call rte_intr_callback_unregister(),
which may return -EAGAIN, if an interrupt source (kernel) has some active
callbacks right now. As a result, the callback (req notifier) can be never
unregistered,
and
18/02/2021 21:32, Ferruh Yigit:
> On 10/15/2020 2:23 PM, nipun.gu...@nxp.com wrote:
> > From: Nipun Gupta
> >
> > This change adds a Rx offload capability and configuration to
> > enable hardware to drop the packets in case of any error in the
> > packets such as L3 checksum error or L4 checksum.
On 10/15/2020 2:23 PM, nipun.gu...@nxp.com wrote:
From: Nipun Gupta
This change adds a Rx offload capability and configuration to
enable hardware to drop the packets in case of any error in the
packets such as L3 checksum error or L4 checksum.
Signed-off-by: Nipun Gupta
Signed-off-by: Rohit R
03/11/2020 09:28, Steve Yang:
> --- a/lib/librte_ethdev/rte_ethdev_driver.h
> +++ b/lib/librte_ethdev/rte_ethdev_driver.h
> @@ -477,6 +477,7 @@ enum rte_filter_type {
> RTE_ETH_FILTER_TUNNEL,
> RTE_ETH_FILTER_FDIR,
> RTE_ETH_FILTER_HASH,
> + RTE_ETH_FILTER_SAMPLE,
> RTE_
Hi,
I'd like to change my dpdk-based application from a pure C to C++ version.
Can anybody help me with a sample cmake or Makefile?
Is there any performance degradation when compiling apps with g++ instead
of gcc?
Regards
Hi Khoa,
On 2/18/2021 10:40 AM, Khoa To wrote:
EAL -a and -b options are used to specify which PCI devices are
explicitly allowed or blocked during PCI bus scan. This evaluation
is missing in the Windows implementation of rte_pci_scan.
This patch provides this missing functionality, so that app
On 2/18/2021 5:58 PM, Ajit Khaparde wrote:
On Wed, Feb 17, 2021 at 2:49 AM Thomas Monjalon wrote:
17/02/2021 11:37, Ferruh Yigit:
On 2/17/2021 5:57 AM, Asaf Penso wrote:
From: Ferruh Yigit
On 2/7/2021 10:52 AM, Asaf Penso wrote:
In http://doc.dpdk.org/guides/nics/overview.html, table 1.1
EAL -a and -b options are used to specify which PCI devices are
explicitly allowed or blocked during PCI bus scan. This evaluation
is missing in the Windows implementation of rte_pci_scan.
This patch provides this missing functionality, so that apps can specify
which NetUIO devices to ignore durin
On 11/11/2020 1:07 PM, Ferruh Yigit wrote:
On 11/2/2020 2:48 PM, Qingqing Li wrote:
the reason is that during the stage of secondary process port initialization,
it lacks the initialization of "eth_dev->dev_ops".
Signed-off-by: Qingqing Li
Hi Ziyang, Guoyang, Xiaoyun,
The patch is around fo
Previous patch included a glue function call, with wrong size
calculation for an output buffer.
This patch fixes the issue, using the correct size calculation.
Fixes: bb7ef9a96281 ("common/mlx5: add register access DevX routine")
Cc: sta...@dpdk.org
Signed-off-by: Dekel Peled
Acked-by: Slava Ovs
Hi Natanael,
06/11/2020 11:44, David Marchand:
> Hello Natanael,
>
> - I suppose you got the mails with the build errors from the robot.
> Build is broken in dpaa (missing a few includes).
> https://travis-ci.com/github/ovsrobot/dpdk/jobs/429242867#L1005
Please could send a new version fixing t
>-Original Message-
>From: Thomas Monjalon
>Sent: Wednesday, February 17, 2021 12:49 PM
>To: Ferruh Yigit
>Cc: Asaf Penso ; dev@dpdk.org; Gal Cohen (ProdM)
>; Andrew Rybchenko ;
>ajit.khapa...@broadcom.com; jer...@marvell.com
>Subject: Re: [dpdk-dev] [PATCH v4] doc: add new tables for rte
On 10/12/2020 9:09 AM, Andrew Rybchenko wrote:
On 10/12/20 12:29 AM, Thomas Monjalon wrote:
09/10/2020 05:48, Kalesh A P:
From: Kalesh AP
Adding support for device reset and recovery events in the
rte_eth_event framework. FW error and FW reset conditions would be
managed internally by PMD wit
The purpose of this patch is to update the l3fwd user guide to include
the changes proposed in this patchset.
Signed-off-by: Conor Walsh
---
doc/guides/sample_app_ug/l3_forward.rst | 103 ++--
1 file changed, 95 insertions(+), 8 deletions(-)
diff --git a/doc/guides/sample_ap
This patch implements the Forwarding Information Base (FIB) library
in l3fwd using the function calls and infrastructure introduced in
the previous patch.
Signed-off-by: Conor Walsh
---
examples/l3fwd/l3fwd_fib.c | 441 -
1 file changed, 435 insertions(+), 6 d
The purpose of this commit is to add the necessary function calls
and supporting infrastructure to allow the Forwarding Information Base
(FIB) library to be integrated into the l3fwd sample app.
The flag '-F' has been added to the applications options to allow
the user to specify that l3fwd uses FI
To prevent code duplication from the addition of lookup methods
the routes specified in lpm should be moved to a common header.
Signed-off-by: Conor Walsh
---
examples/l3fwd/l3fwd_common_route.h | 48 +++
examples/l3fwd/l3fwd_lpm.c | 74 +++--
2 f
The IPv6 subnets used were not within the 2001:200::/48 subnet
Changed to 2001:200:0:{0-7}::/64 where 0-7 is the port ID
Fixes: 37afe381bde4 ("examples/l3fwd: use reserved IP addresses")
Signed-off-by: Conor Walsh
---
examples/l3fwd/l3fwd_lpm.c | 26 --
1 file changed, 1
Currently the l3fwd sample app supports LPM and EM lookup methods this
patchset implements the FIB library as another lookup method for l3fwd.
The flag '-F' has been added to the applications options to allow
the user to use this lookup method.
---
v2: added socket header file to fix FreeBSD buil
Hi,
We are planning to upgrade the Patchwork instance (https://patches.dpdk.org) to
version 2.2.3 on Sunday Feb 21 at 4:00 AM PT. Please expect that Patchwork will
temporarily be unavailable for a few minutes around that time.
The new release includes multiple features, performance improvements
The current machine='default' build name is not descriptive. The actual
default build is machine='native'. Add an alternative string which does
the same build and better describes what we're building:
machine='generic'. Leave machine='default' for backwards compatibility.
Signed-off-by: Juraj Link
Hi Tomek,
We have enabled vhost again and it is now in production with passing
results as expected.
I have closed the bug ticket as well.
Thanks,
Brandon
On Wed, Feb 17, 2021 at 11:06 AM Zawadzki, Tomasz
wrote:
>
> Hi folks,
>
> Patch in question is now part of v21.01.x branch and tests in UNH
remove Akhil
add Gagan
Signed-off-by: Hemant Agrawal
---
MAINTAINERS | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)
diff --git a/MAINTAINERS b/MAINTAINERS
index 1962284e94..596e143823 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -846,7 +846,6 @@ F: doc/guides/nics/features/enetc.in
Meeting minutes of 18 February 2021
---
Agenda:
* Release Dates
* 21.02 retrospective
* LTS
Participants:
* Arm
* Canonical
* Debian/Microsoft
* Intel
* Marvell
* Nvidia
* Red Hat
Release Dates
-
* v21.02 is released on Sunday, 14 February 2021
*
The purpose of this patch is to update the l3fwd user guide to include
the changes proposed in this patchset.
Signed-off-by: Conor Walsh
---
doc/guides/sample_app_ug/l3_forward.rst | 103 ++--
1 file changed, 95 insertions(+), 8 deletions(-)
diff --git a/doc/guides/sample_ap
This patch implements the Forwarding Information Base (FIB) library
in l3fwd using the function calls and infrastructure introduced in
the previous patch.
Signed-off-by: Conor Walsh
---
examples/l3fwd/l3fwd_fib.c | 440 -
1 file changed, 434 insertions(+), 6 d
The purpose of this commit is to add the necessary function calls
and supporting infrastructure to allow the Forwarding Information Base
(FIB) library to be integrated into the l3fwd sample app.
The flag '-F' has been added to the applications options to allow
the user to specify that l3fwd uses FI
To prevent code duplication from the addition of lookup methods
the routes specified in lpm should be moved to a common header.
Signed-off-by: Conor Walsh
---
examples/l3fwd/l3fwd_common_route.h | 48 +++
examples/l3fwd/l3fwd_lpm.c | 74 +++--
2 f
The IPv6 subnets used were not within the 2001:200::/48 subnet
Changed to 2001:200:0:{0-7}::/64 where 0-7 is the port ID
Fixes: 37afe381bde4 ("examples/l3fwd: use reserved IP addresses")
Signed-off-by: Conor Walsh
---
examples/l3fwd/l3fwd_lpm.c | 26 --
1 file changed, 1
Currently the l3fwd sample app supports LPM and EM lookup methods this
patchset implements the FIB library as another lookup method for l3fwd.
The flag '-F' has been added to the applications options to allow
the user to use this lookup method.
Conor Walsh (5):
examples/l3fwd: fix LPM IPv6 subne
The hard-coded thread priority for Windows threads in eal
is REALTIME_PRIORITY_CLASS/THREAD_PRIORITY_TIME_CRITICAL.
This results in issues with DPDK threads causing OS thread starvation
and eventually a bugcheck.
The fix reduce the thread priority to
NORMAL_PRIORITY_CLASS/THREAD_PRIORITY_NORMAL.
On Thu, Feb 18, 2021 at 11:48 AM Ibtisam Tariq wrote:
> On Thu, Feb 18, 2021 at 2:59 PM David Marchand
> wrote:
>>
>> On Thu, Feb 4, 2021 at 8:34 AM Ibtisam Tariq
>> wrote:
>> >
>> > Instead of using getopt_long return value, strcmp was used to
>> > compare the input parameters with the struct
Hi David,
Thanks for the recommendation. In future, I will add a cover letter for a
long patch set.
If you want, I can submit the cover letter for this patch set too.
On Thu, Feb 18, 2021 at 2:59 PM David Marchand
wrote:
> On Thu, Feb 4, 2021 at 8:34 AM Ibtisam Tariq
> wrote:
> >
> > Instead o
On Thu, Feb 4, 2021 at 8:34 AM Ibtisam Tariq wrote:
>
> Instead of using getopt_long return value, strcmp was used to
> compare the input parameters with the struct option array. This
> patch get rid of all those strcmp by directly binding each longopt
> with an int enum. This is to improve readab
This commit introduces support for preferred busy polling
to the AF_XDP PMD. This feature aims to improve single-core
performance for AF_XDP sockets under heavy load.
A new vdev arg is introduced called 'busy_budget' whose default
value is 64. busy_budget is the value supplied to the kernel
with t
poll() is more expensive and requires more tuning
when used with the upcoming busy polling functionality.
Signed-off-by: Ciara Loftus
---
drivers/net/af_xdp/rte_eth_af_xdp.c | 7 ---
1 file changed, 4 insertions(+), 3 deletions(-)
diff --git a/drivers/net/af_xdp/rte_eth_af_xdp.c
b/drivers/
Prior to this the max size was 32 which was unnecessarily
small. Also enforce the max batch size for TX for both
copy and zero copy modes. Prior to this only copy mode
enforced the max size.
Signed-off-by: Ciara Loftus
---
drivers/net/af_xdp/rte_eth_af_xdp.c | 8
1 file changed, 4 inser
Single-core performance of AF_XDP at high loads can be poor because
a heavily loaded NAPI context will never enter or allow for busy-polling.
1C testpmd rxonly (both IRQs and PMD on core 0):
./dpdk-testpmd -l 0-1 --vdev=net_af_xdp0,iface=eth0 -- --forward-mode=rxonly
0.088Mpps
In order to achieve
On Fri, Jan 29, 2021 at 4:19 AM 谢华伟(此时此刻) wrote:
>
> From: "huawei.xhw"
>
> Currently virtio PMD asssumes legacy device uses PIO bar.
> There are three ways to get PIO(PortIO) address for virtio legacy device.
> under igb_uio, get pio address from uio/uio# sysfs attribute
> under uio_pci_
On Wed, Feb 17, 2021 at 3:15 PM 谢华伟(此时此刻) wrote:
>
>
> On 2021/2/17 17:06, David Marchand wrote:
> > On Fri, Jan 29, 2021 at 4:19 AM 谢华伟(此时此刻)
> > wrote:
> >> @@ -517,6 +525,60 @@
> >> }
> >> #endif
> >>
> >> +static inline uint8_t ioread8(void *addr)
> >> +{
> >> + uint8_t val;
> >> +
51 matches
Mail list logo