On 8/21/2020 11:48 AM, Dmitry Kozlyuk wrote:
cmdline_numtype member names clash with Windows system identifiers.
Add CMDLINE_ prefix to cmdline constants to avoid this and possible
future conflicts.
Signed-off-by: Dmitry Kozlyuk
Suggested-by: Ranjit Menon
---
This patch made some lines over
When a device is inserted into an existing BDF slot
that has not been probed, we must overwrite the old
PCI ID with the ID of the new function. Otherwise
we may not probe the function with the correct driver,
if at all.
Signed-off-by: Jim Harris
---
drivers/bus/pci/linux/pci.c | 4 +++-
1 file c
Compiling with GCC 9.3 on Ubuntu 20.04 gives a warning about possible
string truncation when getting the RX queue name:
In file included from init.c:36:
init.c: In function ‘init’:
../shared/common.h:38:28: warning: ‘%u’ directive output may be truncated
writing between 1 and 10 bytes into a regi
When producing a printable mac address the buffer was appropriately sized
for holding the mac address exactly, but the actual snprintf included a
'\n' character at the end, which means that the snprintf technically is
getting truncated i.e. the \n would not be added due to lack of space.
This gets
When compiling on ubuntu 20.04, a warning was issued about possible
truncation of the path string for the power management socket.
channel_manager.c: In function ‘add_all_channels’:
channel_manager.c:470:41: warning: ‘%s’ directive output may be truncated
writing up to 255 bytes into a region of
The channel commands header file contains definitions that are used by the
example application for power management, and so need to be made public.
Similarly the guest_channel.h header is used by the guest_cli example
utility, so needs to be public also. Without this change, the example
apps, or a
While helping prepare some patches for converting the DPDK examples to
build using pkg-config, a number of errors and warnings were encountered in
the example app builds. These patches fix those issues.
NOTE: no makefile changes are included since make support is being removed
in this release
Bru
On Fri, Aug 21, 2020 at 05:29:26PM +0100, Bruce Richardson wrote:
> This patchset adds some small enhancements, some rework and also support
> for new hardware to the ioat rawdev driver. Most rework and enhancements
> are largely self-explanatory from the individual patches.
>
> The new hardware s
Now that all devices can pass the same set of unit tests, elminate the
temporary idxd_rawdev_test function and move the prototype for
ioat_rawdev_test to the proper internal header file, to be used by all
device instances.
Signed-off-by: Bruce Richardson
---
drivers/raw/ioat/idxd_pci.c |
Rather than having the xstats as fields inside the main driver structure,
create a separate structure type for them.
As part of the change, when updating the stats functions referring to the
stats by the old path, we can simplify them to use the id to directly index
into the stats structure, makin
Add update of the relevant stats for the data path functions and point the
overall device struct xstats function pointers to the existing ioat
functions.
At this point, all necessary hooks for supporting the existing unit tests
are in place so call them for each device.
Signed-off-by: Bruce Richa
The xstats functions can be used by all ioat devices so move them from the
ioat_rawdev.c file to ioat_common.c, and add the function prototypes to the
internal header file.
Signed-off-by: Bruce Richardson
---
drivers/raw/ioat/ioat_common.c | 59 +
drivers/raw/ioa
Add the info get function for DSA devices, returning just the ring size
info about the device, same as is returned for existing IOAT/CBDMA devices.
Signed-off-by: Bruce Richardson
---
drivers/raw/ioat/idxd_pci.c | 1 +
drivers/raw/ioat/idxd_vdev.c| 1 +
drivers/raw/ioat/ioat_common.c
Add support for doing copies using DSA hardware. This is implemented by
just switching on the device type field at the start of the inline
functions. Since there is no hardware which will have both device types
present this branch will always be predictable after the first call,
meaning it has litt
Add in the relevant data structures for the data path for DSA devices. Also
include a device dump function to output the status of each device.
Signed-off-by: Bruce Richardson
---
drivers/raw/ioat/idxd_pci.c| 3 +-
drivers/raw/ioat/idxd_vdev.c | 1 +
drivers/raw/ioat/ioat
Add configure function for idxd devices, taking the same parameters as the
existing configure function for ioat. The ring_size parameter is used to
compute the maximum number of bursts to be supported by the driver, given
that the hardware works on individual bursts of descriptors at a time.
Signe
Add the start and stop functions for DSA hardware devices using the
vfio/uio kernel drivers. For vdevs using the idxd kernel driver, the device
must be started using sysfs before the device node appears for vdev use -
making start/stop functions in the driver unnecessary.
Signed-off-by: Bruce Rich
From: Kevin Laatz
For each vdev (DSA work queue) instance, create a rawdev instance.
Signed-off-by: Kevin Laatz
Signed-off-by: Bruce Richardson
---
drivers/raw/ioat/idxd_vdev.c| 107 +++-
drivers/raw/ioat/ioat_private.h | 4 ++
2 files changed, 110 insertions
Devices managed by the idxd kernel driver must be configured for DPDK use
before it can be used by the ioat driver. This example script serves both
as a quick way to get the driver set up with a simple configuration, and as
the basis for users to modify it and create their own configuration
scripts
Add in the basic probe/remove skeleton code for DSA devices which are bound
directly to vfio or uio driver. The kernel module for supporting these uses
the "idxd" name, so that name is used as function and file prefix to avoid
conflict with existing "ioat" prefixed functions.
Since we are adding n
From: Kevin Laatz
Intel Data Streaming Accelerator (Intel DSA) is a high-performance data
copy and transformation accelerator which will be integrated in future
Intel processors [1].
Add DSA device support to dpdk-devbind.py script.
[1] https://01.org/blogs/2019/introducing-intel-data-streaming
When a matching device is found via PCI probe create a rawdev instance for
each queue on the hardware. Use empty self-test function for these devices
so that the overall rawdev_autotest does not report failures.
Signed-off-by: Bruce Richardson
---
drivers/raw/ioat/idxd_pci.c| 236 +++
From: Kevin Laatz
The Intel DSA devices can be exposed to userspace via kernel driver, so can
be used without having to bind them to vfio/uio. Therefore we add support
for using those kernel-configured devices as vdevs, taking as parameter the
individual HW work queue to be used by the vdev.
Sig
Only a few definitions from the hardware spec are actually used in the
driver runtime, so we can copy over those few and make the rest of the spec
a private header in the driver.
Signed-off-by: Bruce Richardson
---
drivers/raw/ioat/ioat_rawdev.c| 3 ++
.../raw/ioat/{rte_ioat_spe
This patchset adds some small enhancements, some rework and also support
for new hardware to the ioat rawdev driver. Most rework and enhancements
are largely self-explanatory from the individual patches.
The new hardware support is for the Intel(R) DSA accelerator which will be
present in future I
Rather than having a single long complicated header file for general use we
can split things so that there is one header with all the publically needed
information - data structs and function prototypes - while the rest of the
internal details are put separately. This makes it easier to read,
under
From: Cheng Jiang
Add a flag which controls whether rte_ioat_enqueue_copy and
rte_ioat_completed_copies function should process handle parameters. Not
doing so can improve the performance when handle parameters are not
necessary.
Signed-off-by: Cheng Jiang
Signed-off-by: Bruce Richardson
---
Since the rawdev autotest can now be used to test all rawdevs on the
system, there is no need for a dedicated ioat autotest command.
Signed-off-by: Bruce Richardson
---
app/test/test_rawdev.c | 20
1 file changed, 20 deletions(-)
diff --git a/app/test/test_rawdev.c b/app/te
Rather than having each rawdev provide its own autotest command, we can
instead just use the generic rawdev_autotest to test any and all available
rawdevs.
Signed-off-by: Bruce Richardson
---
app/test/test_rawdev.c | 28 ++--
1 file changed, 26 insertions(+), 2 deletions(
In case of any failures, include the function name and the line number of
the error message in the message, to make tracking down the failure easier.
Signed-off-by: Bruce Richardson
---
drivers/raw/ioat/ioat_rawdev_test.c | 52 +++--
1 file changed, 34 insertions(+), 18 d
The current selftest function uses a single global variable to track state
which implies that only a single instance can have the selftest function
called on it. Change this to an array to allow multiple instances to be
tested.
Signed-off-by: Bruce Richardson
---
drivers/raw/ioat/ioat_rawdev_tes
At present the "rawdev_autotest" command creates a skeleton rawdev and runs
a series of tests on the rawdev API and on that rawdev. While the rawdev
API set includes a "selftest" function, it is not hooked up to this test so
to test an individual rawdev driver, e.g. ioat, requires that a new test
c
On 20/08/2020 15:32, Kevin Traynor wrote:
> Hi,
>
> On 25/06/2020 10:59, alangordonde...@gmail.com wrote:
>> From: Alan Dewar
>>
>> The QoS scheduler works off port time that is computed from the number
>> of CPU cycles that have elapsed since the last time the port was
>> polled. It divides
> From: Power, Ciara
> Hi Nicolas,
>
>
> >-Original Message-
> >From: Chautru, Nicolas
> >Sent: Friday 21 August 2020 03:13
> >To: Power, Ciara ; dev@dpdk.org
> >Cc: Mcnamara, John ; Kovacevic, Marko
> >
> >Subject: RE: [PATCH v2 20/37] doc: remove references to make in bbdev
> >guides
From: Louise Kilheeney
This patch adds tests for verifying telemetry data structures are
converted to JSON as expected. Both flat and recursive data structures
are tested, for all possible value types.
The app connects to the telemetry socket as a client, and registers one
command with a corresp
The ethdev library now registers a telemetry command for common ethdev
statistics.
An example usage is shown below:
Connecting to /var/run/dpdk/rte/dpdk_telemetry.v2
{"version": "DPDK 20.08.0-rc1", "pid": 14119, "max_output_len": 16384}
--> /ethdev/stats,0
{"/ethdev/stats": {"ipackets": 0, "opack
v8: Rebased onto main.
v7:
- Simplified connecting to socket by removing use of glob.
- Fixed buffer overflow issue when reading from socket.
- Split expected response strings over multiple lines.
v6:
- Fixed FreeBSD build failure for unit tests.
- Added comments and expanded commit log.
Arrays of type uint64_t/int/string can now be included within an array
or dict. One level of embedded containers is supported. This is
necessary to allow for instances such as the ethdev queue stats to be
reported as a list of uint64_t values, rather than having multiple dict
entries with one uint6
On Fri, Aug 21, 2020 at 10:14:50AM +0100, Louise Kilheeney wrote:
> Changed script to explicitly use python3 only to avoid
> maintaining python 2 and removed deprecation notice.
>
> Cc: Neil Horman
> Cc: Ray Kinsella
>
> Signed-off-by: Louise Kilheeney
> Acked-by: Ray Kinsella
> ---
> devtoo
On Fri, Aug 21, 2020 at 10:14:46AM +0100, Louise Kilheeney wrote:
> Changed script to explicitly use python3 only to avoid
> maintaining python 2 and removed deprecation notice.
>
> Cc: Neil Horman
>
> Signed-off-by: Louise Kilheeney
> Reviewed-by: Bruce Richardson
> ---
> usertools/dpdk-pmdi
Currently, rte_ipv4_cksum() and rte_ipv4_udptcp_cksum() assume all IPv4
headers have sizeof(struct rte_ipv4_hdr) bytes. This is not true for
those (rare) packets with IPv4 options. Thus, both IPv4 and TCP/UDP
checksums are calculated wrong.
This patch fixes the issue by using the actual IPv4 heade
From: Kiran Kumar K
This patch reserves 2 bits as input selection to select Inner and
outer layers for RSS computation. It is combined with existing
ETH_RSS_* to choose Inner or outer layers for L2, L3 and L4.
This functionality already exists in rte_flow through level parameter in
RSS action con
From: Kiran Kumar K
Add support to choose rss hash level from ethdev rss config.
Signed-off-by: Kiran Kumar K
---
drivers/net/octeontx2/otx2_ethdev.h | 2 +-
drivers/net/octeontx2/otx2_rss.c| 9 +++--
2 files changed, 8 insertions(+), 3 deletions(-)
diff --git a/drivers/net/octeontx2/
From: Kiran Kumar K
Adding support to set RSS level from ethdev config.
level-inner is default and will set the RSS level to inner layers.
level-outer will set the RSS level to outer layers.
level-inner-outer will set the RSS level to both inner and outer
layers.
Signed-off-by: Kiran Kumar K
--
From: Ajit Khaparde
Sent: Thursday, August 20, 2020 8:49 AM
To: Kiran Kumar Kokkilagadda
Cc: Wenzhuo Lu ; Beilei Xing ;
Bernard Iremonger ; Thomas Monjalon
; Ferruh Yigit ; Andrew Rybchenko
; dpdk-dev ; Jerin Jacob Kollanukkaran
; Ori Kam ; Ziyang Xuan
; Xiaoyun Wang ; Guoyang
Zhou ; Rose
Hi Nicolas,
>-Original Message-
>From: Chautru, Nicolas
>Sent: Friday 21 August 2020 03:13
>To: Power, Ciara ; dev@dpdk.org
>Cc: Mcnamara, John ; Kovacevic, Marko
>
>Subject: RE: [PATCH v2 20/37] doc: remove references to make in bbdev
>guides
>
>> From: Power, Ciara Make is no longer s
On 8/20/2020 10:55 PM, Ed Czeck wrote:
> Update documenation as needed.
>
> Signed-off-by: Ed Czeck
> ---
> doc/guides/nics/ark.rst | 3 ---
> drivers/net/ark/ark_ethdev_tx.c | 42 ++---
> drivers/net/ark/ark_logs.h | 8 ---
> 3 files changed, 23 in
On 8/20/2020 4:41 PM, Ed Czeck wrote:
> On Thu, Aug 20, 2020 at 7:16 AM Ferruh Yigit wrote:
>>
> ...
>>
>> Logging can be controlled in runtime, that is what we should use.
>> In data path, we use compile time flags because of the performance issues.
>> So OK
>> to have 'CONFIG_RTE_LIBRTE_ARK_DEB
On Fri, Aug 21, 2020 at 02:22:14AM +, Chautru, Nicolas wrote:
> From: Power, Ciara
> > Make is no longer supported for compiling DPDK, references are now removed
> > in the documentation.
> >
> > Reviewed-by: Kevin Laatz
> > Signed-off-by: Ciara Power
> > ---
> > doc/guides/bbdevs/fpga_5gn
On Fri, Aug 21, 2020 at 10:14:48AM +0100, Louise Kilheeney wrote:
> Changed script to explicitly use python3 only to avoid
> maintaining python 2 and removed deprecation notice.
>
> Cc: Olivier Matz
>
> Signed-off-by: Louise Kilheeney
>
> ---
> v5: fixed python3 issue casuing script to fail
I
On 20-Aug-20 4:43 PM, Bruce Richardson wrote:
When binding or unbinding a range of devices, it can be useful to use
wildcards to specify the devices rather than repeating the same prefix
multiple times. We can use the python "glob" module to give us this
functionality - at least for PCI devices -
Changed script to explicitly use python3 only to avoid
maintaining python 2 and removed deprecation notice.
Cc: Nicolas Chautru
Signed-off-by: Louise Kilheeney
---
app/test-bbdev/test-bbdev.py | 7 +--
1 file changed, 1 insertion(+), 6 deletions(-)
diff --git a/app/test-bbdev/test-bbdev.p
Changed script to explicitly use python3 only to avoid
maintaining python 2.
Cc: Thomas Monjalon
Signed-off-by: Louise Kilheeney
---
config/arm/armv8_machine.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/config/arm/armv8_machine.py b/config/arm/armv8_machine.py
index 4
Changed script to explicitly use python3 only to avoid
maintaining python 2 and removed deprecation notice.
Signed-off-by: Louise Kilheeney
---
app/test/autotest.py| 7 +--
app/test/autotest_data.py | 1 +
app/test/autotest_runner.py | 21 -
app/te
Changed script to explicitly use python3 only to avoid
maintaining python 2 and removed deprecation notice.
Cc: Neil Horman
Cc: Ray Kinsella
Signed-off-by: Louise Kilheeney
Acked-by: Ray Kinsella
---
devtools/update_version_map_abi.py | 7 +--
1 file changed, 1 insertion(+), 6 deletions(
Changed script to explicitly use python3 only to avoid
maintaining python 2 and removed deprecation notice.
Signed-off-by: Louise Kilheeney
Reviewed-by: Bruce Richardson
---
usertools/cpu_layout.py | 13 ++---
1 file changed, 2 insertions(+), 11 deletions(-)
diff --git a/usertools/cpu_
Changed script to explicitly use python3 only to avoid
maintaining python 2 and removed deprecation notice.
Signed-off-by: Louise Kilheeney
Reviewed-by: Bruce Richardson
---
usertools/dpdk-devbind.py | 22 --
1 file changed, 4 insertions(+), 18 deletions(-)
diff --git a/use
Changed script to explicitly use python3 only to avoid
maintaining python 2 and removed deprecation notice.
Cc: Olivier Matz
Signed-off-by: Louise Kilheeney
---
v5: fixed python3 issue casuing script to fail
---
app/test-cmdline/cmdline_test.py | 9 ++---
app/test-cmdline/cmdline_tes
Changed script to explicitly use python3 only to avoid
maintaining python 2 and removed deprecation notice.
Cc: Neil Horman
Signed-off-by: Louise Kilheeney
Reviewed-by: Bruce Richardson
---
usertools/dpdk-pmdinfo.py | 7 +--
1 file changed, 1 insertion(+), 6 deletions(-)
diff --git a/use
Changed script to explicitly use python3 only to avoid
maintaining python 2 and removed deprecation notice.
Cc: Kevin Laatz
Signed-off-by: Louise Kilheeney
Acked-by: Bruce Richardson
---
usertools/dpdk-telemetry-client.py | 20
1 file changed, 4 insertions(+), 16 deletion
This patch set converts all python scripts in the project to use
python3 only and removes all deprecation notices associated with these
changes. This is due to python2 being EOL in January 2020.
Louise Kilheeney (9):
usertools/dpdk-telemetry-client: support python3 only
usertools/dpdk-devbind
On 20-Aug-20 4:43 PM, Bruce Richardson wrote:
When binding or unbinding a range of devices, it can be useful to use
wildcards to specify the devices rather than repeating the same prefix
multiple times. We can use the python "glob" module to give us this
functionality - at least for PCI devices -
62 matches
Mail list logo