This patch enhances the ethtool example to support to show
bus information and firmware version, in the same way that
the Linux kernel ethtool does.
Signed-off-by: Qiming Yang
---
v2 changes:
* modified the commit log
---
---
examples/ethtool/ethtool-app/ethapp.c | 2 ++
examples/ethtool/lib/rt
Signed-off-by: Qiming Yang
---
drivers/net/i40e/i40e_ethdev.c | 15 +++
1 file changed, 15 insertions(+)
diff --git a/drivers/net/i40e/i40e_ethdev.c b/drivers/net/i40e/i40e_ethdev.c
index 67778ba..f79bc5e 100644
--- a/drivers/net/i40e/i40e_ethdev.c
+++ b/drivers/net/i40e/i40e_ethdev.
Signed-off-by: Qiming Yang
---
drivers/net/e1000/igb_ethdev.c | 46 ++
1 file changed, 46 insertions(+)
diff --git a/drivers/net/e1000/igb_ethdev.c b/drivers/net/e1000/igb_ethdev.c
index 2fddf0c..c47f1c8 100644
--- a/drivers/net/e1000/igb_ethdev.c
+++ b/dr
Signed-off-by: Qiming Yang
---
drivers/net/ixgbe/ixgbe_ethdev.c | 18 ++
1 file changed, 18 insertions(+)
diff --git a/drivers/net/ixgbe/ixgbe_ethdev.c b/drivers/net/ixgbe/ixgbe_ethdev.c
index edc9b22..da9aa31 100644
--- a/drivers/net/ixgbe/ixgbe_ethdev.c
+++ b/drivers/net/ixgbe/
This patch adds a new API 'rte_eth_dev_fwver_get' for fetching firmware
version by a given device.
Signed-off-by: Qiming Yang
---
v2 changes:
* modified some comment statements.
---
---
lib/librte_ether/rte_ethdev.c | 12
lib/librte_ether/rte_ethdev.h | 18
Now, the example ethtool can only show the driver information. From
customers' point of view, it should be better if we can have the same
way that the Linux kernel ethtool does to show the bus-info and
firmware-version.
These five patches add a new API to fetch firmware version and implement
the d
Add two new commands "show port capa " and "show
port capa all"to diaplay what offload capabilities supported
in ports. It will not only display all the capabilities of
the port, but also the enabling condition for each capability
in the running time.
Signed-off-by: Qiming Yang
---
v2 changes:
*
-Original Message-
From: Mcnamara, John [mailto:john.mcnam...@intel.com]
Sent: Monday, December 05, 2016 10:10 PM
To: Akhil Goyal ; dev@dpdk.org
Cc: thomas.monja...@6wind.com; Doherty, Declan ; De
Lara Guarch, Pablo ; Hemant Agrawal
Subject: RE: [dpdk-dev] [PATCH 3/8] doc: Adding NXP
On Thu, Dec 01, 2016 at 04:26:50PM +0100, Jan Wickbom wrote:
> Currently select() is used to monitor file descriptors for vhostuser
> ports. This limits the number of ports possible to create since the
> fd number is used as index in the fd_set and we have seen fds > 1023.
Yeah, it's a known issue
OK. Ferruh, I will update this patch set according to your comments.
-Original Message-
From: Yigit, Ferruh
Sent: Monday, December 5, 2016 10:56 PM
To: Wu, Jingjing ; dev@dpdk.org
Cc: Zhang, Helin
Subject: Re: [dpdk-dev] [PATCH 30/31] net/i40e/base: remove unused marco
On 12/3/2016 1:19
Hi, Maxime:
> -Original Message-
> From: Maxime Coquelin [mailto:maxime.coque...@redhat.com]
> Sent: Friday, December 2, 2016 6:01 PM
> To: Yang, Zhiyong ; dev@dpdk.org
> Cc: yuanhan@linux.intel.com; Richardson, Bruce
> ; Ananyev, Konstantin
>
> Subject: Re: [dpdk-dev] [PATCH 0/4] eal
On Tue, Dec 06, 2016 at 01:40:52PM +0800, linhaifeng wrote:
> 在 2016/12/6 10:28, Yuanhan Liu 写道:
> > On Thu, Dec 01, 2016 at 07:42:02PM +0800, Haifeng Lin wrote:
> >> When reg_size < page_size the function read in
> >> rte_mem_virt2phy would not return, becausue
> >> host_user_addr is invalid.
> >>
在 2016/12/6 10:28, Yuanhan Liu 写道:
> On Thu, Dec 01, 2016 at 07:42:02PM +0800, Haifeng Lin wrote:
>> When reg_size < page_size the function read in
>> rte_mem_virt2phy would not return, becausue
>> host_user_addr is invalid.
>>
>> Signed-off-by: Haifeng Lin
>> ---
>> v2:
>> fix TYPO_SPELLING warni
This commit adds basic unit tests for the eventdev API.
commands to run the test app:
./build/app/test -c 2
RTE>>eventdev_common_autotest
Signed-off-by: Jerin Jacob
---
MAINTAINERS | 1 +
app/test/Makefile| 2 +
app/test/test_eventdev.c | 775 +++
The skeleton driver facilitates, bootstrapping the new
eventdev driver and creates a platform to verify
the northbound eventdev common code.
The driver supports both VDEV and PCI based eventdev
devices.
Signed-off-by: Jerin Jacob
---
MAINTAINERS| 1 +
c
This patch adds infrastructure for registering the vdev or
the PCI based event device.
Signed-off-by: Jerin Jacob
---
lib/librte_eventdev/rte_eventdev.c | 236 +++
lib/librte_eventdev/rte_eventdev_pmd.h | 111 +
lib/librte_eventdev/rte_eventdev
Signed-off-by: Jerin Jacob
---
lib/librte_eventdev/rte_eventdev.h | 38 +
lib/librte_eventdev/rte_eventdev_pmd.h | 286 +
2 files changed, 324 insertions(+)
create mode 100644 lib/librte_eventdev/rte_eventdev_pmd.h
diff --git a/lib/librte_eventdev/rte_ev
This patch implements northbound eventdev API interface using
southbond driver interface
Signed-off-by: Jerin Jacob
---
config/common_base |6 +
lib/Makefile |1 +
lib/librte_eal/common/include/rte_log.h |1 +
lib/librte_
In a polling model, lcores poll ethdev ports and associated
rx queues directly to look for packet. In an event driven model,
by contrast, lcores call the scheduler that selects packets for
them based on programmer-specified criteria. Eventdev library
adds support for event driven programming model,
As previously discussed in RFC v1 [1], RFC v2 [2], with changes
described in [3] (also pasted below), here is the first non-draft series
for this new API.
[1] http://dpdk.org/ml/archives/dev/2016-August/045181.html
[2] http://dpdk.org/ml/archives/dev/2016-October/048592.html
[3] http://dpdk.org/ml
On Thu, Dec 01, 2016 at 07:42:02PM +0800, Haifeng Lin wrote:
> When reg_size < page_size the function read in
> rte_mem_virt2phy would not return, becausue
> host_user_addr is invalid.
>
> Signed-off-by: Haifeng Lin
> ---
> v2:
> fix TYPO_SPELLING warning
> ---
> lib/librte_vhost/vhost_user.c |
Hi Dey,
I'm confused.
rte_eth_allmulticast_enable means the port can receive all the multicast
packets. In another word, it's multicast promiscuous mode.
rte_eth_dev_set_mc_addr_list means adding a series of multicast addresses to
the filter, so the port can receive these specific multicast packe
> On Dec 3, 2016, at 5:18 AM, Jerin Jacob
> wrote:
>
>> On Fri, Dec 02, 2016 at 01:45:56PM -0600, Gage Eads wrote:
>> This commit adds buffered enqueue functionality to the eventdev API.
>> It is conceptually similar to the ethdev API's tx buffering, however
>> with a smaller API surface and no
On 12/4/2016 6:31 AM, Wei Dai wrote:
> This patch updates Inphi configuration to flush the register write with
Do we really need to mention from Inphi here? If so, can you please
explain what it is?
> a reg read. Inphi is configured in ixgbe_setup_mac_link_sfp_x550a.
> The Inphy setup flow has be
On 12/4/2016 6:31 AM, Wei Dai wrote:
> update the version of shared codes to cid-ixgbe.2016.11.21.tar.gz,
> all files in net/ixgbe/base are developped by another team and
> DPDK PMD uses them accordingly.
>
> Signed-off-by: Wei Dai
> ---
> drivers/net/ixgbe/base/README | 3 ++-
> 1 file changed,
On 12/4/2016 6:31 AM, Wei Dai wrote:
> This patch adds EEE support for DNL-controlled PHYs. Because DNL
What is DNL?
> does not indicate EEE capability or status, this patch simply
> assumes that it is supported. As soon as there is a DNL-supported
> PHY that does not support EEE, there will be d
Hi Wenzhuo,
There is nothing set with the rte_eth_dev_set_mc_addr_list and we are trying to
receive the NS packet which has the destination MAC set as 33 33 ff 00 00 14.
Also what I saw is that the handling of allmulticast_enable message in the
kernel has happened after 4.0 version and the PF d
On Mon, Dec 05, 2016 at 04:43:52PM +, Ananyev, Konstantin wrote:
[...]
> > On Fri, Dec 02, 2016 at 01:00:55AM +, Ananyev, Konstantin wrote:
> > [...]
> > > > On Wed, Nov 30, 2016 at 10:54:50AM +, Ananyev, Konstantin wrote:
> > > > [...]
> > > > > Do you have anything particular in mind
Clean up the code to always use the flags RTE_EXEC_ENV_*APP
set up in the DPDK configuration instead of the native ones.
Signed-off-by: Thomas Monjalon
---
app/test-pmd/cmdline.c | 4 ++--
app/test/commands.c | 4 ++--
app/test/test_cmdline_ipaddr.c
> -Original Message-
> From: dev [mailto:dev-boun...@dpdk.org] On Behalf Of Hemant Agrawal
> Sent: Sunday, December 4, 2016 6:17 PM
> To: dev@dpdk.org
> Cc: thomas.monja...@6wind.com; Richardson, Bruce
> ; shreyansh.j...@nxp.com; Hemant Agrawal
>
> Subject: [dpdk-dev] [PATCH 01/32] doc: ad
> -Original Message-
> From: dev [mailto:dev-boun...@dpdk.org] On Behalf Of Akhil Goyal
> Sent: Monday, December 5, 2016 12:56 PM
> To: dev@dpdk.org
> Cc: thomas.monja...@6wind.com; eclan.dohe...@intel.com; De Lara Guarch,
> Pablo ; hemant.agra...@nxp.com; Akhil
> Goyal
> Subject: [dpdk-de
Hi Adrien,
>
> Hi Konstantin,
>
> On Fri, Dec 02, 2016 at 01:00:55AM +, Ananyev, Konstantin wrote:
> [...]
> > > On Wed, Nov 30, 2016 at 10:54:50AM +, Ananyev, Konstantin wrote:
> > > [...]
> > > > > Something is definitely needed here, and only PMDs can provide it. I
> > > > > think
>
P.S. There was also a whitespace warning on commit.
> -Original Message-
> From: Baruch Siach [mailto:bar...@tkos.co.il]
> Sent: Monday, December 5, 2016 3:41 PM
> To: dev@dpdk.org
> Cc: Olivier Matz ; Mcnamara, John
> ; Baruch Siach
> Subject: [PATCH] doc: fix wrong verbatim text paragraphs
>
> Reduce the indentation of these paragraphs s
2016-12-05 16:34, Thomas Monjalon:
> Clean up the code to always use the flags RTE_MACHINE_CPUFLAG_*
> generated by the DPDK makefile rte.cpuflags.mk.
This patch does not work because RTE_MACHINE_CPUFLAG_* are generated
for the whole library when including rte.vars.mk.
So the flags are not accurat
Reduce the indentation of these paragraphs since they are not part of the
verbatim block.
Signed-off-by: Baruch Siach
---
doc/guides/prog_guide/mbuf_lib.rst | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/doc/guides/prog_guide/mbuf_lib.rst
b/doc/guides/prog_guide/mbu
Clean up the code to always use the flags RTE_MACHINE_CPUFLAG_*
generated by the DPDK makefile rte.cpuflags.mk.
Signed-off-by: Thomas Monjalon
---
examples/l3fwd/l3fwd_em.c | 8
examples/l3fwd/l3fwd_lpm.c| 6 +++---
examples/performance-
> -Original Message-
> From: dev [mailto:dev-boun...@dpdk.org] On Behalf Of John McNamara
> Sent: Sunday, December 04, 2016 4:48 PM
> To: dev@dpdk.org
> Cc: sta...@dpdk.org; Mcnamara, John
> Subject: [dpdk-dev] [PATCH v1] doc: fix relative path of Nic table input file
>
> Fix relative pa
On Fri, Dec 02, 2016 at 04:22:16PM +, Declan Doherty wrote:
> On 02/12/16 14:57, Bruce Richardson wrote:
> > On Fri, Dec 02, 2016 at 03:31:24PM +0100, Thomas Monjalon wrote:
> > > 2016-12-02 14:15, Fan Zhang:
> > > > This patch provides the initial implementation of the scheduler poll
> > > >
Hi Konstantin,
On Fri, Dec 02, 2016 at 01:00:55AM +, Ananyev, Konstantin wrote:
[...]
> > On Wed, Nov 30, 2016 at 10:54:50AM +, Ananyev, Konstantin wrote:
> > [...]
> > > > Something is definitely needed here, and only PMDs can provide it. I
> > > > think
> > > > applications should not h
On 12/3/2016 1:19 AM, Jingjing Wu wrote:
> remove X722_SUPPORT and I40E_NDIS_SUPPORT MARCOs
s/marco/macro, same for patch subject
>
> Signed-off-by: Jingjing Wu
> ---
<...>
On 12/3/2016 1:19 AM, Jingjing Wu wrote:
s/marco/macro in commit title
It is good to see that this unused macro removed, thanks.
> Signed-off-by: Jingjing Wu
<...>
On 12/3/2016 1:19 AM, Jingjing Wu wrote:
> We already define I40E_AQ_PHY_TYPE_EXT_25G* flags in the response adminq
> structure above, and do not need to re-define these. See eee_capability
> for an example where we didn't re-define these. This prevents Linux
> driver from complaining about using t
On 12/3/2016 1:18 AM, Jingjing Wu wrote:
> Prevents 25G PHY types from being disabled when setting
> the flow control modes.
>
> Signed-off-by: Jingjing Wu
> ---
> drivers/net/i40e/base/i40e_common.c | 1 +
> 1 file changed, 1 insertion(+)
>
> diff --git a/drivers/net/i40e/base/i40e_common.c
>
On 12/3/2016 1:18 AM, Jingjing Wu wrote:
> Incorrect bit mask was used for testing "get link status" response.
> Instead of I40E_AQ_LSE_ENABLE (which is actually 0x03) it most probably
most probably J
> should be I40E_AQ_LSE_IS_ENABLED (which is defined as 0x01).
>
> Fixes: 8db9e2a1b232 ("i40e:
Hi Jingjing,
On 12/3/2016 1:18 AM, Jingjing Wu wrote:
> Add FEC bits to the PHY capabilities AQ command struct. This is required
> for 25GbE support. Change the name of the generic mod_type_ext field to
> indicate that it is now used for handling FEC.
>
> Signed-off-by: Jingjing Wu
> ---
> driv
On 12/3/2016 3:14 PM, Shepard Siegel wrote:
> Atomic Rules would like to include our Arkville DPDK PMD net/ark in the
> DPDK 17.05 release.
Welcome to the DPDK community, it is great to see new hardware support.
> We have been watching the recent process of
> Solarflare’s net/sfc upstreaming and
2016-11-23 16:34, Olivier Matz:
> Today, all logs whose level is lower than INFO are dropped at
> compile-time. This prevents from enabling debug logs at runtime using
> --log-level=8.
>
> The rationale was to remove debug logs from the data path at
> compile-time, avoiding a test at run-time.
>
On Monday 05 December 2016 03:54 PM, Jerin Jacob wrote:
On Mon, Dec 05, 2016 at 03:42:18PM +0530, Shreyansh Jain wrote:
Hello Jerin,
Hello Shreyansh,
On Sunday 04 December 2016 02:25 AM, Jerin Jacob wrote:
rte_eal_dev_init() is a misleading name.
It actually performs the driver->probe for
On 12/2/2016 2:55 PM, Ferruh Yigit wrote:
> On 11/29/2016 4:18 PM, Andrew Rybchenko wrote:
>> The patch series adds Solarflare libefx-based network PMD.
>>
>> This version of the driver supports Solarflare SFN7xxx and SFN8xxx
>> families of 10/40 Gbps adapters.
>>
>> libefx is a platform-independen
On Thu, 24 Nov 2016 17:59:06 +0100, Olivier Matz
wrote:
> Hi,
>
> On Mon, 2016-11-21 at 09:59 +, Alejandro Lucero wrote:
> > From: Bert van Leeuwen
> >
> > Arrays inside rte_eth_stats have size=RTE_ETHDEV_QUEUE_STAT_CNTRS.
> > Some devices report more queues than that and this code blindly
On Mon, Dec 05, 2016 at 10:09:05AM +, Ananyev, Konstantin wrote:
> Hi Neilo,
>
> >
> > This commit introduces new rte_{le,be}{16,32,64}_t types and updates
> > rte_{le,be,cpu}_to_{le,be,cpu}_*() and network header structures
> > accordingly.
> >
> > Specific big/little endian types avoid unc
Current ixgbevf driver get max_rx_pktlen = 15872, but in fact PF supports
15872-byte jumbo frame and VF only supports 9728-byte jumbo frame. If VF is
running
DPDK driver and set frame_size > 9728 ,PF running kernel ixgbe driver will
report
an error and set VF failed.
This patch fixs DPDK ixgbevf
Current ixgbevf driver get max_rx_pktlen = 15872, but in fact PF supports
15872-byte jumbo frame and VF only supports 9728-byte jumbo frame. If VF is
running
DPDK driver and set frame_size > 9728 ,PF running kernel ixgbe driver will
report
an error and set VF failed.
This patch fixs DPDK ixgbevf
-Original Message-
From: Akhil Goyal [mailto:akhil.go...@nxp.com]
Sent: Monday, December 05, 2016 6:26 PM
To: dev@dpdk.org
Cc: thomas.monja...@6wind.com; eclan.dohe...@intel.com;
pablo.de.lara.gua...@intel.com; Hemant Agrawal ; Akhil
Goyal
Subject: [PATCH 0/8] Introducing NXP DPAA2 SEC
On Mon, Dec 05, 2016 at 10:27:00AM +, Wang, Zhihong wrote:
> > I like this function a lot, since it's really simple and straightforward!
> > Moreover, it performs better.
> >
> > But, I don't quite like how this function is proposed:
> >
> > - rte_movX are more like internal help functions th
On Sun, Dec 04, 2016 at 11:17:06PM +0100, Thomas Monjalon wrote:
> There was an option CONFIG_RTE_INSECURE_FUNCTION_WARNING (disabled by
> default), which prevents from using some libc functions:
> sprintf, snprintf, vsnprintf, strcpy, strncpy, strcat, strncat, sscanf,
> strtok, strsep and strlen.
> I like this function a lot, since it's really simple and straightforward!
> Moreover, it performs better.
>
> But, I don't quite like how this function is proposed:
>
> - rte_movX are more like internal help functions that should be used only
> in corresponding rte_memcpy.h file.
>
> - It's
On Sun, Dec 04, 2016 at 09:22:24AM +0200, Keren Hochman wrote:
> Hello,
> Is there a way to filter packets which received by dpdk kernel or libpcap
> according to ip mask and port ? I need to support fragmented ip packets and
> fragmented tcp packets.
> Can I use *Packet Classification* for this pu
On Mon, Dec 05, 2016 at 03:42:18PM +0530, Shreyansh Jain wrote:
> Hello Jerin,
Hello Shreyansh,
>
> On Sunday 04 December 2016 02:25 AM, Jerin Jacob wrote:
> > rte_eal_dev_init() is a misleading name.
> > It actually performs the driver->probe for vdev,
> > which is parallel to rte_eal_pci_probe
On 12/4/2016 4:47 PM, John McNamara wrote:
> Fix relative path between sphinx conf.py file and Nic table file
> to allow automatic build on ReadTheDocs.
>
> Fixes: 9db3f52126fb ("doc: generate NIC overview table from ini files")
>
> Signed-off-by: John McNamara
Tested-by: Ferruh Yigit
Hello Jerin,
On Sunday 04 December 2016 02:25 AM, Jerin Jacob wrote:
rte_eal_dev_init() is a misleading name.
It actually performs the driver->probe for vdev,
which is parallel to rte_eal_pci_probe.
Changed to rte_eal_vdev_probe for consistency and
moved the vdev specific probe to eal_common_vd
Hi Neilo,
>
> This commit introduces new rte_{le,be}{16,32,64}_t types and updates
> rte_{le,be,cpu}_to_{le,be,cpu}_*() and network header structures
> accordingly.
>
> Specific big/little endian types avoid uncertainty and conversion mistakes.
>
> No ABI change since these are simply typedefs
Hi,
I am working on dpdk box, with below system information, i am facing some
problem with ethernet, It's not getting populated properly.
dmesg output attached.
Please help to figure out the problem.
#uname -a
Linux dpdk-Minnowboard-Turbot-D0-PLATFORM 4.4.0-31-generic #50-Ubuntu SMP
Wed Jul 13 00
-Original Message-
From: Sexton, Rory
Sent: Sunday, December 4, 2016 9:55 PM
To: Wu, Jingjing
Cc: dev@dpdk.org; Marjanovic, Nemanja ; Mcnamara,
John ; Sexton, Rory
Subject: [PATCH v1] net/i40e: set no drop for traffic class
From: John McNamara
The default traffic class in i40e is s
On 12/05/2016 05:36 AM, Yuanhan Liu wrote:
On Sun, Dec 04, 2016 at 04:36:36PM +, Mcnamara, John wrote:
-Original Message-
From: Yuanhan Liu [mailto:yuanhan@linux.intel.com]
Sent: Thursday, December 1, 2016 7:07 AM
To: dev@dpdk.org
Cc: Thomas Monjalon ; Mcnamara, John
; Yuanh
On Thu, Dec 01, 2016 at 08:19:42PM -0500, Zhihong Wang wrote:
> This patch optimizes Vhost performance for large packets when the
> Mergeable Rx buffer feature is enabled. It introduces a dedicated
> memcpy function for vhost enqueue/dequeue to replace rte_memcpy.
>
> The reason is that rte_memcpy
67 matches
Mail list logo