On Thu, Jan 21, 2016 at 05:35:00PM +0200, Arnon Warshavsky wrote:
> Keith,
> For the record, on my end (can only speak for myself) this is not a real
> problem.
> I work around it by using a different theme and live with it happily ever
> after.
> I just provided the input since I encountered it.
On Thu, Jan 21, 2016 at 03:46:21PM +, Wiles, Keith wrote:
> It appears (if I compared the text correctly) the above only move a few
> trailing words to the next line, why?
I believe in trying to leave code / docs cleaner than I found them.
Most Markdown / ReStructured Text has a tradition of
On 2016/01/22 17:14, Xie, Huawei wrote:
> On 1/21/2016 7:09 PM, Tetsuya Mukawa wrote:
>> virtio: Extend virtio-net PMD to support container environment
>>
>> The patch adds a new virtio-net PMD configuration that allows the PMD to
>> work on host as if the PMD is in VM.
>> Here is new configuration
> > > Do you see a fundamental problem with parsing the strings to
> > > retrieve values?
> >
> > I think parsing strings is expensive CPU wise
>
> Parsing the strings can be done once at startup, and the index of the
> statistics in the array cached. When actually reading statistics, access
> of
2016-01-22 16:56, Ferruh Yigit:
> On Fri, Jan 22, 2016 at 05:31:45PM +0100, Thomas Monjalon wrote:
> > Hi Ferruh,
> >
> > Not commenting the implementation, just the method.
> >
> > 2016-01-22 16:00, Ferruh Yigit:
> > > This is slow data path communication implementation based on existing KNI.
>
Hello, everyone.
How about exposing stats according to IF-MIB?
Statistics to be exposed are - octets, unicast packets, multicast packets,
broadcast packets, errors and discards for both TX and RX.
These counters are basic and implemented by most of drivers.
All other driver-specific counters ca
2016-01-22 16:04, David Harton:
> I think parsing strings is expensive CPU wise
[...]
> wondering if something that is performance friendly for the user/application
> and flexible for the drivers is possible.
I think we need some numbers from experimentations and some requirements.
How many cycles
Hi Ferruh,
Not commenting the implementation, just the method.
2016-01-22 16:00, Ferruh Yigit:
> This is slow data path communication implementation based on existing KNI.
> Difference is: librte_kni converted into a PMD, kdp kernel module is almost
> same except all control path functionality re
On Fri, Jan 22, 2016 at 05:31:45PM +0100, Thomas Monjalon wrote:
> Hi Ferruh,
>
> Not commenting the implementation, just the method.
>
> 2016-01-22 16:00, Ferruh Yigit:
> > This is slow data path communication implementation based on existing KNI.
> > Difference is: librte_kni converted into a P
+Jay, (@all, please keep everybody in the CCs :)
> From: David Harton (dharton) [mailto:dharton at cisco.com]
> To: Van Haaren, Harry ; Thomas Monjalon
> > > xstats are driver agnostic and have a well-defined naming scheme.
> >
> > Indeed, described here:
> > http://dpdk.org/doc/guides/prog_guide/
On 2016/01/22 16:26, Xie, Huawei wrote:
> On 1/21/2016 7:08 PM, Tetsuya Mukawa wrote:
>> +static void
>> +phys_legacy_write16(struct virtio_hw *hw, uint16_t *addr, uint16_t val)
>> +{
>> +return outb_p((unsigned short)val,
>> +(unsigned short)(hw->io_base + (uint64_t)addr));
Move blacklist evaluation to rte_eal_pci_probe().
This way, rte_eal_pci_probe_one() (used by hotplug when attaching) now
accepts to probe devices that were blacklisted initially.
A new debug trace is added when skipping a device not part of a given
whitelist.
Signed-off-by: David Marchand
---
l
A device is linked to a driver at probe time.
When detaching, we should call this same driver detach() function and no
need for a driver lookup.
Signed-off-by: David Marchand
---
lib/librte_eal/common/eal_common_pci.c | 25 ++---
1 file changed, 10 insertions(+), 15 deletions
Same idea as a few commits before, no need to implement the same logic in
probe and detach functions.
Here, the driver matching is done by a helper, then probe / detach
functions are called respectively.
Signed-off-by: David Marchand
---
lib/librte_eal/common/eal_common_pci.c | 96 --
Indent previous commit, rename functions (internal and local functions do
not need rte_eal_ prefix).
Signed-off-by: David Marchand
---
lib/librte_eal/common/eal_common_pci.c | 106 -
1 file changed, 52 insertions(+), 54 deletions(-)
diff --git a/lib/librte_eal/co
Move pci id matching to a helper and reuse it in probe and detach
functions.
Signed-off-by: David Marchand
---
lib/librte_eal/common/eal_common_pci.c | 67 --
1 file changed, 23 insertions(+), 44 deletions(-)
diff --git a/lib/librte_eal/common/eal_common_pci.c
b
There is no use for pci_get_kernel_driver_by_path() apart recognising
kernel driver and fill kdrv field.
If driver parsing fails, report "none" driver rather than "unknown".
Signed-off-by: David Marchand
---
lib/librte_eal/linuxapp/eal/eal_pci.c | 48 ++-
1 file c
Those are the only fields that are explicitly set to 0 while the global
dev pointer is set to 0 a few lines before.
Signed-off-by: David Marchand
---
lib/librte_eal/linuxapp/eal/eal_pci.c | 9 ++---
1 file changed, 2 insertions(+), 7 deletions(-)
diff --git a/lib/librte_eal/linuxapp/eal/eal
Remove duplicate code by moving this to helpers in common.
Signed-off-by: David Marchand
---
lib/librte_eal/bsdapp/eal/eal_pci.c | 34 +---
lib/librte_eal/common/eal_common_pci.c | 70 -
lib/librte_eal/common/include/rte_pci.h | 24 +++
li
These lists can be initialized once and for all at build time.
With this, those lists are only manipulated in a common place
(and we could even make them private).
Signed-off-by: David Marchand
---
lib/librte_eal/bsdapp/eal/eal_pci.c| 3 ---
lib/librte_eal/common/eal_common_pci.c | 6 --
Before 2.2.0 release, while preparing for more changes in eal (and fixing
a problem reported by Roger M. [1]), I came up with this patchset that
tries to make the pci code more compact and easier to read.
I did limited testing, but this has been in my tree for quite some time
now, so sending this
Does anybody have an objection if I send a patch to remove "extern"
keywords in header files, the ones for function prototypes.
Regards,
ferruh
> > xstats are driver agnostic and have a well-defined naming scheme.
>
> Indeed, described here:
> http://dpdk.org/doc/guides/prog_guide/poll_mode_drv.html#extended-
> statistics-api
Thanks for sharing. I do think what is in the link is well thought out but it
also may not match how the applic
This patch provides slow data path communication to the Linux kernel.
Patch is based on librte_kni, and heavily re-uses it.
The main difference is librte_kni library converted into a PMD, to
provide ease of use for applications.
Now any application can use slow path communication without any upda
This kernel module is based on KNI module, but this one is stripped
version of it and only for data messages, no control functionality
provided.
FIFO implementation of the KNI is kept exact same, but ethtool related
code removed and virtual network management related code simplified.
This module
This is slow data path communication implementation based on existing KNI.
Difference is: librte_kni converted into a PMD, kdp kernel module is almost
same except all control path functionality removed and some simplification done.
Motivation is to simplify slow path data communication.
Now any a
On Fri, Jan 22, 2016 at 06:02:24PM +0300, Igor Ryzhov wrote:
> How about exposing stats according to IF-MIB?
>
> Statistics to be exposed are - octets, unicast packets, multicast packets,
> broadcast packets, errors and discards for both TX and RX.
>
> These counters are basic and implemented by
+ Harry
2016-01-22 14:40, David Harton:
> Hi Maryam,
>
> I'm not dictating they be re-added (although adding would be nice) but more
> important I'm trying to express an application view point rather than a
> driver view point.
>
> I completely understand how a driver wants to be able to adv
2016-01-22 14:18, Tahhan, Maryam:
> So what can be enabled again in struct rte_eth_stats from what was already
> there is the equivalent of:
> * rx_length_errors
> * rx_crc_errors
> * rx_missed_errors - the deprecation notice was removed for this field.
> * multicast
>
> What should be added in
> From: Thomas Monjalon [mailto:thomas.monjalon at 6wind.com]
> Subject: Re: [dpdk-dev] Future Direction for rte_eth_stats_get()
> + Harry
Hey all,
> xstats are driver agnostic and have a well-defined naming scheme.
Indeed, described here:
http://dpdk.org/doc/guides/prog_guide/poll_mode_drv.htm
Move these error logs and checks on detach capabilities in a common place.
Signed-off-by: David Marchand
---
Changes since v1:
- restore EINVAL error code for rte_eth_dev_(at|de)tach
lib/librte_ether/rte_ethdev.c | 77 ++-
1 file changed, 46 insertions(+)
We are in static functions and those passed arguments can't be NULL.
Signed-off-by: David Marchand
---
lib/librte_ether/rte_ethdev.c | 15 ---
1 file changed, 15 deletions(-)
diff --git a/lib/librte_ether/rte_ethdev.c b/lib/librte_ether/rte_ethdev.c
index ed971b4..cab74e0 100644
---
It was first a preparation step for future patchsets, but I am not sure what
will become of them, so sending this anyway since it does not hurt to clean
this now.
Changes since v1:
- rebased on HEAD (previous patchset was based on another patch I sent
separately)
- restored EINVAL error code for
> From: Thomas Monjalon [mailto:thomas.monjalon at 6wind.com]
> Sent: Friday, January 22, 2016 2:44 PM
> To: Tahhan, Maryam ; David Harton
> (dharton)
> Cc: dev at dpdk.org; olivier.matz at 6wind.com; Van Haaren, Harry
>
> Subject: Re: [dpdk-dev] Future Direction for rte_eth_stats_get()
>
> 2016
Hi Maryam,
I'm not dictating they be re-added (although adding would be nice) but more
important I'm trying to express an application view point rather than a driver
view point.
I completely understand how a driver wants to be able to advertise all the
stats they want to advertise to help th
Hi David
+ Olivier and Harry as contributors and advisors in the past on the stats and
stats API.
So I pulled the rtnl_link_stats64 from
http://lxr.free-electrons.com/source/include/uapi/linux/if_link.h#L41 and
crossed them with http://dpdk.org/dev/patchwork/patch/5842/ and
http://dpdk.org/br
Hi Amit,
On 1/20/2016 11:19 PM, Amit Tomer wrote:
> Hello,
>
>> For this case, please use --single-file option because it creates much more
>> than 8 fds, which can be handled by vhost-user sendmsg().
> Thanks, I'm able to verify it by sending ARP packet from container to
> host on arm64. But some
Hi Maryam,
Thanks for the pointer. I'll review the convo's.
Consider I have an application that uses many(all?) of the DPDK drivers and
their netmap counterparts depending on configuration. The user interface
provides a set of I/O stats to help debug I/O issues and that set is the same
regar
>-Original Message-
>From: dev [mailto:dev-bounces at dpdk.org] On Behalf Of Stephen Hemminger
>Sent: Friday, July 10, 2015 1:38 AM
>To: dev at dpdk.org
>Cc: Mike Davison ; Stephen Hemminger
>
>Subject: [dpdk-dev] [PATCH 1/2] mbuf: Add rte_pktmbuf_copy
>
>From: Stephen Hemminger
>
>Added
On Thu, Jan 21, 2016 at 06:36:00PM +0800, Wang Xiao W wrote:
> The new share code makes fm10k_msg_update_pvid_pf function static, so we can
> not refer to it now in fm10k_ethdev.c. The registered pf handler is almost the
> same as the default pf handler, removing it has no impact on mailbox.
>
> S
On 2016/01/22 11:07, Tan, Jianfeng wrote:
> Hi Tetsuya,
>
> On 1/22/2016 9:43 AM, Tan, Jianfeng wrote:
>> Hi Tetsuya,
>>
>> On 1/21/2016 7:07 PM, Tetsuya Mukawa wrote:
>>> This is a temporary patch to get EAL memory under 16T(1 << 44).
>>>
>>> The patch adds new EAL "--shm" option. If the option is
On 01/21/2016 12:51 PM, Ananyev, Konstantin wrote:
> Hi Panu,
>
>> -Original Message-
>> From: dev [mailto:dev-bounces at dpdk.org] On Behalf Of Panu Matilainen
>> Sent: Thursday, January 21, 2016 10:39 AM
>> To: Andralojc, WojciechX
>> Cc: dev at dpdk.org
>> Subject: Re: [dpdk-dev] [PATCH
> -Original Message-
> From: Ananyev, Konstantin
> Sent: Friday, January 22, 2016 11:05 AM
> To: Panu Matilainen; Andralojc, WojciechX
> Cc: dev at dpdk.org
> Subject: RE: [dpdk-dev] [PATCH v3] Patch introducing API to read/write Intel
> Architecture Model Specific Registers (MSR)...
>
> >
2015-12-21 10:38, Helin Zhang:
> PCIe feature of 'Extended Tag' is important for 40G performance.
> It adds its enabling during each port initialization, to ensure
> the high performance.
If it's so important, why the values are not documented?
Please start to fill a file doc/guides/nics/i40e.rst
2016-01-21 14:49, Zhe Tao:
> VEB switching feature for i40e is used to enable the switching between the
> VSIs connect to the virtual bridge. The old implementation is setting the
> virtual bridge mode as VEPA which is port aggregation. Enable the switching
> ability by setting the loop back mo
Hi David
Some of the stats were HW specific rather than generic stats that should be
exposed through rte_eth_stats and were migrated to the xstats API.
http://dpdk.org/ml/archives/dev/2015-June/019915.html. The naming was also not
generic enough to cover some of the drivers and in some cases wha
> -Original Message-
> From: Panu Matilainen [mailto:pmatilai at redhat.com]
> Sent: Friday, January 22, 2016 10:06 AM
> To: Ananyev, Konstantin; Andralojc, WojciechX
> Cc: dev at dpdk.org
> Subject: Re: [dpdk-dev] [PATCH v3] Patch introducing API to read/write Intel
> Architecture Model
Using iommu_present() to determine whether an IOMMU group is real or
fake has some problems. First, apparently Power systems don't
register an IOMMU on the device bus, so the groups and containers get
marked as noiommu and then won't bind to their actual IOMMU driver.
Second, I expect we'll run in
2016-01-21 20:02, Jan Viktorin:
> On Thu, 21 Jan 2016 12:57:10 +0100
> David Marchand wrote:
> > - if ((name == NULL) || (pci_dev == NULL))
> > - return -EINVAL;
>
> Do you use a kind of assert in DPDK? The patch looks OK, however, I
> would prefer something like
>
> assert_not
Hi Tetsuya,
On 1/22/2016 9:43 AM, Tan, Jianfeng wrote:
> Hi Tetsuya,
>
> On 1/21/2016 7:07 PM, Tetsuya Mukawa wrote:
>> This is a temporary patch to get EAL memory under 16T(1 << 44).
>>
>> The patch adds new EAL "--shm" option. If the option is specified,
>> EAL will allocate one file from hugetl
Hello,
On Fri, Jan 22, 2016 at 3:05 AM, Wu, Jingjing wrote:
> Hi, David
>
> We also noticed this issue before. And we are planning to fix this issue.
> And the patch for i40e is ready:
> http://dpdk.org/dev/patchwork/patch/9832/
> http://dpdk.org/dev/patchwork/patch/9833/
>
> The solution is that
On Fri, Jan 22, 2016 at 9:22 AM, Van Haaren, Harry <
harry.van.haaren at intel.com> wrote:
> > From: Thomas Monjalon [mailto:thomas.monjalon at 6wind.com]
> > Subject: Re: [dpdk-dev] Future Direction for rte_eth_stats_get()
>
> > + Harry
>
> Hey all,
>
> > xstats are driver agnostic and have a wel
Hi Tetsuya,
On 1/21/2016 7:07 PM, Tetsuya Mukawa wrote:
> This is a temporary patch to get EAL memory under 16T(1 << 44).
>
> The patch adds new EAL "--shm" option. If the option is specified,
> EAL will allocate one file from hugetlbfs. This memory is for sharing
> memory between DPDK applicaiton
On Thu, Jan 21, 2016 at 09:02:41AM +, Van Haaren, Harry wrote:
> > From: Qiu, Michael
> > Sent: Thursday, January 21, 2016 6:14 AM
> > To: Van Haaren, Harry ; david.marchand at
> > 6wind.com
> > Cc: dev at dpdk.org
> > Subject: Re: [dpdk-dev] [PATCH] eal: add function to check if primary proc
It adds the setting VLAN ether type of single VLAN, inner and
outer VLAN. Single VLAN is treated as inner VLAN as usual.
Signed-off-by: Helin Zhang
---
drivers/net/i40e/i40e_ethdev.c | 55 +++---
1 file changed, 51 insertions(+), 4 deletions(-)
diff --git a/d
In order to set ether type of VLAN for single VLAN, inner
and outer VLAN, the VLAN type as an input parameter is added
to 'rte_eth_dev_set_vlan_ether_type()'.
In addition, corresponding changes in e1000, ixgbe and i40e are
also added.
Signed-off-by: Helin Zhang
---
app/test-pmd/cmdline.c
It adds setting ether type of single VLAN(inner VLAN) and outer
VLAN for i40e. For ixgbe and e1000/igb, as the external API changed,
it supports setting single VLAN(inner VLAN) only.
Helin Zhang (2):
ethdev: add vlan type for setting ether type
i40e: add VLAN ether type config
app/test-pmd/c
On Fri, 22 Jan 2016 13:40:44 +
"Mrzyglod, DanielX T" wrote:
>
>
> >-Original Message-
> >From: dev [mailto:dev-bounces at dpdk.org] On Behalf Of Stephen Hemminger
> >Sent: Friday, July 10, 2015 1:38 AM
> >To: dev at dpdk.org
> >Cc: Mike Davison ; Stephen Hemminger
> >
> >Subject: [d
This patch implemented the ops of adding and removing mac
address in i40evf driver. Functions are assigned like:
.mac_addr_add= i40evf_add_mac_addr,
.mac_addr_remove = i40evf_del_mac_addr,
To support multiple mac addresses setting, this patch also
extended the mac addresses adding and dele
On 01/21/2016 05:03 PM, Wiles, Keith wrote:
> On 1/21/16, 2:46 AM, "Panu Matilainen" wrote:
>
>> On 01/20/2016 06:26 PM, Wiles, Keith wrote:
>>> On 1/20/16, 12:32 AM, "dev on behalf of Matthew Hall" >> dpdk.org on behalf of mhall at mhcomputing.net> wrote:
>>>
Hello,
Since the pktge
Hello,
On Thu, Jan 21, 2016 at 7:42 PM, Thomas Monjalon
wrote:
> 2016-01-21 19:06, David Marchand:
>> On Thu, Jan 21, 2016 at 4:38 PM, Jan Viktorin
>> wrote:
>> > This change modifies the return value from -EINVAL to -1. I don't know
>> > whether is this an issue but it looks suspicious.
>>
>>
On 1/21/2016 7:09 PM, Tetsuya Mukawa wrote:
> virtio: Extend virtio-net PMD to support container environment
>
> The patch adds a new virtio-net PMD configuration that allows the PMD to
> work on host as if the PMD is in VM.
> Here is new configuration for virtio-net PMD.
> - CONFIG_RTE_LIBRTE_VIR
On 1/21/2016 7:08 PM, Tetsuya Mukawa wrote:
> +static void
> +phys_legacy_write16(struct virtio_hw *hw, uint16_t *addr, uint16_t val)
> +{
> + return outb_p((unsigned short)val,
> + (unsigned short)(hw->io_base + (uint64_t)addr));
outb_p -> outw_p
> +}
> +
> +static void
>
Hi, David
We also noticed this issue before. And we are planning to fix this issue.
And the patch for i40e is ready:
http://dpdk.org/dev/patchwork/patch/9832/
http://dpdk.org/dev/patchwork/patch/9833/
The solution is that: PF reset interrupt will be captured by DPDK VF, then DPDK
Call the applica
Hi
> */
> static void
> -i40e_hw_init(struct i40e_hw *hw)
> +i40e_hw_init(struct rte_eth_dev *dev)
> {
> + struct i40e_hw *hw = I40E_DEV_PRIVATE_TO_HW(dev->data-
> >dev_private);
> +
> + i40e_enable_extended_tag(dev);
If the function i40e_enable_extended_tag is only used here without
C
65 matches
Mail list logo