> Hi Dong,
>
>> -Original Message-
>> From: Wang Dong [mailto:dong.wang.pro at hotmail.com]
>> Sent: Saturday, May 09, 2015 11:24 AM
>> To: Ananyev, Konstantin; dev at dpdk.org
>> Subject: Re: [dpdk-dev] [PATCH] librte_eal:Using compiler memory barrier for
>> IA processor's rte_wmb/rte_r
2015-04-28 09:36, Stephen Hemminger:
> This set of patches starts out with fixing a regression where
> uio_pci_generic broke link state interrupt, then adds better
> management of PCI config space.
>
> Will leave up to document writers to update various release
> notes and API manuals as they see
2015-05-12 19:04, Bruce Richardson:
> drivers/e1000/e1000/e1000_hw.h | 1026
As explained in a previous comment,
http://dpdk.org/ml/archives/dev/2015-May/017509.html
I think this path would be better:
drivers/net/e1000/base/e1000_hw.h
On 5/12/15, 8:07 AM, "Thomas Monjalon" wrote:
>2015-05-01 09:29, Keith Wiles:
>> NO_AUTOLIBS is not required as it was not used or defined in the config
>>files.
>>
>> Signed-off-by: Keith Wiles
>> ---
>> mk/rte.app.mk | 5 -
>> 1 file changed, 5 deletions(-)
>
>Thanks Keith for trying t
Hi Pravin, Kevin, and others!
Many thanks for your comments.
>> This approach works fine on the real hardware but makes some issues when we
>> run openvswitch/dpdk inside the virtual machine. I tried both emulated
>> e1000 NIC and virtio NIC and neither of them worked just from the box.
>> Emulate
Hi Sergio,
On 05/08/2015 06:37 PM, Sergio Gonzalez Monroy wrote:
> Please NOTE that this series is meant to illustrate an idea/approach and start
> discussion on the topic.
>
> Current implemetation allows reserving/creating memzones but not the opposite
> (unreserve/delete). This affects mempools
Hi Linhaifeng,
On Tue, May 12, 2015 at 1:13 AM, Linhaifeng wrote:
> Hi, Ravi Kerur
>
> On 2015/5/9 5:19, Ravi Kerur wrote:
> > Preliminary results on Intel(R) Core(TM) i7-4790 CPU @ 3.60GHz, Ubuntu
> > 14.04 x86_64 shows comparisons using AVX/SSE instructions taking 1/3rd
> > CPU ticks for 16,
On Mon, May 11, 2015 at 3:29 PM, Don Provan wrote:
> I probably shouldn't stick my nose into this, but I can't help myself.
>
> An experienced programmer will tend to ignore the documentation for
> a routine named "blahblah_memcmp" and just assume it functions like
> memcmp. Whether or not there'
On 2015-05-12 16:36, Olivier MATZ wrote:
> Hi Pawel,
>
> On 05/12/2015 01:10 PM, Pawel Wodkowski wrote:
>> This patch adds the ability to process console input in the same thread
>> as packet processing by using poll() function.
>>
>> Signed-off-by: Pawel Wodkowski
>> [...]
>> --- a/lib/librte_cmd
Since the PMDs have moved to the drivers directory, update the docs that
cover the source code organisation of DPDK
Signed-off-by: Bruce Richardson
---
doc/guides/prog_guide/source_org.rst | 37 +---
1 file changed, 26 insertions(+), 11 deletions(-)
diff --git a/
Update the directory list in the GSG to reflect recent changes of PMDs
to the drivers directory
Signed-off-by: Bruce Richardson
---
doc/guides/linux_gsg/build_dpdk.rst | 8 +---
1 file changed, 5 insertions(+), 3 deletions(-)
diff --git a/doc/guides/linux_gsg/build_dpdk.rst
b/doc/guides/li
Following the move of the PMDs to the drivers directory, update the
maintainers file appropriately.
Signed-off-by: Bruce Richardson
---
MAINTAINERS | 28 ++--
1 file changed, 14 insertions(+), 14 deletions(-)
diff --git a/MAINTAINERS b/MAINTAINERS
index f53b87e..2d12e65
Move xenvirt PMD to drivers directory
Signed-off-by: Bruce Richardson
---
drivers/Makefile | 2 +-
drivers/xenvirt/Makefile | 62 ++
drivers/xenvirt/rte_eth_xenvirt.c | 714 +
drivers/xenvirt/rte_
Move vmxnet3 PMD to drivers directory
Signed-off-by: Bruce Richardson
---
drivers/Makefile |2 +-
drivers/vmxnet3/Makefile | 84 ++
drivers/vmxnet3/rte_pmd_vmxnet3_version.map|4 +
drivers/vmxnet3/vmxnet3/README
Move virtio PMD to drivers directory
Signed-off-by: Bruce Richardson
---
drivers/Makefile |2 +-
drivers/virtio/Makefile | 60 +
drivers/virtio/rte_pmd_virtio_version.map|4 +
drivers/virtio/virtio_ethdev.c
Move ring PMD to drivers directory
Signed-off-by: Bruce Richardson
---
drivers/Makefile | 2 +-
drivers/ring/Makefile| 61 +++
drivers/ring/rte_eth_ring.c | 579 +++
drivers/ring/rte_eth_ring.h
Move pcap pmd to drivers directory
Signed-off-by: Bruce Richardson at intel.com
---
drivers/Makefile | 2 +-
drivers/pcap/Makefile| 63 ++
drivers/pcap/rte_eth_pcap.c | 977 +++
drivers/pcap/rte_pmd_pc
Move null PMD to drivers directory
Signed-off-by: Bruce Richardson
---
drivers/Makefile | 2 +-
drivers/null/Makefile| 62 +++
drivers/null/rte_eth_null.c | 585 +++
drivers/null/rte_pmd_null_version.
move mlx4 PMD to drivers directory
Signed-off-by: Bruce Richardson
---
drivers/Makefile |2 +-
drivers/mlx4/Makefile| 121 +
drivers/mlx4/mlx4.c | 4686 ++
drivers/mlx4/mlx4.h
move ixgbe PMD to drivers directory
Signed-off-by: Bruce Richardson
---
drivers/Makefile |2 +-
drivers/ixgbe/Makefile | 126 +
drivers/ixgbe/ixgbe/README | 67 +
drivers/ixgbe/ixgbe/ixgbe_82598.c | 143
move i40e PMD to drivers directory
Signed-off-by: Bruce Richardson
---
drivers/Makefile |2 +-
drivers/i40e/Makefile| 105 +
drivers/i40e/i40e/i40e_adminq.c | 1084 +
drivers/i40e/i40e/i40e_adminq.h | 157 +
move fm10k PMD to drivers directory
Signed-off-by: Bruce Richardson
---
drivers/Makefile |2 +-
drivers/fm10k/Makefile | 102 ++
drivers/fm10k/base/fm10k_api.c | 341
drivers/fm10k/base/fm10k_api.h |
move enic PMD to drivers directory
Signed-off-by: Bruce Richardson
---
drivers/Makefile |2 +-
drivers/enic/LICENSE | 27 +
drivers/enic/Makefile| 71 ++
drivers/enic/enic.h | 200 +
Move e1000 pmd to drivers directory
Signed-off-by: Bruce Richardson
---
drivers/Makefile |2 +-
drivers/e1000/Makefile | 99 +
drivers/e1000/e1000/README | 39 +
drivers/e1000/e1000/e1000_80003es2lan.c| 151
Move bonded ethdev pmd to drivers
Signed-off-by: Bruce Richardson
---
doc/api/doxy-api.conf |2 +-
drivers/Makefile |2 +-
drivers/bonding/Makefile | 68 +
drivers/bonding/rte_eth_bond.h
move af_packet pmd to drivers directory
Signed-off-by: Bruce Richardson
---
drivers/Makefile | 2 +-
drivers/af_packet/Makefile | 64 ++
drivers/af_packet/rte_eth_af_packet.c | 847 +
drivers/af_packet/
Add a new top-level drivers directory to which all PMDs will be moved
for easier maintenance of both lib folder and drivers themselves. This
new directory is a dependency of all the apps in the app folder, so
the makefiles for each app are updated.
Signed-off-by: Bruce Richardson
---
GNUmakefile
In the Makefiles for the PMDs, the paths to the files are often
specified using the full path from $(RTE_SDK) variable. These paths can
be shortened, and make more flexible in case of a future path change by
specifying the paths using $(SRCDIR) instead.
Signed-off-by: Bruce Richardson
---
lib/li
As covered previously in an RFC, this patchset creates a new top-level drivers
folder and moves the PMDs into it. Moving the drivers involves a lot of code -
too big for a single patch, so each driver is moved separately in its own
patchset.
Some doc updates are done as part of this patchset - ba
Hi Keith,
On 05/12/2015 01:14 AM, Keith Wiles wrote:
> Trying to simplify the ifdefs in rte.app.mk to make the code
> more readable and maintainable by moving LDLIBS variable to use
> the same style as LDLIBS-y being used in the rest of the code.
>
> Added a new variable called
Hi Sergio,
On 05/06/2015 06:10 PM, Gonzalez Monroy, Sergio wrote:
> Hi,
>
> I was wondering about the use case of rte_memzone_reserve_ APIs with
> len=0.
>
> From the docs (http://dpdk.org/doc/api/rte__memzone_8h.html):
> len The size of the memory to be reserved. If it is 0, the
> b
2015-05-07 03:37, Wiles, Keith:
> On 5/6/15, 4:49 PM, "Wiles, Keith" wrote:
> >On 5/6/15, 2:37 PM, "Marc Sune" wrote:
> >>On 06/05/15 23:09, Thomas Monjalon wrote:
> >>> Previously, there was a discussion about the contribution rules and
> >>>tools:
> >>> http://dpdk.org/ml/archives/dev/2015-Ma
Hi Pawel,
On 05/12/2015 01:10 PM, Pawel Wodkowski wrote:
> This patch adds the ability to process console input in the same thread
> as packet processing by using poll() function.
>
> Signed-off-by: Pawel Wodkowski
> [...]
> --- a/lib/librte_cmdline/cmdline.h
> +++ b/lib/librte_cmdline/cmdline.h
Hi, Ravi Kerur
On 2015/5/9 5:19, Ravi Kerur wrote:
> Preliminary results on Intel(R) Core(TM) i7-4790 CPU @ 3.60GHz, Ubuntu
> 14.04 x86_64 shows comparisons using AVX/SSE instructions taking 1/3rd
> CPU ticks for 16, 32, 48 and 64 bytes comparison. In addition,
I had write a program to test rte_m
Self NACK - misconfigured git - wrong email address :(
I will resend this.
> -Original Message-
> From: dev [mailto:dev-bounces at dpdk.org] On Behalf Of Pawel Wodkowski
> Sent: Tuesday, May 12, 2015 1:10 PM
> To: dev at dpdk.org
> Subject: [dpdk-dev] [PATCH 0/2] cmdline: add polling mode
Hi Stephen,
2015-05-11 10:07, Stephen Hemminger:
> This is 3rd rev of DPDK changes to QoS scheduler.
> The change from last revision was to fix the example and fix whitespace.
>
> Stephen Hemminger (6):
> rte_sched: make RED optional at runtime
> rte_sched: expand scheduler hierarchy for more
2015-05-01 09:29, Keith Wiles:
> NO_AUTOLIBS is not required as it was not used or defined in the config files.
>
> Signed-off-by: Keith Wiles
> ---
> mk/rte.app.mk | 5 -
> 1 file changed, 5 deletions(-)
Thanks Keith for trying to clean it, but removing half of an obsolete feature
is not a
> -Original Message-
> From: Richardson, Bruce
> Sent: Tuesday, May 12, 2015 2:16 PM
> To: dev at dpdk.org
> Cc: Chilikin, Andrey; Ananyev, Konstantin; Richardson, Bruce
> Subject: [PATCH] l3fwd: make destination mac address configurable
>
> Add a command-line parameter to l3fwd, to allo
2015-05-05 11:14, Simon K?gstr?m:
> On 2015-05-05 11:00, Olivier MATZ wrote:
> > On 05/05/2015 11:00 AM, Olivier Matz wrote:
> >> The script relpath.sh return the relative path of the first directory
> >> from the second directory. It is used to generate relative symlinks,
> >> which can be useful
Add a command-line parameter to l3fwd, to allow the user to specify the
destination mac address for each ethernet port used.
Signed-off-by: Andrey Chilikin
Signed-off-by: Bruce Richardson
---
examples/l3fwd/main.c | 98 +--
1 file changed, 64 inse
Signed-off-by: Keith Wiles
---
doc/build-sdk-quick.txt | 1 +
doc/guides/prog_guide/dev_kit_build_system.rst | 2 ++
doc/guides/prog_guide/dev_kit_root_make_help.rst | 2 +-
3 files changed, 4 insertions(+), 1 deletion(-)
diff --git a/doc/build-sdk-quick.txt b/doc/buil
Simplify the ifdefs in rte.app.mk to make the code more
readable and maintainable by moving LDLIBS variable to
use the same style as LDLIBS-y being used in the rest
of the code. The new internal variable _LDLIBS should
not be used outside of the rte.app.mk file.
Signed-off-by: Keith Wiles
---
mk
Hi
I'm using netperf to check the performance and throughput of the DPDK
application that I'd developed.
For testing the above I need to run netperf on the DPDK bound interface.
But I'm not able to find the correct option for running the netperf on the
DPDK bound interface as the interface is no l
Hello,
We're using dpdk with with the ixgbevf driver on an AWS (Xen hypervisor)
instance. We use the NIC to drive jumbo packets at high throughput.
Occasionally, the vf experiences a non-recoverable TX hang. Specifically,
all descriptors in the TX queue are used up - and remain in this state. A
This patch adds the ability to process console input in the same thread
as packet processing by using poll() function.
Signed-off-by: Pawel Wodkowski
---
lib/librte_cmdline/cmdline.c | 35 ++
lib/librte_cmdline/cmdline.h | 1 +
lib/librte_
When including only some of library headers some definitions
are missing and build fails.
Signed-off-by: Pawel Wodkowski
---
lib/librte_cmdline/cmdline.h| 3 +++
lib/librte_cmdline/cmdline_rdline.h | 1 +
lib/librte_cmdline/cmdline_vt100.h | 2 ++
3 files changed, 6 insertions(+)
diff
This patchset adds the ability to process console input in the same thread
as packet processing by using poll() function and fixes some minor issues.
Pawel Wodkowski (2):
cmdline: fix missing include files
cmdline: add polling mode for command line
lib/librte_cmdline/cmdline.c
> > pcap_rx_queue/pcap_tx_queue should store it's own copy of name/type
> > values, not the pointer to temporary allocated space.
> >
> > Signed-off-by: Konstantin Ananyev
>
> Acked-by: John Mcnamara
Applied, thanks
Please note the new name for this commit:
pcap: fix storage of name a
Changed name to something more meaningful,
and mark rte_jhash2 as deprecated.
Signed-off-by: Pablo de Lara
---
app/test/test_func_reentrancy.c |2 +-
app/test/test_hash.c|4 ++--
lib/librte_hash/rte_jhash.h | 17 +++--
3 files changed, 18 insertions(+), 5 de
rte_jhash is basically like _rte_jhash_2hashes but it returns only 1 hash,
instead of 2.
In order to remove duplicated code, rte_jhash calls _rte_jhash_2hashes,
passing 0 as the second seed and returning just the first hash value.
(performance penalty is negligible)
The same is done with rte_jhas
With the jhash update, two new functions were introduced:
- rte_jhash_2hashes: Same as rte_jhash, but takes two seeds
and return two hashes (uint32_ts)
- rte_jhash2_2hashes: Same as rte_jhash2, but takes two seeds
and return two hashes (uint32_ts)
Signed
Jenkins hash function was developed originally in 1996,
and was integrated in first versions of DPDK.
The function has been improved in 2006,
achieving up to 60% better performance, compared to the original one.
This patch integrates that code into the rte_jhash library.
Signed-off-by: Pablo de L
Cycles per hash calculation were measured per single operation.
It is much more accurate to run several iterations between measurements
and divide by number of iterations.
Signed-off-by: Pablo de Lara
---
app/test/test_hash_func_perf.c | 18 +-
1 files changed, 9 insertions(+),
This patch moves hash function performance tests to a separate file,
so user can check performance of the existing hash functions quicker,
without having to run all the other hash operation performance tests,
which takes some time.
Signed-off-by: Pablo de Lara
---
app/test/Makefile
Jenkins hash function was developed originally in 1996,
and was integrated in first versions of DPDK.
The function has been improved in 2006,
achieving up to 60% better performance, compared to the original one.
This patchset updates the current jhash in DPDK,
including two new functions that gene
Hi Changchun,
Why the title begins with virtio for a patch on vhost?
Could you rephrase it in a positive form?
2015-05-04 14:26, Ouyang Changchun:
> Vring enqueue need consider the 2 cases:
> 1. Vring descriptors chained together, the first one is for virtio header,
> the rest are for real data
> -Original Message-
> From: Pawel Wodkowski [mailto:pwodkowx at stargo]
> Sent: Tuesday, May 12, 2015 12:10 PM
> To: dev at dpdk.org
> Cc: Dumitrescu, Cristian; Jastrzebski, MichalX K
> Subject: [PATCH 0/2] cmdline: add polling mode for command line
>
> This patchset adds the ability to
On Tue, May 12, 2015 at 12:02:32PM +0100, Pablo de Lara wrote:
> Jenkins hash function was developed originally in 1996,
> and was integrated in first versions of DPDK.
> The function has been improved in 2006,
> achieving up to 60% better performance, compared to the original one.
>
> This patchs
> Minor fix for the referring of a pointer when debug and dump is enabled.
> The original commit is: 72ec8d77
>
> Signed-off-by: Changchun Ouyang
Applied, thanks
This bug was not seen before because it was disabled:
examples/vhost/main.h: //#define DEBUG
That's why we must avoid putting some c
On Mon, May 11, 2015 at 10:31:04AM -0700, Stephen Hemminger wrote:
> On Mon, 11 May 2015 12:54:54 +
> Neil Horman wrote:
>
> > On Thu, May 07, 2015 at 04:25:32PM -0700, Stephen Hemminger wrote:
> > > From: Stephen Hemminger
> > >
> > > Some drivers need ability to access PCI config (for exa
On 5/11/2015 11:00 PM, Stephen Hemminger wrote:
> On Mon, 11 May 2015 13:31:04 +0800
> "Liang, Cunming" wrote:
>
>>> Since MSI-X vectors are limited on many hardware platforms, this whole API
>>> should be changed so that max_intr is based on number of rx_queues actually
>>> used by the applicat
Hi Nissim
It seems that our validation guys here can reproduce it in our lab. I will
check that soon later, and update you later.
Thank you very much for the good finding!
Regards,
Helin
> -Original Message-
> From: Nissim Nisimov [mailto:NissimN at Radware.com]
> Sent: Monday, May 11,
Hi, thomas
What about this patch?
Thanks,
Michael
On 4/16/2015 4:09 PM, Chen, Jing D wrote:
> Hi,
>
>> -Original Message-
>> From: Michael Qiu [mailto:qiudayu at cn.ibm.com]
>> Sent: Tuesday, April 14, 2015 5:25 PM
>> To: dev at dpdk.org
>> Cc: Chen, Jing D; Qiu, Michael
>> Subject: [PAT
On 12/05/15 02:28, Marc Sune wrote:
>
>
> On 12/05/15 01:18, Paul Emmerich wrote:
>> Found a really simple solution that almost restores the original
>> performance: just add a prefetch on alloc. For some reason, I assumed
>> that this was already done since the troublesome commit I
>> investi
On 12/05/15 01:18, Paul Emmerich wrote:
> Found a really simple solution that almost restores the original
> performance: just add a prefetch on alloc. For some reason, I assumed
> that this was already done since the troublesome commit I investigated
> mentioned something about prefetching...
Added speed capabilities to all pmds supporting physical NICs:
* e1000
* ixgbe
* i40
* mlx4
* fm10k
This commit should be revised to ensure accuracy. It is mostly
untested (HW not available).
Signed-off-by: Marc Sune
---
lib/librte_pmd_e1000/em_ethdev.c| 6 ++
lib/librte_pmd_e1000/igb
Added constants and bitmap to struct rte_eth_dev_info to be used by PMDs.
Signed-off-by: Marc Sune
---
lib/librte_ether/rte_ethdev.h | 24
1 file changed, 24 insertions(+)
diff --git a/lib/librte_ether/rte_ethdev.h b/lib/librte_ether/rte_ethdev.h
index 4648290..05f6e88
The current rte_eth_dev_info abstraction does not provide any mechanism to
know the supported speed(s) of an ethdev.
For some drivers (e.g. ixgbe), an educated guess can be done based on the
driver's name (driver_name in rte_eth_dev_info), see:
http://dpdk.org/ml/archives/dev/2013-August/000412.h
Found a really simple solution that almost restores the original
performance: just add a prefetch on alloc. For some reason, I assumed
that this was already done since the troublesome commit I investigated
mentioned something about prefetching... I guess the commit referred to
the hardware pref
this improves the throughput of a simple tx-only application by 11% in
the full-featured ixgbe tx path and by 14% in the simple tx path.
---
lib/librte_mbuf/rte_mbuf.h | 1 +
1 file changed, 1 insertion(+)
diff --git a/lib/librte_mbuf/rte_mbuf.h b/lib/librte_mbuf/rte_mbuf.h
index ab6de67..f6895b4
Paul Emmerich:
> I naively tried to move the pool pointer into the first cache line in
> the v2.0.0 tag and the performance actually decreased, I'm not yet sure
> why this happens. There are probably assumptions about the cacheline
> locations and prefetching in the code that would need to be adjus
71 matches
Mail list logo