[dpdk-dev] IGB_UIO port unbinding

2014-04-10 Thread Prashant Upadhyaya
Hi, There was a usecase with ESXi VMXNET3 NIC where I had to use this parameter set to Y to make it work. So kindly ensure that the initialization of vmxnet3 NIC is not vulnerable. Regards -Prashant -Original Message- From: dev [mailto:dev-boun...@dpdk.org] On Behalf Of Thomas Monjalon

[dpdk-dev] Intel I350 T2 drops packets

2014-04-10 Thread sabu kurian
My custom program works perfect inside a VM and using an unsupported NIC card. But the same fails on the host machine that has I350 T2 NIC card (2 ports). Should I need to install the driver for I350 for use with Intel DPDK ?

[dpdk-dev] [PATCH 19/19] pmd: Not having any pci dev pmds shouldn't be fatal

2014-04-10 Thread Neil Horman
Since we support non-pci pmds, we shouldn't return a fatal error if we didn't load any pmds, as we may just be using a non-pci pmd Signed-off-by: Neil Horman --- lib/librte_ether/rte_ethdev.c | 4 +++- 1 file changed, 3 insertions(+), 1 deletion(-) diff --git a/lib/librte_ether/rte_ethdev.c b/l

[dpdk-dev] [PATCH 18/19] vmxnet3: move to using PMD_INIT macro

2014-04-10 Thread Neil Horman
Move teh vmxnet3 pmd to use the PMD_INIT macro Signed-off-by: Neil Horman --- lib/librte_ether/rte_ethdev.c | 13 - lib/librte_ether/rte_ethdev.h | 10 -- lib/librte_pmd_vmxnet3/vmxnet3_ethdev.c | 5 - mk/rte.app.mk | 3 +--

[dpdk-dev] [PATCH 17/19] virtio: Move to using PMD_INIT macro

2014-04-10 Thread Neil Horman
Move the virtio pmd to make use of the PMD_INIT macro Signed-off-by: Neil Horman --- lib/librte_ether/rte_ethdev.c | 7 --- lib/librte_ether/rte_ethdev.h | 9 - lib/librte_pmd_virtio/virtio_ethdev.c | 6 +- mk/rte.app.mk | 3 ++- 4 files ch

[dpdk-dev] [PATCH 16/19] ixgbe: move ixgbe[vf] pmd's to use PMD_INIT macro

2014-04-10 Thread Neil Horman
Move the ixgbe and ixgbevf pmds to use the PMD_INIT macro Signed-off-by: Neil Horman --- examples/dpdk_qat/main.c| 4 examples/vmdq_dcb/main.c| 2 +- lib/librte_ether/rte_ethdev.c | 11 --- lib/librte_ether/rte_ethdev.h | 18 --

[dpdk-dev] [PATCH 15/19] em: move em/e1000 pmd to use PMD_INIT macro

2014-04-10 Thread Neil Horman
Modify the em pmd to use the PMD_INIT macro Signed-off-by: Neil Horman --- lib/librte_ether/rte_ethdev.c| 7 --- lib/librte_ether/rte_ethdev.h| 9 - lib/librte_pmd_e1000/em_ethdev.c | 5 - mk/rte.app.mk| 2 ++ 4 files changed, 6 insertions(+), 17 delet

[dpdk-dev] [PATCH 14/19] igbvf: move igbvf pmd to use PMD_INIT macro

2014-04-10 Thread Neil Horman
Removed references to core library so that it can be linked in whenever needed Signed-off-by: Neil Horman --- lib/librte_ether/rte_ethdev.c | 7 --- lib/librte_ether/rte_ethdev.h | 9 - lib/librte_pmd_e1000/igb_ethdev.c | 3 ++- 3 files changed, 2 insertions(+), 17 deletions(

[dpdk-dev] [PATCH 13/19] igb: Convert PMD to use new PMD_INIT macro

2014-04-10 Thread Neil Horman
Use the PMD init macro to allow separation of the pmd from the rest of the dpdk Signed-off-by: Neil Horman --- examples/dpdk_qat/main.c | 8 +++- lib/librte_ether/rte_ethdev.c | 4 lib/librte_ether/rte_ethdev.h | 9 - lib/librte_pmd_e1000/igb_ethdev.c | 5 -

[dpdk-dev] [PATCH 12/19] pmd: Add PMD_INIT macro for use in pci based PMDs

2014-04-10 Thread Neil Horman
Like their non-pci counterparts, the PMD_INIT macro can be used by pci based PMD's to register an init routine without having the core libraries reference symbols in them directly. Signed-off-by: Neil Horman --- lib/librte_eal/common/include/rte_pmd.h | 9 +++ lib/librte_ether/rte_ethdev.c

[dpdk-dev] [PATCH 11/19] pmd: Move rte_pmd_init_all to be non-inline

2014-04-10 Thread Neil Horman
Organizational change in support of doing dynamic init routine registration Signed-off-by: Neil Horman --- lib/librte_ether/rte_ethdev.c | 52 ++ lib/librte_ether/rte_ethdev.h | 53 +-- 2 files changed, 53 insertions

[dpdk-dev] [PATCH 10/19] make: include whole archive on static link

2014-04-10 Thread Neil Horman
This happens automatically on dyanmic linking, but when linking an archive we need to to include the whole archive to make sure we call all the constructors. Not doing this causes them to be discarded due to the fact theres no symbolic reference connecting the pmds to the application. Signed-off-b

[dpdk-dev] [PATCH 09/19] testpmd: only link pcap pmd when statically linking

2014-04-10 Thread Neil Horman
when doing a static link, we need to add -lpacp to testpmd because it will need to resolve those symbols when it links in librte_pmd_pcap.a Signed-off-by: Neil Horman --- mk/rte.app.mk | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/mk/rte.app.mk b/mk/rte.app.mk index 0499050

[dpdk-dev] [PATCH 08/19] test: fix test app to dynamically link pmd_pcap when needed

2014-04-10 Thread Neil Horman
the test application calls functions in the pmd_pcap driver directly. We should fix this properly, but for now just link in the library Signed-off-by: Neil Horman --- mk/rte.app.mk | 4 +++- 1 file changed, 3 insertions(+), 1 deletion(-) diff --git a/mk/rte.app.mk b/mk/rte.app.mk index d6fdf9

[dpdk-dev] [PATCH 07/19] pmd: remove dead code

2014-04-10 Thread Neil Horman
Now that we've converted the available PMD drivers to use the PMD_INIT_NONPCI macro, we can remove the rest of the old init code Signed-off-by: Neil Horman --- lib/librte_eal/common/eal_common_nonpci_devs.c | 34 +- 1 file changed, 1 insertion(+), 33 deletions(-) diff --

[dpdk-dev] [PATCH 06/19] xenvert: Convert xenvirt pmd to use PMD_INIT_NONPCI macro

2014-04-10 Thread Neil Horman
Convert the xenvirt driver to use the PMD_INIT_NONPCI macro so that we can break the linkages between it and the core library to avoid unnneded loading when built as a DSO Signed-off-by: Neil Horman --- lib/librte_eal/common/eal_common_nonpci_devs.c | 9 - lib/librte_pmd_xenvirt/Makefile

[dpdk-dev] [PATCH 05/19] ring: convert the ring pmd driver to use the PMD_INIT_NONPCI macro

2014-04-10 Thread Neil Horman
Separate the ring pmd from calls within the core eal library so that it will not be loaded unless needed (or compiled in statically) Note: The demo test application calls directly into the ring pmd driver, and that needs to be cleaned up, so that the -d option is used on the command line to test t

[dpdk-dev] [PATCH 04/19] pcap: Convert pcap poll mode driver to use new PMD_INIT_NONPCI macro

2014-04-10 Thread Neil Horman
Convert the pcap poll mode driver to link itself to libpcap and register a init routine via the PMD_INIT_NONPCI macro Signed-off-by: Neil Horman --- lib/librte_eal/common/eal_common_nonpci_devs.c | 9 - lib/librte_pmd_pcap/Makefile | 2 ++ lib/librte_pmd_pcap/rte_eth_pc

[dpdk-dev] [PATCH 03/19] eal: dlopen the DSO built poll mode drivers before init

2014-04-10 Thread Neil Horman
We need to call dlopen on any DSO's referenced on the command line before calling their init routines. This provides the DSO's the opportunity to run the constructors created by the PMD_INIT_NONPCI macro prior to the init list being traversed. Signed-off-by: Neil Horman --- lib/librte_eal/linux

[dpdk-dev] [PATCH 02/19] pmd: Add PMD_INIT_NONPCI macros

2014-04-10 Thread Neil Horman
This macro will allow nonpci based pmd driver to register an init function with the core eal library so that they don't need to be referenced at link time. The macro expands to a constructor that calls an eal library registration function, passing a pointer to the pmd's init routine. Signed-off-b

[dpdk-dev] [PATCH 01/19] makefiles: Fixed -share command line option error

2014-04-10 Thread Neil Horman
The shared libraries built with the current makefile set produce static libraries rather than actual shared objects. This is due to several missing options that are required to correctly build shared objects using ld, as well as a mis-specified -share option (which should be -shared). Switching to

[dpdk-dev] [PATCH 0/19] Separate compile time linkage between eal lib and pmd's

2014-04-10 Thread Neil Horman
Disconnect compile time linkage between eal library / applications and pmd's I noticed that, while tinkering with dpdk, building for shared libraries still resulted in all the test applications linking to all the built pmd's, despite not actually needing them all. We are able to tell an applicati

[dpdk-dev] [PATCH 06/11] vdev: rename eal_common_nonpci_devs.c as eal_common_vdev.c

2014-04-10 Thread Thomas Monjalon
2014-02-28 18:25, Olivier Matz: > The name "nonpci" for virtual devices is ambiguous. A physical device > can be non-PCI (ex: usb, sata, ...). This file only deal with virtual > devices so rename it to avoid confusion. > > Signed-off-by: Olivier Matz > --- a/lib/librte_eal/common/Makefile > +++

[dpdk-dev] [PATCH v2 11/11] testpmd: add several dump commands, useful for debug

2014-04-10 Thread Thomas Monjalon
2014-03-01 13:15, Olivier Matz: > Copy all the dump commands provided in app/test into app/testpmd. These > commands are useful to debug a problem when using testpmd. > > Signed-off-by: Olivier Matz Acked-by: Thomas Monjalon Applied for version 1.6.0r2. -- Thomas

[dpdk-dev] [PATCH v2 10/11] device-args: allow to provide per pci device command line arguments

2014-04-10 Thread Thomas Monjalon
2014-03-01 13:14, Olivier Matz: > Some PCI drivers may require some specific initialization arguments at > start-up. > > Even if unused today, adding this feature seems coherent with virtual > devices in order to provide a full-featured rte_devargs framework. In > the future, it could be added in

[dpdk-dev] [PATCH v2 09/11] device-args: replace use-device eal option by pci-whitelist and vdev

2014-04-10 Thread Thomas Monjalon
2014-03-01 13:14, Olivier Matz: > This commit splits the "--use-device" option in two new options: > > - "--pci-whitelist or -w": add a PCI device in the white list > - "--vdev": instanciate a new virtual device > > Before the patch, the same option "--use-device" was used for these 2 > use-cases

[dpdk-dev] [PATCH 08/11] device-args: use a comma instead of semicolon to separate key/values

2014-04-10 Thread Thomas Monjalon
2014-02-28 18:25, Olivier Matz: > This commit changes the API of --use-device. It changes the separator > used between each key/value pairs from ';' to ','. Indeed, ';' was not > the best choice as this character is also used to separate shell > commands, forcing the user to surround arguments with

[dpdk-dev] [PATCH 05/11] pci: rename device_list as pci_device_list

2014-04-10 Thread Thomas Monjalon
2014-02-28 18:25, Olivier Matz: > To avoid confusion with virtual devices, rename device_list as > pci_device_list and driver_list as pci_driver_list. > > Signed-off-by: Olivier Matz Acked-by: Thomas Monjalon Applied for version 1.6.0r2 with title "pci: rename device and driver lists"

[dpdk-dev] [PATCH 04/11] devices-args: add a dump_devargs command in basic test application

2014-04-10 Thread Thomas Monjalon
2014-02-28 18:25, Olivier Matz: > This is useful for debug purposes. Example: > > echo 100 > > /sys/devices/system/node/node0/hugepages/hugepages-2048kB/nr_hugepages echo > 100 > > /sys/devices/system/node/node1/hugepages/hugepages-2048kB/nr_hugepages > ./app/test -c 0x15 -n 3 -m 64 \ > --use-de

[dpdk-dev] [PATCH v2 03/11] devices-args: use rte_devargs and remove old whitelist code

2014-04-10 Thread Thomas Monjalon
2014-03-01 13:14, Olivier Matz: > Remove old whitelist code: > - remove references to rte_pmd_ring, rte_pmd_pcap and pmd_xenvirt in > is_valid_wl_entry() as we want to be able to register external virtual > drivers as a shared library. Moreover this code was duplicated with > dev_types[] from

[dpdk-dev] [PATCH v2 02/11] devices-args: introduce rte_devargs in eal

2014-04-10 Thread Thomas Monjalon
2014-03-01 13:14, Olivier Matz: > This commit introduces a new API for storing device arguments given by > the user. It only adds the framework and the test. The modification of > EAL to use this new module is done in next commit. > > The final goals: > > - unify pci-blacklist, pci-whitelist, and

[dpdk-dev] [PATCH 01/11] mk: use whole-archive option when creating dpdk binaries

2014-04-10 Thread Thomas Monjalon
2014-02-28 18:25, Olivier Matz: > To fully support dpdk extensions (loading of .so), all symbols provided > by dpdk libraries must be available in the binaries: before this patch, > unused functions/variables from dpdk static libraries could be stripped > by the linker because they are not used. Th

[dpdk-dev] IGB_UIO port unbinding

2014-04-10 Thread Thomas Monjalon
Hi, 2014-04-10 09:39, Burakov, Anatoly: > As you may or may not know, the CONFIG_RTE_EAL_UNBIND_PORTS was deprecated > in the official Intel(r) DPDK 1.6.0 release package. However, the code > itself (e.g. in lib/librte_eal/linuxapp/eal_pci.c and other places) to > support that config option was no

[dpdk-dev] Using DPDK in a multiprocess environment

2014-04-10 Thread Etai Lev Ran
Thanks, Bruce. Yes - artificial linking may be a viable workaround in some cases. However, in the general case, it seems that : a) multi-process DPDK applications work best when using a single (primary) process feeding secondary processes via SW rings; This requires a matching map

[dpdk-dev] [PATCH] rte_pmd_init_all: initialize non-PCI PMDs provided by EAL

2014-04-10 Thread John W. Linville
These PMDs were being initialized by the EAL layer, but many apps were relying on the return value of rte_pmd_init_all to indicate that ethernet interfaces were available for use. Move the initialization of the non-PCI PMDs to this centralized function to have all of the PMDs treated equally. Sig

[dpdk-dev] IGB_UIO port unbinding

2014-04-10 Thread Burakov, Anatoly
Hi everyone As you may or may not know, the CONFIG_RTE_EAL_UNBIND_PORTS was deprecated in the official Intel(r) DPDK 1.6.0 release package. However, the code itself (e.g. in lib/librte_eal/linuxapp/eal_pci.c and other places) to support that config option was not removed. My question would be,

[dpdk-dev] [PATCH 07/11] vdev: allow external registration of virtual device drivers

2014-04-10 Thread Thomas Monjalon
2014-02-28 18:25, Olivier Matz: > Instead of having a list of virtual device drivers in EAL code, add an > API to register drivers. Thanks to this change: > - we don't need to reference pmd_ring, pmd_pcap and pmd_xenvirt in EAL code > - it is now possible to provide a virtual device driver as a sha

[dpdk-dev] DPDK API/ABI Stability

2014-04-10 Thread Neil Horman
On Wed, Apr 09, 2014 at 02:08:49PM -0700, Stephen Hemminger wrote: > On Wed, 9 Apr 2014 14:39:52 -0400 > Neil Horman wrote: > > > Hey all- > > I was going to include this as an addendum to the packaging thread on > > this list, but I can't seem to find it in my inbox, so forgive me starting