> Adding a function to Objects in order to facilitate equality checking and
> enhance readability. You simply specify the 2 objects that you want to check
> for equality, and then provide the functions which will be used to provide
> the values that we will check for equality.
David Alayachew h
> Adding a function to Objects in order to facilitate equality checking and
> enhance readability. You simply specify the 2 objects that you want to check
> for equality, and then provide the functions which will be used to provide
> the values that we will check for equality.
David Alayachew h
> Adding a function to Objects in order to facilitate equality checking and
> enhance readability. You simply specify the 2 objects that you want to check
> for equality, and then provide the functions which will be used to provide
> the values that we will check for equality.
David Alayachew h
> Adding a function to Objects in order to facilitate equality checking and
> enhance readability. You simply specify the 2 objects that you want to check
> for equality, and then provide the functions which will be used to provide
> the values that we will check for equality.
David Alayachew h
On Sat, 27 Jan 2024 04:21:02 GMT, David Alayachew wrote:
>> Adding a function to Objects in order to facilitate equality checking and
>> enhance readability. You simply specify the 2 objects that you want to check
>> for equality, and then provide the functions which will be used to provide
>>
On Sat, 27 Jan 2024 04:21:02 GMT, David Alayachew wrote:
>> Adding a function to Objects in order to facilitate equality checking and
>> enhance readability. You simply specify the 2 objects that you want to check
>> for equality, and then provide the functions which will be used to provide
>>
On Fri, 26 Jan 2024 12:27:02 GMT, Andrew Dinn wrote:
> Luckily, you and your customers are not obliged to use the JPMS
They are obliged to deal with it, and so am I as a tool maintainer. Just look
the the approaches mentioned here. They all are in the category which in German
we would call "vo
> Adding a function to Objects in order to facilitate equality checking and
> enhance readability. You simply specify the 2 objects that you want to check
> for equality, and then provide the functions which will be used to provide
> the values that we will check for equality.
David Alayachew h
Adding a function to Objects in order to facilitate equality checking and
enhance readability. You simply specify the 2 objects that you want to check
for equality, and then provide the functions which will be used to provide the
values that we will check for equality.
-
Commit mes
On Wed, 17 Jan 2024 23:41:53 GMT, Weijun Wang wrote:
> This code change adds an alternative implementation of user-based
> authorization `Subject` APIs that doesn't depend on Security Manager APIs.
> Depending on if the Security Manager is allowed, the methods store the
> current subject diffe
This code change adds an alternative implementation of user-based authorization
`Subject` APIs that doesn't depend on Security Manager APIs. Depending on if
the Security Manager is allowed, the methods store the current subject
differently. See the spec change in the `Subject.java` file for deta
On Fri, 26 Jan 2024 21:52:37 GMT, Joe Darcy wrote:
>> A trivial fix for validate-source.
>
> Marked as reviewed by darcy (Reviewer).
> @jddarcy - Thanks for the lightning fast review!
>
> /integrate auto
Sorry for missing that before pushing.
-
PR Comment: https://git.openjdk.org
On Fri, 26 Jan 2024 21:52:37 GMT, Joe Darcy wrote:
>> A trivial fix for validate-source.
>
> Marked as reviewed by darcy (Reviewer).
@jddarcy - Thanks for the lightning fast review!
-
PR Comment: https://git.openjdk.org/jdk/pull/17599#issuecomment-1912744650
On Fri, 26 Jan 2024 21:51:04 GMT, Daniel D. Daugherty
wrote:
> A trivial fix for validate-source.
Marked as reviewed by darcy (Reviewer).
-
PR Review: https://git.openjdk.org/jdk/pull/17599#pullrequestreview-1846604299
On Fri, 26 Jan 2024 21:51:04 GMT, Daniel D. Daugherty
wrote:
> A trivial fix for validate-source.
This pull request has now been integrated.
Changeset: 70f4a4e1
Author:Daniel D. Daugherty
URL:
https://git.openjdk.org/jdk/commit/70f4a4e18e257110f45565ba0d708f1fa48aed76
Stats: 1
A trivial fix for validate-source.
-
Commit messages:
- 8324786: validate-source fails after JDK-8042981
Changes: https://git.openjdk.org/jdk/pull/17599/files
Webrev: https://webrevs.openjdk.org/?repo=jdk&pr=17599&range=00
Issue: https://bugs.openjdk.org/browse/JDK-8324786
Stat
On Fri, 26 Jan 2024 21:28:47 GMT, Justin Lu wrote:
>>> The "can be used to create" seems conditional.
>>
>> It is conditional - in the sense that you don't _have_ to use it to create a
>> new instance of `MessageFormat`. You can also use it for something else, in
>> other words.
>>
>> But I
On Fri, 26 Jan 2024 21:16:47 GMT, Archie Cobbs wrote:
>> src/java.base/share/classes/java/text/MessageFormat.java line 558:
>>
>>> 556: * @implSpec The implementation in {@link MessageFormat} returns a
>>> string
>>> 557: * that can be used to create a new instance that is semanticall
On Fri, 26 Jan 2024 20:30:42 GMT, Roger Riggs wrote:
> The "can be used to create" seems conditional.
It is conditional - in the sense that you don't _have_ to use it to create a
new instance of `MessageFormat`. You can also use it for something else, in
other words.
But I also understand ho
> This mechanically replaces NULL with nullptr in hpp/cpp native files in test
> native code. This didn't attempt to change NULL in comments or strings to
> just null. If you run into this and it bothers you after this push, you can
> change it in a smaller patch. I didn't see any when it was
On Thu, 25 Jan 2024 21:38:54 GMT, Archie Cobbs wrote:
>> Please consider this fix to ensure that going from `MessageFormat` to
>> pattern string via `toPattern()` and then back via `new MessageFormat()`
>> results in a format that is equivalent to the original.
>>
>> The quoting and escaping r
On Fri, 26 Jan 2024 14:34:39 GMT, Eirik Bjørsnøs wrote:
> To help make progress here, I have relaxed the validation such that we now
> check:
>
> * That the "streaming mode" bit 3 flag is set
> * That at least one of the LOC's size fields are marked 0x.
> * That the LOC extra field has
> This mechanically replaces NULL with nullptr in hpp/cpp native files in test
> native code. This didn't attempt to change NULL in comments or strings to
> just null. If you run into this and it bothers you after this push, you can
> change it in a smaller patch. I didn't see any when it was
This mechanically replaces NULL with nullptr in hpp/cpp native files in test
native code. This didn't attempt to change NULL in comments or strings to just
null. If you run into this and it bothers you after this push, you can change
it in a smaller patch. I didn't see any when it was scrollin
On Fri, 26 Jan 2024 18:58:49 GMT, Justin Lu wrote:
> I wasn't sure if you were waiting to make additional changes or something
> else, but you can go ahead and re-finalize the CSR (when you are ready), now
> that it has been reviewed.
Thanks - I wasn't sure about that. I've updated it now.
--
On Fri, 26 Jan 2024 17:19:25 GMT, Srinivas Vamsi Parasa
wrote:
>> Hello Vamsi (@vamsi-parasa),
>>
>> Could you please run the benchmarking of new DQPS in your environment with
>> AVX?
>>
>> Take all classes below and put them in the package
>> org.openjdk.bench.java.util.
>> ArraysSort class
On Thu, 25 Jan 2024 21:38:54 GMT, Archie Cobbs wrote:
>> Please consider this fix to ensure that going from `MessageFormat` to
>> pattern string via `toPattern()` and then back via `new MessageFormat()`
>> results in a format that is equivalent to the original.
>>
>> The quoting and escaping r
On Tue, 16 Jan 2024 21:18:55 GMT, Vicente Romero wrote:
> Updating ASM to version 9.6,
>
> Thanks in advance for the reviews,
> Vicente
This pull request has now been integrated.
Changeset: 91d8ea79
Author:Vicente Romero
URL:
https://git.openjdk.org/jdk/commit/91d8ea79d947aa7dad91d
On Fri, 26 Jan 2024 01:36:47 GMT, Mandy Chung wrote:
> Looks okay to me. I would rely on your testing for verification.
I have run tier1-6 tests, they look OK
-
PR Comment: https://git.openjdk.org/jdk/pull/17453#issuecomment-1912506728
> This is the proposed patch for Primitive types in patterns, instanceof, and
> switch (Preview).
>
> Draft spec here: https://cr.openjdk.org/~abimpoudis/instanceof/latest/
Aggelos Biboudis has updated the pull request incrementally with one additional
commit since the last revision:
Remove
On Fri, 26 Jan 2024 16:54:14 GMT, Roger Riggs wrote:
>> Jim Laskey has updated the pull request with a new target base due to a
>> merge or a rebase. The incremental webrev excludes the unrelated changes
>> brought in by the merge/rebase. The pull request contains 12 additional
>> commits sinc
> Currently String::translateEscapes does not support unicode escapes, reported
> as a IllegalArgumentException("Invalid escape sequence: ...").
> String::translateEscapes should translate unicode escape sequences to provide
> full coverage,
Jim Laskey has updated the pull request incrementally
On Thu, 18 Jan 2024 21:36:22 GMT, Vladimir Yaroslavskiy
wrote:
>> Hi Vladimir (@iaroslavski)
>>
>> Please see the data below using the latest version of AVX512 sort that got
>> integrated into OpenJDK.
>>
>> > xmlns:o="urn:schemas-microsoft-com:office:office"
>> xmlns:x="urn:schemas-microsoft
On Fri, 26 Jan 2024 15:06:50 GMT, Jim Laskey wrote:
>> Currently String::translateEscapes does not support unicode escapes,
>> reported as a IllegalArgumentException("Invalid escape sequence: ...").
>> String::translateEscapes should translate unicode escape sequences to
>> provide full covera
> Currently String::translateEscapes does not support unicode escapes, reported
> as a IllegalArgumentException("Invalid escape sequence: ...").
> String::translateEscapes should translate unicode escape sequences to provide
> full coverage,
Jim Laskey has updated the pull request with a new ta
On Fri, 26 Jan 2024 14:32:58 GMT, Eirik Bjørsnøs wrote:
>> ZipInputStream.readEnd currently assumes a Zip64 data descriptor if the
>> number of compressed or uncompressed bytes read from the inflater is larger
>> than the Zip64 magic value.
>>
>> While the ZIP format mandates that the data de
> ZipInputStream.readEnd currently assumes a Zip64 data descriptor if the
> number of compressed or uncompressed bytes read from the inflater is larger
> than the Zip64 magic value.
>
> While the ZIP format mandates that the data descriptor `SHOULD be stored in
> ZIP64 format (as 8 byte values
> Currently String::translateEscapes does not support unicode escapes, reported
> as a IllegalArgumentException("Invalid escape sequence: ...").
> String::translateEscapes should translate unicode escape sequences to provide
> full coverage,
Jim Laskey has updated the pull request incrementally
> Currently String::translateEscapes does not support unicode escapes, reported
> as a IllegalArgumentException("Invalid escape sequence: ...").
> String::translateEscapes should translate unicode escape sequences to provide
> full coverage,
Jim Laskey has updated the pull request incrementally
On Fri, 26 Jan 2024 09:12:53 GMT, Alan Bateman wrote:
> The target class is transformed in such a way to call the auxiliary class,
> which necessitates the the aux-class to be in the same classloader as the
> target class. But because the aux-class is defined while the target class is
> still
On Fri, 19 Jan 2024 18:28:22 GMT, Roger Riggs wrote:
>> Jim Laskey has updated the pull request incrementally with one additional
>> commit since the last revision:
>>
>> Update Copyright
>
> test/jdk/java/lang/String/TranslateEscapes.java line 113:
>
>> 111: }
>> 112:
>> 113: stati
On Tue, 23 Jan 2024 21:41:54 GMT, Naoto Sato wrote:
>> Jim Laskey has updated the pull request incrementally with one additional
>> commit since the last revision:
>>
>> Requested changes
>
> src/java.base/share/classes/java/lang/String.java line 4229:
>
>> 4227: * {@code \u005Cu...
On Fri, 26 Jan 2024 08:38:32 GMT, Alan Bateman wrote:
>> Jim Laskey has updated the pull request incrementally with one additional
>> commit since the last revision:
>>
>> Update String.java
>
> src/java.base/share/classes/java/lang/String.java line 4238:
>
>> 4236: * @return String wit
On Fri, 19 Jan 2024 18:27:24 GMT, Roger Riggs wrote:
>> Jim Laskey has updated the pull request incrementally with one additional
>> commit since the last revision:
>>
>> Update Copyright
>
> test/jdk/java/lang/String/TranslateEscapes.java line 127:
>
>> 125: } catch (IllegalArgument
On Fri, 19 Jan 2024 17:39:57 GMT, Raffaello Giulietti
wrote:
>> Jim Laskey has updated the pull request incrementally with one additional
>> commit since the last revision:
>>
>> Update copyright year of test
>
> test/jdk/java/lang/String/TranslateEscapes.java line 2:
>
>> 1: /*
>> 2: * Co
On Fri, 26 Jan 2024 10:17:16 GMT, Alexander Kriegisch wrote:
>>> @AlanBateman, the AspectJ weaving agent creates an auxiliary class to
>>> implement an "around" advice for a method, i.e. a method execution is
>>> intercepted and the user has options to do something before optionally
>>> callin
On Fri, 26 Jan 2024 09:12:53 GMT, Alan Bateman wrote:
> load-time instrumentation that defines auxiliary classes in the same run-time
> package is a reasonable addition
Thanks for finding some common ground. I appreciate it.
> The more general request for an "unrestricted defineClass" conflict
On Thu, 18 Jan 2024 21:36:22 GMT, Vladimir Yaroslavskiy
wrote:
>> Hi Vladimir (@iaroslavski)
>>
>> Please see the data below using the latest version of AVX512 sort that got
>> integrated into OpenJDK.
>>
>> > xmlns:o="urn:schemas-microsoft-com:office:office"
>> xmlns:x="urn:schemas-microsoft
On Fri, 26 Jan 2024 08:27:41 GMT, Alan Bateman wrote:
>>> BB currently opens the jdk.internal.misc.Unsafe class to a module on a
>>> seperate class loader that is not reachable outside an agent, using
>>> Instrumentation.
>>
>> @raphw, may I ask how? Is there any sample code that is not connec
On Thu, 18 Jan 2024 21:36:22 GMT, Vladimir Yaroslavskiy
wrote:
>> Hi Vladimir (@iaroslavski)
>>
>> Please see the data below using the latest version of AVX512 sort that got
>> integrated into OpenJDK.
>>
>> > xmlns:o="urn:schemas-microsoft-com:office:office"
>> xmlns:x="urn:schemas-microsoft
On Fri, 16 Apr 2021 20:30:15 GMT, Rafael Winterhalter
wrote:
>> To allow agents the definition of auxiliary classes, an API is needed to
>> allow this. Currently, this is often achieved by using `sun.misc.Unsafe` or
>> `jdk.internal.misc.Unsafe` ever since the `defineClass` method was removed
On Wed, 24 Jan 2024 13:23:49 GMT, Jim Laskey wrote:
>> Currently String::translateEscapes does not support unicode escapes,
>> reported as a IllegalArgumentException("Invalid escape sequence: ...").
>> String::translateEscapes should translate unicode escape sequences to
>> provide full covera
On Fri, 26 Jan 2024 08:27:41 GMT, Alan Bateman wrote:
>>> BB currently opens the jdk.internal.misc.Unsafe class to a module on a
>>> seperate class loader that is not reachable outside an agent, using
>>> Instrumentation.
>>
>> @raphw, may I ask how? Is there any sample code that is not connec
On Fri, 26 Jan 2024 08:01:59 GMT, Alexander Kriegisch wrote:
> > BB currently opens the jdk.internal.misc.Unsafe class to a module on a
> > seperate class loader that is not reachable outside an agent, using
> > Instrumentation.
>
> @raphw, may I ask how? Is there any sample code that is not c
On Thu, 25 Jan 2024 12:16:13 GMT, Rafael Winterhalter
wrote:
> BB currently opens the jdk.internal.misc.Unsafe class to a module on a
> seperate class loader that is not reachable outside an agent, using
> Instrumentation.
@raphw, may I ask how? Is there any sample code that is not connected
55 matches
Mail list logo