[PATCH] D89407: [clang-tidy] Add scoped enum constants to identifier naming check

2020-10-19 Thread Nathan James via Phabricator via cfe-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rG86ef37980016: [clang-tidy] Add scoped enum constants to identifier naming check (authored by njames93). Changed prior to commit: https://reviews.llvm.org/D89407?vs=298349&id=299058#toc Repository: rG

[PATCH] D89407: [clang-tidy] Add scoped enum constants to identifier naming check

2020-10-19 Thread Aaron Ballman via Phabricator via cfe-commits
aaron.ballman accepted this revision. aaron.ballman added a comment. This revision is now accepted and ready to land. LGTM aside from a minor nit. Comment at: clang-tools-extra/clang-tidy/readability/IdentifierNamingCheck.cpp:410 + if (const auto *EnumConst = dyn_cast(D)) { +

[PATCH] D89407: [clang-tidy] Add scoped enum constants to identifier naming check

2020-10-16 Thread Nathan James via Phabricator via cfe-commits
njames93 added a comment. In D89407#2333560 , @Eugene.Zelenko wrote: > I think will be good idea to add test for suffix/prefix too. Not strictly necessary, there are tests that make sure prefixes and suffixes are applied correctly. Then there are tests

[PATCH] D89407: [clang-tidy] Add scoped enum constants to identifier naming check

2020-10-15 Thread Eugene Zelenko via Phabricator via cfe-commits
Eugene.Zelenko added a comment. I think will be good idea to add test for suffix/prefix too. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D89407/new/ https://reviews.llvm.org/D89407 ___ cfe-commits maili

[PATCH] D89407: [clang-tidy] Add scoped enum constants to identifier naming check

2020-10-15 Thread Nathan James via Phabricator via cfe-commits
njames93 updated this revision to Diff 298349. njames93 added a comment. Removed runtime check in release mode that EnumConstant DeclContext is a EnumDecl Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D89407/new/ https://reviews.llvm.org/D89407 Fi

[PATCH] D89407: [clang-tidy] Add scoped enum constants to identifier naming check

2020-10-14 Thread Nathan James via Phabricator via cfe-commits
njames93 updated this revision to Diff 298200. njames93 added a comment. Small tweak to the docs Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D89407/new/ https://reviews.llvm.org/D89407 Files: clang-tools-extra/clang-tidy/readability/IdentifierN

[PATCH] D89407: [clang-tidy] Add scoped enum constants to identifier naming check

2020-10-14 Thread Nathan James via Phabricator via cfe-commits
njames93 created this revision. njames93 added reviewers: alexfh, JonasToth, aaron.ballman, gribozavr2. Herald added subscribers: cfe-commits, xazax.hun. Herald added a project: clang. njames93 requested review of this revision. Added option `ScopedEnumConstant(Prefix|Case|Suffix)` to readability