aaron.ballman accepted this revision. aaron.ballman added a comment. This revision is now accepted and ready to land.
LGTM aside from a minor nit. ================ Comment at: clang-tools-extra/clang-tidy/readability/IdentifierNamingCheck.cpp:410 + if (const auto *EnumConst = dyn_cast<EnumConstantDecl>(D)) { + assert(isa<EnumDecl>(EnumConst->getDeclContext()) && + "DeclContext of EnumConstant should be EnumDecl"); ---------------- There's no need for this assertion, the use of `cast<>` below will assert if the type is wrong. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D89407/new/ https://reviews.llvm.org/D89407 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits