EricWF accepted this revision.
EricWF added a comment.
This revision is now accepted and ready to land.
LGTM. Thank you for the thorough doc. It sure made the review easy on my end.
I took the liberty of rewriting your 3 benchmarks to use Google Benchmark:
https://gist.github.com/EricWF/6ab9d3ca
Author: ericwf
Date: Sun Jul 24 23:56:32 2016
New Revision: 276608
URL: http://llvm.org/viewvc/llvm-project?rev=276608&view=rev
Log:
Remove use of C++1z static assert in C++11 test
Modified:
libcxx/trunk/test/std/utilities/utility/pairs/pairs.pair/special_member_generation_test.pass.cpp
Mod
Author: majnemer
Date: Sun Jul 24 23:47:44 2016
New Revision: 276606
URL: http://llvm.org/viewvc/llvm-project?rev=276606&view=rev
Log:
[MSVCToolChain] Guard hardcoded Windows paths with LLVM_ON_WIN32
Paths like C:/foo will never work on UNIX platforms, don't bother
implicitly adding them to the s
Author: majnemer
Date: Sun Jul 24 23:47:45 2016
New Revision: 276607
URL: http://llvm.org/viewvc/llvm-project?rev=276607&view=rev
Log:
Update test to account for r276604
Modified:
cfe/trunk/test/CodeGenCXX/atomicinit.cpp
Modified: cfe/trunk/test/CodeGenCXX/atomicinit.cpp
URL:
http://llvm.or
Author: ericwf
Date: Sun Jul 24 23:32:07 2016
New Revision: 276605
URL: http://llvm.org/viewvc/llvm-project?rev=276605&view=rev
Log:
Implement the std::pair parts of "Improving pair and tuple". Completes N4387.
Added:
libcxx/trunk/test/std/utilities/utility/pairs/pairs.pair/const_first_cons
ABataev requested changes to this revision.
This revision now requires changes to proceed.
Comment at: include/clang/AST/OpenMPClause.h:4252
@@ -4237,1 +4251,3 @@
+
+ /// \brief Build clause with number of variables \a NumVars.
///
No \brief
teemperor marked 9 inline comments as done.
Comment at: include/clang/AST/CloneDetection.h:149
@@ +148,3 @@
+/// (e.g. function bodies). Other clones (e.g. cloned comments or declarations)
+/// are not supported.
+///
Put the idea on the future TODO list, but we p
teemperor updated this revision to Diff 65291.
teemperor added a comment.
Ok, so I think I've addressed the points from last meeting in this patch:
It was planned to replace custom hashing with FoldingSetNodeID and a hashmap:
In this patch I removed all custom hashing. It's now done via LLVM's S
ABataev accepted this revision.
ABataev added a comment.
This revision is now accepted and ready to land.
LG with a nit
Comment at: lib/CodeGen/CGOpenMPRuntime.cpp:5280
@@ -5279,5 +5279,3 @@
BP = CGF.EmitLoadOfPointerLValue(PtrAddr.getAddress(),
-
Author: ericwf
Date: Sun Jul 24 21:36:42 2016
New Revision: 276603
URL: http://llvm.org/viewvc/llvm-project?rev=276603&view=rev
Log:
Recommit r276548 - Make pair/tuples assignment operators SFINAE properly.
I think I've solved issues with is_assignable and references to incomplete
types. The upda
Author: ericwf
Date: Sun Jul 24 21:08:55 2016
New Revision: 276599
URL: http://llvm.org/viewvc/llvm-project?rev=276599&view=rev
Log:
Make std::is_assignable tolerate references to incomplete types.
Modified:
libcxx/trunk/include/type_traits
libcxx/trunk/test/std/utilities/meta/meta.unary
Author: ericwf
Date: Sun Jul 24 20:45:07 2016
New Revision: 276598
URL: http://llvm.org/viewvc/llvm-project?rev=276598&view=rev
Log:
Revert r276548 - Make pair/tuples assignment operators SFINAE properly.
This is a breaking change. The SFINAE required is instantiated the second
the class is insta
EricWF closed this revision.
EricWF added a comment.
r276595
https://reviews.llvm.org/D21717
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
Author: ericwf
Date: Sun Jul 24 19:50:32 2016
New Revision: 276595
URL: http://llvm.org/viewvc/llvm-project?rev=276595&view=rev
Log:
Make dtor_noexcept.pass.cpp tests more portable. Patch from s...@microsoft.com
Modified:
libcxx/trunk/test/std/containers/associative/map/map.cons/dtor_noexcep
EricWF accepted this revision.
EricWF added a comment.
This revision is now accepted and ready to land.
I think I'm happy with libc++'s behavior of automatically deducing the dtor
exception specification. This patch LGTM.
https://reviews.llvm.org/D21717
__
Author: ericwf
Date: Sun Jul 24 19:48:36 2016
New Revision: 276594
URL: http://llvm.org/viewvc/llvm-project?rev=276594&view=rev
Log:
Don't SFINAE pair's copy assignment operator in C++03 mode.
In C++03 mode evaluating the SFINAE can cause a hard error due to
access control violations. This is a p
EricWF closed this revision.
EricWF added a comment.
r276593.
https://reviews.llvm.org/D22162
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
EricWF accepted this revision.
EricWF added a comment.
This revision is now accepted and ready to land.
It's not great that our tests have so many non-portable assertions. Normally we
want to avoid writing non-standard assertions at all, but there doesn't seem to
be a way around it here.
However
EricWF closed this revision.
EricWF added a comment.
r276591.
https://reviews.llvm.org/D21718
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
Author: ericwf
Date: Sun Jul 24 19:18:12 2016
New Revision: 276591
URL: http://llvm.org/viewvc/llvm-project?rev=276591&view=rev
Log:
Make move_assign_noexcept.pass.cpp tests more portable. Patch from
s...@microsoft.com
Modified:
libcxx/trunk/test/std/containers/associative/map/map.cons/move
Author: ericwf
Date: Sun Jul 24 19:15:29 2016
New Revision: 276590
URL: http://llvm.org/viewvc/llvm-project?rev=276590&view=rev
Log:
Make swap_noexcept.pass.cpp tests more portable. Patch from s...@microsoft.com.
See D21820 for more information (https://reviews.llvm.org/D21820).
Modified:
EricWF closed this revision.
EricWF added a comment.
r276590.
https://reviews.llvm.org/D21820
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
EricWF accepted this revision.
EricWF added a comment.
This revision is now accepted and ready to land.
I'm not thrilled with this, but as you mentioned actually fixing this will be a
lot of work. I opened a bug to track that work
https://llvm.org/bugs/show_bug.cgi?id=28687.
However for now this
EricWF closed this revision.
EricWF added a comment.
r276589.
https://reviews.llvm.org/D22017
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
Author: ericwf
Date: Sun Jul 24 19:02:23 2016
New Revision: 276589
URL: http://llvm.org/viewvc/llvm-project?rev=276589&view=rev
Log:
Work around MSVC's non-standard ABI for enums. Patch from s...@microsoft.com
Modified:
libcxx/trunk/test/std/utilities/meta/meta.trans/meta.trans.other/underly
EricWF added a comment.
I'll check in this fix with the suggested change.
https://reviews.llvm.org/D22017
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
EricWF accepted this revision.
EricWF added a comment.
This revision is now accepted and ready to land.
> in underlying_type.pass.cpp, I'm simply marking the affected static_asserts
> as libcxx-specific (this probably won't be sufficient when you try to get the
> Clang/LLVM/libcxx stack running
Author: ericwf
Date: Sun Jul 24 18:49:42 2016
New Revision: 276588
URL: http://llvm.org/viewvc/llvm-project?rev=276588&view=rev
Log:
Fix a non-standard allocator in vector tests. Patch from s...@microsoft.com
Modified:
libcxx/trunk/test/std/containers/sequences/vector/vector.cons/construct_i
EricWF closed this revision.
EricWF added a comment.
r276588.
https://reviews.llvm.org/D22016
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
Author: ericwf
Date: Sun Jul 24 18:48:26 2016
New Revision: 276587
URL: http://llvm.org/viewvc/llvm-project?rev=276587&view=rev
Log:
Fix unique_ptr.runtime tests for null inputs. Patch from s...@microsoft.com
Modified:
libcxx/trunk/test/std/utilities/memory/unique.ptr/unique.ptr.runtime/null
EricWF closed this revision.
EricWF added a comment.
r276587.
https://reviews.llvm.org/D22014
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
EricWF accepted this revision.
EricWF added a comment.
This revision is now accepted and ready to land.
I see how the wording doesn't require supporting the literal '0', but if you
provide a concrete 'std::nullptr_t' parameter your going to allow the
conversion from '0'. I think this should prob
Author: ericwf
Date: Sun Jul 24 18:36:18 2016
New Revision: 276585
URL: http://llvm.org/viewvc/llvm-project?rev=276585&view=rev
Log:
Fix portability issues in tests. Patch from s...@microsoft.com
Modified:
libcxx/trunk/test/std/algorithms/alg.modifying.operations/alg.random.shuffle/random_s
EricWF closed this revision.
EricWF added a comment.
r276585.
https://reviews.llvm.org/D22155
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
EricWF closed this revision.
EricWF added a comment.
r276584.
https://reviews.llvm.org/D22157
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
Author: ericwf
Date: Sun Jul 24 18:34:18 2016
New Revision: 276584
URL: http://llvm.org/viewvc/llvm-project?rev=276584&view=rev
Log:
Mark bucket() assertions as non-portable. Patch from s...@microsoft.com
Modified:
libcxx/trunk/test/std/containers/unord/unord.map/bucket.pass.cpp
libcxx/tr
EricWF closed this revision.
EricWF added a comment.
r276583.
https://reviews.llvm.org/D22059
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
Author: ericwf
Date: Sun Jul 24 18:32:48 2016
New Revision: 276583
URL: http://llvm.org/viewvc/llvm-project?rev=276583&view=rev
Log:
Fix MSVC unreferenced parameter warning. Patch from s...@microsoft.com
Modified:
libcxx/trunk/test/std/utilities/tuple/tuple.tuple/tuple.assign/convert_move.pa
EricWF closed this revision.
EricWF added a comment.
r276581.
https://reviews.llvm.org/D21716
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
Author: ericwf
Date: Sun Jul 24 18:19:51 2016
New Revision: 276581
URL: http://llvm.org/viewvc/llvm-project?rev=276581&view=rev
Log:
Make move_noexcept.pass.cpp tests more portable. Patch from s...@microsoft.com
Modified:
libcxx/trunk/test/std/containers/associative/map/map.cons/move_noexcep
EricWF closed this revision.
EricWF added a comment.
r276580.
https://reviews.llvm.org/D22165
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
Author: ericwf
Date: Sun Jul 24 18:16:37 2016
New Revision: 276580
URL: http://llvm.org/viewvc/llvm-project?rev=276580&view=rev
Log:
Make bucket_count() greater-equal assertions portable. Patch from
s...@microsoft.com
Modified:
libcxx/trunk/test/std/containers/unord/unord.map/bucket_count.pa
EricWF closed this revision.
EricWF added a comment.
r276578.
https://reviews.llvm.org/D22159
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
Author: ericwf
Date: Sun Jul 24 18:13:36 2016
New Revision: 276578
URL: http://llvm.org/viewvc/llvm-project?rev=276578&view=rev
Log:
Mark bucket_size() assertions as non-portible. Patch from s...@microsoft.com
Modified:
libcxx/trunk/test/std/containers/unord/unord.map/bucket_size.pass.cpp
Author: gbiv
Date: Sun Jul 24 18:12:40 2016
New Revision: 276577
URL: http://llvm.org/viewvc/llvm-project?rev=276577&view=rev
Log:
[Sema] Replace mem_fn with lambdas. NFC.
I'm told that some optimizers like lambdas a lot more than mem_fn.
Given that the readability difference is basically nil, an
EricWF closed this revision.
EricWF added a comment.
r276576.
https://reviews.llvm.org/D22013
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
Author: ericwf
Date: Sun Jul 24 18:08:21 2016
New Revision: 276576
URL: http://llvm.org/viewvc/llvm-project?rev=276576&view=rev
Log:
Guard libc++ specific tests SFINAE on std::bind's call operator. Patch from
s...@microsoft.com
Modified:
libcxx/trunk/test/std/utilities/function.objects/bind
EricWF added a comment.
For the most part this LGTM. Thanks for putting in all this work. I've noted
some places where the test coverage could be improved.
Comment at: include/array:156
@@ -155,3 +155,3 @@
_LIBCPP_INLINE_VISIBILITY
-iterator begin() _NOEXCEPT {return i
Prazek added a comment.
In https://reviews.llvm.org/D22725#494168, @JDevlieghere wrote:
> In https://reviews.llvm.org/D22725#494167, @Prazek wrote:
>
> > hmm It seems that I mislead you, I suck at C api - memmove source and
> > destination can overlap, but std::move can't. So I guess you have to
JDevlieghere added a comment.
In https://reviews.llvm.org/D22725#494167, @Prazek wrote:
> hmm It seems that I mislead you, I suck at C api - memmove source and
> destination can overlap, but std::move can't. So I guess you have to remove
> the memmove support. Sorry.
No problem, I wasn't awar
Prazek added a comment.
hmm It seems that I mislead you, I suck at C api - memmove source and
destination can overlap, but std::move can't. So I guess you have to remove the
memmove support. Sorry.
https://reviews.llvm.org/D22725
___
cfe-commits m
Author: majnemer
Date: Sun Jul 24 12:44:03 2016
New Revision: 276573
URL: http://llvm.org/viewvc/llvm-project?rev=276573&view=rev
Log:
[Driver] Switch some getenv calls to llvm::sys::Process::GetEnv
No functional change is intended.
Modified:
cfe/trunk/lib/Driver/Driver.cpp
cfe/trunk/lib
JDevlieghere added a comment.
In https://reviews.llvm.org/D22725#494074, @Prazek wrote:
> Maybe the right way would be to have check called
> 'modernize-use-sequence-algorithm' or just 'modernize-use-algorithm' that
> would basically do all those stuff. It would be good to not introduce 5 new
JDevlieghere removed rL LLVM as the repository for this revision.
JDevlieghere updated this revision to Diff 65273.
JDevlieghere added a comment.
- Extended check to replace memmove with std::move and memset with std::fill
- Renamed check to modernize-use-algorithm (I'd be equally fine with moving
Author: ctopper
Date: Sun Jul 24 09:58:06 2016
New Revision: 276564
URL: http://llvm.org/viewvc/llvm-project?rev=276564&view=rev
Log:
[X86] Block pbroadcastq instructions on 32-bit targets instead of pbroadcastb.
Thanks to Simon Pilgrim for catching the mistake.
Modified:
cfe/trunk/lib/Heade
Author: dergachev
Date: Sun Jul 24 03:15:58 2016
New Revision: 276557
URL: http://llvm.org/viewvc/llvm-project?rev=276557&view=rev
Log:
[analyzer] Pring LocationContext in ExplodedGraph dumps.
Remove some FIXMEs in the surrounding code,
which have been addressed long time ago
by introducing check
aaboud updated this revision to Diff 65269.
aaboud added a comment.
Updated test according to comments.
https://reviews.llvm.org/D22045
Files:
include/clang/Basic/Attr.td
include/clang/Basic/AttrDocs.td
lib/CodeGen/CGCall.cpp
lib/Sema/SemaDeclAttr.cpp
test/CodeGenCXX/attr-x86-no_calle
aaboud marked an inline comment as done.
Comment at: include/clang/Basic/Attr.td:1657
@@ +1656,3 @@
+ TargetSpecificAttr {
+ let Spellings = [GNU<"no_caller_saved_registers">];
+ let Subjects = SubjectList<[FunctionLike], WarnDiag, "ExpectedFunc
bkramer added a comment.
As far as I know we still support GCC 4.7, which doesn't have emplace in
std::map. I don't think this patch will work with 4.7. Should we drop support
for 4.7?
https://reviews.llvm.org/D22712
___
cfe-commits mailing list
c
This revision was automatically updated to reflect the committed changes.
Closed by commit rL276557: [analyzer] Pring LocationContext in ExplodedGraph
dumps. (authored by dergachev).
Changed prior to commit:
https://reviews.llvm.org/D22622?vs=65223&id=65267#toc
Repository:
rL LLVM
https://r
Author: ericwf
Date: Sun Jul 24 03:16:37 2016
New Revision: 276558
URL: http://llvm.org/viewvc/llvm-project?rev=276558&view=rev
Log:
commit test missing from r276556
Added:
libcxx/trunk/test/libcxx/utilities/utility/utility.inplace/
libcxx/trunk/test/libcxx/utilities/utility/utility.inpl
Author: ericwf
Date: Sun Jul 24 02:42:13 2016
New Revision: 276556
URL: http://llvm.org/viewvc/llvm-project?rev=276556&view=rev
Log:
Add __is_inplace_type metafunction helper
Modified:
libcxx/trunk/include/utility
Modified: libcxx/trunk/include/utility
URL:
http://llvm.org/viewvc/llvm-proje
alexshap added a comment.
no, i don't.
https://reviews.llvm.org/D22712
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
Prazek added a comment.
In https://reviews.llvm.org/D22725#493970, @JDevlieghere wrote:
> In https://reviews.llvm.org/D22725#493947, @Prazek wrote:
>
> > Thanks for the contribution. Is it your first check?
>
>
> Yes, it is! :-)
Cool! hope to see some other cool checks. You could probably use p
Prazek added inline comments.
Comment at: clang-tidy/modernize/UseCopyCheck.cpp:49
@@ +48,3 @@
+ if (getLangOpts().CPlusPlus) {
+Inserter.reset(new utils::IncludeInserter(
+Compiler.getSourceManager(), Compiler.getLangOpts(), IncludeStyle));
there is
65 matches
Mail list logo