Re: [PATCH,HURD] llistxattr + lremovexattr

2012-07-20 Thread Roland McGrath
Those look fine to me.

Re: [PATCH,HURD] mach: compliance fixes for nanosleep

2012-07-20 Thread Roland McGrath
In a log entry, write a local variable name as FOO rather than `foo'. Write 'remaining != NULL' in tests. Fix the existing cases while you're there. If the second __gettimeofday calls, return failure as it did before. Since I've just seen it repeated here and in your select change, it seems wor

Re: [PATCH,HURD] hurd: compliance fixes for ptsname_r

2012-07-20 Thread Roland McGrath
> Ok, I see that its `buf' argument is marked nonnull. I added that check > because I saw the gnulib test for it explicitly checking that > ptsname_r(fd, NULL, 0) would be properly failing with EINVAL (and the > man page even explicitly mention that return value, unlike with > basically most of

Re: [PATCH,HURD] hurd: compliance fixes for getlogin_r

2012-07-20 Thread Roland McGrath
> > libc code can use C99 freely these days, so use an inline > > initializing declaration rather than pre-declaring a new variable. > > Hm ok; is it bad if I leave them as it is, for now? It's not terrible but there is no reason to let new code in that is not in optimal style, and it's trivial t

Re: [PATCH,HURD] _hurd_select: check for invalid parameter values

2012-07-20 Thread Roland McGrath
> * hurd/hurdselect.c (_hurd_select): Return EINVAL for negative > `timeout' values. > Return EINVAL for `nfds' values either negative or greater than > FD_SETSIZE. In a log entry, write a local variable name as FOO rather than `foo'. > + to = timeout->tv_sec * 1000 +

Re: [PATCH, HURD] hurd: recvfrom(): take into account null address ports

2012-07-20 Thread Roland McGrath
The change itself looks fine to me. In a log entry, write a local variable name as FOO rather than `foo'. Thanks, Roland

Re: [PATCH,HURD] sendto: do not crash when addr is NULL

2012-07-20 Thread Roland McGrath
This looks fine to me.

Re: [PATCH,HURD] sendto: do not crash when addr is NULL

2012-07-20 Thread Roland McGrath
> Hm ok, I saw other cases of shadowing by internal subroutines, and > assumed it was okay (since inside them you want to refer to the local > "err" instead of the outermost one. It's not the worst thing ever, and we don't compile with -Wshadow. But shadowing is usually a good thing to avoid jus

Re: [PATCH,HURD] sendto: do not crash when addr is NULL

2012-07-20 Thread Pino Toscano
Hi, Alle mercoledì 13 giugno 2012, Pino Toscano ha scritto: > Alle martedì 12 giugno 2012, Roland McGrath ha scritto: > > That's almost right, but you should avoid calling > > __mach_port_deallocate if APORT is MACH_PORT_NULL. Also, avoid > > shadowing the local variable ERR with one of the same

Re: Concerning pthreads and such

2012-07-20 Thread Thomas Thomas
>So far so good. I see you've renamed hurd_condition_wait in most places >but did you move the actual definition as well? I am getting undefined >references to hurd_cond_wait. No, I didn't, and that is the problem. The original hurd_condition_wait is in libthreads. That is the most natural place