One more change in the 'thread' module (fixes a link error):
2008-08-18 Bruno Haible <[EMAIL PROTECTED]>
* lib/glthread/thread.h [USE_SOLARIS_THREADS]: Use thread_in_use(), not
pthread_in_use().
*** lib/glthread/thread.h.orig 2008-08-18 12:35:16.0 +0200
--- lib/glthrea
Here is the Win32 implementation of the thread module.
Please review it; it's quite complicated. The complexity comes from
1. the need to have a 'void *' as thread exit value, where Win32 only
manages a 32-bit value,
2. weird thread APIs: In Win32, every thread has an id and multiple handl
In the 'yield' module, there were references to the Win32 API without
#include .
*** lib/glthread/yield.h.orig 2008-08-17 21:53:21.0 +0200
--- lib/glthread/yield.h2008-08-17 21:45:59.0 +0200
***
*** 73,79
/* Use the old Solaris threads library. */
In C++ mode, there were many unclosed 'extern "C" {' lines (syntax error).
Fixed as follows:
*** lib/glthread/cond.h.orig2008-08-17 21:24:15.0 +0200
--- lib/glthread/cond.h 2008-08-17 21:24:03.0 +0200
***
*** 140,145
--- 140,149
# define glthread_cond_de
Some more changes in the 'thread' module:
- glthread_create must return ENOSYS if no multithreading is available,
- gl_thread_create calling convention: it should better simply return the
created thread.
*** lib/glthread/thread.h.orig 2008-08-17 21:17:32.0 +0200
--- lib/glthread/t
Yoann Vandoorselaere wrote:
> Here is an updated patch, that fixes several naming issue and implement
> the yield module.
I've added the 'yield' module, again with minor updates:
- Renamed LIBSCHED to YIELD_LIB (same convention as we use e.g. for
ROUND_LIBM).
- In the module description, ment
> *** modules/thread2008-08-17 17:11:17.0 +0200
> --- /packages/GNULIB/gnulib-git/modules/thread2008-08-17
> 18:00:33.0 +0200
> ***
> *** 17,22
> --- 17,25
> Include:
> "glthread/thread.h"
>
> + Link:
> + $(LTLIBTHREAD) when linking with lib
Yoann Vandoorselaere wrote:
> Here is an updated patch, that fixes several naming issue and implement
> the yield module.
Thanks. I added the 'thread' module, with a few modifications (attached):
- Changed the module description to say "Creating threads".
- Added some documentation of the 6 facil
Yoann Vandoorselaere wrote:
> Here is an updated patch, that fixes several naming issue and implement
> the yield module.
Thanks. I added the module 'cond' with a few modifications (attached):
- Changed the module description to say "Condition variables".
- Fixed specification of gl_cond_* mac
Le jeudi 14 août 2008 à 11:30 +0200, Yoann Vandoorselaere a écrit :
> Le jeudi 14 août 2008 à 10:58 +0200, Bruno Haible a écrit :
> > Yoann Vandoorselaere wrote:
> > > > Can you see alternatives? Maybe something like ,
> > > > , , ,
> > > > ?
> > >
> > > Look good to me, can you handl
Le jeudi 14 août 2008 à 10:58 +0200, Bruno Haible a écrit :
> Yoann Vandoorselaere wrote:
> > > Can you see alternatives? Maybe something like ,
> > > , , ,
> > > ?
> >
> > Look good to me, can you handle the renaming part so that all the
> > modules look consistant?
>
> Done as foll
Yoann Vandoorselaere wrote:
> > Can you see alternatives? Maybe something like ,
> > , , ,
> > ?
>
> Look good to me, can you handle the renaming part so that all the
> modules look consistant?
Done as follows:
2008-08-14 Bruno Haible <[EMAIL PROTECTED]>
* lib/glthread/lo
Le mercredi 13 août 2008 à 11:59 +0200, Bruno Haible a écrit :
> Hello Yoann,
>
> > I'm wondering whether there is a problem with the last set of patch I
> > sent you on the mailing list, that may prevent you from checking them
> > in?
>
> Sorry, I had zero time from Friday to Monday.
>
> Your p
Hello Yoann,
> I'm wondering whether there is a problem with the last set of patch I
> sent you on the mailing list, that may prevent you from checking them
> in?
Sorry, I had zero time from Friday to Monday.
Your patch looks quite good. Thanks for the many updates. (Only the test-lock
part has
14 matches
Mail list logo