Hi Bruno,
Le lundi 18 août 2008 à 12:55 +0200, Bruno Haible a écrit :
> Another fix:
Here is another patch on top of current GnuLib HEAD:
- Make use of the thread module in lock-test
- Include missing cond unit-test.
- Isolate thread specific CPP flags into THREADCPPFLAGS (this is useful
for a li
Another fix:
2008-08-18 Bruno Haible <[EMAIL PROTECTED]>
* lib/glthread/lock.h [USE_SOLARIS_THREADS]: Fix
glthread_recursive_lock_* macros.
* lib/glthread/lock.c (glthread_recursive_lock_destroy_multithreaded):
Fix syntax error.
*** lib/glthread/lock.h.orig2
Another addendum: Since the macros now use abort() on all platforms,
must be included always.
2008-08-17 Bruno Haible <[EMAIL PROTECTED]>
* lib/glthread/lock.h: Include always.
* lib/glthread/tls.h: Likewise.
* lib/glthread/cond.h: Likewise.
--- lib/glthread/lock.h.or
Addendum:
For the gettext macros, it's better to distinguish macros and functions, i.e.
not to have symbols which are macros on one platform and functions on others.
I'm applying this:
2008-08-14 Bruno Haible <[EMAIL PROTECTED]>
* lib/glthread/lock.h (glthread_lock_lock, glthread_lock_
Le mardi 22 juillet 2008 à 01:44 +0200, Bruno Haible a écrit :
> > > > - Implement support for condition variable.
> > >
> > > You are welcome to contribute a module for this.
> >
> > I started working on condition variable support. To me, it make sense to
> > do that directly within the lock mod
Le dimanche 03 août 2008 à 20:46 +0200, Bruno Haible a écrit :
> Yoann Vandoorselaere wrote:
> > > Declaration: gl_lock_define(extern, name)
> > > Initializer: gl_lock_define_initialized(, name)
> > > Initialization: gl_lock_init (name);
> > > Taking the loc
Le samedi 02 août 2008 à 12:15 +0200, Bruno Haible a écrit :
> Yoann Vandoorselaere wrote:
> > > Can you propose a reasonable compromise?
> >
> > Move the macro code into inline function, use the macro to call the
> > appropriate function. The function return the error, the macro abort()
> > in ca
Yoann Vandoorselaere wrote:
> > Can you propose a reasonable compromise?
>
> Move the macro code into inline function, use the macro to call the
> appropriate function. The function return the error, the macro abort()
> in case an error is returned.
OK, sounds acceptable. What naming convention
Le mercredi 30 juillet 2008 à 00:00 +0200, Bruno Haible a écrit :
> Yoann Vandoorselaere wrote:
> > Additionally, your current lock.h code still make use of abort() which
> > I'm reluctant to see in library code. Would you agree to propagate the
> > error return in case of problem?
>
> We started
Yoann Vandoorselaere wrote:
> Would it be okay if contrary to the current lock.h module (which define
> the various gl_lock_ functions as macros), I use real function?
Sure. For code that you write, you decide how it's written. I have no
requirements coming from gettext or anywhere else.
> Addit
Hi Bruno,
Le mardi 22 juillet 2008 à 01:44 +0200, Bruno Haible a écrit :
> > > > - Implement support for condition variable.
> > >
> > > You are welcome to contribute a module for this.
> >
> > I started working on condition variable support. To me, it make sense to
> > do that directly within
Hi Yoann,
Yoann Vandoorselaere wrote:
> > I think you can effectively already do it. Like this:
> >
> > gl_LOCK
> > if test $gl_threads_api = pth; then
> > AC_FATAL([The pth threads implementation is not supported by this
> > package.])
> > fi
>
> Thanks! Wouldn't it be better to dire
Hi Bruno,
Le lundi 21 juillet 2008 à 12:24 +0200, Bruno Haible a écrit :
> > - Ability to disable specific backend on demand: some implementation use
> > certain functionality that are incompatible with libpth, or depend on
> > library that provide pthread support but no libpth support. As a resul
Hi Yoann,
> - Ability to disable specific backend on demand: some implementation use
> certain functionality that are incompatible with libpth, or depend on
> library that provide pthread support but no libpth support. As a result,
> it would be great if it was possible to explicitly disable a giv
Hi,
I would be interested in performing the following lock module
modification:
- Ability to disable specific backend on demand: some implementation use
certain functionality that are incompatible with libpth, or depend on
library that provide pthread support but no libpth support. As a result,
i
15 matches
Mail list logo