Le samedi 02 août 2008 à 12:15 +0200, Bruno Haible a écrit : > Yoann Vandoorselaere wrote: > > > Can you propose a reasonable compromise? > > > > Move the macro code into inline function, use the macro to call the > > appropriate function. The function return the error, the macro abort() > > in case an error is returned. > > OK, sounds acceptable. What naming convention would you propose? We currently > have > > Declaration: gl_lock_define(extern, name) > Initializer: gl_lock_define_initialized(, name) > Initialization: gl_lock_init (name); > Taking the lock: gl_lock_lock (name); > Releasing the lock: gl_lock_unlock (name); > De-initialization: gl_lock_destroy (name); > > What should be the names of the 4 inline functions?
In the current lock.c implementation, the glthread_ prefix is being used, so we could keep using this scheme, keeping the current gl_ prefix for macros, and using the following for inline function: int glthread_lock_lock(name); int glthread_lock_unlock(name); int glthread_lock_destroy(name); Regards,