On Sun, Jan 18, 2009 at 03:42:29 +0100, Bruno Haible wrote:
> The module 'c-strtod' is under GPL, not LGPL. This alone is enough of a
> hint that the function is not really usable in libraries.
I don't agree that this is a good enough hint, since some libraries are
licensed under the GPL (includin
On Mon, 19 Jan 2009, Ralf Wildenhues wrote:
Well,
alias lgdb='libtool --mode=execute gdb'
is still shorter than what you suggest, but for reference, here's a
patch that does what you want.
What do the others think, should libtool be lenient here? I don't have
a strong preference (sure don't
Eric Blake wrote:
> What about these files?
>
> modules/uniconv/u16-conv-from-enc:AC_REQUIRE([AC_C_BIGENDIAN])
> modules/uniconv/u16-conv-to-enc:AC_REQUIRE([AC_C_BIGENDIAN])
> modules/uniconv/u16-strconv-to-enc:AC_REQUIRE([AC_C_BIGENDIAN])
Oops, I missed these. Thanks.
2009-01-19 Bruno Haible
Hello Eric, Martin,
> > Or print a message and return 77, to skip the test, if the current fs
> > doesn't support links at this point (such as FAT).
>
> I'd like to do that, but it it not easy to detect this condition. POSIX
> does not specify an error code for it, Linux uses EPERM (which can als
Bruno Haible clisp.org> writes:
> Thank you for reporting this. Yes, the failure reason is the same for all.
> The function u16_conv_from_encoding is converting to UTF-16LE instead of
> UTF-16BE (on a big-endian PowerPC machine!). This is because WORDS_BIGENDIAN
> is not defined in config.h. Beca
Hello Martin,
Thanks for the test. I committed it with minor tweaks:
- Add comments to the shell script.
- In the .c file, include . By convention, in gnulib, we
include the specification header file right after config.h. In some
situations, this allows to uncover bugs.
- In the .c f
Hi Simon,
> Several of the unicode printf modules appear to fail on powerpc:
>
> http://autobuild.josefsson.org/gnulib/log-200901190238061664000.txt
> http://autobuild.josefsson.org/gnulib/log-200901190501828983000.txt
> http://autobuild.josefsson.org/gnulib/log-200901190606100971000.txt
> http:/
Hello Bruno,
* Bruno Haible wrote on Wed, Jan 14, 2009 at 10:51:46PM CET:
>
> The removal of */.libs/lt- prefixes is done so that "make check" produces
> reliable results, and because the precise location of the executable used
> under the hood by libtool is a detail that the user should not know
Bruno Haible clisp.org> writes:
> > since my last big cygwin-related doc patch, cygwin has finally
> > started implementing wide character functions):
>
> The patch implies that wprintf() and vwprintf() existed in cygwin 1.5.x and
> were withdrawn in cygwin 1.7. Is this correct?
http://sourcewa
Hi Eric,
> since my last big cygwin-related doc patch, cygwin has finally
> started implementing wide character functions):
The patch implies that wprintf() and vwprintf() existed in cygwin 1.5.x and
were withdrawn in cygwin 1.7. Is this correct?
Bruno
Eric Blake wrote:
>> Meanwhile, I will be working on a gnulib patch that fixes
>> unistd.h to provide STD{IN,OUT,ERR}_FILENO (gnulib has several files that
>> do ad-hoc definition of these constants, but we might as well provide it
>> for free in our replacement header).
>
> I'm applying this:
>
>
Hello Eric!
On Mon, 19. Jan 2009, 05:57:14 -0700, Eric Blake wrote:
> > The minimal test is probably to
> > - create one file,
> > - use link() to create a new name for it,
>
> Or print a message and return 77, to skip the test, if the current fs
> doesn't support links at this point (such as
Hello Bruno,
On Sun, 18. Jan 2009, 19:42:11 +0100, Bruno Haible wrote:
> Can you please also provide a unit test for this module?
> The minimal test is probably to
> - create one file,
> - use link() to create a new name for it,
> - then verify that the contents is the same,
> - then modif
Eric Blake byu.net> writes:
> > Meanwhile, I will be working on a gnulib patch that fixes
> > unistd.h to provide STD{IN,OUT,ERR}_FILENO (gnulib has several files that
> > do ad-hoc definition of these constants, but we might as well provide it
> > for free in our replacement header).
>
> I'm ap
> Meanwhile, I will be working on a gnulib patch that fixes
> unistd.h to provide STD{IN,OUT,ERR}_FILENO (gnulib has several files that
> do ad-hoc definition of these constants, but we might as well provide it
> for free in our replacement header).
I'm applying this:
>From ae5dae6fd1caa993e969b
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA1
[dropping bug-autoconf, now that you have managed to get past your shell
bug, and adding bug-gnulib for a defect in our replacement ]
According to Elbert_Gmail on 1/18/2009 3:27 AM:
> Meanwhile, since you obviously
> can't rename an in-use file, you c
Hi Bruno,
Several of the unicode printf modules appear to fail on powerpc:
http://autobuild.josefsson.org/gnulib/log-200901190238061664000.txt
http://autobuild.josefsson.org/gnulib/log-200901190501828983000.txt
http://autobuild.josefsson.org/gnulib/log-200901190606100971000.txt
http://autobuild.j
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA1
According to Bruno Haible on 1/17/2009 11:42 PM:
> Eric Blake wrote:
>>> +This function is missing on some platforms:
>>> +..., Cygwin, mingw, Interix 3.5.
>> Cygwin 1.5.x lacks [v]dprintf, but cygwin 1.7.0 provides them.
>
> So, feel free to update t
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA1
According to Bruno Haible on 1/18/2009 11:42 AM:
> Hello Martin,
>
> Can you please also provide a unit test for this module?
> The minimal test is probably to
> - create one file,
> - use link() to create a new name for it,
Or print a message an
Bruno Haible wrote:
> Jim Meyering wrote:
>> FYI, I've just pushed this:
>> * lib/gettimeofday.c: Move extern declaration out of function.
>
> Why not also do the same thing with the 'gmtime' declaration in the same file?
Thanks. I didn't see that.
tzset's too:
>From 8396579b2baa56fa38e8011ba7
Hi,
A triplet for GNU/kOpenSolaris has been assigned in GNU config now. Here's
the patch for gnulib to detect it. In addition to my previous patch, this
one also adds it to host-os.m4.
--
Robert Millan
The DRM opt-in fallacy: "Your data belongs to us. We will decide when (and
how) you ma
Pushed.
Btw, the getdate module is useful in libraries (e.g., libshishi in GNU
Shishi), so it would be useful to get rid of the xalloc dependency. It
is not important for me to fix this now, though. There is only one (1)
use of xmalloc in the getdate.y, to handle large time zone strings. Are
th
Bruno Haible writes:
> Simon Josefsson wrote:
>> How about the patch below? Tested on debian lenny x86 and mac os x
>> 10.4.
>
> Looks perfect.
I've pushed it.
> Additionally, a few tests are using module 'progname' but are not
> initializing it upon program startup. This fixes it.
Great, I n
Jim Meyering wrote:
> FYI, I've just pushed this:
> * lib/gettimeofday.c: Move extern declaration out of function.
Why not also do the same thing with the 'gmtime' declaration in the same file?
Bruno
24 matches
Mail list logo